QSB6.7 CM2350 B112

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111.

Last Modified: 13-Dec-2013
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code 115.

Last Modified: 17-Mar-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 122.

Last Modified: 19-Mar-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 123.

Last Modified: 19-Mar-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes for this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
Refer to Troubleshooting Fault Code 135.

Last Modified: 26-Mar-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 141.

Last Modified: 26-Mar-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 17-Mar-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 17-Mar-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 17-Mar-2015


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 108°C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146.

Last Modified: 17-Mar-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Engine will be shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 113°C [ 235°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 17-Mar-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 19-Mar-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 19-Mar-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine will be shut down.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 17-Mar-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code 187.

Last Modified: 17-Mar-2015


Fault Code Path Selection

FAULT CODE 308-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 308-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 308-fc195-3wire

Last Modified: 11-Aug-2014


Fault Code Path Selection

FAULT CODE 308-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 308-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 308-fc196-3wire

Last Modified: 11-Aug-2014


Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | Possible reduced engine performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was higher than 3-VDC for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 197.

Last Modified: 19-Mar-2015


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 11-Feb-2014


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine will be shut down.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 17-Mar-2015


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Engine will be shut down.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.

Refer to Troubleshooting Fault Code 235.

Last Modified: 17-Mar-2015


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 13-Dec-2013


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 13-Dec-2013


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-245.

Last Modified: 16-Mar-2015


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the fuel pump actuator signal or return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the short circuit condition is or was intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 19-Mar-2015


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272.

Last Modified: 19-Mar-2015


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 13-Dec-2013


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 286.

Last Modified: 13-Dec-2013


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 322.

Last Modified: 17-Mar-2015


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 323.

Last Modified: 17-Mar-2015


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 324.

Last Modified: 17-Mar-2015


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 325.

Last Modified: 17-Mar-2015


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 331.

Last Modified: 17-Mar-2015


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 332.

Last Modified: 17-Mar-2015


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 13-Dec-2013


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 17-Mar-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352.

Last Modified: 13-Dec-2013


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 13-Dec-2013


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine will be shut down.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 17-Mar-2015


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | None on performance.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 13-Dec-2013


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the OEM VECU.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if the ECM stops receiving Speed Bias, Alternate Frequency, or Idle/Rated information from the generator drive controller over the data link.

Refer to Troubleshooting Fault Code 426.

Last Modified: 13-Dec-2013


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Open RETURN or SIGNAL circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428.

Last Modified: 13-Dec-2013


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include:

Short to ground in the wire harness

Signal wire shorted to ground

Refer to Troubleshooting Fault Code 429.

Last Modified: 13-Dec-2013


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON posistion or the engine is running.
  • The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine oil pressure switch

High resistance in the engine harness.

Refer to Troubleshooting Fault Code 435.

Last Modified: 13-Dec-2013


Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the main battery supply voltage was less than 9-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 13-Dec-2013


Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the main battery supply voltage was greater than 36-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 13-Dec-2013


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P157 SPN: 157 FMI: 0/0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the maximum pressure allowed by the fuel pressure relief valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Fault Code 449 is activated when the sensed fuel rail pressure exceeds the normal operating fuel system pressure. It is used to indicate a fuel pressure relief valve which fails to open or does not regulate pressure. Troubleshooting must be focused on inspecting the drain line path of the fuel pressure relief valve for restrictions/obstructions and checking or replacing the fuel pressure relief valve. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the fuel system. Check the fuel drain line restriction from the fuel rail to the tank for damage.

Refer to Troubleshooting Fault Code 449.

Last Modified: 17-Feb-2014


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 19-Mar-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 19-Mar-2015


Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 483

Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 483 PID: P129 SPN: 1349 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail 2 pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 2 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure 2 signal voltage was greater than 4.75-VDC for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel rail pressure sensor
  • A short circuit to battery in the engine harness.
  • An open return circuit in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 483.

Last Modified: 19-Mar-2015


Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 484

Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 484 PID: P129 SPN: 1349 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail 2 pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 2 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure 2 signal voltage was less than 0.25-VDC for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel rail pressure sensor
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 484.

Last Modified: 19-Mar-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold pressure is above the maximum operating limit. | Engine will be shut down.
Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488.

Last Modified: 19-Mar-2015


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 13-Dec-2013


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 516.

Last Modified: 13-Dec-2013


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553.

Last Modified: 17-Mar-2015


Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555.

Last Modified: 13-Dec-2013


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. High crankcase pressure detected. | Engine will be shut down.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 556.

Last Modified: 19-Mar-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure is below the commanded fuel rail pressure by at least 100 bar [1450 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel inlet restriction
  • Low fuel gear pump output pressure
  • Air in the fuel
  • Leaking fuel rail pressure relief valve
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel injectors and or fuel injector connectors
Refer to Troubleshooting Fault Code 559.

Last Modified: 19-Mar-2015


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 595.

Last Modified: 26-Mar-2015


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 600 rpm for more than 1 second when the engine speed was greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Items that can cause this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector). For the fault code to clear, the ratio of boost pressure to ambient pressure must be above 1.19:1 for at least 30 consecutive seconds. This condition can only be achieved during a test drive when the engine is under load.

Operating the engine at idle or high idle while stationary will not create enough load to maintain boost pressure at 1.19 times ambient pressure for 30 consecutive seconds. .

Although it is possible for a damaged ECM to be the root cause of this fault code, it is highly unlikely. ECM replacement should only be considered as a last resort, if no other repairs are successful in clearing the fault code.

In very rare cases, it has been shown that the turbocharger can cause this fault code to come active and turbocharger replacement may be the only way to clear the fault code.

Refer to Troubleshooting Fault Code t05-687.

Last Modified: 17-Mar-2015


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 17-Mar-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 13-Dec-2013


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 13-Dec-2013


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 731.

Last Modified: 26-Mar-2015


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 741

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 741 PID: S314 SPN: 1176 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbochager.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Open return circuit in the engine harness, connector, sensor
  • Open signal circuit in the engine harness, connectors, or sensor
  • Damaged sensor
Refer to Troubleshooting Fault Code 741.

Last Modified: 13-Dec-2013


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 742

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 742 PID: S314 SPN: 1176 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbochager.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor
Refer to Troubleshooting Fault Code 742.

Last Modified: 13-Dec-2013


Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 743

Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 743 PID: S314 SPN: 1176 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure - Data erratic, intermittent or incorrect | Possible reduced engine performance.
Turbocharger Compessor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbochager.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF.
  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Stuck in-range ambient air temperature sensor
  • ECM malfunction.
Refer to Troubleshooting Fault Code 743.

Last Modified: 26-Mar-2015


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 778.

Last Modified: 26-Mar-2015


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | None on performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists

FAULT CODE 1664

Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: S380 SPN: 4796 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists. The aftertreatment diesel oxidation catalyst is not present in the exhaust system. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the aftertreatment diesel oxidation catalyst intake temperature sensor and the aftertreatment diesel oxidation catalyst outlet temperature sensor are reading the same temperature during an active SCR system cleaning of the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Tampering with the catalyst system
  • Removing the catalyst system from the vehicle
  • A damaged catalyst.
Refer to Troubleshooting Fault Code 1664.

Last Modified: 26-Mar-2015


Fault Code Path Selection

FAULT CODE 308-fc1668
Fault Code Path Selection

Is the aftertreatment diesel exhaust fluid tank level sensor a 2-wire sensor? | Go to 308-fc1668-2wire
Is the aftertreatment diesel exhaust fluid tank level sensor a 3-wire sensor? | Go to 308-fc1668-3wire

Last Modified: 12-Aug-2014


Fault Code Path Selection

FAULT CODE 308-fc1669
Fault Code Path Selection

Is the aftertreatment diesel exhaust fluid tank level sensor a 2-wire sensor? | Go to 308-fc1669-2wire
Is the aftertreatment diesel exhaust fluid tank level sensor a 3-wire sensor? | Go to 308-fc1669-3wire

Last Modified: 12-Aug-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level. The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was critically low.

Action Taken When the Fault Code is Active

The Diesel Exhaust Fluid Lamp will be flashing.

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically. This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1677.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: None SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1678.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature sensor
  • Damaged wiring harness

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1679.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fliud Dosing Unit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • The diesel exhaust fluid suction and return lines between the dosing unit and diesel exhaust fluid tank are reversed
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
Refer to Troubleshooting Fault Code 1682.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank heater circuit is shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid tank heater signal wire and return wire shorted together
  • Malfunctioning diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1683.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid tank heating will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid tank heater control valve
  • A short circuit to ground
Refer to Troubleshooting Fault Code 1684.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1685

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1685 PID: SPN: 3364 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage below normal, or shorted to low source | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependant. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
  • Short to ground in the wiring harness
Refer to Troubleshooting Fault Code 1685.

Last Modified: 27-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1686

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1686 PID: SPN: 3364 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage above normal, or shorted to high source | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependant. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Short circuit to voltage source in the OEM harness

Refer to Troubleshooting Fault Code 1686.

Last Modified: 27-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 5298 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The temperature increase across the aftertreatment catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at high idle for 15 minutes. It is necessary to elevate the exhaust flow to clear this fault code. For certain applications, it can be necessary to drive the vehicle in order to achieve adequate exhaust flow.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning diesel oxidation catalyst
Refer to Troubleshooting Fault Code 1691.

Last Modified: 13-Dec-2013


Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: SPN: 3226 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the aftertreatment intake and outlet NOx sensor readings.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test found in the ECM Diagnostic Tests Section.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output
  • Exhaust system leaks
  • NOx sensor part number is incorrect.
  • Possible engine misfire
Refer to Troubleshooting Fault Code 1694.

Last Modified: 27-Mar-2015


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature failed to thaw after the aftertreatment diesel exhaust fluid tank heater was commanded on for a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1712.

Last Modified: 13-Dec-2013


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank heater is continuously in the ON position. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is NOT being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the DEF tank temperature was greater than 65°C [149°F] indicating the aftertreatment diesel exhaust fluid tank heater was in the ON position when the ECM was commanding the heater to be in the OFF position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Before troubleshooting this fault code, make sure the equipment is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

Reason: If there is a problem with the diesel exhaust fluid (DEF) tank heater control valve, the valve is stuck open, there is coolant leaking past the valve seat, or the valve is incorrectly installed, it can take long periods of operation at high load before the tank temperature gradually increases to the fault code threshold value of 65°C [149°F]. As soon as the temperature drops below 65°C [149°F] due to a stopped engine, overnight parking, reduced coolant temperature, and so forth, the fault code will go inactive while the root cause of the issue is still present.

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve installed incorrectly, reversed relative to coolant flow direction.
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve – stuck open or leakage past the valve seat.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1713.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

FAULT CODE 1714

Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1714 PID: SPN: 3364 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration. The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaut Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependant. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1714.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

FAULT CODE 1715

Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1715 PID: SPN: 3364 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known | Engine may be shut down.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependant. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1715.

Last Modified: 17-Mar-2015


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 13-Dec-2013


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 13-Dec-2013


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature signal indicates engine coolant temperature is above the engine protection warning limit. | Engine will be shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine will only idle or will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • Malfunctioning coolant temperature sensor

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS

Refer to Troubleshooting Fault Code 1847.

Last Modified: 27-Mar-2015


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water-In-Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 13-Dec-2013


Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect. An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

  • Engine coolant temperature is 68°C [154°F] or higher.
  • Intake manifold air temperature is 7°C [44°F] or higher.
  • Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher or lower than a calibratable value when the keyswitch was turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • High resistance in the wiring harness on the signal or return wire.
  • Plugged or restricted EGR differential pressure sensor flow ports.
Refer to Troubleshooting Fault Code 1866.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1885

Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: P102 SPN: 3216 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor has malfunctioned or is damaged
  • The aftertreatment intake NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1885.

Last Modified: 17-Mar-2015


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: P2202 SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1887.

Last Modified: 17-Mar-2015


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The EGR valve has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

The EGR valve will close when the fault code is active. The fault code will remain active until the next key cycle.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

Refer to Troubleshooting Fault Code 1896.

Last Modified: 19-Mar-2015


ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: S212 SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

Voltage supplied to the Variable Geometry Turbocharger (VGT) actuator dropped below 10-VDC for 10 seconds and the engine speed was at zero rpm or greater than 575 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the voltage to the VGT actuator drops below 10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code 1938.

Last Modified: 13-Dec-2013


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2/2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Engine Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure sensor was reading an erratic value at key ON or the crankcase pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor
  • Crankcase pressure sensor is not installed correctly in the housing.
Refer to Troubleshooting Fault Code 1942.

Last Modified: 13-Dec-2013


EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1961

EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1961 PID: S146 SPN: 2791 FMI: 0/15 LAMP: Amber SRT: | EGR Valve Control Circuit Calculated Over Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. High EGR valve driver temperature has been detected. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve device driver is internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature of the EGR valve driver internal to the ECM was greater than 150°C [302°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code may be inactive when the vehicle is in the shop because the EGR valve driver temperature has cooled down. Therefore, troubleshoot multiple inactive counts of this fault code as an active fault code.

Possible causes of this fault code include:

  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1961.

Last Modified: 26-Feb-2016


VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1962

VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1962 PID: S27 SPN: 641 FMI: 0/15 LAMP: Amber SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level. High internal VGT actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The internal temperature of the Variable Geometry Turbocharger (VGT) actuator exceeded 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down. Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code 1962.

Last Modified: 13-Dec-2013


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure reading was higher than a threshold for 60 cumulative minutes at idle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool “Data Monitor/Logger” feature to monitor "Crankcase Pressure" with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather element may need to be replaced.

Refer to Troubleshooting Fault Code 1974.

Last Modified: 13-Dec-2013


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit. | Engine will be shut down.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

Gain adjust setting is not set correctly

Erroneous generator speed/load governing bias signal from the generator set

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 1992.

Last Modified: 17-Mar-2015


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S27 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | VGT Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator did not receive a valid J1939 data link message from the Engine Control Module (ECM) for 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Intermittent J1939 data link connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code 2198.

Last Modified: 17-Mar-2015


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve position sensor signal voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

EGR valve position sensor wiring shorted to ground, open circuit, or shorted to power supply.

  • Loss of the EGR valve position sensor supply voltage or the ground circuit.
Refer to Troubleshooting Fault Code 2272.

Last Modified: 19-Mar-2015


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was greater than 4.8-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage
  • A damaged EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 2273.

Last Modified: 19-Mar-2015


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was less than 0.26-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground
  • A malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 2274.

Last Modified: 19-Mar-2015


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code 2288.

Last Modified: 17-Mar-2015


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit had an intermittent circuit concern, or the fuel pump actuator resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 2311.

Last Modified: 17-Mar-2015


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: S384 SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbine intake temperature was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

Refer to Troubleshooting Fault Code 2346.

Last Modified: 13-Dec-2013


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Below Normal or Open Circuit. Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or EGR valve motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • EGR motor circuit open circuit
  • Open circuit in the wiring harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 2349.

Last Modified: 17-Mar-2015


EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 2353

EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2353 PID: S146 SPN: 2791 FMI: 6/6 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Above Normal or Grounded Circuit. A short circuit to ground has been detected in the EGR valve motor circuit. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • One of the EGR motor circuits shorted to ground in the EGR valve motor
  • One of the EGR motor circuits shorted to ground in the harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 2353.

Last Modified: 17-Mar-2015


EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment. The EGR valve motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve was commanded open and the EGR valve was unable to move to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is triggered when the EGR valve motor is unable to move the EGR valve in the open position. This is normally caused by a restriction in the EGR valve not allowing the EGR valve to move to the commanded position.

Refer to Troubleshooting Fault Code 2357.

Last Modified: 19-Mar-2015


Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor.
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 2373.

Last Modified: 19-Mar-2015


Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 2374.

Last Modified: 19-Mar-2015


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • An open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 2375.

Last Modified: 19-Mar-2015


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal shorted to ground in the harness
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 2376.

Last Modified: 19-Mar-2015


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the harness or fan control solenoid.
  • A short circuit to voltage source in the OEM harness.
  • A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-2377.

Last Modified: 17-Mar-2015


VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2387

VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S27 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position could not meet the commanded position for greater than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The VGT actuator will continue to attempt to meet commanded position, even when the CHECK ENGINE lamp is on.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • A malfunctioning turbocharger actuator

The aftertreatment system must be inspected for potential damage after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system can possibly have occurred.

Refer to Troubleshooting Fault Code 2387.

Last Modified: 19-Mar-2015


Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448.

Last Modified: 17-Mar-2015


Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Erratic, Intermittent or Incorrect. The exhaust gas pressure sensor is reading an erratic value. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

  • The Engine Control Module (ECM) detected the exhaust pressure reading was higher or lower than the other absolute pressure sensors when the keyswitch is OFF and the engine is not running.
  • The Engine Control Module (ECM) detected the exhaust pressure was higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70°C or 158°F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and run it at high idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range exhaust gas pressure sensor reading
  • High resistance in the exhaust gas pressure sensor signal or return lines
  • Plugging or restriction in the exhaust gas pressure sensor tube
  • Leaks in the exhaust system
Refer to Troubleshooting Fault Code 2554.

Last Modified: 19-Mar-2015


Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2555 PID: S70 SPN: 729 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays while 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake air heater circuit pulse width modulated (PWM) signal was greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Intake air heater relay signal wire not connected to the relay
  • Intake air heater relay return wire not connected to the relay
  • Open circuit in the intake air heater relay signal wire
  • Open circuit in the intake air heater relay return wire
  • Intake air heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code 2555.

Last Modified: 11-Mar-2014


Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: S70 SPN: 729 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays while 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake air heater circuit pulse width modulated (PWM) signal was not system voltage when the PWM signal was on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A shorted intake air heater relay
  • Intake air heater relay supply wire shorted to ground.
Refer to Troubleshooting Fault Code 2556.

Last Modified: 11-Mar-2014


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: S27 SPN: 641 FMI: 12/12 LAMP: Red SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position; or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code 2634.

Last Modified: 19-Mar-2015


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: S27 SPN: 641 FMI: 11/31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the VGT actuator and the ECM has been detected. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The turbocharger actuator calibration revision in the VGT actuator is not compatible with the ECM software.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger application identification number in the VGT actuator does not match the turbocharger application identification number in the ECM.

Refer to Troubleshooting Fault Code 2635.

Last Modified: 19-Mar-2015


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S27 SPN: 641 FMI: 9/9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine ECM and the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.
  • Rapid cycling of the keyswitch
  • An open return circuit on the VGT actuator circuit
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link
  • A damaged termination resistor in the engine data link harness
Refer to Troubleshooting Fault Code 2636.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

FAULT CODE 2637

Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2637 PID: S380 SPN: 5018 FMI: 11/11 LAMP: None SRT: | Aftertreatment Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known. The front face of the aftertreatment diesel oxidation catalyst has been detected to be plugged with soot. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

This fault code is set when the intake face of the diesel oxidation catalyst is detected to be plugged with soot.

Action Taken When the Fault Code is Active

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is set when the inlet face of the diesel oxidation catalyst is detected to be plugged with soot.

Possible causes of this fault code include.

  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
Refer to Troubleshooting Fault Code 2637.

Last Modified: 17-Mar-2015


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 14/31 LAMP: Amber SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was above a threshold and closed the EGR valve to reduce the engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code 2646.

Last Modified: 17-Mar-2015


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2753

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2753 PID: P412 SPN: 412 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Engine will be shut down.
EGR Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A fouled EGR cooler
  • Plugged or restricted EGR differential pressure sensor ports
  • A damaged EGR valve
  • A low reading from the EGR differential pressure sensor
Refer to Troubleshooting Fault Code 2753.

Last Modified: 19-Mar-2015


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The Aftertreatment Outlet NOx Sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment outlet NOx sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the ECM on the J1939 data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2771.

Last Modified: 17-Mar-2015


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 210°C [410°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted EGR differential pressure sensor ports
  • Damaged EGR differential pressure tubes
  • A malfunctioning EGR valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger
  • A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2961.

Last Modified: 17-Mar-2015


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 250°C [482°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A fouled EGR cooler
  • Plugged or restricted EGR differential pressure sensor ports
  • A damaged EGR valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2962.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2976

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2976 PID: SPN: 3361 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the ON position, and continues until the diesel exhaust fluid dosing unit attempts to prime.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit internal temperature was not communicated to the ECM by the diesel exhaust dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning dosing unit
  • Short circuit to ground in the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature wire.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2976.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intake temperature sensor

Refer to Troubleshooting Fault Code 3142.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3143.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3144

Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The SCR intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intake temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3144.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3146.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3147.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the SCR catalyst outlet temperature is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3148.

Last Modified: 17-Mar-2015


Aftertreatment SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Tampering with SCR catalyst system, removal of SCR catalyst from vehicle, or malfunctioning SCR catalyst
  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3151.

Last Modified: 17-Mar-2015


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | Engine will be shut down.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 800°C [1472°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3165.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3228

Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3228 PID: SPN: 3216 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx reading was higher or lower than the calculated aftertreatment intake NOx value for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • EGR system leaks
  • Exhaust system leaks
  • An incorrectly installed aftertreatment intake NOx sensor
  • An aftertreatment intake NOx sensor that has carbon buildup on the tip of the sensor
  • A malfunctioning EGR differential pressure sensor.
  • A malfunctioning EGR valve
  • Excessive oil consumption
  • Possible engine misfire
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 3228.

Last Modified: 29-Feb-2016


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3229

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3229 PID: SPN: 4360 FMI: 0/0 LAMP: Red SRT: | Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the maximum temperature limit. | Engine will be shut down.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning fuel injectors
  • Contaminated diesel exhaust fluid
  • A malfunctioning aftertreatment SCR intake temperature sensor
Refer to Troubleshooting Fault Code 3229.

Last Modified: 17-Mar-2015


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3231

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3231 PID: SPN: 4360 FMI: 0/16 LAMP: Red SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The SCR intake temperature sensor reading has exceeded the maximum temperature limit. | Engine will be shut down.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code are:

  • Malfunctioning fuel injectors
  • Contaminated diesel exhaust fluid
Refer to Troubleshooting Fault Code 3231.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code was triggered when the ECM loses J1939 data link communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment intake NOx sensor circuit between the battery circuit aftertreatment intake NOx sensor.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment intake NOx sensor.
  • Intermittent communications between the aftertreatment intake NOx sensor and the ECM on the J1939 data link

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3232.

Last Modified: 17-Mar-2015


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 0/16 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The SCR outlet temperature sensor reading has exceeded the maximum temperature limit. | Engine will be shut down.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 650°C [1202°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3235.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: S254 SPN: 4340 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3237.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3238

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3238 PID: SPN: 4340 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaustl Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • A malfunctioning line heater
Refer to Troubleshooting Fault Code 3238.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3239

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3239 PID: SPN: 4342 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3239.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3241

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3241 PID: SPN: 4342 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • A malfunctioning line heater
Refer to Troubleshooting Fault Code 3241.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded ON. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater was commanded on by the engine engine control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictions in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3242.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3251

Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3251 PID: S326 SPN: 4765 FMI: 0/16 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel oxidation catalyst intake temperature sensor reading has exceeded the maximum temperature limit. | Engine will be shut down.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the diesel oxidation catalyst intake was greater than 745°C [1373°F] for 65 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3251.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3258

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3258 PID: SPN: 4340 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit. Open circuit detected in the diesel exhaust fluid line heater 1. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3258.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3261

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3261 PID: S254 SPN: 4342 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit. Open circuit detected in the diesel exhaust fluid line heater 2. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3261.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3313

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3313 PID: SPN: 4765 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst intake sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst intake temperature sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3313.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3314

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3314 PID: SPN: 4765 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3314.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3315

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3315 PID: SPN: 4765 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel oxidation catalyst intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

"The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and aftertreatment diesel oxidation catalyst outlet temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at high idle for 15 minutes. It is necessary to elevate the exhaust flow to clear this fault code. For certain applications, it can be necessary to drive the vehicle in order to achieve adequate exhaust flow.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor
  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3315.

Last Modified: 17-Mar-2015


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

FAULT CODE 3326

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9/9 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate. The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3326.

Last Modified: 17-Mar-2015


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | Transmission Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3328.

Last Modified: 17-Mar-2015


Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3341

Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3341 PID: SPN: 107 FMI: 0/16 LAMP: Amber SRT: | Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level | None on performance.
Turbocharger Compessor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The combination turbocharger compressor intake pressure/temperature sensor is located in the original equipment manufacturer (OEM) intake air plumbing.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake air restriction is above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged or highly restricted air filter can also possibly cause this fault to become active, especially at higher altitudes.
Refer to Troubleshooting Fault Code 3341.

Last Modified: 17-Mar-2015


Intake Manifold 1 Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 3385

Intake Manifold 1 Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3385 PID: P105 SPN: 105 FMI: 1/18 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level. The intake manifold temperature is below a critical threshold | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The intake manifold temperature was less than 20°C [68°F] while the engine was idleing for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The EGR valve was closed because the engine was idling with cold intake manifold temperatures for an extended period of time.

Refer to Troubleshooting Fault Code 3385.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3422

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3422 PID: SPN: 4344 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • Malfunctioning aftertreatment diesel exhaust fluid contoller.
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3422.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3423

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3423 PID: SPN: 4344 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The line heater will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning line heater
  • A short circuit to ground in the OEM harness
Refer to Troubleshooting Fault Code 3423.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3425

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3425 PID: S254 SPN: 4344 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit. Open circuit detected in the diesel exhaust fluid line heater 3. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater relay
  • Malfunctioning line heater

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3425.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3497

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3497 PID: SPN: 1761 FMI: 1/17 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid tank level is low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was low.

Action Taken When the Fault Code is Active

  • The Diesel Exhaust Fluid Lamp will be illuminated.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is low, and the tank must be refilled at the operator's earliest convenience.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3497.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

The Diesel Exhaust Fluid Lamp will be flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3498.

Last Modified: 17-Mar-2015


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • A short circuit to battery in the engine harness.
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3539.

Last Modified: 10-Apr-2015


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3541.

Last Modified: 10-Apr-2015


Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: P2202 SPN: 3226 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Abnormal Rate of Change. The aftertreatment outlet NOx sensor reading is not valid. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1887, 2771, or 3682 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-3545.

Last Modified: 30-Mar-2015


Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: S115 SPN: 4096 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists. The diesel exhaust fluid tank is empty. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was empty and the dosing unit was unable to prime.

Action Taken When the Fault Code is Active

There are two levels of action taken by the ECM when this fault code is active:

Level 1: Action taken when the diesel exhaust fluid tank is empty:

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Diesel Exhaust Fluid Lamp will be flashing.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced.

Level 2: Action taken when the diesel exhaust fluid tank is empty and engine shutdown or extended idle.

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Diesel Exhaust Fluid Lamp will be flashing.

  • Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the aftertreatment diesel exhaust fluid tank is empty and needs refilled immediately.

Refer to Troubleshooting Fault Code 3547.

Last Modified: 17-Mar-2015


Engine Wait to Start Lamp - Abnormal Update Rate

FAULT CODE 3555

Engine Wait to Start Lamp - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3555 PID: SPN: 1081 FMI: 9/9 LAMP: Amber SRT: | Engine Wait to Start Lamp - Abnormal update rate. A loss of communication has been detected. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the Engine Wait to Start Lamp.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect feature and parameter settings
  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 3555.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fliud Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibratible value or the diesel exhaust fluid dosing unit supply was shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing unit
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3558.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fliud Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • A short circuit to ground in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3559.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 3562

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3562 PID: SPN: 5491 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater relay. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Relay Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay driver signal was shorted to high source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid line heater relay circuit
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3562.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3563

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3563 PID: SPN: 5491 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid line heater relay. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluid line heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay control signal was out or range low or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the aftertreatment diesel exhaust fluid line heater relay circuit
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3563.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

To validate the repair:

  • Perform a key cycle.
  • Start and idle the engine.
  • Monitor the Aftertreatment Diesel Exhaust Fluid Dosing Unit State in INSITE™ electronic service tool.
  • The Aftertreatment Diesel Exhaust Fluid Dosing Unit State in INSITE™ electronic service tool must transition to Dosing, indicating the system has primed.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Turn the key switch ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3567.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3568

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Responding or Out of adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 3568.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3571.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3572.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Malfunctioning diesel exhaust fluid dosing unit
  • Contaminated diesel exhaust fluid
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3574.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than 1100 kpa [159 psi] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit return line or return line fitting
  • Malfunctioning diesel exhaust fluid dosing unit.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3575.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid return valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve circuit was out of range high or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be aftertreatment diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines can freeze and the SCR system can become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3577.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid return valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines could freeze and become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3578.

Last Modified: 17-Mar-2015


Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3582

Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3582 PID: SPN: 4364 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. NOx conversion across the SCR catalyst is too low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.
Refer to Troubleshooting Fault Code 3582.

Last Modified: 17-Mar-2015


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
  • Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3583.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when diesel exhaust fluid dosing unit is fully primed, and is actively maintaining diesel exhaust fluid pressure in the dosing system.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Leaking diesel exhaust fluid lines
  • Malfunctioning diesel exhaust fluid dosing unit
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Blocked or restricted diesel exhaust fluid filters
  • Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3596.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Heater - Abnormal rate of change. The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Intermittent power connection to the aftertreatment intake NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3649.

Last Modified: 17-Mar-2015


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: P411 SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment outlet NOx sensor power supply - Data erratic, intermittent, or incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibratible threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the outlet NOx sensor
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3681.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: P190 SPN: 3218 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect. The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the intake NOx sensor
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3682.

Last Modified: 05-Apr-2017


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 3697.

Last Modified: 17-Mar-2015


Aftertreatment Outlet NOx Sensor - Out of Calibration

FAULT CODE 3717

Aftertreatment Outlet NOx Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3717 PID: SPN: 3226 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor -Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment Outlet NOx Sensor Power Supply

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment outlet NOx sensor and ECM calibration
  • System voltage incorrect for installed aftertreatment outlet NOx sensor part number.
  • Incorrect aftertreatment outlet NOx sensor is installed in exhaust system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3717.

Last Modified: 17-Mar-2015


Aftertreatment Intake NOx - Out of Calibration

FAULT CODE 3718

Aftertreatment Intake NOx - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3718 PID: SPN: 3216 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Intake NOx - Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment intake NOx sensor. | None on performance.
CM2350- Aftertreatment Intake NOx Sensor Power Supply

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment intake NOx sensor and ECM calibration.
  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3718.

Last Modified: 17-Mar-2015


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3724

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3724 PID: P168 SPN: 168 FMI: 1/17 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Low voltage to the EGR valve device driver has been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

Component Location

The EGR valve device driver is internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low power at the EGR valve device driver. The ECM was no longer able to control the EGR valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates an internal failure in the ECM.

Refer to Troubleshooting Fault Code 3724.

Last Modified: 17-Mar-2015


Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: P102 SPN: 3216 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Rate of Change. The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.
  • Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1885, 3232, or 3681 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code t05-3725.

Last Modified: 17-Mar-2015


High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3727

High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3727 PID: S254 SPN: 5571 FMI: 7/7 LAMP: None SRT: | High-Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment. The fuel rail high-pressure relief valve has opened at a lower than expected pressure. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure relief valve had opened at a pressure lower than expected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • It is necessary to perfrom this step twice.
  • Turn the key switch ON.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

This fault code may also be triggered by a sudden and significant loss of fuel pressure in the fuel system.

Refer to Troubleshooting Fault Code 3727.

Last Modified: 09-Jan-2014


Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High. An offset in the intake NOx sensor reading has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Improperly installed aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 3748.

Last Modified: 17-Mar-2015


Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: S254 SPN: 3226 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High. An offset in the outlet NOx sensor reading has been detected. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3749.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3867

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3867 PID: SPN: 3364 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid (DEF) has been detected to be below a critical threshold. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

To Validate the repair, perform a key cycle, start the engine and let it idle for 10 minutes.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhuast fluid
Refer to Troubleshooting Fault Code 3867.

Last Modified: 22-Mar-2016


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change .No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment DEF quality sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
  • An open circuit in the OEM harness
Refer to Troubleshooting Fault Code 3868.

Last Modified: 09-Apr-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3876

Aftertreatment Diesel Exhaust Fluid Quality Sensor - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3876 PID: SPN: 3364 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor - Mechanical System Not Responding or Out of Adjustment | Engine may be shut down.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Degraded, diluted, or incorrect diesel exhaust fluid
Refer to Troubleshooting Fault Code 3876.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor - Bad Intelligent Device or Component

FAULT CODE 3877

Aftertreatment Diesel Exhaust Fluid Quality Sensor - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3877 PID: SPN: 3364 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor - Bad intelligent device or component | Engine may be shut down.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Damaged sensor.
Refer to Troubleshooting Fault Code 3877.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid (DEF) quality sensor has detected an over temperature condition. | Engine may be shut down.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.

Use INSITE electronic service tool to verify the fault code is inactive.

  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing temperature sensor
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 3878.

Last Modified: 09-Apr-2015


Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3931

Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3931 PID: SPN: 1109 FMI: 0/0 LAMP: Red SRT: | Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Most Severe Level. Critical fault codes have been active for an extended period of time and require immediate attention. | Engine will be shut down.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3931.

Last Modified: 17-Mar-2015


Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4135

Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4135 PID: SPN: 1109 FMI: 0/16 LAMP: Amber SRT: | Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Moderately Severe Level. Critical fault codes related to engine operatior are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) continuously monitors the fault code status to determine if any critical fault codes are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4135.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4152

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4152 PID: SPN: 5743 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal update rate. No communication on the J1939 data link between the ECM and the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low battery voltage supply
  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Incorrect Battery System Voltage setting in INSITE
Refer to Troubleshooting Fault Code 4152.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay CIrcuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4155

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay CIrcuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4155 PID: SPN: 5746 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater relay circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater relay is used to provide power to the aftertreatment diesel exhaust fluid dosing unit heater.

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater relay signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay
  • A short circuit to battery in the OEM harness
Refer to Troubleshooting Fault Code 4155.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4156

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4156 PID: SPN: 5746 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater relay circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater relay is used to provide power to the aftertreatment diesel exhaust fluid dosing unit heater.

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater relay signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
Refer to Troubleshooting Fault Code 4156.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4157

Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4157 PID: SPN: 4376 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical system not responding or out of adjustment. A stuck aftertreatment diesel exhaust fluid return valve has been detected. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is used to purge the aftertreatment diesel exhaust fluid dosing system. When the return valve is energized, the dosing system will purge and return the aftertreatment diesel exhaust fluid to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure did not drop when the aftertreatment diesel exhaust fluid return valve was commanded on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid return valve
Refer to Troubleshooting Fault Code 4157.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4159

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4159 PID: SPN: 5743 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad intelligent device or component. An internal error has been detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR temperature sensor module
Refer to Troubleshooting Fault Code 4159.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4164

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4164 PID: SPN: 5743 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal, or Shorted to High Source. High battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High battery voltage supply
Refer to Troubleshooting Fault Code 4164.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4165

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4165 PID: SPN: 5743 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage below normal, or shorted to low source. Low battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low battery voltage supply
Refer to Troubleshooting Fault Code 4165.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4166

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4166 PID: SPN: 5743 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 4166.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4168

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4168 PID: SPN: 5745 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Voltage Above Normal, or Shorted to High Source. The aftertreatment diesel exhasut fluid dosing unit heater is detected to be stuck on. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature was rising when the aftertreatment diesel exhaust fluid dosing unit heater was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay
  • A short circuit to battery in the OEM harness
Refer to Troubleshooting Fault Code 4168.

Last Modified: 26-Feb-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4169

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4169 PID: SPN: 5745 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Voltage below normal, or shorted to low source. The aftertreatment diesel exhasut fluid dosing unit heater is detected to be stuck off. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature was not rising when the aftertreatment diesel exhaust fluid dosing unit heater was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay
  • A short circuit to ground in the OEM harness
Refer to Troubleshooting Fault Code 4169.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4171

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4171 PID: SPN: 5745 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid dosing unit failed to thaw. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit failed to reach a target temperature after heating for a calibratable amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater
Refer to Troubleshooting Fault Code 4171.

Last Modified: 17-Mar-2015


Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4213

Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4213 PID: SPN: 3695 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Regeneration Inhibit Switch - Data erratic, intermittent or incorrect. The aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile SCR System Cleaning.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position and the ECM is requesting active regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test found in the ECM Diagnostic Tests Section.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment regeneration permit switch circuit.
  • Incorrect feature and parameter settings
Refer to Troubleshooting Fault Code 4213.

Last Modified: 17-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality - Received Network Data in Error

FAULT CODE 4241

Aftertreatment Diesel Exhaust Fluid Quality - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4241 PID: SPN: 3364 FMI: 2/19 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change .No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment DEF quality sensor. | Possible reduced engine performance.
SAE J1939 Data Link Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link
Refer to Troubleshooting Fault Code 4241.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

FAULT CODE 4243

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4243 PID: SPN: 3515 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Temperature 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

A damaged DEF smart sensor

Refer to Troubleshooting Fault Code 4243.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change

FAULT CODE 4249

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4249 PID: SPN: 4337 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change. The aftertreatment diesel exhaust fluid dosing unit temperature is stuck. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit temperature is not changing when the heater is commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit temperature sensor
Refer to Troubleshooting Fault Code 4249.

Last Modified: 17-Mar-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4261

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4261 PID: SPN: 5743 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known. Intermittent battery voltage supply detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4261.

Last Modified: 16-Mar-2015


High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4262

High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4262 PID: SPN: 5571 FMI: 3/3 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit is detected at the High Pressure Common Rail Fuel Pressure Relief Valve circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
High Pressure Common Rail Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the high pressure common rail fuel pressure relief valve circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the high pressure common rail fuel pressure relief valve circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, or low resistance (high pressure common rail fuel pressure relief valve is shorted internally). If there is high harness resistance or an intermittent open circuit, Fault Code 4867 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the high pressure common rail fuel pressure relief valve actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code 4262.

Last Modified: 19-Mar-2015


High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4263

High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4263 PID: SPN: 5571 FMI: 4/4 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Voltage below Normal, or Shorted to low Source. Low signal voltage is detected at the High Pressure Common Rail Fuel Pressure Relief Valve circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
High Pressure Common Rail Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the High Pressure Common Rail Fuel Pressure Relief Valve circuit signal or return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the high pressure common rail fuel relief valve circuit. Causes for this fault code are short circuit to ground or low resistance (high pressure common rail fuel pressure relief valve actuator coil is shorted internally). When excessive current or a short circuit is detected, the ECM driver to the high pressure common rail fuel pressure relief valve actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Refer to Troubleshooting Fault Code 4263.

Last Modified: 19-Mar-2015


High Pressure Common Rail Fuel Pressure Relief Valve - Root Cause Not Known

FAULT CODE 4265

High Pressure Common Rail Fuel Pressure Relief Valve - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4265 PID: SPN: 5571 FMI: 11/11 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Root Cause Not Known .The ECM detects high pressure common rail fuel pressure relief valve stuck closed at key off (Shutdown). | None on performance.
Engine Control Module (ECM)

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was greater than the 1200 bar [17405psi] for 10 seconds after keyoff.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • It is necessary to perfrom this step twice.
  • Turn the key switch ON.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel pressure relief valve
Refer to Troubleshooting Fault Code 4265.

Last Modified: 13-Jan-2014


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

FAULT CODE 4277

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4277 PID: SPN: 3364 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change .No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment DEF quality sensor. | Engine will be shut down.
Aftertreatment Diesel Exhaust Fluid Quality Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Shorted or open J1939 data link wiring.
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 4277.

Last Modified: 17-Mar-2015


Vehicle Identification Number - Out of Calibration

FAULT CODE 4517

Vehicle Identification Number - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4517 PID: SPN: 237 FMI: 13/13 LAMP: Amber SRT: | Vehicle Identification Number - Out of Calibration. The vehicle identification number has not been programmed into the ECM. | None on performance.
Engine Control Module (ECM)

Circuit Description

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the vehicle identification number (VIN) was not programmed in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect feature and parameter settings
Refer to Troubleshooting Fault Code 4517.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 4533

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4533 PID: SPN: 4766 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftreatment diesel oxidation catalyst temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported the aftertreatment diesel oxidation catalyst outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 4533.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4534

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4534 PID: SPN: 4766 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftreatment diesel oxidation catalyst temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported the aftertreatment diesel oxidation catalyst outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 4534.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate. The ECM lost communication with the aftertreatment diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Intermittent communication from the aftertreatment diesel exhaust fluid tank temperature sensor
  • An open or short circuit in the SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 4572.

Last Modified: 16-Mar-2015


Aftertreatment 1 SCR Catalyst System - Special Instructions

FAULT CODE 4585

Aftertreatment 1 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4585 PID: SPN: 4792 FMI: 14/14 LAMP: Red SRT: | Aftertreatment 1 SCR Catalyst System - Special Instructions. The Incorrect SCR system has been Installed | Engine will be shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been manufactured with the incorrect SCR

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include.

  • A malfunctioning aftertreatment SCR temperature sensor module

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 4585.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

FAULT CODE 4737

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4737 PID: SPN: 3031 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4737.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4739.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4741

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4741 PID: SPN: 3364 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Below Normal or Open Circuit. | None on performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an error on the DEF circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
Refer to Troubleshooting Fault Code 4741.

Last Modified: 08-Aug-2014


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4742

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4742 PID: SPN: 3364 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Current Above Normal or Grounded Circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an error on the DEF circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the aftertreatment diesel exhaust fluid controller harness
  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
Refer to Troubleshooting Fault Code 4742.

Last Modified: 08-Aug-2014


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4743

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4743 PID: SPN: 3515 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Below Normal or Open Circuit | Possible reduced engine performance.
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an error on the DEF circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid controller harness
Refer to Troubleshooting Fault Code 4743.

Last Modified: 08-Aug-2014


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4744

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4744 PID: SPN: 3515 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Above Normal or Grounded Circuit | Possible reduced engine performance.
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an error on the DEF circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to battery in the aftertreatment diesel exhaust fluid controller harness
Refer to Troubleshooting Fault Code 4744.

Last Modified: 08-Aug-2014


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

FAULT CODE 4745

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4745 PID: SPN: 3515 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Level/Temperature Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • This fault code can not be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4745.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

FAULT CODE 4768

Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4768 PID: SPN: 3521 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known. Unknown fluid inside DEF tank. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
Refer to Troubleshooting Fault Code 4768.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change. A valid diesel exhaust fluid tank level reading has NOT been received. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
  • Tampering of the aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4769.

Last Modified: 16-Mar-2015


Aftertreatment SCR Operator Inducement Active - Condition Exists

FAULT CODE 4863

Aftertreatment SCR Operator Inducement Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4863 PID: SPN: 5245 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Operator Inducement Active - Condition Exists-Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when faults related to SCR have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

Possible causes of this fault code include:

This fault code is information ONLY.make sure that critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4863.

Last Modified: 17-Mar-2015


High Pressure Common Rail Fuel Pressure Relief Valve - Condition Exists

FAULT CODE 4867

High Pressure Common Rail Fuel Pressure Relief Valve - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4867 PID: SPN: 5571 FMI: 11/31 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Condition Exists. The high pressure common rail fuel relief valve circuit resistance is too high or too low, or an intermittent connection has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
High Pressure Common Rail Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the high pressure common rail fuel relief valve circuit had an intermittent circuit concern, or the high pressure common rail fuel relief valve resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

  • Engine harness high resistance
  • Intermittent circuit malfunctions

If an intermittent electrical circuit problem of the fuel pump pressurizing assembly circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump pressurizing assembly circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 4867.

Last Modified: 19-Mar-2015


Variable Geometry Turbocharger Actuator Software - Out of Calibration

FAULT CODE 4956

Variable Geometry Turbocharger Actuator Software - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4956 PID: SPN: 6713 FMI: 13/13 LAMP: Red SRT: | Engine Variable Geometry Turbo (VGT) Software - Out of Calibration. VGT software does not match application. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an application software mismatch with the Turbocharger actuator calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger application identification number in the VGT actuator does not match the turbocharger application identification number in the ECM.

Refer to Troubleshooting Fault Code 4956.

Last Modified: 17-Mar-2015


Variable Geometry Turbocharger Actuator Software - Condition Exists

FAULT CODE 4957

Variable Geometry Turbocharger Actuator Software - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4957 PID: SPN: 6713 FMI: 11/31 LAMP: Red SRT: | Engine Variable Geometry Turbo (VGT) Software - Condition Exists. The VGT actuator and ECM software is not compatible. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The turbocharger actuator calibration revision in the VGT actuator is not compatible with the ECM software.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger actuator interface level in the VGT actuator is not compatible with the ECM software.

Refer to Troubleshooting Fault Code 4957.

Last Modified: 17-Mar-2015


Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

FAULT CODE 5177

Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5177 PID: P SPN: 6713 FMI: 9/9 LAMP: Amber SRT: | Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate. The ECM lost communication or did not support message from the VGT actuator. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the ECM did not recieve the turbocharger actuator identification message from the VGT actuator.

Refer to Troubleshooting Fault Code 5177.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5386

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5386 PID: SPN: 4766 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect.The aftertreatment diesel oxidation catalyst outlet temperature is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

"The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and aftertreatment diesel oxidation catalyst outlet temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor
  • A malfunctioning aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5386.

Last Modified: 16-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5387

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5387 PID: SPN: 4766 FMI: 0/0 LAMP: Red SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The aftertreatment diesel oxidation catalyst outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Engine will be shut down.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

"The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst outlet temperature reading was greater than 800°C [1472°F] for more than 30 seconds, or the temperature differential across the diesel oxidation catalyst was greater than 540°C [1004°F] for more than 90 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes for this fault code include:

  • A malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Excessive engine oil being introduced into the exhaust system from the engine.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 5387.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5388

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5388 PID: SPN: 4766 FMI: 0/16 LAMP: Red SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level.The aftertreatment diesel oxidation catalyst outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Engine will be shut down.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active SCR system cleaning of the aftertreatment is not occurring

Conditions for Setting the Fault Codes

"The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst outlet temperature reading was greater than 800°C [1472°F] for more than 30 seconds, or the temperature differential across the diesel oxidation catalyst was greater than 540°C [1004°F] for more than 90 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 5388.

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5389

Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5389 PID: SPN: 4766 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level.The aftertreatment diesel oxidation catalyst outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

"The aftertreatment diesel oxidation catalyst outlet temperature sensor reading was greater than 650°C [1202°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise the exhaust temperatures. This can be done by initiating a stationary regeneration using INSITE electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible caused of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 5389.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 5391

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5391 PID: SPN: 6882 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Abnormal Update Rate.No communications on the J1939 data link between the ECM and the aftertreatment diesel oxidation catalyst temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

"The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel oxidation catalyts temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Low battery voltage supply
  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
Refer to Troubleshooting Fault Code 5391.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 5392

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5392 PID: SPN: 6882 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel oxidation catalyst temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module Circuit

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning aftertreatment diesel oxidation catalyst
Refer to Troubleshooting Fault Code 5392.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 5393

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5393 PID: SPN: 6882 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Above Normal or Shorted to High Source. High battery supply voltage detected at the aftertreatment diesel oxidation catalyst temperature Sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module Circuit

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High battery voltage supply
Refer to Troubleshooting Fault Code 5393.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5394

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5394 PID: SPN: 6882 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source. Low battery supply voltage detected at the aftertreatment diesel oxidation catalyst temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low battery voltage supply
Refer to Troubleshooting Fault Code 5394.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Root Cause Not Known

FAULT CODE 5395

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5395 PID: SPN: 6882 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Root Cause Not Known. Intermittent battery voltage supply detected at the aftertreatment diesel oxidation catalyst temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment diesel oxidation catalyst temperature sensor module resulting in an internal reset of the module

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 5395.

Last Modified: 16-Mar-2015


Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5396

Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5396 PID: SPN: 6882 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment diesel oxidation catalyst temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module

Circuit Description

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

"The aftertreatment diesel oxidation catalyst temperature sensor module is mounted on the aftertreatment diesel oxidation catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel oxidation catalyst temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel oxidation catalyst temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to over heating of the aftertreatment diesel oxidation catalyst temperature sensor module.

Refer to Troubleshooting Fault Code 5396.

Last Modified: 16-Mar-2015


Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5576

Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5576 PID: SPN: 107 FMI: 0/15 LAMP: Maintenance SRT: | Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level | None on performance.
Turbocharger Compressor Intake Pressure Sensor Circuit

Circuit Description

The turbocharger compressor intake pressure sensor is a differential pressure sensor and is used to measure the air pressure drop entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake pressure sensor signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air pressure drop into the compressor intake.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbochager.

Conditions for Running the Diagnostics

This diagnostic runs continuously after the engine has been running for 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake air restriction is above a calibratible value.

Action Taken When the Fault Code is Active

The Engine Control Module (ECM) will flash the Amber CHECK ENGINE lamp at key ON

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes. If the fault code does not go inactive after key ON, it may be necessary to drive the vehicle for at least 5 continuous minutes.

Shop Talk

Possible causes of this fault code include:

  • Plugged or highly restricted air filter can also possibly cause this fault to become active, especially at higher altitudes.
Refer to Troubleshooting Fault Code 5576.

Last Modified: 20-Mar-2017


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5585

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5585 PID: SPN: 5571 FMI: 0/15 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Least Severe Level. Excessive fuel flow restriction to the high pressure fuel pump has been detected, or leaking high pressure common rail pressure relief valve. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump pressurizing assembly) or decrease (CLOSE the fuel pump pressurizing assembly) the fuel supply to the high-pressure pump.

Component Location

There are two fuel filters and several original equipment manufacturer (OEM) supplied components that can impact this fault code. The pressure-side fuel filter is typically mounted directly to the engine, but can also be remote mounted. The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter, and the exact filter location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure was less than a calibratible value during high fuel flow conditions indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low fuel pressure at rated speed/load indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Possible causes of this fault code include:

  • A plugged pressure or suction side fuel filter
  • Collapsed fuel inlet lines
  • An obstructed suction tube in the fuel tank
  • Plugged fuel tank vents.
  • Malfunctioning high-pressure fuel system
Refer to Troubleshooting Fault Code 5585.

Last Modified: 01-Sep-2015


Aftertreatment 1 Diesel Oxidation Catalyst System - Special Instructions

FAULT CODE 5617

Aftertreatment 1 Diesel Oxidation Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5617 PID: SPN: 5018 FMI: 14/14 LAMP: Red SRT: | Aftertreatment 1 Diesel Oxidation Catalyst System - Special Instructions. The Incorrect DOC system has been Installed | Engine will be shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been manufactured with the incorrect DOC

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the vehicle assembly process. If this fault code is active, the aftertreatment part numbers should be verified.

Refer to Troubleshooting Fault Code 5617.

Last Modified: 17-Mar-2015


SCR System Cleaning Inhibited Due to System Timeout - Condition Exists

FAULT CODE 5631

SCR System Cleaning Inhibited Due to System Timeout - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5631 PID: SPN: 6928 FMI: 11/31 LAMP: None SRT: | SCR System Cleaning Inhibited Due to System Timeout - Condition Exists. The system was unable to perform an active SCR System Cleaning of the aftertreatment SCR filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted by the OEM near the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the system is requesting an active SCR system cleaning of the aftertreatment SCR system for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test found in the ECM Diagnostic Tests Section.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is an information only fault code indicating that the system was requesting an active SCR system cleaning of the aftertreatment system, but was unable to perform an active SCR system cleaning .

Refer to Troubleshooting Fault Code 5631.

Last Modified: 13-Mar-2015


SCR System Cleaning Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 5632

SCR System Cleaning Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5632 PID: SPN: 6918 FMI: 11/31 LAMP: Maintenance SRT: | SCR System Cleaning Inhibited Due to Inhibit Switch - Condition exists. Cleaning of the SCR system has been prevented due to the permit switch being disabled. | None on performance.
Engine Control Module (ECM)

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile SCR System Cleaning.

Component Location

The SCR catalyst is located in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR system cleaning permit switch was disabling SCR system cleaning while the ECM was requesting active SCR system cleaning.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The ECM will illuminate the MAINTENANCE lamp on the key cycle after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test found in the ECM Diagnostic Tests Section.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 5632.

Last Modified: 17-Mar-2015


SCR Operator Inducement Override Switch - Abnormal Update Rate

FAULT CODE 5653

SCR Operator Inducement Override Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5653 PID: SPN: 6881 FMI: 9/9 LAMP: Amber SRT: | SCR Operator Inducement Override Switch - Abnormal Update Rate. No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the SCR override switch. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
Refer to Troubleshooting Fault Code 5653.

Last Modified: 17-Mar-2015


SCR Operator Inducement Override Switch - Out of Calibration

FAULT CODE 5654

SCR Operator Inducement Override Switch - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5654 PID: SPN: 6881 FMI: 13/13 LAMP: Amber SRT: | SCR Operator Inducement Override Switch - Out of Calibration. The received datalink message was not valid. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5654.

Last Modified: 17-Mar-2015


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5879

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5879 PID: SPN: 3464 FMI: 3/3 LAMP: Amber SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage above normal, or shorted to high source. A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 5879.

Last Modified: 10-Apr-2015


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5881

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5881 PID: SPN: 3464 FMI: 4/4 LAMP: Amber SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage above normal, or shorted to high source. A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 5881.

Last Modified: 10-Apr-2015


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5882

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5882 PID: SPN: 3464 FMI: 7/7 LAMP: Amber SRT: | Electronic Throttle Control Actuator - Mechanical system not responding or out of adjustment. The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 5882.

Last Modified: 10-Apr-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (2-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 (2-Wire Sensor) PID: P203C SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1668 (2-Wire Sensor).

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668 (3-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 (3-Wire Sensor) PID: P203C SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1668 (3-Wire Sensor).

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (2-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 (2-Wire Sensor) PID: P203D SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1669 (2-Wire Sensor).

Last Modified: 17-Mar-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669 (3-Wire Sensor)

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 (3-Wire Sensor) PID: P203D SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1669 (3-Wire Sensor).

Last Modified: 17-Mar-2015


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 (2-Wire Sensor) PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 195 (2-Wire Sensor).

Last Modified: 13-Dec-2013


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the OEM harness
  • An open circuit in the OEM harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 195 (3-Wire Sensor).

Last Modified: 13-Dec-2013


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 (2-Wire Sensor) PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the harness, sensor or connectors
  • Damaged sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 196 (2-Wire Sensor).

Last Modified: 13-Dec-2013


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 (3-Wire Sensor).

Last Modified: 13-Dec-2013


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Feb-2017


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | IF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | IF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 40221704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310840
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367219
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete.

Last Modified: 28-Apr-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 L115 | 4388626
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 SN | 4310736
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK78 CM2250 K104 | 4332682
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISM/QSM11 CM570 | 3666266
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for all engines except QSM11 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.
  • Use the following procedure for QSM11 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 195 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L102 | 4332796
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X105 | 4332667
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X106 | 4332712
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G110 | 4367323
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L107 | 4367386
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L118 | 4388673
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L122 | 5411278
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X118 | 5467247
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 7388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5427252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Conenct INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jan-2017


FAULT CODE 195 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L102 | 4332796
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X105 | 4332667
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X106 | 4332712
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CN2350 B112 | 4358498
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G110 | 4367323
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L107 | 4367386
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L118 | 4388673
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L122 | 5411278
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X118 | 5467247
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Mar-2017


FAULT CODE 196 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L102 | 4332796
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X105 | 4332667
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X106 | 4332712
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G110 | 4367323
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L107 | 4367386
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L118 | 4388673
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L122 | 5411278
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X118 | 5467247
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Contol Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Contol Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch off
  • Disconnect the OEM harness from the ECM
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jan-2017


FAULT CODE 196 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L102 | 4332796
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X105 | 4332667
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X106 | 4332712
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B112 | 4358498
Engine Cooolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z101 | 4358364
Engine Cooolant Level Sensor | Refer to Procedure 019-017 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G110 | 4367323
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L107 | 4367386
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L118 | 4388673
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSL9 CM2350 L122 | 5411278
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2350 G113 | 5467252
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the wiring diagram for connector in identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Mar-2017


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K105 | 4326157
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K108 | 4332823
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K116 | 4367444
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K111 | 4358519
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K117 | 4367449
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K121 | 4388645
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss symptom troubleshooting tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 197 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 15-May-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Contact a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring down hill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring down hill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not operating above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2017


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K105 | 4326157
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K108 | 4332823
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K111 | 4358519
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K116 | 4367444
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K117 | 4367449
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K121 | 4388645
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60.8 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5411484

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply wire. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 271 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harnes | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2250 | 4022254
Fuel Pump Actuator | Refer to Procedure 019-117 | ISC8.3 and ISL9 CM2250 | 4022257
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 GX CM2250 | 4022250
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12/ISX11.9 CM2250 | 2883445
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine QSB6.7 CM2250 | 4310611
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2250 | 4022256
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 | 4022255
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 EC | 2883621
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX11.9 CM2250 ECF | 2883561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 ECF | 2883557
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 ECF | 4310661
Fuel Pump Actuator | Refer to Procedure 019-117 | PowerGen QSX15 CM2250 | 4310664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 EC | 2883647
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B101 | 2883567
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L101 | 4310787
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12 CM2350 X102 | 4310646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2350 X101 | 4310641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2250 SN | 4310736
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F101 | 4310846
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F103 | 4310839
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5 CM2350 B104 | 4332646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B103 | 4332641
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B105 | 4332778
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L102 | 4332796
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 L110 | 4358475
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F110 | 4358480
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 M CM2250 L106 | 4358343
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L111 | 4367223
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F105 | 4358561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2350 F109 | 4367218
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F107 | 4367316
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B106 | 4367376
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G110 | 4367323
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F114 | 4383734
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F117 | 4388578
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2250 B128 | 4388601
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2250 L115 | 4388626
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L118 | 4388673
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B130 | 4388668
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F116 | 4383664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F119 | 4388703
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F118 | 4388708
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSC8.3 CM2880 C102 | 4388785
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F126 | 5411159
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2250 B131 | 4388774
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 B137 | 5411058
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B142 | 5411131
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2250 X115 | 4388739
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X114B | 5411181
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X116B | 5411186
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B121B | 5411223
Fuel Pump Actuator | Refer to Procedure 019-117 | F3.8 CM2350 F120B | 5411237
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L116B | 5411330
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B129B | 5411247
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B147B | 5411252
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B135B | 5411257
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B148B | 5411262
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L119B | 5411267
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B145 | 5411273
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L122 | 5411278
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B144 | 5411382
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L123B | 5411465
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F131 | 5411489
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G113 | 5467252
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F125 | 5411494
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F124 | 5411484
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF4.5 CM2220 F123 | 5411320
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Check for a signal-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2B. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes | Fault Code 271 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair Complete

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Check for a signal-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Inspect the ECM pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3

Guided Step 2B - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module (ECM) connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness fuel pump actuator connector and fuel pump actuator RETURN pin in the engine harness fuel pump actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.”

Repair complete

Escalate or call for assistance

Last Modified: 13-May-2017


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 SN | 4022190
Fuel Pump Actuator | Refer to Procedure 019-117 | ISZ13 CM2150 | 4022133
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B101 | 2883567
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L101 | 4310787
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX12 CM2350 X102 | 4310646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISX15 CM2350 X101 | 4310641
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F101 | 4310846
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F103 | 4310839
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB4.5 CM2350 B104 | 4332646
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B103 | 4332641
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B105 | 4332778
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L102 | 4332796
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD4.5 CM2150 B119 | 4358465
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2150 B120 | 4358470
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2150 L110 | 4358475
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F110 | 4358480
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9 CM2350 L111 | 4367223
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z101 | 4358364
Fuel Pump Actuator | Refer to Procedure 019-117 | QSZ13 CM2150 Z102 | 4358369
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F105 | 4358561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2350 F109 | 4367218
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F107 | 4367316
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B106 | 4367376
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G110 | 4367323
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F114 | 4383734
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F117 | 4388578
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L118 | 4388673
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B130 | 4388668
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF3.8 CM2220 F116 | 4383664
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F119 | 4388703
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F118 | 4388708
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSC8.3 CM2880 C102 | 4388785
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F126 | 5411159
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2250 B131 | 4388774
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB3.3 CM2250 B137 | 5411058
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB6.7 CM2350 B142 | 5411131
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X114B | 5411181
Fuel Pump Actuator | Refer to Procedure 019-117 | X15 CM2350 X116B | 5411186
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B121B | 5411223
Fuel Pump Actuator | Refer to Procedure 019-117 | F3.8 CM2350 F120B | 5411237
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L116B | 5411330
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B129B | 5411247
Fuel Pump Actuator | Refer to Procedure 019-117 | B4.5 CM2350 B147B | 5411252
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B135B | 5411257
Fuel Pump Actuator | Refer to Procedure 019-117 | B6.7 CM2350 B148B | 5411262
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L119B | 5411267
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B145 | 5411273
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L122 | 5411278
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B144 | 5411382
Fuel Pump Actuator | Refer to Procedure 019-117 | L9 CM2350 L123B | 5411465
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F131 | 5411489
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2350 G113 | 5467252
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F125 | 5411494
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F124 | 5411484
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active or inactive fuel pump actuator fault code. | Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 2C. Check the fault codes. | Fault Code 272 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active or inactive fuel pump actuator fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 2A

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

  • Inspect the ECM pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19. Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the fuel pump actuator.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Connect the engine harness to the ECM connector.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L109 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2880 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358365
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358375
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358380
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L109 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Operate the engine. | Will engine start?
 | STEP 1C. Read the fault codes. | Fault Code 351 active?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Operate the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine.

Will engine start?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES NO

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

 No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle with no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2016


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for Fault Code 418. | Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 12-Jun-2017


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B101 | 2883567
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L101 | 4310787
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2350 F109 | 4367218
Water in Fuel Sensor | Refer to Procedure 019-127 | F3.8 CM2350 F120B | 5411237
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X115 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L116B | 5411330
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L123B | 5411465
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water in fuel sensor.

Action

Inspect the engine harness, and water in fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water in fuel SIGNAL pin and the water in fuel RETURN pin at the water in fuel sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms?
YES NO

Replace the water in fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor RETURN pin and the engine harness water in fuel sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor SIGNAL pin and the engine water in fuel sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 L110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine QSB6.7 CM2250 | 4310611
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X1152 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F124 | 5411484
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water in fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turnkeyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery connection. | Batteries connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2017


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 AN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B101 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L101 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358575
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358580
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | GSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | GSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | GSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | GSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 AN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 EC | 4310575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332687
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K105 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358570
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358580
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 IAN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSb4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 483 - Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B101 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L101 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 483 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 484 active and Fault Code 483 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 483 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 484 active and Fault Code 483 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 VOLT SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 484 active and Fault Code 483 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 484 - Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 484 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 483 active and Fault Code 484 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 484 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 484 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 active and Fault Code 484 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 484 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 484 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 483 active and Fault Code 484 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 484 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 B2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X105 | 4332667
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X106 | 4332712
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
YES NO

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS in the appropriate service manual.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 515 - Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 515 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 515 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 6 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 516 - Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K117 | 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male WeatherPack™ test lead, Part Number 3823996 - female WeatherPack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 516 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 516 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the original equipment manufacturer (OEM) harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L116B | 5411330
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L116B | 5411330
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L123B | 5411465
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Verify crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase breather filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element. Refer to Procedure 003-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • Reference the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B105 | 4332778
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B101 | 2883567
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 | 4358498
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411223
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?
 | STEP 2B. Very crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tubes, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check for progressive damage. |
 | STEP 4A. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase ventilation filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance interval for a specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 and ISL9 CM2250 L115 engines: Refer to Procedure 003-021 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tubes, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tubes, or oil separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engines equipped with automatic transmissions only.
  • Measure the crankcase blowby.

Refer to Procedure 014-010 in the Associated Procedures Table.

It may be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace, as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check for progressive damage.

Guided Step 4A - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to the high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

Reference the appropriate service manual for a specific engine application.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the damaged gasket, seal, or other component.

Troubleshoot the possible causes for excessive crankcase gases. Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS in the appropriate service manual for a specific engine application.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X105 | 4332667
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X106 | 4332712
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4368668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2350 X105 | 4332667
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2350 X106 | 4332712
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L102 | 4332796
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L118 | 4388673
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L107 | 4367386
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B129B | 5411247
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B147B | 5411252
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B135B | 5411257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B148B | 5411262
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L122 | 5411278
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB4.5 CM2350 B144 | 5411382

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Codes 122, 123, 221, or 222 active?
STEP 2. | Check for an intermittent fault condition. |
 | STEP 2A. Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active. | Fault Code 595 become active during engine keyswitch ON?
 | STEP 2B. Operate the engine and confirm that the turbocharger speed fault comes active. | Fault Code 595 become active during engine keyswitch ON?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the turbocharger speed sensor circuit continuity. | Within 10 ohms of sensor resistance?
 | STEP 4C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the ECM. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Fault Code 595 come active during engine operation?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code trouble shooting tree.

Go to 2A

Guided Step 2 - Check for an intermittent fault condition.

Guided Step 2A - Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 become active during engine keyswitch ON?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

An intermittent fault condition exists.

Go to 2B

Guided Step 2B - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 come active during engine operation?
YES NO
No Repair

An intermittent fault code condition exists.

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-390 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance form the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

  • Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance form the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Inspect the engine harness for a short between two pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM.

Guided Step 5A - Connect all components and determine if the fault code occurs again.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 come active during engine operation?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The faulty condition was repaired when the components were reconnected.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Nov-2016


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L102 | 4332796
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL8.9 CM2150 SN | 4022190
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2250 | 4022254
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 | 4022256
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 | 4022255
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 EC | 2883621
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 ECF | 2883557
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Speed Sensor | Refer to Procedure 019-390 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L101 | 4310787
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX12 CM2350 X102 | 4310646
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISX15 CM2350 X101 | 4310641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISL9 CM2350 L111 | 4367223
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2250 L115 | 4388626
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L118 | 4388673
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L107 | 4367386
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSX15 CM2250 X115 | 4388739
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B129B | 5411247
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B4.5 CM2350 B147B | 5411252
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B135B | 5411257
Turbocharger Speed Sensor | Refer to Procedure 019-390 | B6.7 CM2350 B148B | 5411262
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L119B | 5411267
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSL9 CM2350 L122 | 5411278
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L116B | 5411330
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Speed Sensor | Refer to Procedure 019-390 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Replace the turbocharger speed sensor. Refer to Procedure 019-030 in the Associated Procedures Table.

A short has been detected in the engine harness.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L102 | 4332796
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?

YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compressor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM, engine harness, or OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM, engine harness, or OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL pin and the turbocharger compressor intake air temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor RETURN pin and the engine harness turbocharger compressor intake air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor SIGNAL pin and the engine harness turbocharger compressor intake air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSL9 CM2250 | 4022256
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 | 4022255
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2350 F124 | 5411484

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • Use the following procedure for engines equipped with a turbocharger compresssor intake air temperature sensor. Refer to Procedure 019-395 in the Associated Procedures Table.
  • Use the following procedure for engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, engine harness, or OEM harness.

Guided Step 3A - Inspect the ECM and engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated faults will become active at this time as well. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine turbocharger compressor intake temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2350 B105 | 4332778
Camshaft | Refer to Procedure 001-008 | QSL9 CM2350 L102 | 4332796
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2350 B112 | 4358498
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2350 F107 | 4367316
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2350 B106 | 4367376
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2350 B130 | 4388668
Camshaft | Refer to Procedure 001-008 | QSL9 CM2350 L118 | 4388673
Camshaft | Refer to Procedure 001-008 | QSL9 CM2350 L107 | 4367386
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2350 F118 | 4388708
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2350 F119 | 4388703
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2350 B122 | 4388767
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2350 B145 | 5411273
Camshaft | Refer to Procedure 001-008 | QSL9 CM2350 L122 | 5411278
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2350 B144 | 5411382
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2350 F125 | 5411494
Crankshaft | Refer to Procedure 001-016 | QSX15 CM2350 X105 | 4332667
Crankshaft | Refer to Procedure 001-016 | QSX15 CM2350 X106 | 4332712
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2350 B105 | 4332778
Crankshaft | Refer to Procedure 001-016 | QSL9 CM2350 L102 | 4332796
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2350 B112 | 4358498
Crankshaft | Refer to Procedure 001-016 | QSF2.8 CM2880 F105 | 4358561
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2350 F107 | 4367316
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2350 B106 | 4367376
Crankshaft | Refer to Procedure 001-016 | QSG12 CM2350 G110 | 4367323
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2350 B130 | 4388668
Crankshaft | Refer to Procedure 001-016 | QSL9 CM2350 L118 | 4388673
Crankshaft | Refer to Procedure 001-016 | QSL9 CM2350 L107 | 4367386
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2350 F118 | 4388708
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2350 F119 | 4388703
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2350 B122 | 4388767
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2350 B145 | 5411273
Crankshaft | Refer to Procedure 001-016 | QSL9 CM2350 L122 | 5411278
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2350 B144 | 5411382
Crankshaft | Refer to Procedure 001-016 | QSX15 CM2350 X118 | 5467247
Crankshaft | Refer to Procedure 001-016 | QSG12 CM2350 G113 | 5467252
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2350 F125 | 5411494
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSX15 CM2350 X105 | 4332667
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSX15 CM2350 X106 | 4332712
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSB6.7 CM2350 B105 | 4332778
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 CM2350 L102 | 4332796
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSB6.7 CM2350 B112 | 4358498
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSG12 CM2350 G110 | 4367323
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSB6.7 CM2350 B130 | 4388668
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 CM2350 L118 | 4332667
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 CM2350 L107 | 4332712
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSB6.7 CM2350 B145 | 5411273
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSL9 CM2350 L122 | 5411278
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSG12 CM2350 G113 | 5467252
Vibration Damper, Viscous | Refer to Procedure 001-052 | QSF3.8 CM2350 F125 | 5411494
Overhead Camshaft, Valve | Refer to Procedure 002-024 | QSX15 CM2350 X105 | 4332667
Overhead Camshaft, Valve | Refer to Procedure 002-024 | QSX15 CM2350 X106 | 4332712
Overhead Camshaft, Valve | Refer to Procedure 002-024 | QSG12 CM2350 G110 | 4367323
Overhead Camshaft, Valve | Refer to Procedure 002-024 | QSX15 CM2350 X118 | 5467247
Overhead Camshaft, Valve | Refer to Procedure 002-024 | QSG12 CM2350 G113 | 5467252
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X105 | 4332667
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X106 | 4332712
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G110 | 4367323
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388673
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L107 | 4367386
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F118 | 4388708
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F119 | 4388703
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B122 | 4388767
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X118 | 5467247
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X105 | 4332667
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X106 | 4332712
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check static timing. | Engine timed correctly?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 the only active fault?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for damage.

Any damage?
YES NO

Replace the speed or position sensor.

Use the following procedure for the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Use the following procedure for the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

  • Make sure the component having engine timing marks (typically the vibration damper or pulley) is correctly aligned with the crankshaft by verifying it is properly installed on the dowel or index pin that orients it.
  • Refer to Procedure 001-052 in the Associated Procedures Table.
  • Use the following procedure for ISX engines, remove the oil pan and check by hand for a loose crankshaft tone wheel or damaged teeth.

Any damage?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft removal and installation. Refer to Procedure 001-016 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation. Refer to Procedure 001-008 in the Associated Procedures Table. Refer to Procedure 002-024 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check the static timing.

Guided Step 4A - Check static timing.

Conditions

  • Remove the gear cover.

Action

Inspect the timing.

N/A

Engine timed correctly?
YES NO
No Repair

Properly time the engine.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | Westport HD CM2250 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harnes | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2150 SN | 4022190
Camshaft Position Sensor | Refer to Procedure 019-363 | ISZ13 CM2150 | 4022133
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2250 | 4022254
Camshaft Position Sensor | Refer to Procedure 019-363 | ISC8.3 and ISL9 CM2250 | 4022257
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 GX CM2250 | 4022250
Camshaft Position Sensor | Refer to Procedure 019-363 | Westport HD CM2250 | 4021560
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12/ISX11.9 CM2250 | 2883445
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 | 4022256
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 | 4022255
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 EC | 2883621
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX11.9 CM2250 ECF | 2883561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 ECF | 2883557
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 ECF | 4310661
Camshaft Position Sensor | Refer to Procedure 019-363 | PowerGen QSX15 CM2250 | 4310664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 EC | 2883647
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine QSB6.7 CM2250 | 4310611
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B101 | 2883567
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L101 | 4310787
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX12 CM2350 X102 | 4310646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2350 X101 | 4310641
Camshaft Position Sensor | Refer to Procedure 019-363 | ISX15 CM2250 SN | 4310736
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F101 | 4310846
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F103 | 4310839
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB4.5 CM2350 B104 | 4332646
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B103 | 4332641
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B105 | 4332778
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4332796
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD4.5 CM2150 B119 | 4358465
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2150 B120 | 4358470
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358475
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L102 | 4358480
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 M CM2250 L106 | 4358343
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9 CM2350 L111 | 4367223
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B112 | 4358498
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z101 | 4358364
Camshaft Position Sensor | Refer to Procedure 019-363 | QSZ13 CM2150 Z102 | 4358369
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F105 | 4358561
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F114 | 4383734
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F107 | 4367316
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2350 F109 | 4367218
Camshaft Position Sensor | Refer to Procedure 019-363 | F3.8 CM2350 F120B | 5411237
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B106 | 4367376
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G110 | 4367323
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2250 B128 | 4388601
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2250 L115 | 4388626
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L107 | 4367386
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F117 | 4388578
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B130 | 4388668
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L118 | 4388673
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F118 | 4388708
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F119 | 4388703
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B122 | 4388767
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F126 | 5411159
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2250 B131 | 4388774
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.3 CM2250 B137 | 5411058
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X114B | 5411181
Camshaft Position Sensor | Refer to Procedure 019-363 | X15 CM2350 X116B | 5411186
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B121B | 5411223
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB6.7 CM2350 B142 | 5411131
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2250 X115 | 4388739
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B129B | 5411247
Camshaft Position Sensor | Refer to Procedure 019-363 | B4.5 CM2350 B147B | 5411252
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B135B | 5411257
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 CM2350 B148B | 5411262
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L119B | 5411267
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L116B | 5411330
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2350 B145 | 5411273
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9 CM2350 L122 | 5411278
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2350 B144 | 5411382
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F124 | 5411484
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2350 F125 | 5411494
Camshaft Position Sensor | Refer to Procedure 019-363 | L9 CM2350 L123B | 5411465
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F131 | 5411489
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2350 G113 | 5467252
Camshaft Position Sensor | Refer to Procedure 019-363 | QSX15 CM2350 X118 | 5467247
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault coe Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

For QSB6.7 CM2250 B128 and QSL9 CM2250 L115 engines: If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]. During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 1664 - Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF2.8 CM2220 F101 | 4310486
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | L9 CM2350 L119B | 5411267
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX15 CM2250 ECF | 2883557
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX12 CM2350 X102 | 4310646
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX15 CM2350 X101 | 4310641

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, or 3318 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1963 active?
 | STEP 1C. Check for the presence of a diesel oxidation catalyst (DOC). | DOC present in the aftertreatment system?
STEP 2. | Check engine control module (ECM) calibration. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 3A. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
 | STEP 3B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, or 3318 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for the presence of a diesel oxidation catalyst (DOC).

Conditions

  • Turn keyswitch OFF.
  • Remove the DOC from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Check the DOC.

  • Inspect for the presence of the DOC in the exhaust system.

DOC present in the aftertreatment system?
YES NO
No Repair

Install the proper DOC for the application. See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check engine control module (ECM) calibration.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment fuel injector, if equipped.

Guided Step 3A - Check the flow of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Note: If the aftertreatment fuel injector is not equipped, proceed to Step 4A.

Action

Perform the Aftertreatment System Test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

Aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the Aftertreatment System Test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Oct-2016


FAULT CODE 1673 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 1685 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit malfunction has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2015


FAULT CODE 1686 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit failure has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2015


FAULT CODE 1714 - Aftertreatment Diesel Exhaust Fluid Quality - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 1714 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1714 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 03-May-2017


FAULT CODE 1715 - Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Replace the aftertreatment DEF quality sensor. See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Nov-2015


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2250 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2250 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B1O6 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2250 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2015


FAULT CODE 1866 - Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | QSF3.8 CM2350 F107 | 4367316
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 EC | 2883621
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B101 | 2883567
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L101 | 4310787
Air Intake Connection | Refer to Procedure 010-080 | ISB4.5 CM2350 B104 | 4332646
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B103 | 4332641
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B105 | 4332778
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L102 | 4332796
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L111 | 4367223
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F105 | 4358561
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F114 | 4383734
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B130 | 4388668
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L118 | 4388673
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B121B | 5411223
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B142 | 5411131
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L116B | 5411330
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B129B | 54111247
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B135B | 5411257
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B147B | 5411252
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B148B | 5411262
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L119B | 5411267
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L123B | 5411465
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX11.9 CM2250 ECF | 2883561
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2250 ECF | 2883557
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12 CM2350 X102 | 4310646
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2350 X101 | 4310641
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X114B | 5411181
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F14 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2273 and 2274. | Fault Code 2273 or 2274 active?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor ports. |
 | STEP 2A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins.
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 2273 and 2274.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 or 2274 active?
YES | NO
No Repair | No Repair

Fault Code 2273 or 2274 troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor ports.

Guided Step 2A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB, ISC, ISL, QSB, and QSL engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB, ISC, ISL, QSB, QSL, B4.5, and B6.7 engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1885 - Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 | 4367444
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K117 | 4367449
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K121 | 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B147B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 or 3682 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Code 1885 active or inactive with more than one count?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 or 3682 is active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885 active or inactive with more than one count?
YES NO

An internal error has been detected in the aftertreatment intake nitrogen oxides (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1896 - EGR Valve Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B105 | 4332778
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L102 | 4332796
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 B105 | 4332667
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 B106 | 4332712
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B112 | 4358498
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F107 | 4367316
EGR Valve | Refer to Procedure 011-022 | QSF2.8 CM2880 F105 | 4358561
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B106 | 4367376
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B122 | 4388767
EGR Valve | Refer to Procedure 011-022 | QSF2.8 CM2880 F114 | 4383734
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L107 | 4367386
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B130 | 4388668
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L118 | 4388673
EGR Valve | Refer to Procedure 011-022 | ISF2.8 CM2220 | 4022178
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B105 | 4332778
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L102 | 4332796
Snap Acceleration Test | Refer to Procedure 014-017 | QSX15 CM2350 B105 | 4332667
Snap Acceleration Test | Refer to Procedure 014-017 | QSX15 CM2350 B106 | 4332712
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 | 4358498
Snap Acceleration Test | Refer to Procedure 014-017 | QSF3.8 CM2350 F107 | 4367316
Snap Acceleration Test | Refer to Procedure 014-017 | QSF2.8 CM2880 F105 | 4358561
Snap Acceleration Test | Refer to Procedure 014-017 | QSB4.5 CM2350 B106 | 4367376
Snap Acceleration Test | Refer to Procedure 014-017 | QSB4.5 CM2350 B122 | 4388767
Snap Acceleration Test | Refer to Procedure 014-017 | QSF2.8 CM2880 F114 | 4383734
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B130 | 4388668
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L118 | 4388673

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1896 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the EGR valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 1 minute and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Clean the EGR valve assembly.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

  • Refer to Procedure 014-017 in the Associated Procedrues Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Dec-2016


FAULT CODE 1938 - ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal conditions?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
STEP 3. | Check the sensor supply voltage at the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage at the ECM. |
STEP 4. | Check if an ECM calibration and clear fault codes. |
 | STEP 4A. Compare ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable and clear fault code. |

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code tree

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least 12 VDC (12 VDC systems)
  • At least 24 VDC (24 VDC systems).

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the VGT actuator or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the VGT actuator: Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator voltage SUPPLY pin and the VGT actuator RETURN pin at the VGT actuator wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the supply voltage at the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Use a digital multimeter to measure the voltage between the VGT actuator SUPPLY pin and the VGT actuator RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than 10 VDC?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 G CM2180 EJ | 4310682
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 M2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISV5.0 CM3230 V104 | 4367291
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISL G CM2180 | 4021649
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B142 | 5411131
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411330
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B135B | 5411257
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B148B | 5411262
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332541
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411189
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1843 and 1844. | Fault Code 1843 or 1844 active?
 | STEP 1B. Check the oil fill cap. | Oil fill cap properly installed?
 | STEP 1C. Check the crankcase filter tube, if equipped. | Crankcase breather hose connected properly and free of restrictions?
 | STEP 1D. Check the crankcase breather element, if equipped. | Crankcase breather element installed correctly?
 | STEP 1E. Check the mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below maintenance interval?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1844 active?
 | STEP 3C. Check the circuit response. | Fault Code 1843 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the oil fill cap.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fill cap.

  • Check the oil fill cap for proper installation.

Oil fill cap properly installed?
YES NO
No Repair

Install the oil fill cap properly.

Go to 1C

Go to 1C

Guided Step 1C - Check the crankcase filter tube, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Skip to Step 1D, if the engine is not equipped with a crankcase filter tube.

Action

Check the crankcase breather tube between the engine and the crankcase filter assembly.

Make sure the breather tube is properly connected and there are no kinks or other restrictions present.

Crankcase breather hose connected properly and free of restrictions?
YES NO
No Repair

Properly connect the crankcase breather hose.

Go to 1D

Go to 4A

Guided Step 1D - Check the crankcase breather element, if equipped.

Conditions

  • Turn keyswitch OFF.

Action

Check that the crankcase breather element is correctly installed.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Crankcase breather element installed correctly?
YES NO
No Repair

Install the crankcase breather element correctly.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 1E

Repair complete.

Guided Step 1E - Check the mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate the maintenance record (miles/hours) of the latest crankcase breather filter replacement.

Action

Check the filter maintenance record.

  • Check the mileage/hours on the crankcase breather filter since the last maintenance.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather filter.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

An in-range malfunction of the crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin on the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 1961 - EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM). |
 | STEP 1A. Check the ECM. | Fault Code 1961 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1961. | Less than 5 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF.
  • Start the engine and let it idle for 1 minute.

Fault Code 1961 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1961.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 1961.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1961.

Less than 5 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-May-2017


FAULT CODE 1962 - VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2250 | 4022254
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 | 4022255
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 EC | 2883621
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL8.9 CM2220 SN | 4022190
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL9 CM2350 L101 | 4310787
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2250 | 4022256
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX12 CM2350 X102 | 4310646
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISX15 CM2350 X101 | 4310641
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2250 ECF | 2883557
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L102 | 4332796
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISL9 CM2350 L111 | 4367223
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L107 | 4367386
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2250 L115 | 4388626
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L118 | 4388673
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2250 X115 | 4388739
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B4.5 CM2350 B129B | 5411247
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B6.7 CM2350 B135B | 5411257
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B4.5 CM2350 B147B | 5411252
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | B6.7 CM2350 B148B | 5411262
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSL9 CM2350 L122 | 5411278
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | L9 CM2350 L119B | 5411267
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the variable geometry turbocharger (VGT) actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature active or high count or inactive coolant temperature related faults?
 | STEP 1B. Inspect VGT actuator coolant lines. | Blockages found in the VGT actuator cooling plate or coolant lines?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the VGT actuator cooling system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
YES NO

The VGT actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Inspect VGT actuator coolant lines.

Action

Inspect the VGT actuator coolant lines for kinks and blockages.

  • Blow shop air in reverse flow through the VGT actuator cooling plate and associated coolant lines to check blockages.

Blockages found in the VGT actuator cooling plate or coolant lines?
YES NO

Repair or replace the blocked coolant line.

  • Refer to Procedure 010-041 in the Associated Procedures Table.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 1974 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 EC | 4310575
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather (Internal) | Refer to Procedure 003-002 | ISB6.7 CM2350 B103 | 4332641
Crankcase Breather (Internal) | Refer to Procedure 003-002 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 | 4022255
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 EC | 2883621
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 EC | 4310575
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B105 | 4332778
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 1974?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Check mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2B. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, valves, breather tube, or oil separator plugged?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1974 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Check mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate maintenance record (miles/hours) of latest crankcase breather filter replacement.

Action

Check mileage/hours on the crankcase breather filter since last maintenance.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine applications.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather element.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-002 in the Associated Procedures Table.
  • Refer to Procedure 003-019 in the Associated Procedures Table.

Replace the crankcase breather element.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 2198 - VGT Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.6 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 or 1894 active?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2636 or 1894 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2198 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2198 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES | NO
No Repair | No Repair

Fault Code 2636 or 1894 troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 2273 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2273 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related ti this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2274 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2274 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2274 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2288 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X105 | 4332667
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X106 | 4332712
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B105 | 4332778
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L102 | 4332796
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X105 | 4332667
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X106 | 4332712
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F105 | 4358561
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B106 | 4367376
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F114 | 4383734
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F131 | 5411489
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B130 | 4388668
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L118 | 4388673
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F118 | 4388708
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F119 | 4388703
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B122 | 4388767
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L122 | 5411278
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2350 B144 | 5411382
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B145 | 5411273
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F124 | 5411484
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2350 F125 | 5411494
Fuel Pump Actuator | Refer to Procedure 019-117 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2311 active?
 | STEP 1B. Read the fault codes. | Active or inactive counts of Fault Code 271 or 272?
STEP 2. | Check the fuel pump actuator. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Between 1 and 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Between 1 and 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Code 2311, 271, and/or 272 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 271 or 272?
YES NO

Troubleshoot Fault Code 271 or 272 first.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1 and 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Code 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness or fuel pump actuator connector and/or pins. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 2346 - Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2346 active or high inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 active or high inactive counts?
YES NO

The engine power output was derated to limit the exhaust temperatures. This is normal operation. No repairs are necessary.

 No Repair

Reference Fault Code 2451 troubleshooting procedures.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2349 - EGR Valve Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B105 | 4332778
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L102 | 4332796
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L107 | 4367386
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 X105 | 4332798
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 X106 | 4332712
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B112 | 4358498
EGR Valve | Refer to Procedure 011-022 | QSF2.8 CM2880 F105 | 4358563
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F107 | 4367316
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B106 | 4367376
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B130 | 4388668
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L118 | 4388673
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F118 | 4388708
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F119 | 4388703
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332798
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358563
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X105 | 4332798
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X106 | 4332712
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358563
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR motor circuit fault codes. | Fault Code 2349 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR motor. | Any measurements greater than 5 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2349 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the EGR motor supply and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 2349 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Check the EGR motor supply and return circuit.

Note: All measurements are to be made on the EGR motor, not the wiring harness.

  • Measure the resistance from the EGR motor SUPPLY A pin to the EGR motor SUPPLY B pin at the EGR motor connector.
  • Measure the resistance from the EGR motor SUPPLY A pin to the EGR motor SUPPLY C pin at the EGR motor connector.
  • Measure the resistance from the EGR motor SUPPLY B pin to the EGR motor SUPPLY C pin at the EGR motor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Any measurements greater than 5 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

An open circuit has been detected in the EGR valve motor.

Replace the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the EGR motor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the EGR motor supply and return circuit.

Note: All measurements are to be made on the wiring harness, not the ECM.

  • Measure the resistance from the EGR motor SUPPLY A pin at the EGR motor engine harness connector to the EGR motor SUPPLY A pin at the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY B pin at the EGR motor engine harness connector to the EGR motor SUPPLY B pin at the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY C pin at the EGR motor engine harness connector to the EGR motor SUPPLY C pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2016


FAULT CODE 2353 - EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B105 | 4332778
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L102 | 4332796
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L107 | 4367386
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 X105 | 4332667
EGR Valve | Refer to Procedure 011-022 | QSX15 CM2350 X106 | 4332712
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B112 | 4358498
EGR Valve | Refer to Procedure 011-022 | QSF2.8 CM2880 F105 | 4358561
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F107 | 4367316
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B106 | 4367376
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B130 | 4388668
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L118 | 4388673
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F118 | 4388708
EGR Valve | Refer to Procedure 011-022 | QSF3.8 CM2350 F119 | 4388703
EGR Valve | Refer to Procedure 011-022 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X105 | 4332667
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X106 | 4332712
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR motor circuit fault codes. | Fault Code 2353 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR motor. | Greater than 100k ohms??
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 2353 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2353 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR motor.

  • Measure the resistance from the EGR motor SUPPLY A pin at the EGR motor connector to block ground.
  • Measure the resistance from the EGR motor SUPPLY B pin at the EGR motor connector to block ground.
  • Measure the resistance from the EGR motor SUPPLY C pin at the EGR motor connector to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the EGR valve motor.

  • Replace the EGR valve. Refer to Procedure 011-022 the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR valve from the engine harness.

Action

Check the EGR motor supply pins for a short circuit to ground.

  • Measure the resistance from the EGR motor SUPPLY A pin at the EGR motor engine harness connector to block ground.
  • Measure the resistance from the EGR motor SUPPLY B pin at the EGR motor engine harness connector to to block ground.
  • Measure the resistance from the EGR motor SUPPLY C pin at the EGR motor engine harness connector to block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR valve from the engine harness.

Action

Check the EGR motor supply pins for a pin-to-pin short.

  • Measure the resistance from the EGR motor SUPPLY A pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY B pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY C pin at the ECM connector to all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2353 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2016


FAULT CODE 2373 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119 | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332968
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to the Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2374 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM3250 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM3250 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2250 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM3250 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP :1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2375 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2250 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F017 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2220 F103 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2250 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 43332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2250 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L102 | 4332796
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F107 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F114 | 4383734
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2375 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2376 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V102102 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2220 F103 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F017 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EFR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123 | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2376 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310849
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10 ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 5 VDC?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the OEM harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Use the following procedure for the ISF2.8 CM2220 E, ISF2.8 CM2220 EN, ISF2.8 CM2220 IAN engines: Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 | ISZ13 CM2150 | 4022133
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | ISB/ISD4.5 CM2150 B119 | 4358465
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2150 B120 | 4358470
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 L110 | 4358475
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F110 | 4358480
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 2448 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Mar-2017


FAULT CODE 2554 - Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F101 | 4310846
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F117 | 4388578
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F126 | 5411159
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2250 | 4022254
Turbocharger | Refer to Procedure 010-033 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger | Refer to Procedure 010-033 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 | 4022256
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 | 4022255
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 EC | 2883621
Turbocharger | Refer to Procedure 010-033 | QSX11.9 CM2250 ECF | 2883561
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 ECF | 2883557
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B101 | 2883567
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L101 | 4310787
Turbocharger | Refer to Procedure 010-033 | ISX12 CM2350 X102 | 4310646
Turbocharger | Refer to Procedure 010-033 | ISX15 CM2350 X101 | 4310641
Turbocharger | Refer to Procedure 010-033 | ISB4.5 CM2350 B104 | 4332646
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B103 | 4332641
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B105 | 4332778
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L102 | 4332796
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B112 | 4358498
Turbocharger | Refer to Procedure 010-033 | ISL9 CM2350 L111 | 4367223
Turbocharger | Refer to Procedure 010-033 | QSF3.8 CM2350 F107 | 4367316
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F101 | 4310846
Turbocharger | Refer to Procedure 010-033 | QSG12 CM2350 G110 | 4367323
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F117 | 4388578
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2250 B128 | 4388601
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2250 L115 | 4388626
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B130 | 4388668
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L118 | 4388673
Turbocharger | Refer to Procedure 010-033 | ISB6.7 CM2350 B142 | 5411131
Turbocharger | Refer to Procedure 010-033 | ISF2.8 CM2220 F126 | 5411159
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X114B | 5411181
Turbocharger | Refer to Procedure 010-033 | X15 CM2350 X116B | 5411186
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B121B | 5411223
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2250 X115 | 4388739
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L116B | 5411330
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B129B | 5411247
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B135B | 5411257
Turbocharger | Refer to Procedure 010-033 | B4.5 CM2350 B147B | 5411252
Turbocharger | Refer to Procedure 010-033 | B6.7 CM2350 B148B | 5411262
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L119B | 5411267
Turbocharger | Refer to Procedure 010-033 | L9 CM2350 L123B | 5411465
Turbocharger | Refer to Procedure 010-033 | QSB4.5 CM2350 B106 | 4367376
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B145 | 5411273
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L122 | 5411278
Turbocharger | Refer to Procedure 010-033 | QSB4.5 CM2350 B144 | 5411382
Turbocharger | Refer to Procedure 010-033 | QSX15 CM2350 X118 | 5467247
Turbocharger | Refer to Procedure 010-033 | QSG12 CM2350 G113 | 5467252
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | QSG12 CM2350 G110 | 4367323
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | QSG12 CM2350 G113 | 5467252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB4.5 CM2350 B104 | 4332646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F117 | 4388578
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F126 | 5411159
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | CM2350 L119B | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB4.5 CM2350 B106 | 4367376
Turbocharger, Variable Flow | Refer to Procedure 010-148 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSF3.8 CM2350 F107 | 4367316
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
465Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2373 and 2374. | Fault Code 2373 or 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the exhaust gas pressure sensor tube. |
 | STEP 4A. Check the exhaust gas pressure sensor tube. | Plugging or damage found on the exhaust gas pressure sensor tube?
STEP 5. | Check the variable flow turbocharger actuator motor and circuit. |
 | STEP 5A. Inspect the variable flow turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the turbocharger variable flow for binding. | Turbocharger, variable flow linkage bent or is the turbocharger variable flow pivot arm binding or seized?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2373 and 2374.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 or 2374 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas pressure sensor from the engine harness

Action

Check for an open circuit

  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the ECM connector and the SUPPLY pin at the exhaust gas pressure sensor connector.
  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the ECM connector and the SIGNAL pin at the exhaust gas pressure sensor connector.
  • Measure the resistance between the exhaust gas pressure sensor RETURN pin at the ECM connector and the RETURN pin at the exhaust gas pressure sensor connector.

Use a circuit or wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin in the ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin in the ECM connector and ground.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the exhaust gas pressure sensor tube.

Guided Step 4A - Check the exhaust gas pressure sensor tube.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

Action

Check the exhaust gas pressure sensor tube.

Inspect the inside of the tube. If clogged, use compressed air to remove debris or soot buildup.

Check the tube for cracks and thread damage. Replace the tube if cracks or damage are found. Refer to Procedure 011-027 in the Associated Procedures Table.

Plugging or damage found on the exhaust gas pressure sensor tube?
YES NO

Clean or replace the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the variable flow turbocharger actuator motor and circuit.

Guided Step 5A - Inspect the variable flow turbocharger actuator motor and connector

Conditions

  • Turn keyswitch OFF
  • Disconnect the variable flow turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable flow turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damage pins

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the turbocharger variable flow for binding.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger, variable flow linkage from the turbocharger, variable flow actuator.

Action

Inspect the variable flow turbocharger actuator.

  • Inspect the turbocharger, variable flow linkage and actuator arm for debris that could cause binding.
  • Move the turbocharger, variable flow pivot arm on the turbocharger assembly to check for binding/seizure.

Is the turbocharger, variable flow linkage bent or is the turbocharger, variable flow pivot arm binding or seized?
YES NO

Replace the turbocharger, variable flow assembly. Refer to Procedure 010-148 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 11-May-2017


FAULT CODE 2555 - Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 100 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, supply wire, and return circuit. | Greater than 3.75 VDC?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

For 12 volt systems, both relays must be checked.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay SIGNAL wire and the intake air heater relay RETURN wire at the intake air heater relay connector of the OEM harness.

For 12 volt systems, both leads must be tested.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

For 12 volt systems, both leads must be tested.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay signal; circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 06-May-2017


FAULT CODE 2556 - Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM3250 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 active and Fault Code 2556 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 active and Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 active?
YES NO

A damaged intake air heater relay has been detected.

Replace the intake air heater relay. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

For 12 volt systems, both leads must be tested.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the intake air heater relay wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 06-May-2017


FAULT CODE 2635 - VGT Actuator Driver Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.3 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2150 SN | 4022190
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISF2.8 CM2220 F101 | 4310846
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L119B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | ECM code correct for the engine control parts list (CPL)?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

ECM code correct for the engine control parts list (CPL)?
YES NO

An incorrect variable geometry turbocharger actuator for the voltage application has been detected.

Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Download the correct ECM code for the engine CPL.

2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2646 - Engine Coolant Temperature - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2646 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2646 active?
YES NO

The exhaust gas recirculation (EGR) valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Feb-2014


FAULT CODE 2961 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X105 | 4332667
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X106 | 4332712
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B105 | 4332778
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L102 | 4332796
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B112 | 4358498
Air Intake Connection | Refer to Procedure 010-080 | QSF3.8 CM2350 F107 | 4367316
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B130 | 4388668
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L118 | 4388673
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B105 | 4332778
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L102 | 4332796
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L107 | 4367386
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L107 | 4367386
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2350 X105 | 4332667
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2350 X106 | 4332712
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B112 | 4358498
EGR Cooler | Refer to Procedure 011-019 | QSF3.8 CM2350 F107 | 4367316
EGR Cooler | Refer to Procedure 011-019 | QSB4.5 CM2350 B106 | 4367376
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B130 | 4388668
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L118 | 4388673
EGR Cooler | Refer to Procedure 011-019 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X105 | 4332667
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X106 | 4332712
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSF3.8 CM2350 F107 | 4367316
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B122 | 4388767
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2350 X105 | 4332667
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2350 X106 | 4332712
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367387
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2350 X105 | 4332667
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2350 X106 | 4332712
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L102 | 4332796
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2350 X105 | 4332667
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2350 X106 | 4332712
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F107 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2961?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2961?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Refer to Procedure 008-018 in the Associated Procedures Table.
  • Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX12, ISX11.9, and ISX15 engines: Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX12, ISX11.9, and ISX15 engines: Refer to Procedure 011-066 in the Associated Procedures Table.

Clean the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. THe ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jan-2016


FAULT CODE 2962 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4332796
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X105 QSX15 CM2350 X106 | 4332667 4332712
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B105 | 4332778
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L102 | 4332796
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B112 | 4358498
Air Intake Connection | Refer to Procedure 010-080 | QSF3.8 CM2350 F107 | 4367316
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B130 | 4388668
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L118 | 4388673
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B105 | 4332778
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L102 | 4332796
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L107 | 4367386
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2350 X105 | 4332667
EGR Cooler | Refer to Procedure 011-019 | QSX15 CM2350 X106 | 4332712
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B112 | 4358498
EGR Cooler | Refer to Procedure 011-019 | QSF3.8 CM2350 F107 | 4367316
EGR Cooler | Refer to Procedure 011-019 | QSB4.5 CM2350 B106 | 4367376
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B130 | 4388668
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L118 | 4388673
EGR Cooler | Refer to Procedure 011-019 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L107 | 4332796
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X105 | 4332667
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSX15 CM2350 X106 | 4332712
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSF3.8 CM2350 F107 | 4367316
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB4.5 CM2350 B122 | 4388767
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2350 X105 | 4332667
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2350 X106 | 4332712
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2350 X105 | 4332667
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2350 X106 | 4332712
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L102 | 4332796
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2350 X105 | 4332667
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2350 X106 | 4332712
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F107 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2962?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2962?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature sensor.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

NOTE: Low engine coolant level may cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For engines:ISX12/ISX11.9 and ISX15engines. Refer to Procedure 019-370 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB6.7, ISC8.3, and ISL9 engines: Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX12/ISX11.9 and ISX15 engines: Refer to Procedure 019-370 in the Associated Procedures Table.

Clean the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jan-2016


FAULT CODE 3326 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3326 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Feb-2017


FAULT CODE 3328 - Transmission Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Reference Service Bulletin Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have ben completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3385 - Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X105 | 4332667
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X106 | 4332712
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Monitor intake manifold temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

The EGR valve was closed because the engine was operating with cold intake manifold temperatures for an extended period of time.

No repair is necessary.

Replace the intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jan-2017


FAULT CODE 3497 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3497 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3497 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 3498 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3498 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3498 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 3539 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L11 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3539 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 inactive and Fault Code 3541 active?
 | STEP 2C. Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the engine intake throttle actuator position sensor supply and return circuit at the ECM. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 3539 inactive and Fault Code 3541 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the engine intake throttle actuator connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position +5 VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator position 5 VDC SUPPLY pin and the engine intake throttle actuator position return at the ECM port.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM engine connector.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3541 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L111 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411186
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3541 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 active and Fault Code 3541 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3541 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins.. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and engine intake throttle actuator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake throttle actuator position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator +5 VDC position SUPPLY pin and the engine intake throttle actuator position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3545 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK19 CM2350 K105 | 4326157
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK50 CM2350 K108 | 4332823
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K116 | 4367444
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K117 | 4367449
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K121 | 4388645
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B X15 CM2350 X116B | 5411181 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1887, 2771, or 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3545 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771 or 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3545 active?
YES NO

An internal error has been detected in the aftertreatment outlet nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3547 - Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3547 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3547 active?
YES NO

Diesel exhaust fluid (DEF) has not been detected in the DEF tank.

Add DEF to the DEF tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Sep-2015


FAULT CODE 3555 - Engine Wait to Start Lamp - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with the INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with the INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3555 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3555 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

–

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Refer to Multiplexing Troubleshooting, Bulletin 4021378.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.
  • Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Appropriate ECM No Communication troubleshooting symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 3583 - Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2880 L112 | 4358493
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 F110 | 4358483
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 L110 | 4358478
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD6.7 CM2150 B120 | 4358473
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD4.5 CM2150 B119 | 4354868
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B X15 CM2350 X116B | 5411181 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3583 active?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of Fault Code 1887, 2771, or 3681?
 | STEP 1C. Check for active fault codes. | Fault Code 3144, 3146, 3147, or 3148 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3583 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1887, 2771, or 3681?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3144, 3146, 3147, or 3148 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreament outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment outlet NOx sensor heater has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3649 - Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3649 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1885, 3232, or 3682 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 3313, 3314, or 3315 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3649 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3313, 3314, or 3315 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON, while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment intake NOx sensor heater has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3681 - Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
 | STEP 2F. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt system)
  • At least +24 VDC (24 volt system).

Cranking conditions:

  • At least +6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery (s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-May-2017


FAULT CODE 3682 - Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
 | STEP 2F. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3682 active?
YES NO

No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

the wiring diagram for connector pin identification.

Use the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment intake NOx sensor.

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 FDC (12 volt system)
  • At least +24 VDC (24 volt system)/

Cranking conditions:

  • At least _6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
5467376Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module. | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2350 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the engine control module (ECM).

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 22-May-2017


FAULT CODE 3717 - Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 X101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK19 CM2350 K105 | 4326157
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK50 CM2350 K108 | 4332823
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K116 | 4367444
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K117 | 4367449
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K121 | 4388645
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check the aftertreatment outlet NOx sensor. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
 | STEP 2C. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3717 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3717 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter setting.

  • Use INSITE™ electronic tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify the aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

The aftertreatment outlet NOx sensor is available in 12 or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch ON.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3717 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Note: The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3718 - Aftertreatment 1 Intake NOx - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3718 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor the correct sensor for the engine CPL?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3718 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3718 active?
YES NO

No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment intake NOx sensor.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment intake NOx sensor

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

An incorrect aftertreatment outlet NOx sensor for the voltage application has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3718 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3724 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM). | Fault Code 3724 active?
 | STEP 1B. Check the inactive counts of Fault Code 3724. | Less than three counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.

Start the engine and let it idle for 1 minute.

Fault Code 3724 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the inactive counts of Fault Code 3724.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 3724.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 3724.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2017


FAULT CODE 3725 - Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.3 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2250 | 4022256
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2250 | 4022255
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1885, 3232, or 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3725 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1885, 3232 or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3725 active?
YES NO

An internal error has been detected in the aftertreatment intake mono-nitrogen oxide (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 3867 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B105 | 4332778
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L102 | 4332796
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F107 | 4367316
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B106 | 4367376
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F118 | 4388708
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B130 | 4388668
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B122 | 4388767
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3867. | Fault Code 3867 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3867.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3867 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table. For B6.7 CM2350 B121B, ISB6.7 CM2350 B101, ISL9 CM2350 L101, and ISV5.0 CM3230 V104 engines, see equipment manufacturer service information.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to

Last Modified: 09-Jan-2017


FAULT CODE 3876 - Aftertreatment Diesel Exhaust Fluid Quality Sensor - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3876 active?
 | STEP 1B. Check for active fault codes. | Fault codes for DEF level active?
STEP 2. | Check the aftertreatment DEF quality sensor. |
 | STEP 2A. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quailty sensor properly installed?
 | STEP 2B. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quality sensor meets the inspection criteria?
 | STEP 2C. Inspect the aftertreatment DEF quality sensor. | Fault Code 3876 active?
 | STEP 2D. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3876 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes for DEF level active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF quality sensor.

Guided Step 2A - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF quality sensor.

  • Check to make sure the aftertreatment DEF quality sensor is properly installed.
  • Refer to the original equipment manufacturer (OEM) service manual.

Aftertreatment DEF quality sensor properly installed?
YES NO
No Repair

Drain the DEF fluid tank and fill with new DEF.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF quality sensor.

  • Inspect the aftertreatment DEF quality sensor for crystallization or debris. Refer to Procedure 019-475 in the Associated Procedures Table.

Aftertreatment DEF quality sensor meets the inspection criteria?
YES NO
No Repair

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Place the aftertreatment DEF quality sensor in a beaker of new DEF. Refer to Procedure 019-475 in the Associated Procedures Table.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3876 active?
YES NO

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the DEF for contamination.

Conditions

  • Check the DEF for contamination.

Action

Check the DEF in the tank for contamination, water, or incorrect fluid.

  • Use the DEF refractometer, Part Number 4919318, to check the DEF concentration.
  • Inspect the DEF for contamination.

DEF contaminated?
YES NO

Empty and clean the DEF tank.

Refill the tank with new DEF.

Continue to investigate the cause of contamination.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3877 - Aftertreatment Diesel Exhaust Fluid Quality Sensor - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3877 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) quality sensor. |
 | STEP 2A. Inspect the aftertreatment DEF quality sensor. | Aftertreatment DEF quality sensor meets inspection criteria?
 | STEP 2B. Check for active fault codes. | Fault Code 3877 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3877 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Guided Step 2A - Inspect the aftertreatment DEF quality sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF quality sensor.

Action

Inspect the aftertreatment DEF quality sensor.

  • Inspect the aftertreatment DEF quality sensor for damage or debris. Refer to Procedure 019-475 in the Associated Procedures Table.

Aftertreatment DEF quality sensor meets inspection criteria?
YES NO

Clean the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for active fault codes.

Conditions

  • Install the aftertreatment DEF quality sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3877 active?
YES NO

An internal error has been detected in the aftertreatment DEF quality sensor.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 3878 - Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3878. | Fault Code 3878 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the aftertreatment DEF concentration. | Aftertreatment DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3878.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3878 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.
  • See equipment manufacturer service information for B6.7 CM2350 B121B, ISB6.7 CM2350 B101, ISL9 CM2350 L101, ISX15 CM2350 X101, ISX12 CM2350 X102, and ISV5.0 CM3230 V104 products.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4164 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12 CM2350 X102 | 4310646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L102 | 4332796
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L111 | 4367223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSG12 CM2350 G110 | 4367323
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L118 | 4388673
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B121B | 5411223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X114B | 5411181
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X116B | 5411186
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | F3.8 CM2350 F120B | 5411237
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B129B | 5411247
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B135B | 5411257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B147B | 5411252
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B148B | 5411262
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L119B | 5411267
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4164 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage greater than 18 volts of direct current (VDC)? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment SCR temperature sensor module. | Aftertreatment SCR temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment SCR temperature sensor module. | Fault Code 4164 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery. | Voltage greater than 18 VDC? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
 | STEP 3B. Check for a short circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage greater than 18 VDC? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4164 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.
  • Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 18 volts of direct current (VDC)? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.
  • To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment SCR temperature sensor module.

Action

Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

  • The aftertreatment SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment SCR temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR temperature sensor module
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4164 active?
YES NO

A malfunctioning aftertreatment SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the voltage of the battery.

Voltage greater than 18 VDC? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
YES NO

Troubleshoot the cause of the overcharging condition.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for a short circuit

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage greater than 18 VDC? (For 12 VDC systems) Voltage greater than 30 VDC? (For 24 VDC systems)
YES NO

A short circuit to battery has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 4165 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12 CM2350 X102 | 4310646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L102 | 4332796
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L111 | 4367223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSG12 CM2350 G110 | 4367323
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L118 | 4388673
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B121B | 5411223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X114B | 5411181
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X116B | 5411186
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | F3.8 CM2350 F120B | 5411237
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B129B | 5411247
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B135B | 5411257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B147B | 5411252
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B148B | 5411262
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L119B | 5411267
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4165 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage less than 6 -volts of direct current (VDC)? (For 12 VDC systems) Voltage less than 18 VDC? (For 24 VDC systems)
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment SCR temperature sensor module. | Aftertreatment SCR temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment SCR temperature sensor module. | Fault Code 4165 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage less than 6 VDC? (For 12 VDC systems) Voltage less than 18 VDC? (For 24 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4165 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.
  • Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 volts of direct current (VDC)? (For 12 VDC systems) Voltage less than 18 VDC? (For 24 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.
  • To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment SCR temperature sensor module.

Action

Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

  • The aftertreatment SCR temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment SCR temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4165 active?
YES NO

A malfunctioning aftertreatment SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC? (For 12 VDC systems) Voltage less than 18 VDC? (For 24 VDC systems)
YES NO

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 4166 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Heat Shield | Refer to Procedure 011-032 | ISB4.5 CM2350 B104 | 4332646
Heat Shield | Refer to Procedure 011-032 | ISB6.7 CM2350 B101 | 2883567
Heat Shield | Refer to Procedure 011-032 | ISB6.7 CM2350 B103 | 4332641
Heat Shield | Refer to Procedure 011-032 | ISL9 CM2350 L101 | 4310787
Heat Shield | Refer to Procedure 011-032 | ISX12 CM2350 X102 | 4310646
Heat Shield | Refer to Procedure 011-032 | ISX15 CM2350 X101 | 4310641
Heat Shield | Refer to Procedure 011-032 | QSB6.7 CM2350 B105 | 4332778
Heat Shield | Refer to Procedure 011-032 | QSL9 CM2350 L102 | 4332796
Heat Shield | Refer to Procedure 011-032 | ISL9 CM2350 L111 | 4367223
Heat Shield | Refer to Procedure 011-032 | QSB6.7 CM2350 B112 | 4358498
Heat Shield | Refer to Procedure 011-032 | QSF3.8 CM2350 F107 | 4367316
Heat Shield | Refer to Procedure 011-032 | QSB4.5 CM2350 B106 | 4367376
Heat Shield | Refer to Procedure 011-032 | QSL9 CM2350 L107 | 4367386
Heat Shield | Refer to Procedure 011-032 | QSB6.7 CM2350 B130 | 4388668
Heat Shield | Refer to Procedure 011-032 | QSL9 CM2350 L118 | 4388673
Heat Shield | Refer to Procedure 011-032 | QSF3.8 CM2350 F118 | 4388708
Heat Shield | Refer to Procedure 011-032 | QSB4.5 CM2350 B122 | 4388767
Heat Shield | Refer to Procedure 011-032 | ISB6.7 CM2350 B142 | 5411131
Heat Shield | Refer to Procedure 011-032 | B4.5 CM2350 B129B | 5411247
Heat Shield | Refer to Procedure 011-032 | B6.7 CM2350 B135B | 5411257
Heat Shield | Refer to Procedure 011-032 | B4.5 CM2350 B147B | 5411252
Heat Shield | Refer to Procedure 011-032 | B6.7 CM2350 B148B | 5411262
Heat Shield | Refer to Procedure 011-032 | L9 CM2350 L119B | 5411267
Heat Shield | Refer to Procedure 011-032 | L9 CM2350 L123B | 5411465
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12 CM2350 X102 | 4310646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L102 | 4332796
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L111 | 4367223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSG12 CM2350 G110 | 4367323
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L118 | 4388673
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB4.5 CM2350 B122 | 4388708
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B121B | 5411223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X114B | 5411181
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | X15 CM2350 X116B | 5411186
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | F3.8 CM2350 F120B | 5411237
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B129B | 5411247
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B135B | 5411257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B147B | 5411252
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L119B | 5411267
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4166 active or more than three inactive counts?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module. |
 | STEP 2A. Make sure that the aftertreatment SCR temperature sensor module is properly mounted. | Aftertreatment SCR temperature sensor module properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment SCR temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4166 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module.

Guided Step 2A - Make sure that the aftertreatment SCR temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating

Action

Verify the aftertreatment SCR temperature sensor module is properly mounted.

  • Verify the module is mounted correctly. Refer to Procedure 019-449 in the Associated Procedures Table.
  • Verify the proper heat shield is mounted over the temperature sensor module. Refer to Procedure 011-032 in the Associated Procedures Table.

QSG12 CM2350 G110 does not use a heat shield.

Aftertreatment SCR temperature sensor module properly installed?
YES NO
No Repair

  • Relocate and/or secure the aftertreatment SCR temperature sensor module at the correct mounting location. Refer to Procedure 019-449 in the Associated Procedures Table.
  • Install the heat shield. Refer to Procedure 011-032 in the Associated Procedures Table.

QSG12 CM2350 G110 does not use a heat shield.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating.

Action

Check the aftertreatment SCR temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

No Repair

Go to 3A

Repair complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4168 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSX15 CM2350 X105 | 4332667
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSX15 CM2350 X106 | 4332712
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4168 active?
 | STEP 1B. Check for active fault codes. | Fault Code 2976, 4155, or 4156 active or any inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit heater relay circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit heater relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for pin-to-pin short circuit in the aftertreatment DEF dosing unit heater relay. | Greater than 100k ohms?
 | STEP 2C. Check for pin-to-ground short in the aftertreatment DEF dosing unit heater relay circuit. | Greater than 100k ohms?
STEP 3. | Check the aftertreatment DEF dosing unit heater supply circuit. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin-to-pin short in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4168 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976, 4155, or 4156 active or any inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit heater relay circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Inspect the aftertreatment DEF dosing unit heater relay and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for pin-to-pin short circuit in the aftertreatment DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Check the resistance of the aftertreatment DEF dosing unit heater relay.

  • Measure the resistance between pin 30 and pin 87 of the aftertreatment DEF dosing unit heater relay.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the switch side of the aftertreatment DEF dosing unit heater relay has been detected.

Replace the aftertreatment DEF dosing unit heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for pin-to-ground short in the aftertreatment DEF dosing unit heater relay circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-ground short in the aftertreatment DEF dosing unit heater relay circuit.

  • Measure the resistance between pin 86 at the aftertreatment DEF dosing unit heater relay connector and chassis ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the OEM harness has been detected.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing unit supply circuit.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the aftertreatment DEF dosing unit and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for pin-to-pin short in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin to pin short in the aftertreatment DEF dosing unit heater supply circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater supply at the aftertreatment DEF dosing unit connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning aftertreatment DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit in the OEM harness has been detected.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-May-2017


FAULT CODE 4241 - Aftertreatment Diesel Exhaust Fluid Quality - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4241 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration udate for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4241 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the accelerator pedal or lever idle validation switch or OEM vehicle electronic control unit.

Refer to the OEM service manual.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair Complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 4277 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISF3.8 CM2350 F109 | 4367318
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4277. | Fault Code 4277 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Inspect aftertreatment DEF tank for contamination. | Foreign objects or debris detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration within 32.5 percent ± 1.5 percent?
 | STEP 2C. Check for low DEF tank level. |
 | STEP 2D. Check for Fault Code 4277. |
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4277.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4277 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for foreign objects or debris.

Foreign objects or debris detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF Cummins® refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 percent ± 1.5 percent?
YES NO
No Repair

Drain the DEF tank and fill with new DEF.

Go to 2C

Go to 3A

Guided Step 2C - Check for low DEF tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank level.

  • Check that tank level is at least 50 percent.

Tank level is less than 50 percent?
YES NO

Fill tank completely with fresh DEF.

 No Repair

Go to 2D

Go to 2D

Guided Step 2D - Check for Fault Code 4277.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Wait 5 minutes.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4277 active?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps haven been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 12-Jun-2017


FAULT CODE 4517 - Vehicle Identification Number - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4517 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the engine control module (ECM) calibration for a vehicle identification number. |
 | STEP 2A. Check for a vehicle identification number in the ECM. | Vehicle identification number present?
STEP 3. | Check the ECM calibration for a vehicle identification number. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4517 active or inactive with more than one count logged in the last engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM calibration for a vehicle identification number.

Guided Step 2A - Check for a vehicle identification number in the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a vehicle identification number under the vehicle/original equipment manufacturer (OEM) information in the system ID and Dataplate section of Features and Parameters in INSITE™ electronic service tool.

–

Vehicle identification number present?
YES NO
No Repair

Enter the vehicle identification number into the appropriate field.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 4585 - Aftertreatment 1 SCR Catalyst System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9 CM2350 L101 | 4310787
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12 CM2350 X102 | 4310646
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX15 CM2350 X101 | 4310641
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK19 CM2350 K105 | 4326157
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L102 | 4332796
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK50 CM2350 K108 | 4332833
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9 CM2350 L111 | 4367223
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK50 CM2350 K108 | 4332823
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK19 CM2350 K105 | 4326157
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K116 | 4367444
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K117 | 4367449
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSG12 CM2350 G110 | 4367323
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L107 | 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L118 | 4388673
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | L9 CM2350 L123B | 5411465
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K121 | 4388645
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | X15 CM2350 X114B | 5411181
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | X15 CM2350 X116B | 5411186
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does one of the scenarios apply?"
 | STEP 1B. Check for active fault codes. | Fault Code 4585 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Determine if the calibration and selective catalytic reduction (SCR) are compatible.

The following scenarios that can lead to Fault Code 4585 coming active. Below are the listed scenarios and solutions:

1. A calibration has been transferred to an ECM that has under 50 hours of cumulative Engine Run Time

  • Follow Repair 1 directions.

2. A calibration has been transferred to an ECM after an ECM ROM Boot

  • Follow Repair 2 directions.

3. A calibration has been transferred to the new ECM after an ECM replacement

  • Follow Repair 2 directions.

4. Save and Restore doesn’t perform correctly during calibration transfer, Engine Run Time is under 50 hours

  • Follow Repair 2 directions.

5. Save and Restore doesn’t perform correctly during calibration transfer, Engine Run Time is over 50 hours

  • Follow Repair 3 directions.

Does one of the scenarios apply?
YES NO

Repair 1:

  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.

Repair 2:

  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.
  • Transfer template to ECM. Verify information has been transferred correctly.

Repair 3:

  • ROM Boot the ECM and transfer the calibration.
  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.
  • Transfer template to ECM. Verify information has been transferred correctly.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4585 active?
YES NO

This fault code indicates that the incorrect aftertreatment selective catalytic reduction system has been installed with the engine.

Verify the correct aftertreatment selective catalytic reduction system has been installed with the engine.

If the incorrect aftertreatment selective catalytic reduction system has been installed, replace it with the correct aftertreatment selective catalytic reduction system. Refer to procedure 011-036 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 4768 - Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B105 | 4332778
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L102 | 4332796
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F107 | 4367316
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B106 | 4367376
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F118 | 4388708
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B130 | 4388668
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B122 | 4388767
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4768. | Fault Code 4768 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the aftertreatment DEF for contamination and concentration. | DEF concentration within 32.5 ± 1.25 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4768.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4768 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF for contamination and concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel. Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

Diesel contamination may damage the DEF quality sensor.

Replace the DEF quality sensor. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. See equipment manufacturer service information.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to

Last Modified: 08-Jan-2017


FAULT CODE 4769 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4769 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 4679, 4732, 4738, or 4739 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4769 active?
YES NO

An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 4863 - Aftertreatment SCR Operator Inducement Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4863 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4863.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 4863 active?
YES NO

This is an information-only fault code that will only become active if other critical selective catalytic reduction (SCR) fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2013


FAULT CODE 4956 - Variable Geometry Turbocharger Actuator Software - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L101 | 4310789
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L102 | 4332796
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L111 | 4367223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L107 | 4367386
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L1118 | 4388673
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B121B | 5411223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L116B | 5411330
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X114B | 5411181
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X116B | 5411186
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISX12 CM2350 X102 | 4310646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSX15 CM2350 X105 | 4332667
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L122 | 5411278
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B129B | 5411247
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B135B | 5411257
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B147B | 5411252
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B148B | 5411262
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L119B | 5411267
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4956 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for Active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4956 active?
YES NO

The turbocharger application identification number in the variable geometry turbocharger (VGT) actuator does not match the turbocharger application identification number in the ECM.

Download the turbocharger actuator calibration code with the correct turbocharger application identification number into the VGT actuator.

  • Refer to Procedure 010-150 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 4957 - Variable Geometry Turbocharger Actuator Software - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L101 | 4310789
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L111 | 4367223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L102 | 4332796
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L107 | 4367386
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L118 | 4388673
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISX12 CM2350 X102 | 4310646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L116B | 5411330
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L122 | 5411278
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B121B | 5411223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X114B | 5411181
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X116B | 5411186
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B129B | 5411247
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B135B | 5411257
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B147B | 5411252
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B148B | 5411262
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L119B | 5411267
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4957 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4957 active?
YES NO

The turbocharger actuator interface level in the variable geometry turbocharger (VGT) actuator is not compatible with the ECM software.

Check the turbocharger interface level in the VGT actuator and the allowed turbocharger interface levels using the Turbocharger Actuator Compatibility feature under Advanced ECM Data in INSITE electronic service tool.

Download the turbocharger actuator calibration code with the correct turbocharger application identification number and interface level.

Refer to Procedure 010-150 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 5177 - Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5177 active?
 | STEP 1B. Check the fault codes. | Fault Code 2636 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 5177 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2636 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2636 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2013


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSB6.7 CM2350 B112 | 4358498
Fuel System Diagnostics | Refer to Procedure 005-236 | QSB6.7 CM2350 B112 | 4358498
Air in Fuel | Refer to Procedure 006-003 | QSB6.7 CM2350 B112 | 4358498
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2350 B112 | 4358498
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | QSB6.7 CM2350 B112 | 4358498
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | QSB6.7 CM2350 B112 | 4358498
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498
Engine Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 322, 323, 324, 325, 331, or 332 active?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 271, 272, 449, 451, 452, 483, 484, 515, 516, 553, 2311, 2372, 3727, or 3741 active or inactive counts?
STEP 2. | Check the engine operation. |
 | STEP 2A. Check for an adequate fuel supply. | Adequate fuel supply?
STEP 3. | Check the low-pressure fuel system. |
 | STEP 3A. Check the low-pressure fuel system. | Low-pressure fuel system meets specifications?
STEP 4. | Check the fuel rail pressure sensor. |
 | STEP 4A. Verify the fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 4B. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Check the high-pressure injector return flow. | Injector return flow meets the specification?
 | STEP 5B. Check the high-pressure fuel rail return flow. | Fuel pressure relief valve return flow meets the specification?
STEP 6. | Check the high-pressure fuel pump. |
 | STEP 6A. Check the high-pressure fuel pump return flow. | Fuel pump return flow meets the specification?
 | STEP 6B. Check the fuel pump actuator. | Measured fuel rail pressure varies more than ± 100 bar [1450 psi] from the commanded fuel rail pressure?
 | STEP 6C. Check the high-pressure fuel pump supply flow. | High-pressure fuel pump supply flow meets the specification?
 | STEP 6D. Check for debris in the fuel tank. | Debris found in the tank?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, 324, 325, 331, or 332 active?
YES NO

Troubleshoot the fault codes listed above first.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 449, 451, 452, 483, 484, 515, 516, 553, 2311, 2372, 3727, or 3741 active or inactive counts?
YES NO

Troubleshoot the fault codes listed above first.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine operation.

Guided Step 2A - Check for an adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for an adequate fuel supply.

  • Do not rely on the vehicle fuel gauge.
  • Verify there is fuel in the tank.

Adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge. Refer to the original equipment manufacturer (OEM) service manual.

Go to 3A

Go to 6A

Guided Step 3 - Check the low-pressure fuel system.

Guided Step 3A - Check the low-pressure fuel system.

Conditions

  • Turn keyswitch ON.
  • Use the following procedure for information on low-pressure fuel system checks. Refer to Procedure 005-236 in the Associated Procedures Table.

Action

Check the low-pressure fuel system.

  • Check for fuel inlet restriction above specification.
  • Check for air in the fuel.
  • Check for fuel drain line restriction above specification.
  • Check for gear pump output pressure below specification.
  • Check for fuel filter restriction above specification.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Low-pressure fuel system meets specifications?
YES NO
No Repair

If the fuel pressure is below the minimum at the inlet side of the filter, verify there are no issues with fuel inlet restriction or air in the fuel.

Investigate the cause of the low-pressure fuel system issue.

Repair or replace the damaged component(s).

Engine Will Start - Repair direction priority:

  • Fuel inlet restriction. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Air in the fuel. Refer to Procedure 006-003 in the Associated Procedures Table.
  • Fuel filter restriction - Replace fuel filter. Refer to Procedure 006-015 in the Associated Procedures Table.
  • Fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.
  • Gear pump pressure - Replace the fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Engine Will Not Start - Repair direction priority:

  • Fuel System primed. Refer to Procedure 006-015 in the Associated Procedures Table.
  • Air in the fuel. Refer to Procedure 006-003 in the Associated Procedures Table.
  • Fuel filter restriction - Replace fuel filter. Refer to Procedure 006-015 in the Associated Procedures Table.
  • Fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.
  • Gear pump pressure - Replace the fuel pump gear pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the fuel rail pressure sensor.

Guided Step 4A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the fuel rail pressure sensor make sure it is correct for the engine CPL.

.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 4B

Go to 7A

Guided Step 4B - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the rail fuel pressure sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Check the high-pressure injector return flow.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow meets the specification?
YES NO
No Repair

A cause of this problem could be that the customer is operating on fuels lighter than specified. Fuels with low viscosity result in higher leakage and greater drain flow rates.

High injector return flow repair direction priority:

  • Verify high-pressure connector nut torque. Refer to Procedure 006-052 in the Associated Procedures Table.
  • Isolate injector drain flows. Refer to Procedure 005-236 in the Associated Procedures Table.
  • Inspect high-pressure connector and cylinder head anti-rotation slot for damage. Refer to Procedure 006-052 in the Associated Procedures Table.
  • Inspect injector sealing washer and o-rings for damage. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Replace injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5B

Go to 7A

Guided Step 5B - Check the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive fuel leakage from the fuel pressure relief valve.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel pressure relief valve return flow meets the specification?
YES NO
No Repair

If Fault Codes 272, 449, 553, 2311, or 3741 are active, do not replace the fuel rail pressure relief valve without first determining the cause of the fault condition. See the appropriate troubleshooting tree(s).

Replace the fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 6 - Check the high-pressure fuel pump.

Guided Step 6A - Check the high-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Check for excessive fuel return from the high-pressure fuel pump.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel pump return flow meets the specification?
YES NO
No Repair

A cause of this problem could be that the customer is operating on fuels lighter than specified. Fuels with low viscosity result in higher leakage and greater drain flow rates.

If the high-pressure injection pump does not meet the flow specifications, and the fuel inlet restriction and air-in-fuel checks are within specification, replace the fuel pump.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 6B

Go to 7A

Guided Step 6B - Check the fuel pump actuator.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for correct operation.

  • Use INSITE™ electronic service tool to monitor commanded fuel rail pressure and measured fuel rail pressure while the engine is idling.

Measured fuel rail pressure varies more than ± 100 bar [1450 psi] from the commanded fuel rail pressure?
YES NO

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6C

Guided Step 6C - Check the high-pressure fuel pump supply flow.

Conditions

  • Turn keyswitch ON.
  • Crank the engine.

Action

Check the high-pressure injection pump fuel flow.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel pump supply flow meets the specification?
YES NO
No Repair

If the high-pressure injection pump does not meet the flow specifications and the fuel inlet restriction, air in fuel, and fuel filter restriction checks are within specification, replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

After replacing the fuel pump actuator, measure the fuel pump supply flow again. If the supply flow is not within specification, replace the fuel pump.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 6D

Go to 7A

Guided Step 6D - Check for debris in the fuel tank.

Conditions

  • Turn keyswitch OFF.
  • Remove fuel tank filler cap.

Action

Check for debris in the fuel tank.

  • Refer to the OEM service manual.

Debris found in the tank?
YES NO

Remove the debris from the tank. Refer to the OEM service manual.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 3727 - High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3727 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 3727. | Less than three counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3727 inactive?
YES NO

Replace the high pressure common rail fuel relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

 No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 3727.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 3727.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 3727.

Less than 3 counts?
YES NO
No Repair

Replace the high pressure common rail fuel relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 4262 - High Pressure Common Rail Fuel Pressure Relief Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4262 active?
STEP 2. | Check the high-pressure common rail fuel pressure relief valve and circuit. |
 | STEP 2A. Inspect the engine harness and valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4263 active and Fault Code 4262 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4262 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4263 active and Fault Code 4262 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4262 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the high-pressure common rail fuel pressure relief valve and circuit.

Guided Step 2A - Inspect the engine harness and valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Inspect the engine harness and valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check the circuit response.

  • Place a jumper wire between the high-pressure common rail pressure relief valve SIGNAL pin and high-pressure common rail pressure relief valve RETURN pin at the high-pressure common rail pressure relief valve connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 4263 active and Fault Code 4262 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the high-pressure common rail fuel pressure relief valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active?

YES NO

A damaged high-pressure common rail pressure relief valve has been detected.

Replace the high pressure common rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the circuit response.

  • Place a jumper wire between the high-pressure common rail pressure relief valve SIGNAL pin and high-pressure common rail pressure relief valve RETURN pin at the engine control module engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 active and Fault Code 4262 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin at the ECM connector of the engine harness and the high-pressure common rail fuel pressure relief valve SIGNAL pin at the high-pressure common rail fuel pressure relief valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-pin short circuit on one connector.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Start the engine and let it idle for 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Feb-2014


FAULT CODE 4263 - High-Pressure Common Rail Fuel Pressure Relief Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4263 active?
STEP 2. | Check the high-pressure common rail fuel pressure relief valve and circuit. |
 | STEP 2A. Inspect the engine harness and valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4262 active and Fault Code 4263 inactive?
 | STEP 2C. Check the fault codes and verify valve condition. | Fault Code 4263 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4262 active and Fault Code 4263 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4263 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - the high-pressure common rail fuel pressure relief valve and circuit.

Guided Step 2A - Inspect the engine harness and valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Inspect the engine harness and valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Start the engine and let it idle for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 4262 active and Fault Code 4263 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the high-pressure common rail fuel pressure relief valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify valve condition.

  • Start the engine and let it idle for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 4263 active?
YES NO

A damaged high-pressure common rail fuel pressure relief valve has been detected.

Replace the high-pressure common rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active and Fault Code 4263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-pin short circuit on one connector.

  • Measure the resistance between the high pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been be detected.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Feb-2014


FAULT CODE 4265 - High Pressure Common Rail Fuel Pressure Relief Valve - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 4265 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 4265. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4265 inactive?
YES NO
No Repair

Replace the high pressure common rail fuel relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 4265.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 4265.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 4265.

Less than 3 counts?
YES NO
No Repair

Replace the high pressure common rail fuel relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Feb-2014


FAULT CODE 4867 - High Pressure Common Rail Fuel Pressure Relief Valve - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
High Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4867 active?
 | STEP 1B. Read the fault codes. | Active or inactive counts of Fault Code 4262 or 4263?
STEP 2. | Check the high pressure common rail fuel pressure relief valve. |
 | STEP 2A. Inspect the high pressure common rail fuel pressure relief valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the high pressure common rail fuel pressure relief valve resistance. | Between 3 and 5 ohms?
 | STEP 2C. Check the fuel high pressure common rail fuel pressure relief valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Code 4867, 4262, and/or 4263 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4867 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 4262 or 4263?
YES NO

Troubleshoot Fault Code 4262 or 4263 first.

 No Repair

Go to appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the high pressure common rail fuel pressure relief valve.

Guided Step 2A - Inspect the high pressure common rail fuel pressure relief valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure common rail fuel pressure relief valve from the engine harness.

Action

Inspect the high pressure common rail fuel pressure relief valve and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check thehigh pressure common rail fuel pressure relief valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure common rail fuel pressure relief valve from the engine harness.

Action

Check the high pressure common rail fuel pressure relief valve resistance.

  • Measure the resistance between thehigh pressure common rail fuel pressure relief valve SIGNAL pin and the high pressure common rail fuel pressure relief valve RETURN pin at the valve connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3 and 5 ohms?
YES NO
No Repair

Replace the high pressure common rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the high pressure common rail fuel pressure relief valve for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure common rail fuel pressure relief valve from the engine harness.

Action

Check the high pressure common rail fuel pressure relief valve resistance.

  • Measure the resistance between the high pressure common rail fuel pressure relief valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the high pressure common rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the high pressure common rail fuel pressure relief valve to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the high pressure common rail fuel pressure relief valve SIGNAL pin and the high pressure common rail fuel pressure relief valve RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure common rail fuel pressure relief valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and high pressure common rail fuel pressure relief valve resistance.

  • Measure the resistance between the high pressure common rail fuel pressure relief valve SIGNAL pin and the high pressure common rail fuel pressure relief valve connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the high pressure common rail fuel pressure relief valve.

If a short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Code 4867, 4262, and/or 4263 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness or high pressure common rail fuel pressure relief valve connector and/or pins. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the high pressure common rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 5585 - High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSB6.7 CM2350 B112 | 4358489
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | QSB6.7 CM2350 B112 | 4358489
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSB6.7 CM2350 B112 | 4358489
Fuel Supply Lines | Refer to Procedure 006-024 | QSB6.7 CM2350 B112 | 4358489
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358489
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | QSB6.7 CM2350 B112 | 4358489
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358489

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5585 active or counts of inactive?
STEP 2. | Check the pressure-side fuel filter. |
 | STEP 2A. Measure the pressure drop across the pressure-side fuel filter. | Pressure drop across the pressure-side fuel filter less than 69 kPa [10 psi]?
STEP 3. | Check the fuel inlet restriction. |
 | STEP 3A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 4. | Check the high pressure fuel system. |
 | STEP 4A. Measure the high-pressure fuel rail return flow | Fuel return flow within specifications outlined in the appropriate procedure?
STEP 5. | Check the injector. |
 | STEP 5A. Check the injector return flow. | Injector return flow within the specifications outlined in the appropriate procedure?
 | STEP 5A-1. Check the high-pressure connector torque specification. |
 | STEP 5A-2. Check for individual leaking injectors. |
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5585 active or counts of inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the pressure-side fuel filter.

Guided Step 2A - Measure the pressure drop across the pressure-side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Engine at high idle.

Action

Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.

  • Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load. Refer to Procedure 005-236 in the Associated Procedures Table.

Pressure drop across the pressure-side fuel filter less than 69 kPa [10 psi]?
YES NO
No Repair

Replace the pressure-side fuel filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the fuel inlet restriction.

Guided Step 3A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the line restriction.

Refer to the original equipment manufacturer (OEM) service manual.

Go to FC559 for additional troubleshooting steps.

Go to 6A

Guided Step 4 - Check the high pressure fuel system.

Guided Step 4A - Measure the high-pressure fuel rail return flow.

Conditions

Make sure all high-pressure fuel lines are tightened to the correct specification. Refer to procedure 006-024 in the Associated Procedure Table.

Make sure the high pressure fuel relief valve is tightened to the correct specification. Refer to procedure 006-061 in the Associated Procedure Table.

  • Turn keyswitch ON.
  • Start and Idle engine to operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Action

Check for excessive fuel return from the high-pressure fuel rail.

Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel return flow within specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the fuel rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the injectors.

Guided Step 5A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain that the engine is at operating temperature before performing the test.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow within the specifications outlined in the appropriate procedure?
YES NO

Replace the suction-side fuel filter or repair the line restriction.

Refer to the OEM service manual.

Go to 6A

Go to 5A-1

Guided Step 5A-1 - Check the high-pressure connector torque specification.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque specification.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector pressure connector torque measurement meets the specification outlined in the appropriate procedure?
YES NO
No Repair

Tighten the injector high-pressure connector.

Check the injector return flow again. Go back to Step 5A.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

If the injector return flow is now within specification, go to Step 6A.

If the injector return flow is still high, proceed to the next step below.

Go to 6A

Go to 5A-2

Guided Step 5A-2 - Check for individual leaking injectors

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Action

Make certain the engine is at operating temperature before performing the test.

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel injector return flow within specifications outlined in the appropriate procedure with an injector capped off?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high injector return flow.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Cap off additional injectors to identify the source of high injector return flow.

Replace the high-pressure connector and injector for the cylinder(s) causing the high injector return flow.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2015


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B112 | 4358498
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B112 | 4358498
EGR Valve | Refer to Procedure 011-022 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the exhaust gas recirculation (EGR) valve position sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the EGR differential pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Check the intake air throttle position sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

  • Refer to Procedure 011-027 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the EGR valve position sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and the EGR valve position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the EGR valve position sensor.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the EGR differential pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the intake air throttle position sensor and circuit connected to the sensor number 2 supply and return, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air throttle sensor from the engine harness, if equipped.

Action

Inspect the engine harness and EGR oriface pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air throttle sensor from the engine harness, if equipped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake air throttle.

  • Refer to Procedure 010-140 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2350 B112 | 4358498
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB6.7 CM2350 B112 | 4358498
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Did the fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

Refer to Procedure in 019-063 in the Associated Procedures Table.

Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness,and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • Refer to Procedure in 019-063 in the Associated Procedures Table.
  • Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may operate at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Oct-2015


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2350 B112 | 4358498
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB6.7 CM2350 B112 | 4358498
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure Refer to Prcedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Oct-2015


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2350 B112 | 4358498
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB6.7 CM2350 B112 | 4358498
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may operate at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Oct-2015


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2350 B112 | 4358498
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB6.7 CM2350 B112 | 4358498
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may operate at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Oct-2015


FAULT CODE 331- Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2350 B112 | 4358498
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB6.7 CM2350 B112 | 4358498
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injctor harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank.Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may operate at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Oct-2015


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L102 | 4332796
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L102 | 4332796
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L102 | 4332796
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Assoicated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may operate at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-Oct-2015


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped). | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Check the turbocharger compressor intake pressure/temperature sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and the intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the crankcase pressure sensor.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness (if equipped).
  • If engine is not equipped with an engine oil pressure sensor, skip to Step 2E.

Action

Inspect the engine harness and engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2E - Check the turbocharger compressor intake pressure/temperature sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness (if equipped).
  • If engine is not equipped with an aftertreatment fuel pressure sensor, skip to Step 3A.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the turbocharger compressor intake pressure/temperature sensor.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Feb-2014


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connetor, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 426 - J1939 Network # 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - engine control module (ECM) Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the ECM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ 5 data link adapter to the ECM SAE J1939 data link connector
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ (J1939) ECM connection.

Does the INSITE™ electronic service tool communicate with ECM?

YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Reference the OEM service manual for information on troubleshooting the SAE J1939 data link network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the ECM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ECM Harness from the ECM 60-pin connector.

Action

Inspect the ECM and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

  • Repair or replace the ECM harness connector pins. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the damaged section of the ECM harness. Refer to the OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM 60-pin connector
  • Connect the ECM bench calibration harness to the ECM 60-pin connector
  • Connect the INLINE™ data link adapter
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Connect to the ECM using the ECM Bench Top Calibration Harness, Part Number 3163151, and the ECM Bench Calibration Adapter Cable, Part Number 3164185.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Refer to the OEM service manual

Reference the ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Nov-2015


FAULT CODE 435 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Electronic Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Electronic Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141. | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 and Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An in-range malfunction of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Monitor the INSITE™ electronic service tool Data Monitor/Logger for engine oil pressure.

INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Oct-2015


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump | Refer to Procedure 005-016 | QSL9 CM2350 L107 | 4367386
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2350 B112 | 4358498
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSL9 CM2350 L107 | 4367386
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSB6.7 CM2350 B112 | 4358498
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 449 active?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 4B. Check for active fault codes. | Fault Codes 1117 or 2311 active or high inactive counts?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect the drain line from the high pressure relief valve to the original equipment manufacturer (OEM) connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Do not operate engine.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Correct fuel pressure relief valve part number installed and no tampering found?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

If replacing the fuel pump actuator does not resolve the issue, take the following action:

  • For QSB6.7 CM2350 B112 engine, replace the fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair the tampering or replace the fuel pressure relief valve.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Oct-2015


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSB6.7 CM2350 B112 | 4358498
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2350 B112 | 4358498
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271, 272, 449, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 2B. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Measured Fuel Rail Pressure deviates from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Fuel pump actuator damaged?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Codes 271, 272, 449, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the rail fuel pressure sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Operate the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Measured Fuel Rail Pressure deviates from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Oct-2015


FAULT CODE 741 - Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 741 active?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 742 active and Fault Code 741 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 741 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake pressure sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 volt SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active and Fault Code 741 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 volt SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor.

  • Refer to Procedure 019-466 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 volt SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active and Fault Code 741 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 inactive?
YES NO

The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature 5 volt SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 742 - Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 742 active?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 741 active and Fault Code 742 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 742 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake pressure sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor.

  • Refer to Procedure 019-466 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 inactive?
YES NO

The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 743 - Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 741 and Fault Code 742. | Fault Code 741 or Fault Code 742 active?
STEP 2. | Check the turbocharger compressor intake pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 742 active?
 | STEP 2C. Check the circuit response. | Fault Code 741 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 742 active?
 | STEP 3C. Check the circuit response. | Fault Code 741 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 741 and Fault Code 742.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 or Fault Code 742 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature sensor +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES NO

An in-range malfunction of the turbocharger compressor intake pressure/temperature sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor. Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature sensor +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1668 (2-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1668 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1668 is active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 is active?
YES NO

A damaged aftertreatment diesel exhaust fluid tank level sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1668 (3-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1668 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pin. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level SUPPLY pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor connector of the OEM harness.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid (DEF) level tank sensor SUPPLY pin and the aftertreatment DEF tank level sensor SIGNAL pin at the aftertreatment DEF tank level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel exhaust fluid tank level sensor SUPPLY pin and the OEM harness aftertreatment diesel exhaust fluid tank level sensor connector SUPPLY pin.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the OEM harness aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1669 (2-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1668 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and Fault Code 1669 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the original equipment manufacturer (OEM) and ECM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor wiring harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES NO

A damaged aftertreatment diesel exhaust fluid tank level sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.

Use the wiring diagram for connector pin identification. Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged ECM has been detected. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1669 (3-Wire Sensor) - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1669 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank level sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and Fault Code 1669 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank level sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid tank level sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level SUPPLY pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor connector of the OEM harness.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid tank level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel exhaust fluid tank level sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Use the circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged ECM has been detected. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1677 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1677 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the ECM and original epuipment manufacturer (OEM) and harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Fault Code 1677 inactive?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1678 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1678 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the circuit response.

  • Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the sensor connector of the OEM harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active and Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO

A damaged aftertreatment DEF tank temperature sensor has been detected.

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor RETURN pin at the OEM wiring harness temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1679 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 334 or 436?
STEP 2. | Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Verify the aftertreatment DEF tank temperature sensor accuracy. | INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
STEP 3. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check the connector and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 or 1678 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 334 or 436?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the aftertreatment DEF tank temperature sensor.

Guided Step 2A - Verify the aftertreatment DEF tank temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the aftertreatment DEF tank temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor RETURN pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor RETURN pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit.

Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF tank temperature sensor SIGNAL pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1682 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSB6.7 CM2350 B112 | 4358498
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1682 active or more than two inactive counts?
 | STEP 1B. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1C. Check for related fault codes. | Fault Codes 3574, 3575, 3569, or 3596 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any reversed, damaged, leaking, or restricted lines or connetors found?
STEP 3. | Check the DEF dosing valve circuit. |
 | STEP 3A. Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment DEF tank filter. |
 | STEP 4A. Inspect the DEF tank filter for blockage and/or contamination. | DEF tank filter blocked and/or contamination found in the tank?
STEP 5. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 5A. Perform the aftertreatment DEF dosing unit airless flush. | Aftertreatment DEF dosing unit flush meets the specifications in Procedure 011-058?
 | STEP 5B. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
 | STEP 5C. Check for air in the DEF. | Air detected in the DEF?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1682 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active fault codes: Fault Code 1673, 3497, or 3498.

DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
YES NO

Troubleshoot occurrences of Fault Code 3574, 3575, 3569, or 3596 before troubleshooting Fault Code 1682.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and connections.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines, fittings, and connections.

Conditions

  • Turn keyswitch OFF.

Action

There are three DEF lines on the selective catalytic reduction (SCR) dosing system:

1. Dosing unit supply line between the tank and the dosing unit (suction line).

2. Dosing valve supply line between the dosing unit and the dosing valve (pressure line).

3. Return line between the dosing unit and the tank (return line).

Inspect all three DEF lines and associated connectors:

  • Verify the suction and return line connections are not swapped at the dosing unit or DEF tank connections. Reversed DEF line connections cause the dosing unit to fail to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check all three dosing unit connections for loose, leaking, or damaged connections.
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (three connections), and dosing valve (one connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted lines or connectors found?

YES NO

Replace or install correctly the DEF line as necessary. See equipment manufacturer service information.

Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the DEF dosing valve circuit.

Guided Step 3A - Check for a pin-to-pin short circuit in the aftertreatment DEF dosing valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the connector.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and RETURN pin of the OEM harness connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment DEF tank filter.

Guided Step 4A - Inspect the DEF tank filter for blockage and/or contamination.

Conditions

  • Turn keyswitch OFF.
  • Remove the tank level and temperature sensor from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage, buildup, and/or contamination.

Refer to the OEM service manual.

DEF tank filter blocked and/or contamination found in the tank?
YES NO

Clean or replace the DEF tank filter.

Drain, clean, and refill the DEF tank. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the aftertreatment DEF dosing unit operation.

Guided Step 5A - Perform the aftertreatment DEF dosing unit airless flush.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch OFF for 90 seconds, then turn keyswitch ON.

Action

Flush the aftertreatment DEF dosing unit with clean water.

  • Use the following procedure in Section Off Chassis Non Air Flush for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

Place a container having a minimum capacity of 3.78 liters [1 gallon], underneath the DEF filter cap cavity, prior to run the Aftertreatment DEF Doser Pump Override Test.

Aftertreatment DEF dosing unit flush meets the specifications in Procedure 011-058?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 5B

Go to 5C

Guided Step 5B - Check aftertreatment DEF dosing unit for proper opertion.

Conditions

  • Connect the DEF suction line to the dosing unit and install and tighten the filter cap.
  • Remove the aftertreatment DEF dosing valve from the decompostion tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for specifications and and instructions. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 5C

Go to 5C

Guided Step 5C - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Remove the aftertreatment DEF dosing valve supply line from the aftertreatment DEF dosing valve.
  • Connect INSITE™ electronic service tool.

Action

Air detected in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air detected in the DEF?
YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1683 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1683 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1684 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1683 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Inspect the engine harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank heater control valve SUPPLY pin and the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment DEF tank heater control valve OEM harness connector.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the aftertreatment DEF tank heater control valve ON with the Diesel Exhaust Fluid Tank Heater Override.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the aftertreatment DEF tank heater control valve ON using the Diesel Exhaust Fluid Tank Heater Override.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the tank heater control valve wiring harness connector and the aftertreament DEF tank heater control valve SUPPLY pin at the OEM harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open return circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve RETURN pin at the tank heater control valve wiring harness connector and the aftertreatment DEF tank heater control valve RETURN pin at the OEM harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the OEM harness ECM connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2014


FAULT CODE 1684 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1684 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1683 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1684 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for active or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment DEF tank heater control valve to the OEM harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater control valve ON with the Diesel Exhaust Fluid Tank Heater Override.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the OEM harness ECM connector and block ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the OEM harness ECM connector and all other pins.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2014


FAULT CODE 1691 - Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 | 4358498
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1691 active?
 | STEP 1B. Read the fault codes. | Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors active?
 | STEP 1C. Read the fault codes. | Fault codes related to the variable geometry turbocharger (VGT) or exhaust gas recirculation (EGR) valve active?
 | STEP 1D. Read the fault codes. | Fault codes related to the fuel system active?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks are found?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Inspect the aftertreatment diesel oxidation catalyst. | Problems found during inspection of the aftertreatment diesel oxidation catalyst?
 | STEP 3B. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
 | STEP 3C. Inspect the exhaust for excessive black smoke. | Excessive black smoke according to the procedure?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1691 active?

YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors active?
YES | NO
No Repair | No Repair

Refer to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the VGT or EGR active?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the fuel system active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks are found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Inspect the aftertreatment diesel oxidation catalyst.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Inspect the aftertreatment diesel oxidation catalyst for plugging from soot or oil contamination.
  • Inspect the aftertreatment diesel oxidation catalyst for cracks or damage of any cells in the catalyst.
  • Inspect the aftertreatment diesel oxidation catalyst for soot plugging the front face of the catalyst.

Refer to Procedure 011-049 in the Associated Procedures Table.

Problems found during inspection of the aftertreatment diesel oxidation catalyst?
YES NO

Repair or replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Continue to troubleshoot the system to determine the root cause of the problem.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel, coolant, or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the turbocharger outlet.
  • Operate engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected procedure to check for excessive black smoke. Refer to Procedure 014-017 in the Associated Procedures Table.

Excessive black smoke according to the procedure?
YES NO

Troubleshoot the cause of the excessive black smoke.

Reference the appropriate engine performance troubleshooting tree in Section TT of the appropriate service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1694 - Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSL9 CM2350 L107 | 4367386
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1694 active?
 | STEP 1B. Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment SCR temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active aftertreatment diesel exhaust fluid (DEF) dosing system fault codes. | Aftertreatment DEF dosing system related fault codes active?
STEP 2. | Check the aftertreatment outlet NOx sensor. |
 | STEP 2A. Inspect the NOx sensor body and condition of the NOx sensor harness. | External damage to the sensor body, head (component fitted to the exhaust gas processor), or harness?
 | STEP 2B. Inspect the NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the NOx sensor installation. | NOx sensor installed correctly and the exhaust system free of leaks?
 | STEP 2D. Check pin-to-pin continuity in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2E. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment Selective Catalytic Reduction (SCR) Performance Test. | Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the Aftertreatment SCR Performance Test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment mono-NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active aftertreatment SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active aftertreatment DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

Aftertreatment DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor.

Guided Step 2A - Inspect the NOx sensor body and condition of the NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the NOx sensor body and the NOx sensor harness.

  • Inspect the NOx sensor body and NOx sensor harness for cracks or damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

External damage to the sensor body, head (component fitted to the exhaust gas processor), or harness?
YES NO

Replace the NOx sensor. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • If broken pins are found within the NOx sensor, replace the NOx sensor.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the NOx sensor installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment NOx sensor installation and check the vehicle exhaust system.

Check for active fault codes.

  • Check that the NOx sensor is securely installed in the correct position with the correct fittings and fasteners.
  • Check the exhaust system for leaks and loose connections.

NOx sensor installed correctly and the exhaust system free of leaks?
YES NO
No Repair

Repair the NOx sensor installation and/or exhaust system. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check pin-to-pin continuity in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NOx sensor.
  • Disconnect the OEM harness ECM connector.

Action

Check the continuity of the NOx sensor circuit in the OEM wiring harness.

  • Check the pin-to-pin resistance of the OEM harness between the ECM connector and the NOx sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

The OEM wiring harness resistance is excessive. Repair or replace the OEM wiring harness. See equipment manufacturer service information.

Go to 2E

Go to 5A

Guided Step 2E - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.
  • The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. This filter can not be reused and must be changed upon removal. Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment DEF Doser Pump Override Test again, with the new filter. If the dosing unit still does not operate according to the specifications, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Perform the Aftertreatment Selective Catalytic Reduction (SCR) Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Repeat the Aftertreatment SCR Performance Test.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the Aftertreatment Outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1712 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, or 1684 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Inspect the DEF tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, or 1684 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system.

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including original equipment manufacturer (OEM) in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 1713 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1713 active?
 | STEP 1B. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, or 1684 active or high inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Check the aftertreatment DEF tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify that the aftertreatment DEF tank heater control valve is installed correctly. | DEF tank heater control valve installed correctly?
 | STEP 3B. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1713 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, or 1684 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF temperature sensor.

Guided Step 2A - Check the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the DEF in the DEF tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
YES NO
No Repair

Replace the DEF tank temperature sensor.

  • Refer to the original equipment manufacturer (OEM) service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify that the aftertreatment DEF tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

Refer to the OEM service manual for details on the tank heater control valve.

DEF tank heater control valve installed correctly?
YES NO
No Repair

Remove the DEF tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction, where applicable.

Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Start and Idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Verify the proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

  • Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.
  • Use the Diesel Exhaust Fluid Tank Heater option in the test menu to override the tank heater control valve to ON.
  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

Refer to OEM service manual for details on the tank heater control valve.

NOTE: The Diesel Exhaust Fluid Doser System Heater Test allows the technician to override the tank heater control valve to on. It does not test if the tank heater control valve is operating correctly. With the tank heater control valve commanded on, a temperature rise may be felt on the coolant hose to the diesel exhaust fluid tank.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1847?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Section TS of the QSB6.7 CM2350 B112 Service Manual, Bulletin 4358498.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Feb-2014


FAULT CODE 1887 - Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2771 or 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887 active?
STEP 2. | Check engine contol module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 or 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 active?
YES NO

An internal error has been detected in the aftertreatment outlet mono-nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can BE COMBUSTIBLE vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to its application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator ARE responsible for safe operation in a hostile environment. Consult A Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ Electronic Service Tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ Electronic Service Tool.

Conditions

  • Connect INSITE™ Electronic Service Tool
  • Turn keyswitch ON
  • Engine is running.

Action

Check the engine rpm with INSITE™ Electronic Service Tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ Electronic Service Tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Reference the appropriate circuit or wiring diagram for all engine harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ Electronic Service Tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ Electronic Service Tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2015


FAULT CODE 2272 - EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L017 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2272 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness. |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the component with the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the EGR valve connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for an open circuit in the EGR position circuit.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the EGR valve engine harness connector and the EGR valve position SIGNAL A pin at the ECM engine harness connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the EGR valve engine harness connector and the EGR valve position SIGNAL B pin at the ECM engine harness connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the EGR valve engine harness connector and the EGR valve position SIGNAL C pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit in the EGR position circuit.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the ECM engine harness connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit to ground.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Aug-2015


FAULT CODE 2357 - EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the exhaust gas recirculation (EGR) valve position sensor signal for a short circuit. | Greater than 100k ohms?
STEP 2. | Check the ECM. |
 | STEP 2A. Check the EGR valve position sensor signal voltage. | Less than 0.1-VDC?
STEP 3. | Check the EGR valve assembly. |
 | STEP 3A. Perform the INSITE™ electronic service tool EGR Valve Test. | EGR valve position 100 percent when open?
 | STEP 3B. Perform the INSITE™ electronic service tool EGR Valve Test. | EGR valve position less than 10 percent when closed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the EGR valve position sensor signal for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the EGR valve position SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check the EGR valve position sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the Society of Automotive Engineers (SAE) J1939 or SAE J1587 data link connector.

Action

Use the INSITE™ electronic service tool Data Logger/Monitor, to check the EGR valve position sensor signal voltage.

Less than 0.1-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the EGR valve assembly.

Guided Step 3A - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify engine coolant temperature is above 82°C [180°F].
  • Do not operate engine.

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Open the EGR valve.

EGR valve position 100 percent when open?
YES NO
No Repair

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify engine coolant temperature is above 82°C [180°F].
  • Do not operate engine.

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Close the EGR valve.

EGR valve position less than 10 percent when closed?
YES NO
No Repair

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 2387 - VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSB6.7 CM2350 B112 | 4358498
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSL9 CM2350 L107 | 4367386
Turbocharger | Refer to Procedure 010-033 | QSB6.7 CM2350 B112 | 4358498
Turbocharger | Refer to Procedure 010-033 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | Actuator removed or replaced during the current repair event?
 | STEP 1C. Check for exhaust gas recirculation (EGR)-related fault codes. | EGR system fault codes active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment SCR Performance Test. | Aftertreatment SCR Performance Test completed?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 4A

Guided Step 1B - Check for previous variable geometry turbocharger (VGT) actuator removals.

Conditions

Not applicable.

Action

Check for previous replacements.

  • Determine if the actuator has been removed or replaced and Fault Code 2387 is active.

Has the actuator been removed or replaced during the current repair event?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for exhaust gas recirculation (EGR)-related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve, EGR temperature, and EGR differential pressure-related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active Fault Codes 1896, 2349, 2353, 2961, and 2962.

EGR system fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting procedure

Go to 1D

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Check for a broken drive gear on the VGT actuator.

Gear broken on the variable geometry turbocharger actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10?

YES NO

A damaged VGT actuator has been detected.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Perform the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.
  • Refer to Procedure 014-015 in the Associated Procedures Table.

Aftertreatment SCR Performance Test completed?
YES | NO
No Repair | No Repair

Go to 4A

Refer to SCR System Cleaning - Will Not Complete in the troubleshooting symptom tree in Section TS.

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 29-Jun-2017


FAULT CODE 2634 - VGT Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Aftertreatment System | Refer to Procedure 011-050 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment System | Refer to Procedure 011-050 | QSL9 CM2350 L107 | 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 | 4358498
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VGT actuator installation. |
 | STEP 1A. Check the VGT actuator installation. | Fault Codes 2449 and 2634 both active?
 | STEP 1B. Check for previous VGT actuator removals. | Was the VGT actuator recently removed from the turbocharger and the keyswitch turned ON?
 | STEP 1C. Disconnect and connect VGT actuator connector. | Fault Code 2634 inactive after disconnecting and connecting the VGT actuator connector?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check for progressive damage. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check VGT actuator installation.

Guided Step 1A - Check VGT actuator installation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Fault Codes 2449 and 2634 both active?
YES NO

Remove the actuator and install it in the correct position. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

  • Check if Fault Code 2634 is active.

Action

None.

Was the VGT actuator recently removed from the turbocharger and the keyswitch turned ON?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Disconnect and connect VGT actuator connector.

Conditions

Not applicable.

Action

If the VGT actuator is removed from the turbocharger and the keyswitch is turned ON with the wiring harness connected to the VGT actuator, Fault Code 2634 will be active. Follow the procedures below:

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness and connect.
  • Fault Code 2636 will be active temporarily when the turbocharger actuator is disconnected.
  • Refer to Procedure 010-134 in the Associated Procedures Table.

Fault Code 2634 is inactive after disconnecting and connecting the VGT actuator connector?
YES | NO
No Repair | No Repair

Repair complete

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged VGT actuator has been detected.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check for progressive damage.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform aftertreatment initial check procedure to test for damaged aftertreatment components.
  • Connect all components.

Action

Progressive damage to the aftertreatment system may have occurred.

Perform aftertreatment initial check procedure to test for damaged aftertreatment components.

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Progressive damage to the aftertreatment system is detected?
YES NO

Replace the damaged aftertreatment component. Refer to Procedure 011-050 in the Associated Procedures Table.

Check for active aftertreatment-related fault codes and follow any active aftertreatment fault code troubleshooting trees.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 2636 - VGT Actuator Driver Circuit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Snap Acceleration Test | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. |
 | STEP 1C. Check for active fault codes. | Fault Code 2771, 3232, 3682, 3868, 4152, 4572, or 5391 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the VGT actuator internal terminating resistance. | 108 to 132 ohms?
 | STEP 2C. Check the voltage to the VGT actuator at the VGT actuator wiring harness connector. | Voltage is within +/- 1 volt DC of battery voltage?
 | STEP 2C-1. Check the voltage to the VGT actuator at the ECM. |
 | STEP 2C-2. Check the battery supply. |
 | STEP 2D. Check J1939 data link circuit voltage at the VGT actuator wiring harness connector. | Voltage between 1.0 and 4.5 VDC?
 | STEP 2E. Check the J1939 data link circuit voltage at ECM connector. | Voltage between 1.0 and 4.5 VDC?
STEP 3. | Check the J1939 terminating resistance. |
 | STEP 3A. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 3B. Check the OEM terminating resistance. | 108 to 132 ohms?
 | STEP 3C. Check the VGT actuator internal terminating resistance. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit. | Greater than 100k ohms?
STEP 4. | Check the equipment battery system. |
 | STEP 4A. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions??
STEP 5. | Check the J1939 components. |
 | STEP 5A. Measure J1939 wiring harness voltage. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5B. Check the VGT actuator | Voltage between 1.0 and 4.5 VDC?
 | STEP 5C. Check the intake NOx sensor. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5D. Check the outlet NOx sensor. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5E. Check the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor, if equipped. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5F. Check the diesel particulate filter temperature sensor module. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5G. Check the SCR temperature sensor module. | Voltage between 1.0 and 4.5 VDC?
 | STEP 5H. Check for the wiring harness. | Voltage between 1.0 and 4.5 VDC?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1962 or 1976 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3232, 3682, 3868, 4152, 4572, or 5391 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger (VGT) actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the VGT actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the VGT actuator internal terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Check the resistance.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the VGT actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check the voltage to the VGT actuator at the VGT actuator wiring harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the VGT actuator battery voltage supply circuit and the VGT actuator battery voltage return circuit at the VGT actuator wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check the voltage to the VGT actuator at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the VGT actuator battery voltage SUPPLY pin on the ECM and the VGT actuator battery voltage RETURN pin on the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES NO

A malfunctioning engine wiring harness has been detected.

  • Replace the engine harness. Refer to Procedure 019-043 in the associated Procedure Table.

 No Repair

Go to 6A

Go to 2C-2

Guided Step 2C-2 - Check the battery supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the voltage.

  • Measure the battery voltage SUPPLY pin on the OEM harness to the battery voltage RETURN pin on the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES NO

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the associated Procedure Table.

A malfunctioning OEM wiring harness has been detected.

  • See equipment manufacturer service information.

Go to 6A

Go to 6A

Guided Step 2D - Check J1939 data link circuit voltage at the VGT actuator wiring harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin and the battery ground at the engine harness connector.
  • Measure the voltage between the SAE J1939 data link (-) pin and the battery ground at the engine harness connector.

Some products may contain a jumper harness between the VGT actuator and the engine harness. Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2E

Guided Step 2E - Check the J1939 data link circuit voltage at ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin and the battery ground at the engine harness connector.
  • Measure the voltage between the SAE J1939 data link (-) pin and the battery ground at the engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning engine harness has been detected.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 3 - Check the J1939 terminating resistance.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator.

Action

Check the resistance.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3 pin service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

Check for an open circuit

  • Measure the resistance between the pins of the OEM terminating resistor.

The J1939 data link harness is terminated at each end with a 120 ohm resistor. The terminating resistors must be in place to maintain proper communication. One resistor is located in a removable cap on the wiring harness, the other is integrated into the VGT actuator. Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

A malfunctioning OEM terminating resistor has been detected.

  • Replace the OEM terminating resistor. See equipment manufacturer service information.

Go to 3C

Go to 6A

Guided Step 3C - Check the VGT actuator internal terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Check the resistance.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the VGT actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

A malfunctioning VGT actuator has been detected.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the engine harness at the 14 pin cross-over connector.
  • Disconnect the intake NOx sensor.
  • Disconnect the VGT actuator from the engine harness.

Action

Check the resistance.

  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the equipment battery system.

Guided Step 4A - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the batteries and the unswitched battery supply circuit. Make sure the battery cable connections are tight and free of corrosion.

Perform the following checks at the battery(s).

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal at keyswitch ON engine Off.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Keyswitch ON engine off condtions:

  • At least 12 VDC (12 volt systems).
  • At least 24 VDC (24 volt systems).

Cranking conditions:

  • At least 10.8 VDC (12 volt systems)

At least 18 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 5 - Check the J1939 components.

Guided Step 5A - Measure J1939 wiring harness voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the components on the J1939 data link connector.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the VGT actuator.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the VGT actuator.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning variable geometry turbocharger actuator has been detected.

Replace the variable geometry turbocharger actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the intake NOx sensor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the intake NOx sensor.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning intake NOx sensor has been detected.

Replace the intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5D

Guided Step 5D - Check the outlet NOx sensor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the outlet NOx sensor.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning outlet NOx sensor has been detected.

Replace the outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5E

Guided Step 5E - Check the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor, if equipped.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning data link aftertreatment diesel exhaust fluid tank.

Replace the data link aftertreatment diesel exhaust fluid tank level/temperature/quality sensor. See equipment manufacturer service information.

No Repair

Go to 6A

Go to 5F

Guided Step 5F - Check the diesel particulate filter temperature sensor module.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the diesel particulate filter temperature sensor module.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning diesel particulate filter temperature sensor module has been detected.

Replace the diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5G

Guided Step 5G - Check the SCR temperature sensor module.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the SCR temperature sensor module.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning SCR temperature sensor module has been detected.

Replace the SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5H

Guided Step 5H - Check for the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the engine harness at the 14 pin cross-over connector.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between the SAE J1939 data link (+) pin at the 3 pin service data link connector and battery ground.
  • Measure the voltage between the SAE J1939 data link (-) pin at the 3 pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 1.0 and 4.5 VDC?
YES NO

A malfunctioning OEM wiring harness has been detected. See equipment manufacturer service manual.

A malfunctioning engine wiring harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-May-2017


FAULT CODE 2637 - Aftertreatment 1 Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Exhaust System - Overview | Refer to Procedure 011-999 | QSB6.7 CM2350 B112 | 4358498
Exhaust System - Overview | Refer to Procedure 011-999 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for .Exhaust Gas Recirculation (EGR) valve and Variable Geometry Turbocharger (VGT) related fault codes | Fault codes found that are related to the EGR or VGT operation?
STEP 2. | Check Features and Parameters, regeneration rrequency, and the engine control module (ECM) calibration. |
 | STEP 2A. Check the equipment manufacturer service procedures or customer selected regeneration inhibit features and parameters. | Features and Parameter settings preventing or interrupting regeneration?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
STEP 3. | Inspect the exhaust for smoke. |
 | STEP 3A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for Exhaust Gas Recirculation (EGR) valve and Variable Geometry Turbocharger (VGT) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the EGR valve or VGT operation.

Fault codes found that are related to the EGR or VGT operation?
YES NO

Troubleshoot the EGR or VGT related fault codes. A stuck open EGR valve or a damaged VGT actuator can cause face plugging of the DOC.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check Features and Parameters, regeneration frequency, and engine control module (ECM) calibration.

Guided Step 2A - Check the equipment manufacturer service procedures or customer selected regeneration inhibit features and parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the OEM or customer selected inhibit features

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in powertake off (PTO) and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events.

  • Refer to Procedure 011-999 in the Associated Procedures Table.

Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate the average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Average aftertreatment regeneration frequency 8 hours or less?
YES NO

Reference the Troubleshooting Symptom Tree t204-tr in Section T, in the appropriate service manual..

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the exhaust for smoke.

Guided Step 3A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect exhaust pipe from the aftertreatment inlet.
  • Operate engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.

To perform a Snap Acceleration Test, it can become necessary to temporarily adjust the Maximum Engine Speed with no vehicle speed sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

Reference the appropriate engine performance troubleshooting tree.

 No Repair

Reference the appropriate engine performance troubleshooting tree.

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the inlet face of the aftertreatment DOC for soot accumulation.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the inlet face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 2753 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B112 | 4358498
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
EGR Cooler | Refer to Procedure 011-019 | QSB6.7 CM2350 B112 | 4358498
EGR Cooler | Refer to Procedure 011-019 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2753?
STEP 2. | Check the cooling system. |
 | STEP 2A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 2B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 3. | Check the exhaust gas recirculation (EGR) system. |
 | STEP 3A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure ports?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2753?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the cooling system.

Guided Step 2A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture. Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture. Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Low engine coolant level may cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.
  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary. Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the exhaust gas recirculation (EGR) system.

Guided Step 3A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure ports?
YES NO

Clear the debris or replace the EGR differential pressure tube. Refer to Procedure 010-080 in the Associated Procedures Table.

Clean the EGR cooler. Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 2771 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2771 active?
 | STEP 1B. Check for active fault codes. | Fault codes 2636, 3232, 3868, 4152, 4572, or 5391 active?
STEP 2. | Check the aftertreatment outlet mono-nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage greater than 11-VDC (12 volt systems) or voltage greater than 22-VDC (24 volt systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage greater than 11-VDC (12 volt systems) or voltage greater than 22-VDC (24 volt systems)?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 2771 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 2636, 3232, 3868, 4152, 4572, or 5391 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment outlet mono-nitrogen oxides (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.
  • Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Reference the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 11-VDC (12 volt systems) or voltage greater than 22-VDC (24 volt systems)?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Clean the terminals and tighten the loose connections.

Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 11-VDC (12 volt systems) or voltage greater than 22-VDC (24 volt systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness.

Refer to the OEM service manual.

An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Check for blown or missing fuses. Check for damaged or missing relays. Troubleshoot all interconnects. Repair or replace the damaged component(s) as necessary.

Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM engine harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel selective catalyst reduction (SCR) temperature sensor module from the OEM harness.
  • Disconnect the data link aftertreatment diesel exhaust fluid (DEF) tank sensors, if equipped.
  • Disconnect the variable geometry turbocharger (VGT) actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.
  • Disregard any resistance between 110 and 130 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel SCR temperature sensor module from the OEM harness.
  • Disconnect the data link aftertreatment DEF sensors, if equipped.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.
  • Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • All other components connected.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the aftertreatment outlet NOx sensor OEM harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.
  • All other components connected.

Action

Measure the terminating resistance of the engine harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in the VGT actuator.

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment outlet NOx sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2771 active?
YES NO

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 2976 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2976 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and harness. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness connector. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and harness.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness.

Action

Inspect the OEM harness and dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL (temperature) pin at the harness connector and the OEM ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit RETURN pin at the connector and the OEM ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin of the OEM connector and all other pins in the connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the OEM harness connector and ground.

Greater than 100k ohms?
YES NO

A malfunction has been detected in the aftertreatment DEF dosing unit.

Replace the aftertreatment DEF dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 3142 - Aftertreatment 1 SCR Intake Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Oct-2015


FAULT CODE 3143 - Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Oct-2015


FAULT CODE 3144 - Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the selective catalytic reduction (SCR) inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3142 active?
STEP 4. | Verify the repair. |
 | STEP 4A. Verify the repair | SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 3142 or 3143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ Engine service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the selective catalytic reduction (SCR) inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and SCR inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Make sure engine coolant temperature is above 60°C [140°F].
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO
No Repair

Replace the SCR inlet temperature sensor.

Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Make sure engine coolant temperature is above 60°C [140°F].
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger.

  • Compare INSITE™ electronic service tool reading for catalyst inlet temperature and catalyst outlet temperature.

SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Oct-2015


FAULT CODE 3146 - Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Oct-2015


FAULT CODE 3147 - Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Oct-2015


FAULT CODE 3148 - Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Oct-2015


FAULT CODE 3151 - Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSL9 CM2350 L107 | 4367386
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3151 active?
 | STEP 1B. Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault Code 1694, 3228, 3748, or 3749 active?
 | STEP 1C. Check for active aftertreatment SCR temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related fault codes active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Inspect the DEF dosing system for external leaks | External leaks detected in the system?
 | STEP 2C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2D. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
 | STEP 2E. Check the aftertreatment DEF dosing valve for proper operation. | DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment Selective Catalytic Reduction (SCR) Performance Test. | Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the aftertreatment SCR performance test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3151 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active aftertreatment SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1D

Guided Step 1D - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • DEF tank connectors.
  • DEF dosing unit and dosing unit connectors.
  • DEF lines.
  • DEF dosing valve.

DEF will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. This filter can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment DEF Doser Pump Override Test again with the new filter. If the dosing unit still does not operate according to the specifications, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the aftertreatment DEF dosing valve for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing valve for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under engine control module Diagnostic Tests. Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
YES NO

A leaking aftertreatment DEF dosing valve has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Perform the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Repeat the Aftertreatment SCR Performance Test.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the Aftertreatment Outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Nov-2015


FAULT CODE 3165 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 3228 - Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3228 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1885, 3232, 3649, 3682, or 3748 active?
STEP 2. | Check exhaust gas recirculation (EGR) system for leaks. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected in the EGR system?
STEP 3. | Check ECM calibration. |
 | STEP 3A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Check for active fault codes. | Fault Code 3228 active?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3228 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3232, 3649, 3682, or 3748 active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check exhaust gas recirculation (EGR) system for leaks.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Inspect the EGR system for external leaks.

  • Leaks should be easily noted by traces of soot.
  • If necessary, operate the engine at idle speed to help detect any EGR leaks.

Leaks detected in the EGR system?
YES NO

Repair or replace the leaking EGR system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3228 active?
YES NO

A damaged aftertreatment intake NOx sensor has been detected.

Replace the aftertreatment intake Mono-Nitrogen Oxides (NOx) sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Repair complete

Guided Step 4 - Clear fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3229 - Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4367386
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Snap Acceleration Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment exhaust restriction. |
 | STEP 5A. Check for aftertreatment exhaust restriction. | Check for aftertreatment exhaust restriction?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check for aftertreatment exhaust restriction.

Guided Step 5A - Check for aftertreatment exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Aftertreatment exhaust restriction with specification?
YES NO
No Repair

Check the exhaust piping for damage. See equipment manufacturer service information.

Check for any fault codes related to the Cummins® diesel oxidation catalyst (DOC) that indicate a possible damaged or plugged aftertreatment system.

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3231 - Aftertreatment 1 SCR Intake Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Exhaust Restriction | Refer to Procedure 011-009 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4152, 4159, 4164, 4165, 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment exhaust restriction. |
 | STEP 5A. Check for aftertreatment exhaust restriction. | Aftertreatment exhaust restriction with specification?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4152, 4159, 4164, 4165, 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of contamination in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Inspect the aftertreatment exhaust restriction.

Guided Step 5A - Check for aftertreatment exhaust restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Aftertreatment exhaust restriction with specification?
YES NO
No Repair

Check the exhaust piping for damage. See equipment manufacturer service information.

Check for any fault codes related to the Cummins® diesel oxidation catalyst (DOC) that indicate a possible damaged or plugged aftertreatment system.

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 3232 - Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 active?
 | STEP 1B. Check for active fault codes. | Fault Code 2636, 2771, 3868, 4152, 4572, or 5391 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage greater than 10 VDC (12 volt systems) or voltage greater than 20 VDC (24 volt systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment Intake NOx sensor battery voltage supply. | Voltage greater than 10 VDC (12 volt systems) or voltage greater than 20 VDC (24 volt systems)?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 3232 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, 2771, 3868, 4152, 4572, or 5391 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 10 VDC (12 volt systems) or voltage greater than 20 VDC (24 volt systems)?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Clean the terminals and tighten loose connections. See equipment manufacturer service information.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the engine harness to engine block ground.

Check the voltage at keyswitch ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 10 VDC (12 volt systems) or voltage greater than 20 VDC (24 volt systems)?
YES NO

An open or high resistance circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open or high resistance circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Check for blown or missing fuses. Troubleshoot the engine harness, OEM harness, and all interconnects. Repair or replace the damaged component(s) as necessary. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the aftertreatment intake NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector 1.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment intake NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM engine harness connector 1.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open or short has been detected on the J1939 data link. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel selective catalyst reduction (SCR) temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment diesel exhaust fluid (DEF) tank sensors (level, temperature, and quality) from the OEM harness, if equipped.
  • Disconnect the variable geometry turbocharger (VGT) actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector 1 and all other pins in the connector.

Disregard any resistance between 100 and 130 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel SCR temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment DEF tank sensors (level, temperature, and quality) from the OEM harness, if equipped.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector 1 and ground.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM engine harness connector 1 and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.
  • Connect all other components.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE 1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment intake NOx sensor OEM harness connector.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.

Action

Measure the terminating resistance of the engine harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment intake NOx sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active?
YES NO

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3235 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 2 - Check the DEF for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank and follow the appropriate steps in the service manual. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Aftertreatment DOC removed.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3237 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3237 active?
 | STEP 1B. Check for an inactive fault code. | Fault Codes 3237, 3239, and 3422 all active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 1. | Between 2 and 100 ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a damaged aftertreatment DEF line heater relay | Greater than 100K ohms?
STEP 4. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin to pin short in the OEM harness connector | Greater than 100K ohms?
 | STEP 4C. Check for a short to battery in the OEM harness connector | Voltage is equal to battery voltage?
 | STEP 4D. Check for an active fault code | Fault Code 3237 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3237 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3237, 3239, and 3422 all active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment 1 DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 1 and the OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO
No Repair

The line heater 1 resistance is out of specification.

  • Replace the aftertreatment DEF line heater 1. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay connector pins

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM connector.

Action

Inspect the aftertreatment DEF line heater relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a damaged aftertreatment DEF line heater relay

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM connector.

Action

Measure the resistance between pins 30 and 87 on the aftertreatment DEF line heater relay.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay. See equipment manufacturer service information.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short in the OEM harness connector.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short to battery in the OEM harness connector.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Connect the OEM harness connector to the ECM.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage between the aftertreatment DEF line heater 1 SIGNAL and the aftertreatment DEF line heater 1 RETURN at the aftertreatment DEF line heater 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage is equal to battery voltage?
YES NO

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3237 active?
YES NO

A malfunctioning aftertreatment DEF line heater has been detected.

Replace the aftertreatment DEF line heater 1. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3238 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3238 inactive?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
STEP 2. | Check the aftertreatment DEF line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF line heater relay. | Less than 10 ohms?
 | STEP 2C. Check the aftertreatment DEF line heater relay power supply. | Is voltage equal to battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the aftertreatment DEF line heater 1 signal circuit. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-pin short in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 3238 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3238 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 1 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM harness.

Action

Check for a damaged aftertreatment DEF line heater relay.

  • Install a jumper wire from pin 85 on the aftertreatment DEF line heater relay to battery + and connect a jumper wire from pin 86 on the aftertreatment DEF line heater relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment DEF line heater relay.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment DEF line heater relay power supply

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment DEF line heater 1 relay.

  • Measure the voltage between the aftertreatment DEF line heater 1 relay pin 30 in the aftertreatment DEF line heater 1 relay pin connector in the OEM harness and chassis ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage equal to battery voltage?
YES NO
No Repair

An open circuit or short circuit to ground has been detected in the OEM harness line heater power supply circuit.

This could be caused by:

  • Burned out in-line fuse on the line heater power supply circuit, if equipped
  • Open circuit or short to ground in the OEM harness line heater power supply circuit.

Repair or replace the malfunctioning component.

  • See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the aftertreatment DEF line heater 1 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the aftertreatment DEF line heater 1 connector and chassis ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

There is a short circuit to battery somewhere in the OEM harness. Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

A pin-to-pin short has been detected in the OEM harness.

  • Repair or replace the harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3239 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3239 inactive?
 | STEP 1B. Check for an inactive fault code. | Fault Codes 3237, 3239, and 3422 all active?
STEP 2. | Check the aftertreatment 1 diesel exhaust fluid (DEF) line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check resistance of the aftertreatment DEF line heater 2. | Between 2 and 100 ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF heater relay connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a damaged aftertreatment DEF line heater relay. | Greater than 100K ohms?
STEP 4. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM harness connector pins | Dirty or damaged pins?
 | STEP 4B. Check for a pin to pin short in the OEM harness connector. | Greater than 100K ohms?
 | STEP 4C. Check for a short to battery in the OEM harness connector | Voltage equal to battery voltage?
 | STEP 4D. Check for an active fault code. | Fault Code 3239 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3239 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3237, 3239, and 3422 all active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 2 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 2 and the OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 2 or harness connector.

Clean the connector and pins

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment DEF line heater 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.

Action

Check the resistance of the aftertreatment DEF line heater 2.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin and the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector.

Use the circuit diagram and a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO
No Repair

The line heater 2 resistance is out of specification.

Replace the aftertreatment DEF line heater 2. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM connector.

Action

Inspect the aftertreatment DEF line heater relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a damaged aftertreatment DEF line heater relay.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM connector.

Action

Measure the resistance between pins 30 and 87 on the aftertreatment DEF line heater relay

  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay.

  • See equipment manufacturer service information.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short in the OEM harness connector

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short to battery in the OEM harness connector.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage between the aftertreatment DEF line heater 2 SIGNAL and the aftertreatment DEF line heater 2 RETURN at the aftertreatment DEF line heater 2 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage equal to battery voltage?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an active fault code.

Conditions

  • Connect INSITE™ electronic service tool.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3239 inactive?
YES NO

A malfunctioning aftertreatment DEF line heater has been detected. Replace the aftertreatment DEF line heater 2.

  • See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3241 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3241 inactive?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
STEP 2. | Check the aftertreatment DEF line heater 2 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF line heater relay. | Less than 10 ohms?
 | STEP 2C. Check the aftertreatment DEF line heater relay power supply | Voltage equal to battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the aftertreatment DEF line heater 2 signal circuit. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-pin short in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 3241 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3241 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 2 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.

Action

Check for a damaged aftertreatment DEF line heater relay

  • Install a jumper wire from pin 85 on the aftertreatment DEF line heater relay to battery + and connect a jumper wire from pin 86 on the aftertreatment DEF line heater relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment DEF line heater relay

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment DEF line heater relay power supply

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment DEF line heater 2 relay.

  • Measure the voltage between the aftertreatment DEF line heater 2 relay pin 30 in the aftertreatment DEF line heater 2 relay pin connector in the OEM harness and chassis ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage equal to battery voltage?
YES NO
No Repair

An open circuit or short circuit to ground has been detected in the OEM harness line heater power supply circuit.

This could be caused by:

  • Burned out in-line fuse on the line heater power supply circuit, if equipped.
  • Open circuit or short to ground in the OEM harness line heater power supply circuit.

Repair or replace the malfunctioning component.

  • See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the aftertreatment DEF line heater 2 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the aftertreatment DEF line heater 2 connector and chassis ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

  • Repair or replace the harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3241 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3242 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 4168, or 4169 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Inspect the DEF tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 4168, or 4169 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines, including the original equipment manufacturer (OEM) in-line shutoff valve, if equipped.
  • Loose connections
  • Leaking seals or gaskets.

See equipment manufacturer service information for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level ok?
YES NO
No Repair

Fill the coolant. Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure that the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3251 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 | 4358498
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4162, 5391, 5392, 5393, 5394, or 5395 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4162, 5391, 5392, 5393, 5394, or 5395 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Cylinder Performance Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. Refer to the OEM service manual.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3258 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3258 active?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 1 and relay circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the aftertreatment DEF line heater 1 relay signal voltage. | Is voltage 5 VDC +/- 1VDC?
 | STEP 2C. Inspect the aftertreatment DEF line heater 1 signal voltage. | Is voltage 5 VDC +/- 1VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF line heater 1 signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF line heater 1 signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the aftertreatment DEF line heater 1 return circuit. | Less than 10 ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3258 active?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Check the aftertreatment DEF line heater relay voltage. | Is voltage equal to battery voltage?
 | STEP 4B. Check for an open circuit in the aftertreatment DEF line heater 1 return circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the aftertreatment DEF line heater 1 return circuit. | Greater than 100K ohms?
 | STEP 4D. Check for an active fault code. | Fault Code 3258 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES | NO
No Repair | No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and relay circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 1 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the aftertreatment DEF line heater 1 relay signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage between pin 87 at the aftertreatment DEF line heater 1 relay connector and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage 5 VDC +/- 1VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the aftertreatment DEF line heater 1 signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage 5 VDC +/- 1VDC?
YES NO

Replace the aftertreatment DEF line heater 1.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF line heater 1 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the aftertreatment DEF line heater 1 connector and the aftertreatment DEF line heater 1 SIGNAL pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF line heater 1 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 1 relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin at the aftertreatment DEF line heater 1 connector and pin 87 at the aftertreatment DEF line heater 1 relay connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the aftertreatment DEF line heater 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 active?
YES NO

Replace the aftertreatment DEF line heater 1.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check OEM harness returns and fuse.

Guided Step 4A - Check the aftertreatment DEF line heater relay voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between pin 30 at the aftertreatment DEF line heater relay connector and chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage equal to battery voltage?
YES NO
No Repair

Inspect the aftertreatment DEF line heater relay fuse and replace if necessary.

If the fuse is not blown, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the aftertreatment DEF line heater 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground in the aftertreatment DEF line heater 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector and chassis ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 3261 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3261 active?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 2 and relay circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the aftertreatment DEF line heater 2 relay signal voltage. | Voltage 5 VDC +/- 1VDC?
 | STEP 2C. Inspect the aftertreatment DEF line heater 2 signal voltage. | Voltage 5 VDC +/- 1VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF line heater 2 signal circuit | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF line heater 2 signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the aftertreatment DEF line heater 2 return circuit. | Less than 10 ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3261 active?
STEP 4. | Check OEM harness returns and fuse. |
 | STEP 4A. Check the aftertreatment DEF line heater relay voltage. | Voltage equal to battery voltage?
 | STEP 4B. Check for an open circuit in the aftertreatment DEF line heater 2 return circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the aftertreatment DEF line heater 2 return circuit. | Greater than 100K ohms?
 | STEP 4D. Check for an active fault code. | Fault Code 3258 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3261 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES NO

Appropriate fault code troubleshooting tree

 No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 2 and relay circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 2 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the aftertreatment DEF line heater 2 relay signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage between pin 87 at the aftertreatment DEF line heater 2 relay connector and the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage 5 VDC +/- 1VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the aftertreatment DEF line heater 2 signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness
  • Turn keyswitch ON.

Action

.Check the signal voltage

  • Measure the voltage between the aftertreatment DEF line heater 2 SIGNAL pin and the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage 5 VDC +/- 1VDC?
YES NO

Replace the aftertreatment DEF line heater 2.

  • Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF line heater 2 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the aftertreatment DEF line heater 2 connector and the aftertreatment DEF line heater 2 SIGNAL pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF line heater 2 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 2 relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 2 SIGNAL pin at the aftertreatment DEF line heater 2 connector and pin 87 at the aftertreatment DEF line heater 2 relay connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the aftertreatment DEF line heater 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3261 active?
YES NO

Replace the aftertreatment DEF line heater 2

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check OEM harness returns and fuse.

Guided Step 4A - Check the aftertreatment DEF line heater relay voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between pin 30 at the aftertreatment DEF line heater relay connector and chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Is voltage equal to battery voltage?
YES NO
No Repair

Inspect the aftertreatment DEF line heater relay fuse and replace if necessary.

  • If the fuse is not blown, repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the aftertreatment DEF line heater 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground in the aftertreatment DEF line heater 2 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 2 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 2 RETURN pin at the aftertreatment DEF line heater 2 connector and chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

  • Repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3258 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 3313 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, or 5395 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, or 5395 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst temperature sensor module has been detected.

Replace the aftertreatment diesel oxidation catalyst temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3314 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, 5395, or 5396 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, 5395, or 5396 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst (DOC) temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3315 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, 5395, or 5396 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, 5395, or 5396 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst (DOC) temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3341 - Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Cleaner Element | Refer to Procedure 010-014 | QSB6.7 CM2350 B112 | 4358498
Air Cleaner Element | Refer to Procedure 010-014 | QSL9 CM2350 L107 | 4367386
Air Intake Restriction | Refer to Procedure 010-031 | QSB6.7 CM2350 B112 | 4358498
Air Intake Restriction | Refer to Procedure 010-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Initial Checks. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 741, 742, or 743, active or inactive counts?
 | STEP 1C. Check for active fault codes. | Fault Code 3341 active?
STEP 2. | Check the air intake system. |
 | STEP 2A. Check the air intake for restriction. | Air intake restriction within specifications?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Initial Checks.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741,742, or 743, active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

Turn keyswitch ON.

Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Operate the engine under normal operating conditions for 5 minutes.

Fault Code 3341 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the air intake system.

Guided Step 2A - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component. Refer to procedure 010-014 in the Associated Procedures table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jul-2015


FAULT CODE 3422 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 3422 active?
 | STEP 1B. Check for active fault code. | Fault Codes 3237, 3239, and 3422 all active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater 3 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 3. | Between 2 and 100 ohms?
STEP 3. | Check the aftertreatment DEF line heater relay. |
 | STEP 3A. Inspect the aftertreatment DEF line heater relay connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a damaged aftertreatment DEF line heater relay. | Greater than 100k ohms?
STEP 4. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the OEM harness connector. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit to battery in the OEM harness connector. | Voltage is equal to battery voltage?
 | STEP 4D. Check for an active fault code. | Fault Code 3422 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3422 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3237, 3239, and 3422 all active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 3 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 3 and the OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in line heater 3 or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check resistance of the aftertreatment DEF line heater 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.

Action

Check the resistance of the aftertreatment DEF line heater 3.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin and the aftertreatment DEF line heater 3 SUPPLY pin at the aftertreatment DEF line heater 3 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO
No Repair

The line heater 3 resistance is out of specification.

Replace the aftertreatment DEF line heater 3. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF line heater relay.

Guided Step 3A - Inspect the aftertreatment DEF line heater relay connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM connector.

Action

Inspect the aftertreatment DEF line heater relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a damaged aftertreatment DEF line heater relay.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM connector.

Action

Measure the resistance between pins 30 and 87 on the aftertreatment DEF line heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM and harness connector pins.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short circuit in the OEM harness connector.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to battery in the OEM harness connector.

Conditions

  • Turn keyswitch OFF and wait at least 90 seconds before proceeding.
  • Connect the OEM harness connector to the ECM.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage between the aftertreatment DEF line heater 3 SIGNAL and the aftertreatment DEF line heater 3 RETURN at the aftertreatment DEF line heater 3 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage is equal to battery voltage?
YES NO

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for active fault code.

Conditions

  • Connect INSITE™ electronic service tool.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3422 active?
YES NO

A damaged aftertreatment DEF line heater has been detected. Replace the aftertreatment DEF line heater 3. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 3423 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3423 active?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
STEP 2. | Check the aftertreatment DEF line heater 3 relay. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF line heater relay. | Less than 10 ohms?
 | STEP 2C. Check the aftertreatment DEF line heater relay power supply. | Voltage equal to battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the aftertreatment DEF line heater 3 signal circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 3423 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3423 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 3 relay.

Guided Step 2A - Inspect the aftertreatment DEF line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 3 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF line heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.

Action

Check for a damaged aftertreatment DEF line heater relay.

  • Install a jumper wire from pin 85 on the aftertreatment DEF line heater relay to battery + and connect a jumper wire from pin 86 on the aftertreatment DEF line heater relay to chassis ground.
  • Measure the resistance between pin 30 and pin 87 on the aftertreatment DEF line heater relay.

Less than 10 ohms?
YES NO
No Repair

Replace the aftertreatment DEF line heater relay. See equipment manufacturer service information

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment DEF line heater relay power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check for voltage to the aftertreatment DEF line heater 3 relay.

  • Measure the voltage between the aftertreatment DEF line heater 3 relay pin 30 in the aftertreatment DEF line heater 3 relay pin connector in the OEM harness and chassis ground.

Voltage equal to battery voltage?
YES NO
No Repair

An open circuit or short circuit to ground has been detected in the OEM harness line heater power supply circuit. This could be caused by:

  • Burned out in-line fuse on the line heater power supply circuit, if equipped.
  • Open circuit or short to ground in the OEM harness line heater power supply circuit.

Repair or replace the malfunctioning component. See equipment manufacturer service information

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the aftertreatment DEF line heater 3 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the aftertreatment DEF line heater 3 connector and chassis ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3423 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3425 - Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3425 active?
 | STEP 1B. Check for active diesel exhaust fluid (DEF) line heater relay fault codes. | Fault Code 3562, 3563, or 3564 active?
 | STEP 1C. Check for multiple active DEF line heater fault codes. | Fault Codes 3258, 3261, and 3425 all active?
STEP 2. | Check the aftertreatment DEF line heater 3 and relay circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 3 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the aftertreatment DEF line heater 3 relay signal voltage. | Voltage 5-VDC +/- 1-VDC?
 | STEP 2C. Inspect the aftertreatment DEF line heater 3 signal voltage. | Voltage 5-VDC +/- 1-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the aftertreatment DEF line heater 3 signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the aftertreatment DEF line heater 3 signal circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the aftertreatment DEF line heater 3 return circuit. | Less than 10 ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3425 active?
STEP 4. | Check OEM harness returns and fuse. |
 | STEP 4A. Check the aftertreatment DEF line heater relay voltage. | Voltage equal to battery voltage?
 | STEP 4B. Check for an open circuit in the aftertreatment DEF line heater 3 return circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the aftertreatment DEF line heater 3 return circuit. | Greater than 100k ohms?
 | STEP 4D. Check for an active fault code. | Fault Code 3425 active?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3425 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active DEF line heater relay fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF line heater relay fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562, 3563, or 3564 active?
YES NO

Refer to appropriate fault code troubleshooting tree.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for multiple active DEF line heater fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active DEF line heater fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258, 3261, and 3425 all active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 3 and relay circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 3 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 3 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the aftertreatment DEF line heater 3 relay signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage between pin 87 at the aftertreatment DEF line heater 3 relay connector and the aftertreatment DEF line heater 3 RETURN at the aftertreatment DEF line heater 3 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage 5-VDC +/- 1-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the aftertreatment DEF line heater 3 signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage between the aftertreatment DEF line heater 3 SIGNAL pin and the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Voltage 5-VDC +/- 1-VDC?
YES NO

Replace the aftertreatment DEF line heater 3. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF line heater 3 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the aftertreatment DEF line heater 3 connector and the aftertreatment DEF line heater 3 SIGNAL pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the aftertreatment DEF line heater 3 signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the aftertreatment DEF line heater 3 relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 SIGNAL pin at the aftertreatment DEF line heater 3 connector and pin 87 at the aftertreatment DEF line heater 3 relay connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the aftertreatment DEF line heater 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3425 active?
YES NO

Replace the aftertreatment DEF line heater 3. Refer to OEM service manual.

The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check OEM harness returns and fuse.

Guided Step 4A - Check the aftertreatment DEF line heater relay voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Measure the voltage between pin 30 at the aftertreatment DEF line heater relay connector and chassis ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage equal to battery voltage?
YES NO
No Repair

Inspect the aftertreatment DEF line heater relay fuse and replace if necessary.

If fuse is not blown, repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the aftertreatment DEF line heater 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector and the aftertreatment DEF line heater RETURN 1 pin at the OEM harness connector.
  • Measure the resistance between the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector and the aftertreatment DEF line heater RETURN 2 pin at the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground in the aftertreatment DEF line heater 3 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 3 from the OEM harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance between the aftertreatment DEF line heater 3 RETURN pin at the aftertreatment DEF line heater 3 connector and chassis ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3425 active?
YES NO

Replace the aftertreatment DEF line heater 3. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 3558 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3558 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment DEF dosing unit supply. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit on the aftertreatment DEF dosing unit supply. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit on the aftertreatment DEF dosing unit signal. | Greater than 100k ohms?
 | STEP 2E. Check for DEF dosing unit functionality. | Fault code inactive?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3558 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment DEF dosing unit supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness aftertreatment DEF dosing unit SUPPLY pin and OEM harness ECM connector aftertreatment DEF dosing unit SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit on the aftertreatment DEF dosing unit supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit on the aftertreatment DEF dosing unit signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL / dosing unit temperature pin of the OEM harness connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedure Table.

A pin-to-pin short circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for DEF dosing unit functionality.

Conditions

  • Turn keyswitch ON.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.

Action

Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests in the INSITE™ electronic service tool

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Fault code inactive?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3559 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3559 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit on the aftertreatment DEF dosing unit signal. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit on the aftertreatment DEF dosing unit supply. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit on the aftertreatment DEF dosing unit signal. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ground short circuit on the aftertreatment DEF dosing unit supply. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
 | STEP 2G. Check for DEF dosing unit functionality. | Fault code inactive?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit on the aftertreatment DEF dosing unit signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL / dosing unit temperature pin at the dosing unit wiring harness connector and aftertreatment DEF dosing unit SIGNAL / dosing unit temperature pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit on the aftertreatment DEF dosing unit supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin at the dosing unit wiring harness connector and aftertreatment DEF dosing unit SUPPLY pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-ground short circuit on the aftertreatment DEF dosing unit signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin of the OEM harness connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ground short circuit on the aftertreatment DEF dosing unit supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin of the OEM harness connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for DEF dosing unit functionality.

Conditions

  • Turn keyswitch ON.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.

Action

Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests in the INSITE™ electronic service tool

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Fault code inactive?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedure Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3562 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3562 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater relays. |
 | STEP 2A. Inspect the aftertreatment DEF line heater relays and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater relay circuit. | Less than 100 ohms?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check the circuit response. | Fault Code 3562 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3562 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF line heater relays.

Guided Step 2A - Inspect the aftertreatment DEF line heater relays and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness connector.

Action

Inspect the aftertreatment DEF line heater relays 1, 2, 3 and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater relay circuit.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness connector.

Action

Check the resistance of the aftertreatment DEF line heater relay coil.

  • Measure the resistance between the aftertreatment DEF line heater 1 relay pin 85 and the aftertreatment DEF line heater relay 1 pin 86 at the relay.
  • Measure the resistance between the aftertreatment DEF line heater 2 relay pin 85 and the aftertreatment DEF line heater relay 2 pin 86 at the relay.
  • Measure the resistance between the aftertreatment DEF line heater 3 relay pin 85 and the aftertreatment DEF line heater relay 3 pin 86 at the relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF relay coil.

Replace the aftertreatment DEF relay. Refer to the OEM service manual.

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater 1 relay coil RETURN pin at the OEM harness connector and all other pins in the OEM harness.
  • Measure the resistance between the aftertreatment DEF line heater 2 relay coil RETURN pin at the OEM harness connector and all other pins in the OEM harness.
  • Measure the resistance between the aftertreatment DEF line heater 3 relay coil RETURN pin at the OEM harness connector and all other pins in the OEM harness.
  • There will be continuity between the line heater 1, line heater 2, and line heater 3 pins in the OEM harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF line heater 1 relay coil RETURN pin at the relay connector and the aftertreatment DEF line heater exhaust fluid line heater 1 RETURN pin at the OEM harness.
  • Measure the resistance between the aftertreatment DEF line heater 2 relay coil RETURN pin at the relay connector and the aftertreatment DEF line heater exhaust fluid line heater 2 RETURN pin at the OEM harness.
  • Measure the resistance between the aftertreatment DEF line heater 3 relay coil RETURN pin at the relay connector and the aftertreatment DEF line heater exhaust fluid line heater 3 RETURN pin at the OEM harness.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool and perform the DEF doser system heater test and energize the aftertreatment DEF line heater relay.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3562 active?
YES NO

Replace the line heater relay(s). Refer to the OEM service manual

None: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 14-Feb-2014


FAULT CODE 3563 - Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted To Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3563 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater relay. |
 | STEP 2A. Inspect the aftertreatment DEF line heater relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF line heater relay circuit. | Voltage equal to battery voltage +/ - 1 VDC?
 | STEP 2C. Check for an aftertreatment DEF line heater relay blown fuse. | Blown fuse?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check the circuit response. | Fault Code 3563 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3563 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF line heater relay.

Guided Step 2A - Inspect the aftertreatment DEF line heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness.

Action

Inspect the relays and OEM harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF line heater relay circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness.
  • Turn keyswitch ON.

Action

Check the voltage of the aftertreatment DEF line heater relay power supply.

  • Measure the voltage between the aftertreatment DEF line heater relay 1 supply at the aftertreatment DEF line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment DEF line heater relay 2 supply at the aftertreatment DEF line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment DEF line heater relay 3 supply at the aftertreatment DEF line heater relay connector and chassis ground.

Voltage equal to battery voltage +/ - 1 VDC?
YES NO

Replace the aftertreatment DEF line heater relay fuse.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step - 2C - Check for an aftertreatment DEF line heater relay blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for an aftertreatment DEF line heater relay blown fuse.

  • Check the aftertreatment DEF line heater relay fuse.

Blown fuse?
YES NO

Replace the aftertreatment DEF line heater relay fuse.

See equipment manufacturer service information.

An open or a short circuit to ground has been detected in the OEM power supply.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the OEM connector and engine block ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See equipment manufacturer service information. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step - 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF and wait at least 90 seconds before proceeding.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF line heater relays 1, 2, and 3 from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF line heater relay RETURN pin at the OEM connector and all other pins in the OEM harness.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See equipment manufacturer service information. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step - 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3563 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3567 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4358498

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3567 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF dosing valve resistance. | Between 11 and 18 ohms?
 | STEP 2C. Check for a short to ground in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open supply circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open return circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Inspect the harness and aftertreatment DEF dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check the resistance of the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and RETURN pin at the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 11 and 18 ohms?
YES NO
No Repair

An internal short or open has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short-to-ground in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DEF dosing valve

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open supply circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DEF dosing valve SUPPLY pin and the SUPPLY pin at the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected. Troubleshoot the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DEF dosing valve RETURN pin and the RETURN pin at the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness. Troubleshoot the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit circuit has been detected in the harness.

Troubleshoot the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3568 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3568 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve. |
 | STEP 2A. Check for a stuck closed aftertreatment DEF dosing valve. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3568 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment DEF dosing valve.

Guided Step 2A - Check for a stuck closed aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment DEF dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing valve has been detected.

Inspect and Clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test again. If the dosing valve does not meet the specification outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3571 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3571 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3572 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3571 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3571 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Other aftertreatment DEF dosing unit fault codes will be active.

Fault Code 3572 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF pressure sensor SUPPLY pin and the aftertreatment DEF pressure sensor RETURN pin at the aftertreatment DEF dosing unit connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected inside the aftertreatment DEF dosing unit.

Replace the aftertreatment diesel exhaust dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor RETURN pin at the OEM harness ECM connector and the aftertreatment DEF pressure sensor RETURN pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3572 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3572 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3571 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3572 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3572 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF pressure SUPPLY pin and the aftertreatment DEF pressure RETURN pin at the aftertreatment DEF pressure sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF pressure sensor SUPPLY pin and the aftertreatment DEF pressure sensor SIGNAL pin at the aftertreatment DEF dosing unit connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other DEF dosing unit fault codes will be active.

Fault Code 3571 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected inside the aftertreatment DEF dosing unit.

Replace the aftertreatment diesel exhaust dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SUPPLY pin at the OEM harness ECM connector and the aftertreatment DEF pressure sensor SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF pressure sensor SIGNAL pin at the OEM harness aftertreatment DEF dosing unit connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness. Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3574 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSB6.7 CM2350 B112 QSL9 CM2350 L107 | 4358498 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3574 active or more than two inactive counts?
 | STEP 1B. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty?
 | STEP 1C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 1D. Check for active aftertreatment DEF system fault codes. | Any fault codes related to the DEF dosing system?
 | STEP 1E. Check for active aftertreatment DEF system fault codes. | Fault Code 1713 active or inactive?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 2C. Check for air in the DEF. | Air detected in the DEF?
 | STEP 2D. Inspect the aftertreatment DEF dosing unit supply line and return line fittings. | Dosing unit supply line or return line fitting blocked?
STEP 3. | Check the aftertreatment DEF tank filter. |
 | STEP 3A. Inspect the DEF tank filter for blockage. | DEF tank filter blocked?
STEP 4. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 4A. Perform the aftertreatment DEF doser pump override test. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
 | STEP 4B. Perform the aftertreatment DEF dosing unit airless flush. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low diesel exhaust fluid (DEF) tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to check the aftertreatment DEF tank level and compare it to the gauge on the dash.

DEF tank empty?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Visually inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with pure DEF. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 1D

Go to 1D

Guided Step 1D - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active fault codes relating to the DEF dosing system.

Any fault codes related to the DEF dosing system?
YES NO

Troubleshoot any active fault codes in this list before troubleshooting Fault Code 3574.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active or inactive Fault Code 1713.

Fault Code 1713 active or inactive?
YES NO

If Fault Code 1713 is active or inactive, go to the troubleshooting tree for Fault Code 1713 and complete step 4B.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, outlet, and return connectors and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, outlet, and return connectors and look for signs of buildup or blockage.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking DEF line or fitting as necessary. See equipment manufacturer service information.

Repair or replace the aftertreatment DEF dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (suction line between the tank and dosing unit).
  • Disconnect the aftertreatment DEF dosing unit supply line from the DEF tank.

Action

Check the DEF dosing unit supply line for blockage.

  • Look at both ends of the line to check for signs of buildup or blockage.
  • Blow compressed shop air through the supply line to establish/confirm free flow.

DEF dosing unit supply line blocked or restricted?
YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing unit supply line. See equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for air in the DEF.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air detected in the DEF?
YES NO

Check the following components for damage or leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the aftertreatment DEF dosing unit supply line and return line fittings.

Conditions

  • Turn keyswitch OFF.
  • Remove the DEF dosing supply line and return line fittings.

Action

Inspect the aftertreatment DEF dosing unit supply line and return line fittings for blockage.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line or return line fitting blocked?
YES NO

Replace the blocked fitting.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF tank filter.

Guided Step 3A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

  • See equipment manufacturer service information.

DEF tank filter blocked?
YES NO

Clean or change the DEF tank filter.

Drain, clean, and fill the DEF tank. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the aftertreatment DEF dosing unit operation.

Guided Step 4A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Perform the aftertreatment DEF dosing unit airless flush.

Conditions

  • Remove the aftertreatment DEF dosing valve.
  • Remove the aftertreatment DEF dosing unit.
  • Connect INSITE™ electronic service tool.

Action

Flush the aftertreatment DEF dosing unit with clean water.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jul-2015


FAULT CODE 3575 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3575 active or more than two inactive counts?
 | STEP 1B. Check for active aftertreatment diesel exhaust fluid (DEF) system fault codes. | Any faults related to the DEF dosing system?
STEP 2. | Check the aftertreatment DEF lines and fittings |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Damaged, leaking, or restricted connections found?
 | STEP 2B. Check the aftertreatment DEF dosing unit return line. | DEF return line blocked or restricted?
 | STEP 2C. Inspect the aftertreatment DEF dosing unit return line fitting. | Dosing unit return line fitting blocked?
STEP 3. | Check aftertreatment DEF dosing unit operation |
 | STEP 3A. Perform Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test. | Aftertreatment DEF dosing unit operates according to the specifications in procedure 011-063?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active fault codes relating to the DEF dosing system.

Any faults related to the DEF dosing system?
YES NO

Troubleshoot any active faults before troubleshooting Fault Code 3575.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings

Guided Step 2A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all three aftertreatment DEF dosing unit fittings and lines.

  • Check the dosing unit supply, dosing valve supply, return connectors, and fittings for loose or leaking connections.
  • Disconnect the dosing unit supply, dosing valve supply, and return connectors on the dosing unit and look for signs of buildup or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.

Refer to Procedure 011-058 in the Associated Procedures Table.

Damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns DEF to the tank).
  • Disconnect the aftertreatment DEF dosing unit return line from the DEF tank.

Action

Check the DEF return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the aftertreatment DEF dosing unit return line fitting.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns DEF to the tank).
  • Remove the DEF dosing unit return line fitting.

Action

Inspect the aftertreatment DEF dosing unit return line fitting for blockage or restrictions.

  • If necessary, blow compressed shop air through the return line fitting.

Note: The return line fitting is equipped with an internal check valve that only allows flow in one direction.

Refer to Procedure 011-058 in the Associated Procedure Table.

Dosing unit return line fitting blocked?
YES NO

Replace the DEF dosing unit return line fitting. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment DEF dosing unit operation

Guided Step 3A - Perform Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Aftertreatment DEF dosing unit operates according to the specifications in procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. (Note that this filter can not be reused and must be replaced upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new filter. If measure volume of DEF is still not within specifications, replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 3577 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3577 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Resistance between 17 and 25 ohms for 24 volt systems, or 4.5 and 9 ohms for 12 volt systems?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF return valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF return valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the resistance of the aftertreatment DEF return valve.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin and the aftertreatment DEF return valve RETURN pin at the aftertreatment DEF dosing unit connector.

Resistance between 17 and 25 ohms for 24 volt systems, or 4.5 and 9 ohms for 12 volt systems?
YES NO
No Repair

A malfunctioning aftertreatment DEF return valve has been detected in that aftertreatment DEF dosing unit. Replace the aftertreatment DEF dosing unit. Refer to procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the aftertreatment DEF dosing unit wiring harness connector and the aftertreatment DEF return valve SUPPLY pin at the OEM harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF return valve supply circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF return valve RETURN pin at the aftertreatment DEF dosing unit wiring harness connector and the aftertreatment DEF return valve RETURN pin at the OEM harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF return valve return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 3578 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3578 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) return valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF return valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment diesel exhaust fluid return valve. | Resistance meet specification?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF return valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF return valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF return valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the resistance of the aftertreatment DEF return valve.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin and the aftertreatment DEF return valve RETURN pin at the aftertreatment DEF dosing unit connector.
  • For 12V system resistance must be between 4.5 and 9.0 ohms
  • For 24V system resistance must be between 17 and 25 ohms.

Resistance meet specification?
YES NO
No Repair

A malfunctioning aftertreatment DEF return valve has been detected in that aftertreatment DEF dosing unit. Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF return valve RETURN pin at the aftertreatment DEF dosing unit wiring harness connector and ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF return valve supply circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the aftertreatment diesel exhaust fluid return valve supply circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 3582 - Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSL9 CM2350 L107 | 4367386
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3582 active?
 | STEP 1B. Check for active aftertreatment nitrogen oxides (NOx) sensor fault codes. | Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment SCR temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related fault codes active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Inspect the DEF dosing system for external leaks | External leaks detected in the system?
 | STEP 2C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2D. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
 | STEP 2E. Check the aftertreatment DEF dosing valve for proper operation. | DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment Selective Catalytic Reduction (SCR) Performance Test. | Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for DEF deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the aftertreatment SCR performance test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3582 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active aftertreatment SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active diesel exhaust fluid (DEF) dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • DEF tank connectors.
  • DEF dosing unit and dosing unit connectors.
  • DEF lines.
  • DEF dosing valve.

DEF will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. This filter can not be reused and must be changed upon removal.

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment DEF Doser Pump Override Test again with a new filter. If the dosing unit still does not operate according to the specifications, replace the dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the aftertreatment DEF dosing valve for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing valve for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under engine control module Diagnostic Tests. Refer to Procedure Refer to Procedure 011-063 in the Associated Procedures Table.

Perform the DEF Doser Pump Overide Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
YES NO

A leaking aftertreatment diesel exhaust fluid dosing valve has been detected.

Replace the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Perform the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for DEF deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Repeat the Aftertreatment SCR Performance Test.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the Aftertreatment Outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 3596 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | QSL9 CM2350 L107 | 4367386
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSB6.7 CM2350 B112 | 4358498
Air in the Diesel Exhaust Fluid | Refer to Procedure 011-075 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3571 and 3572. | Fault Code 3571 or 3572 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor. | Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
STEP 3. | Check the aftertreatment DEF lines and fittings |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any damaged, leaking, or restricted connections found?
 | STEP 3B. Check the aftertreatment DEF dosing unit supply line. | DEF dosing unit supply line blocked or restricted?
 | STEP 3C. Check the aftertreatment DEF dosing unit return line. | DEF return line blocked or restricted?
 | STEP 3D. Check for air in the DEF. | Air in the DEF detected?
 | STEP 3E. Inspect the aftertreatment DEF dosing unit supply line fitting. | Dosing unit supply line or return line fitting blocked?
STEP 4. | Check the aftertreatment DEF tank filter |
 | STEP 4A. Inspect the aftertreatment DEF tank filter for blockage. | DEF tank filter blocked?
STEP 5. | Check aftertreatment DEF dosing unit operation. |
 | STEP 5A. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in procedure 011-063?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3571 and 3572.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 or 3572 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF pressure sensor.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve supply line from the aftertreatment DEF dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment DEF pressure sensor.

  • Use INSITE™ electronic service tool to monitor the aftertreatment DEF pressure.

Aftertreatment DEF pressure reading in INSITE™ electronic service tool equal to 0 ± 69 KPa [0 ± 10 psi]?
YES NO
No Repair

A damaged aftertreatment DEF pressure sensor has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the aftertreatment DEF lines and fittings.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit lines and fittings.

There are three DEF lines on the SCR dosing system:

  • Dosing unit supply line between the tank and the dosing unit (suction line)
  • Dosing valve supply line between the dosing unit and the dosing valve (pressure line)
  • Return line between the dosing unit and the tank (return line)

Inspect all three DEF lines and associated fittings/connectors:

  • Check the DEF tank connections (suction and return lines) for cracks and pitting
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (three connections), and dosing valve (one connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the aftertreatment DEF dosing unit supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit supply line from the dosing unit (this is the suction line between the dosing unit and DEF tank).
  • Disconnect the aftertreatment DEF dosing unit supply line from the DEF tank.

Action

Check the DEF dosing unit supply line for blockage.

  • Visually check both ends of the dosing unit supply line for signs of build-up or blockage.
  • Blow compressed shop air through the dosing unit supply line to make sure of free flow.

DEF dosing unit supply line blocked or restricted?

YES NO

Try to clean the dosing unit supply line using shop air. If necessary, replace the dosing valve supply line.

Refer to OEM service manual.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check the aftertreatment DEF dosing unit return line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit return line from the dosing unit (return line runs between the tank and dosing unit and returns DEF to the tank).
  • Disconnect the aftertreatment DEF dosing unit return line from the DEF tank.

Action

Check the aftertreatment DEF return line for blockage.

  • Visually check both ends of the line for signs of buildup or blockage.
  • Blow compressed shop air through the return line to make sure of free flow.

DEF return line blocked or restricted?
YES NO

Try to clean the return line using shop air. If necessary, replace the return line.

Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3D

Guided Step 3D - Check for air in the DEF.

Conditions

  • Connect the aftertreatment DEF dosing unit supply and return lines to the DEF tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for air in the DEF.

  • Refer to Procedure 011-075 in the Associated Procedures Table.

Air in the DEF detected?

YES NO

Check the following components for damage/leaks and repair as necessary:

  • Aftertreatment DEF dosing unit fittings
  • Aftertreatment DEF dosing unit supply line
  • Aftertreatment DEF tank fittings.

Refer to Procedure 011-075 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3E

Guided Step 3E - Inspect the aftertreatment DEF dosing unit supply line fitting.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DEF dosing supply line and return line fittings.

Action

Inspect the aftertreatment DEF dosing unit supply line fitting.

  • Inspect the aftertreatment DEF dosing unit supply line and return line fittings for blockage. Refer to Procedure 011-058 in the Associated Procedures Table.

Dosing unit supply line or return line fitting blocked?

YES NO

Replace the blocked fitting. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment DEF tank filter

Guided Step 4A - Inspect the aftertreatment DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the DEF tank.

Action

Inspect the DEF tank filter for blockage.

  • Inspect the aftertreatment DEF tank filter for signs of blockage or buildup. Refer to the OEM service manual.

DEF tank filter blocked?
YES NO

Clean or replace the DEF tank filter.

Drain, clean, and refill the DEF tank.

Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check aftertreatment DEF dosing unit operation.

Guided Step 5A - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing unit for proper operation.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test, under ECM Diagnostics Tests. Refer to Procedure 011-063 in the Associated Procedures Table.

Note: The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. (Note that this filter cannot be reused and must be replaced upon removal.) Refer to Procedure 011-060 in the Associated Procedures Table.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new filter. If the measured volume of DEF is still not within specifications, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM Code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 3748 - Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3748 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1885, 3232, 3649, or 3682 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3748 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, 3649, or 3682 active?
YES NO
No Repair

Verify the aftertreatment intake mono-nitrogen oxides (NOx) sensor is present and has been installed properly.

If the aftertreatment intake NOx sensor is present and installed properly, a damaged aftertreatment intake NOx sensor is a possible cause.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 3749 - Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Decomposition Tube | Refer to Procedure 011-062 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3749 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3583, or 3681 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) valve and decomposition tube. |
 | STEP 2A. Check the decomposition tube for crystallization. | Crystallization buildup in the decomposition tube?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3749 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1887, 2771, 3583, or 3681 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

Inspect the aftertreatment outlet NOx sensor for proper installation.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment DEF valve and decomposition tube.

Guided Step 2A - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table.

Action

Check for DEF crystallization.

Inspect the decomposition tube for crystallization. Refer to Procedure 011-062 in the Associated Procedures Table.

Crystallization buildup in the decomposition tube?
YES NO

Remove the crystallization buildup. Refer to Procedure 011-062 in the Associated Procedures Table.

A damaged aftertreatment outlet NOx sensor has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 3868 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the battery. To reduce the possibility of arching, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3868 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) quality sensor and circuit. |
 | STEP 2A. Inspect the DEF quality sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the DEF quality sensor. | Voltage within 1-VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) wiring harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the DEF quality sensor battery voltage supply. | Voltage within 1-VDC of battery voltage?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | Resistance between 50 and 70 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the DEF quality sensor and circuit.

Guided Step 2A - Inspect the DEF quality sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the DEF quality sensor

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF quality sensor.

  • Measure the voltage between the DEF quality sensor battery voltage SUPPLY circuit and the DEF quality sensor battery voltage return circuit at the sensor wiring harness connector.

Note: Check the voltage at key ON, while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM wiring harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the DEF quality sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM wiring harness.

Action

Check for an open circuit.

  • Measure the voltage from the DEF quality sensor battery voltage SUPPLY pin of the OEM wiring harness connector to engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the DEF quality sensor battery voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the DEF quality sensor battery voltage.

Troubleshoot the OEM harness, any fuses, and/or relays in the supply circuit.

Repair or replace the necessary components.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link harness.

Guided Step 4A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the DEF quality sensor wiring harness connector and the SAE J1939 (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the DEF quality sensor wiring harness connector and the SAE J1939 (-) wire at the ECM OEM harness connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF quality sensor from the OEM wiring harness.
  • Disconnect the DEF dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and all other pins in the connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF quality sensor from the OEM wiring harness.
  • Disconnect the DEF dosing unit from the OEM harnesses.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF quality sensor from the OEM harness.

Action

Check the terminating resistance of the J1939 data link.

  • Measure the resistance between the J1939 data link (+) wire and the J1939 data link (-) wire at the DEF quality sensor wiring harness connector.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An incorrect terminating resistance has been detected in the OEM harness.

Repair the OEM J1939 data link. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 3931 - Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3931 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 3931 active?
YES NO

This is an information only fault code that will only become active if other critical engine performance fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 4135 - Engine Protection System Approaching Shutdown - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4135 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4135.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 4135 active?
YES NO

This is an information-only fault code that will only become active if other critical engine performance fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 4152 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152 active?
 | STEP 1B. Check for active fault codes. | Fault Code 2636, 2771, 3232, 3868, 5391 new workhorse fault code, or 4572 also active?
STEP 2. | Check the aftertreatment selective catalyst reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage greater than 10-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage greater than 10-VDC?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check for active fault codes. | Fault Code 4151 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, 2771, 3232, 3868, 5391 new workhorse fault code, or 4572 also active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Note: Check the voltage at key ON while cranking the engine, and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

  • Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Turn keyswitch ON.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES NO

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Repair or replace the OEM harness. Refer to the OEM service manual.

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Check for blown or missing fuses. Check for damaged or missing relays. Troubleshoot all interconnects. Repair or replace the damaged component(s), as necessary. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR temperature sensor module the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the SCR temperature sensor module OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the SCR temperature sensor module OEM harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet mono-nitrogen oxides (NOx) sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment diesel oxidation catalyst sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel SCR temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment diesel exhaust fluid tank sensors (level, temperature, quality), if equipped.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

Troubleshoot the engine harness, OEM harness, and all interconnects. Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment diesel oxidation catalyst sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel SCR temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment diesel exhaust fluid tank sensors (level, temperature, quality), if equipped.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

  • Troubleshoot the engine harness, OEM harness, and all interconnects.
  • Repair or replace the damaged or malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • All other components connected.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the SCR temperature sensor module OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.
  • All other components connected.

Action

Measure the terminating resistance of the OEM harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Measure the terminating resistance of the variable geometry turbocharger actuator.

  • Measure the resistance between the variable geometry turbocharger actuator J1939 data link (+) wire and the variable geometry turbocharger actuator J1939 data link (-) wire at the variable geometry turbocharger actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in variable geometry turbocharger actuator.

Replace the variable geometry turbocharger actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment SCR temperature sensor module to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 active?
YES NO

Replace the aftertreatment SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 4155 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4155 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit heater relay and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF dosing unit heater relay. | Less than 1 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to battery. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 4155 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit heater relay and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the DEF dosing unit heater relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Check the resistance of the aftertreatment DEF dosing unit heater relay.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay pin 85 and the aftertreatment DEF dosing unit heater relay pin 86 of the aftertreatment DEF dosing unit heater relay.

Less than 1 ohms?
YES NO

A malfunctioning aftertreatment DEF dosing unit heater relay has been detected.

Replace the aftertreatment DEF dosing unit heater relay. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay RETURN pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF dosing unit heater relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit circuit to battery.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay RETURN pin at the OEM harness ECM connector and battery positive (+).

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery has been detected in the aftertreatment DEF dosing unit heater relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 4156 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4156 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit heater relay and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF dosing unit heater relay. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4156 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit heater relay and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit heater relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Check the resistance of the aftertreatment DEF dosing unit heater relay.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay pin 85 and the aftertreatment dosing unit heater relay pin 86 of the aftertreatment DEF dosing unit heater relay.

Greater than 100k ohms?
YES NO

A malfunctioning aftertreatment DEF dosing unit heater relay has been detected.

Replace the aftertreatment DEF dosing unit heater relay. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay RETURN pin at the heater relay wiring harness connector and the aftertreatment DEF dosing unit heater relay RETURN pin at the OEM harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay RETURN pin at the OEM harness ECM connector and block ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing unit heater relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater relay RETURN pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the aftertreatment DEF dosing unit heater relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 4157 - Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4157 inactive?
 | STEP 1B. Read the fault codes. | Fault Code 3571, 3572, 3574, 3575, 3577, 3578, or 3596 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit lines and fittings. | Any reversed, damaged, leaking, or restricted connections found?
 | STEP 2B. Complete a aftertreatment DEF dosing unit purge cycle. | Fault Code 4157 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes..

Fault Code 3571, 3572, 3574, 3575, 3577, 3578, or 3596 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 3A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - - Inspect the aftertreatment DEF dosing unit lines and fittings.

Conditions

  • Turn keyswitch OFF.

Action

There are three diesel exhaust fluid lines on the selective catalytic reduction (SCR) dosing system:

  • 1. Dosing unit supply line between the tank and the dosing unit (suction line).
  • 2. Dosing valve supply line between the dosing unit and the dosing valve (pressure line).
  • 3. Return line between the dosing unit and the tank (return line).

Inspect all three DEF lines and associated fittings/connectors:

  • Verify the suction and return line connections are not swapped at the dosing unit or DEF tank connections. Reversed DEF line connectors cause the dosing unit not to prime.
  • Check the DEF tank connections (suction and return lines) for cracks and pitting.
  • Check all three dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line, pressure line, and return line dosing unit connectors and look for signs of buildup or blockage.
  • Check the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the DEF.
  • Verify proper sealing at all connection points, including DEF tank (two connections), dosing unit (three connections), and dosing valve (one connection).

Refer to Procedure 011-058 in the Associated Procedures Table.

Any reversed, damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking DEF line or fitting as necessary.

Refer to the original equipment manufacturer (OEM) service manual.

Repair or replace the aftertreatment DEF dosing unit as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Complete a aftertreatment DEF dosing unit purge cycle.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn the keyswitch ON.

Action

Complete a aftertreatment DEF dosing unit purge cycle.

  • Perform the INSITE™ electronic service tool Aftertreatment Diesel Exhaust Fluid System Leak Test and allow the aftertreatment DEF system to prime.
  • Turn the keyswitch OFF.
  • Allow the aftertreatment DEF system to purge for 90 seconds.
  • Turn the keyswitch ON.

Fault Code 4157 active?
YES NO

A malfunctioning aftertreatment DEF dosing unit has been detected. Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 4159 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 4169 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4169 active?
 | STEP 1B. Check for active fault codes. | Fault Code 2976, 4155, or 4156 active or any inactive counts?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit heater relay circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit heater relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the DEF dosing unit heater relay for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the DEF line heater relay supply circuit. | Voltage within 1-VDC of battery voltage?
STEP 3. | Check the aftertreatment DEF dosing unit heater relay circuit. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit heater connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for open circuit in the DEF line heater supply circuit. | Less than 10 ohms?
 | STEP 3C. Check for pin-to-ground short in the aftertreatment DEF dosing unit heater supply circuit. | Less than 100k ohms?
 | STEP 3D. Check for high resistance in the DEF dosing unit heater return circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4169 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976, 4155, or 4156 active or any inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit heater relay circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit heater relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the DEF dosing unit heater relay and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2B - Check the DEF dosing unit heater relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit heater relay from the OEM harness.

Action

Check for an open circuit.

  • Place a jumper wire between the DEF dosing unit heater relay SIGNAL pin (86) and battery positive (+).
  • Place a jumper wire between the DEF dosing unit heater relay RETURN pin (85) and battery negative (-).
  • Measure the resistance between the DEF dosing unit heater relay SUPPLY pin (30) and the DEF dosing unit heater SUPPLY pin (87).

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected.

Replace the DEF unit heater relay.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the DEF line heater relay supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage between pin 30 at the aftertreatment DEF dosing unit heater relay connector and ground.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit heater supply circuit.

Check the aftertreatment DEF dosing unit heater fuse.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing unit heater supply circuit.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit heater connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the aftertreatment DEF dosing unit and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for open circuit in the DEF line heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the resistance of the aftertreatment DEF dosing unit heater relay.

  • Measure the resistance between pin 87 of the aftertreatment DEF line heater relay connector and the aftertreatment DEF dosing unit heater supply at the aftertreatment DEF dosing unit connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short in the aftertreatment DEF dosing unit heater supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-ground short in the aftertreatment DEF dosing unit heater supply circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater supply at the aftertreatment DEF dosing unit connector and chassis ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 3D

Guided Step 3D - Check for high resistance in the DEF dosing unit heater return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit heater relay from the OEM harness.

Action

Check for high resistance of the aftertreatment DEF dosing unit return circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit heater return at the aftertreatment DEF dosing unit connector and chassis ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioned aftertreatment DEF dosing unit has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Nov-2015


FAULT CODE 4171 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 249, 256, 2398, 2976, 4155, 4156, 4168, 4169, or 4244 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249, 256, 2398, 2976, 4155, 4156, 4168, 4169, or 4244 active?
YES NO
No Repair

A failed aftertreatment diesel exhaust fluid (DEF) dosing unit heater has been detected.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 4213 - Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4213 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4213 active?
YES NO

This fault code indicates that the selective catalyst reduction (SCR) System Cleaning Inhibit switch was disabled.

Perform a Stationary SCR performance testing using INSITE™. Verify that the permit switch (inhibit switch) has been set up properly for the original equipment manufacturer (OEM) application. Refer to Procedure 011-056 in the Associated Procedures Table.

Refer to the OEM service manual or consult the OEM if the SCR System Cleaning has malfunctioned due to the permit switch (inhibit switch).

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Oct-2015


FAULT CODE 4243 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature 2 - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4233 or 4234 active?
STEP 2. | Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Verify the aftertreatment DEF tank temperature sensor accuracy. | INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
STEP 3. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DEF tank level / temperature / quality sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 4233 active?
 | STEP 3C. Check the circuit response. | Fault Code 4234 active?
STEP 4. | Check the engine control module (ECM) and harness. |
 | STEP 4A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 4C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4233 or 4234 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor.

Guided Step 2A - Verify the aftertreatment DEF tank temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DEF tank level / temperature / quality sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level / temperature / quality sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank level / temperature / quality sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level / temperature / quality sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4233 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank level / temperature / quality sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank level / temperature / quality SIGNAL pin and the aftertreatment DEF tank level / temperature / quality RETURN pin at the aftertreatment DEF tank level / temperature / quality sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4234 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine control module (ECM) and harness.

Guided Step 4A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF DEF tank level / temperature / quality sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF tank level / temperature / quality RETURN pin at the OEM harness ECM connector and the aftertreatment DEF tank level / temperature / quality RETURN pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank level / temperature / quality sensor from the OEM harness.

Action

Check for an open circuit.

Measure the resistance between the aftertreatment DEF tank level / temperature / quality SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF tank level / temperature / quality SIGNAL pin at the OEM wiring harness temperature sensor connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment DEF tank level / temperature / quality sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank level / temperature / quality sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Oct-2015


FAULT CODE 4249 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4249 active?
 | STEP 1B. Check for ambient air temperature sensor fault codes. | Fault Codes 153 or 154 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and harness. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness connector. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4249 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for ambient air temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 153 or 154 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and harness.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the original equipment manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit connector and the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin OEM connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin OEM connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin of the OEM harness and all other pins in the connector.

Refer to the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin of the OEM harness and ground.

Greater than 100k ohms?
YES NO

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Oct-2015


FAULT CODE 4261 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4261 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4152 or 4165 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage less than 6 VDC? (For 12 VDC systems): Voltage less than 18 VDC? (For 24 VDC systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage less than 6 VDC? (For 12 VDC systems): Voltage less than 18 VDC? (For 24 VDC systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4261 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 or 4165 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC? (For 12 VDC systems?

Voltage less than 18 VDC? (For 24 VDC systems)?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment SCR temperature sensor module.

Troubleshoot the connector and OEM harness for intermittent shorts and/or opens.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC? (For 12 VDC systems?

Voltage less than 18 VDC? (For 24 VDC systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2014


FAULT CODE 4533 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, 5395, or 5396 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, 5395, or 5396 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst (DOC) temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 4534 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, 5395, or 5396 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, 5395, or 5396 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst (DOC) temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 4572 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 4572 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 2636, 2771, 3232, 3868, 4152, or 5391 also active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF tank temperature sensor. | Voltage greater than 10 volts?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the OEM fuse is installed correctly. | Fuse installed correctly or has it been replaced?
 | STEP 3C. Check for an open circuit in the battery power circuit. | Voltage greater than 10 volts?
STEP 4. | Check the SAE J1939 data link. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check the fault codes. | Fault Code 4572 is active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4572 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, 2771, 3232, 3868, 4152, or 5391 also active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF tank temperature sensor.

  • Measure the voltage between the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage supply circuit and the aftertreatment DEF tank temperature sensor return circuit at the aftertreatment DEF tank temperature sensor wiring harness connector.

Note: Check the voltage at keyswitch ON, while cranking the engine, with the engine at idle.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is greater than 10 volts?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

The aftertreatment DEF tank temperature sensor power SUPPLY wire contains a 20 ampere fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.

Fuse installed correctly, or has it been replaced?
YES NO
No Repair

Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 3B-1

Guided Step 3C - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the aftertreatment DEF tank temperature sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Voltage greater than 10 volts?
YES NO

An open circuit or high resistance in the OEM battery return circuit from the aftertreatment DEF tank temperature sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit or high resistance in the OEM battery supply circuit from the aftertreatment DEF tank temperature sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the SAE J1939 data link.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment DEF tank temperature sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment DEF tank temperature sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM engine harness connector

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the damaged component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Disconnect the variable geometry turbocharger (VGT) actuator from the engine harness.
  • Disconnect the data link aftertreatment DEF tank temperature sensor from the OEM harness.
  • Disconnect the aftertreatment DEF quality sensor from the OEM harness, if equipped.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 110 and 130 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the damaged component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment SCR temperature sensor module form the OEM harness.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the data link aftertreatment diesel exhaust fluid tank temperature sensor from the OEM harness.
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor from the OEM harness, if equipped.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and ground

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the damaged component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the OEM harness.
  • All other components connected.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment DEF tank temperature sensor OEM harness connector.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 14-pin OEM connector from the engine harness.
  • All other components connected.

Action

Measure the terminating resistance of the engine harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 14-pin connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the variable geometry turbocharger (VGT) actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire of the VGT actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Remove the additional terminating resistance or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment DEF tank temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 4572 is active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 4737 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor.

Replace the aftertreatment DEF tank temperature sensor.

Refer to the original equipment manufacturer (OEM) service manual.

Note: The aftertreatment DEF tank temperature sensor may be a combination type sensor that measures tank level, temperature, and quality. Refer to the OEM service manual.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2014


FAULT CODE 4739 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4739 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4739 active?
YES NO
No Repair

An internal failure has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor.

Refer to the original equipment manufacturer (OEM) service manual.

Note: The aftertreatment DEF tank temperature sensor may be a combination type sensor that measures tank level, temperature, and quality. Refer to the OEM service manual.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2014


FAULT CODE 4741 - Aftertreatement Diesel Exhaust Fluid Quality Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3868 or 3878 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4741 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 3878 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4741 active?
YES NO

An internal error has been detected in the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Replace the aftertreatment DEF quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Feb-2014


FAULT CODE 4742 - Aftertreatement Diesel Exhaust Fluid Quality Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1685, 1686, 3876, 3877, or 4741 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1685, 1686, 3876, 3877, or 4741 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel exhaust fluid (DEF) quality sensor module has been detected.

Replace the aftertreatment DEF quality sensor module. See equipment manufacturer service information.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Feb-2014


FAULT CODE 4743 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4242 or 4243 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4743 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4242 or 4243 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4743 active?
YES NO

An internal malfunction has been detected in the aftertreatment 1 diesel exhaust fluid (DEF) temperature 2 sensor.

Replace the aftertreatment DEF temperature 2 sensor. Refer to the original equipment manufacturer (OEM) service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Feb-2014


FAULT CODE 4744 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4233, 4234, 4242, 4243, 4743 or 4745 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4233, 4234, 4242, 4243, 4743 or 4745 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel exhaust fluid (DEF) temperature 2 sensor module has been detected.

Replace the aftertreatment DEF temperature 2 sensor module. Refer to the original equipment manufacturer (OEM) service manual.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Feb-2014


FAULT CODE 4745 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 or 4572 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 or 4572 active?
YES NO
No Repair

An internal failure has been detected in the aftertreatment diesel exhaust fluid (DEF) tank level sensor.

Replace the aftertreatment DEF tank level sensor. Refer to the original equipment manufacturer (OEM) service manual.

The aftertreatment DEF tank temperature sensor may be a combination type sensor that measures tank level, temperature, and quality. Refer to the OEM service manual.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Feb-2014


FAULT CODE 5386 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, 5395, or 5396 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, 5395, or 5396 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel oxidation catalyst (DOC) temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5387 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B105 | 4358498
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B105 | 4358498
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B105 | 4358498
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5392, 5393, 5394 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391, 5392, 5393, 5394 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Performance Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. Refer to the original equipment manufacturer (OEM) service manual.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment DOC.

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5388 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358489
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B112 | 4358489
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391,5392, 5393, 5394, 5395, 5396 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391,5392, 5393, 5394, 5395, 5396 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Cylinder Performance Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. Refer to the OEM service manual.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment DOC.

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5389 - Aftertreatment 1 Diesel Oxidation Catalyst Outlet Gas Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSB6.7 CM2350 B112 | 4358489
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5392, 5393, 5394, 5395 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than fifty percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391, 5392, 5393, 5394, 5395 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Appropriate troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. Refer to the original equipment manufacturer (OEM) service manual.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment DOC.

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than fifty percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove aftertreatment DOC.

Action

Inspect the aftertreatment DOC

  • Check for cracks in the aftertreatment DOC cell walls.

Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5391 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358489
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358489
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391 active?
 | STEP 1B. Check for active fault codes. | Fault Code 2636, 2771, 3232, 3868, or 4152 also active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DOC temperature sensor module. | Voltage greater than 10-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply. | Voltage greater than 10-VDC?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4G. Check the J1939 terminating resistance. | 110 to 130 ohms?
 | STEP 4H. Check for active fault codes. | Fault Code 5391 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, 2771, 3232, 3868, or 4152 also active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DOC temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment DOC temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DOC temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DOC temperature sensor module.

  • Measure the voltage between the aftertreatment DOC temperature sensor module battery voltage supply circuit and the aftertreatment DOC temperature sensor module return circuit at the aftertreatment DOC temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

  • Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DOC temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES NO

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage return circuit.

Repair or replace the OEM harness. Refer to the OEM service manual.

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage supply circuit.

Check for blown or missing fuses. Check for damaged or missing relays. Troubleshoot all interconnects. Repair or replace the damaged component(s) as necessary. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DOC temperature sensor module the OEM harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the DOC temperature sensor module OEM harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the DOC temperature sensor module OEM harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link. Troubleshoot the engine harness, OEM harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet mono-nitrogen oxides (NOx) sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel selective catalyst reduction (SCR) temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment diesel exhaust fluid tank sensors (level, temperature, quality), if equipped.
  • Disconnect the variable geometry turbocharger (VGT) actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

  • Troubleshoot the engine harness, OEM harness, and all interconnects.
  • Repair or replace the damaged or malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn the keyswitch OFF and wait at least 1 minute before proceeding.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Disconnect the aftertreatment diesel SCR temperature sensor module from the OEM harness.
  • Disconnect any data link aftertreatment diesel exhaust fluid tank sensors (level, temperature, quality), if equipped.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

  • Troubleshoot the engine harness, OEM harness, and all interconnects.
  • Repair or replace the damaged or malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • All other components connected.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) wire at the diesel particulate filter temperature sensor module OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES | NO
No Repair | No Repair

Go to 4H

Go to 4F

Guided Step 4F - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 24-pin OEM connector from the engine harness.
  • All other components connected.

Action

Measure the terminating resistance of the OEM harness.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 24-pin connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 4G

Guided Step 4G - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the VGT actuator J1939 data link (+) wire and the VGT actuator J1939 data link (-) wire at the VGT actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

110 to 130 ohms?
YES NO

Incorrect terminating resistance has been detected in the engine harness.

Remove the additional terminating resistance or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Incorrect terminating resistance has been detected in the VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4H - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the aftertreatment DOC temperature sensor module to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391 active?
YES NO

Replace the aftertreatment DOC temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5392 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5391, 5393, 5394, or 5396 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 5391, 5393, 5394, or 5396 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 5393 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5393 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, or 597 active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment DOC temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DOC temperature sensor module. | Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment DOC temperature sensor module. | Aftertreatment DOC temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment DOC temperature sensor module. | Fault Code 5393 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery. | Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
 | STEP 3B. Check for a short circuit in the aftertreatment DOC temperature sensor module battery voltage supply. | Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5393 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, or 597 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the aftertreatment DOC temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment DOC temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DOC temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DOC temperature sensor module.

  • Measure the voltage between the aftertreatment DOC temperature sensor module battery voltage supply circuit and the aftertreatment DOC temperature sensor module battery voltage return circuit at the aftertreatment DOC temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Note: To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DOC temperature sensor module.

Action

Verify the aftertreatment DOC temperature sensor module is correct for the engine configuration.

Note: The aftertreatment DOC temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment DOC temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DOC temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 5393 active?
YES NO

A malfunctioning aftertreatment DOC temperature sensor module has been detected. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.

Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
YES NO

Troubleshoot the cause of the overcharging condition.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the aftertreatment DOC temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Check for a short circuit.

  • Measure the voltage from the aftertreatment DOC temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage greater than 18 VDC? (For 12 VDC systems); Voltage greater than 30 VDC? (For 24 VDC systems)
YES NO

A short circuit to battery has been detected in the aftertreatment DOC temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5394 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5394 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, or 597 active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment DOC temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DOC temperature sensor module. | Voltage less than 6 VDC? (For 12 VDC systems); Voltage less than 18 VDC? (For 24 VDC systems)
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment DOC temperature sensor module. | Aftertreatment DOC temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment DOC temperature sensor module. | Fault Code 5394 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply. | Voltage less than 6 VDC? (For 12 VDC systems); Voltage less than 18 VDC? (For 24 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5394 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, or 578 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the aftertreatment DOC temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment DOC temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DOC temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DOC temperature sensor module.

  • Measure the voltage between the aftertreatment DOC temperature sensor module battery voltage supply circuit and the aftertreatment DOC temperature sensor module battery voltage return circuit at the aftertreatment DOC temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC? (For 12 VDC systems); Voltage less than 18 VDC? (For 24 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

NOTE: To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for the correct aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DOC temperature sensor module.

Action

Verify the aftertreatment DOC temperature sensor module is correct for the engine configuration.

Note: The aftertreatment DOC temperature sensor module is available in 12 volt or 24 volt versions.

Aftertreatment DOC temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DOC temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 5394 active?
YES NO

A malfunctioning aftertreatment DOC temperature sensor module has been detected.

Replace the aftertreatment DOC temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment DOC temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC? (For 12 VDC systems); Voltage less than 18 VDC? (For 24 VDC systems)
YES NO

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5395 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5395 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
 | STEP 1C. Check for active fault codes. | Fault Code 5391 or 5394 active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment DOC temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DOC temperature sensor module. | Voltage less than 6 VDC (For 12 volt systems) or voltage less than 18 VDC (For 24 volt systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply. | Voltage less than 6 VDC (For 12 volt systems) or voltage less than 18 VDC (For 24 volt systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5395 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5391 or 5394 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the aftertreatment DOC temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment DOC temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DOC temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DOC temperature sensor module.

  • Measure the voltage between the aftertreatment DOC temperature sensor module battery voltage supply circuit and the aftertreatment DOC temperature sensor module return circuit at the aftertreatment DOC temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC (For 12 volt systems) or voltage less than 18 VDC (For 24 volt systems)?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment DOC temperature sensor module.

Troubleshoot the connector and the OEM harness for intermittent short or open circuits.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

  • Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment DOC temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC temperature sensor module.
  • Turn keyswitch ON.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment DOC temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Voltage less than 6 VDC (For 12 volt systems) or voltage less than 18 VDC (For 24 volt systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment DOC temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 5396 - Aftertreatment Diesel Oxidation Catalyst Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Heat Shield | Refer to Procedure 011-032 | QSB6.7 CM2350 B112 | 4358489
Heat Shield | Refer to Procedure 011-032 | QSL9 CM2350 L107 | 4367386
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5396 active or more than three inactive counts?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) temperature sensor module. |
 | STEP 2A. Make sure that the aftertreatment DOC temperature sensor module is properly mounted. | Aftertreatment DOC temperature sensor module properly mounted?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment DOC temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5396 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment DOC temperature sensor module.

Guided Step 2A - Make sure that the aftertreatment DOC temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not running

Action

Verify the aftertreatment DOC temperature sensor module is properly mounted.

  • Verify the module is mounted correctly. Refer to procedure 019-449 in the Associated Procedures Table.
  • Verify the proper heat shield is mounted over the temperature sensor module. Refer to procedure 011-032 in the Associated Procedures Table.

Aftertreatment DOC temperature sensor module properly mounted?
YES NO
No Repair

Relocate and/or secure the aftertreatment DOC temperature sensor module at the correct mounting location.

  • Refer to Procedure 019-449 in the Associated Procedures Table.
  • Refer to Procedure 011-032 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment DOC temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the aftertreatment DOC temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module
  • Aftermarket shields, flaps, or brackets mounted too close to the module
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

Refer to the OEM service manual for proper aftertreatment installation.

Go to 3A

Repair complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5576 - Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSB6.7 CM2350 B112 | 4358489
Air Intake Restriction | Refer to Procedure 010-031 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP :1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 741, 742, or 743 active or inactive counts?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 5576 active?
STEP 3. | Check the intake restriction. |
 | STEP 3A. Check the intake restriction. | Air intake restriction within specifications?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 741, 742, or 743 active or inactive counts?
YES NO

Troubleshoot the fault codes listed above.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Start the engine and let it run under normal operating conditions for five minutes.

Fault Code 5576 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

3A

Go to 4A

Guided Step 3 - Check the intake restriction.

Guided Step 3A - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 4A

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5617 - Aftertreatment 1 Diesel Oxidation Catalyst System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSB6.7 CM2350 B112 | 4358489
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5617 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5617 active?
YES NO

This fault code indicates that the incorrect aftertreatment diesel oxidation catalyst (DOC) system has been installed with the engine.

Verify the correct aftertreatment DOC system has been installed with the engine.

If the incorrect aftertreatment DOC system has been installed, replace it with the correct aftertreatment DOC system. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5631 - SCR System Cleaning Inhibited Due to System Timeout - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any fault codes other than Fault Code 5631 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fault codes other than Fault Code 5631 active?

After completion of troubleshooting any other active fault code, perform an INSITE™ electronic service tool Aftertreatment SCR Performance Test, unless this test was directed to be performed while troubleshooting any other active fault code.

YES NO
No Repair

This is an information only fault code, indicating that the ECM is requesting active SCR System Cleaning of the aftertreatment but is unable to perform active SCR System Cleaning of the aftertreatment system.

It is possible to perform INSITE™ electronic service tool Aftertreatment SCR Performance Test with this fault code active.

No repair is necessary.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2015


FAULT CODE 5632 - SCR System Cleaning Inhibited Due to Inhibit Switch - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active faults. |
 | STEP 1A. Check for active fault codes. | Fault Code 5632 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5632 active?
YES NO

This fault code indicates that the SCR System Cleaning permit switch was disabled when the ECM was requesting an active SCR system cleaning of the aftertreatment system.

Verify that the permit switch (inhibit switch) has been set up properly for the original equipment manufacturer (OEM) application. Refer to Procedure 011-056 in the Associated Procedures Table.

Refer to the OEM service manual or consult the OEM if the aftertreatment system has malfunctioned due to the permit switch (inhibit switch).

  • Perform the aftertreatment testing procedure to check the performance of the aftertreatment system. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Oct-2015


FAULT CODE 5653 - Selective Catalytic Reduction (SCR) Operator Inducement Override Switch - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 5653 active?
STEP 3. | Check the fault codes. |
 | STEP 3A. Determine which vehicle eclectronic control unit (VECU) multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the original equipment manufacturer (OEM) VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 5653 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5653 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the fault codes.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5653 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Appropriate ECM - No Communication troubleshooting symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5654 - SCR Operator Inducement Override Switch - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5654 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration matchs the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5654 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Note: Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matchs the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Feb-2014


FAULT CODE 5879 - Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5879 active?
STEP 2. | Check the intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake throttle actuator motor. | Less than 15 ohms?
 | STEP 2B-1. Check for an open circuit in the intake throttle actuator motor. |
 | STEP 2B-2. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to a voltage source. | Less than 1.5-VDC?
 | STEP 3C. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5879 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Inspect the intake throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake throttle actuator motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake throttle actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the intake throttle actuator motor circuit.

  • Measure the resistance between the intake throttle actuator motor connector SIGNAL (+) pin and the intake throttle actuator motor connector SIGNAL (-) pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for an open circuit in the intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Check for an open circuit in the intake throttle actuator motor.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator motor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

An open circuit has been detected in the intake throttle actuator motor circuit.

Replace the intake throttle actuator assembly.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for an open circuit in the engine harness. Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (+) pin at the intake throttle actuator connector of the engine harness.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit to voltage has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5881 - Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B112 | 4358498
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5881 active?
STEP 2. | Check the engine intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the engine intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the engine intake throttle actuator motor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5881 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5881 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the engine intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator motor from the engine harness.

Action

Inspect the engine harness and the engine intake throttle actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the engine intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Check for a short circuit to ground in the engine intake throttle actuator motor.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit from pin to pin in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


FAULT CODE 5882 - Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B112 | 4358498
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5882 active?
STEP 2. | Check the engine intake throttle. |
 | STEP 2A. Check for a restricted engine intake throttle. | Restriction or debris blocking the engine intake throttle?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3C. Inspect the engine intake throttle actuator motor and connector pins. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5882 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle.

Guided Step 2A - Check for a restricted engine intake throttle.

Conditions

  • Turn keyswitch OFF.

Action

Check for a restriction.

  • Inspect the engine intake throttle for a restriction or debris blocking the throttle plate.
  • Refer to Procedure 010-140 in the Associated Procedures Table.

Restriction or debris blocking the engine intake throttle?
YES NO

Remove the restriction or debris.

  • Refer to Procedure 010-140 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator motor from the engine harness.

Action

Inspect the engine harness and the engine intake throttle actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (+) pin at the intake throttle actuator connector of the engine harness.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A malfunctioning engine intake throttle has been detected.

Replace the engine intake throttle.

Refer to Procedure 010-140 in the Associated Procedures Table.

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Oct-2015


INDEX
308-fc111.htm

00-t05-111.htm

308-fc115.htm

00-t05-115.htm

308-fc122.htm

00-t05-122.htm

308-fc123.htm

00-t05-123.htm

308-fc135.htm

00-t05-135.htm

308-fc141.htm

00-t05-141.htm

308-fc143.htm

00-t05-143.htm

308-fc144.htm

00-t05-144.htm

308-fc145.htm

00-t05-145.htm

308-fc146.htm

00-t05-146.htm

308-fc151.htm

00-t05-151.htm

308-fc153.htm

00-t05-153.htm

308-fc154.htm

00-t05-154.htm

308-fc155.htm

00-t05-155.htm

308-fc187.htm

329-t05-187.htm

308-fc195.htm

308-fc195-2wire.htm

00-t05-195-2wire.htm

308-fc195-3wire.htm

00-t05-195-3wire.htm

308-fc196.htm

308-fc196-2wire.htm

00-t05-196-2wire.htm

308-fc196-3wire.htm

00-t05-196-3wire.htm

308-fc197.htm

00-t05-197.htm

308-fc227.htm

329-t05-227.htm

308-fc234.htm

00-t05-234.htm

308-fc235.htm

00-t05-235.htm

308-fc238.htm

00-t05-238.htm

308-fc239.htm

00-t05-239.htm

308-fc245.htm

00-t05-245.htm

308-fc271.htm

00-t05-271.htm

308-fc272.htm

00-t05-272.htm

308-fc285.htm

00-t05-285.htm

308-fc286.htm

00-t05-286.htm

308-fc322.htm

329-t05-322.htm

308-fc323.htm

329-t05-323.htm

308-fc324.htm

329-t05-324.htm

308-fc325.htm

329-t05-325.htm

308-fc331.htm

329-t05-331.htm

308-fc332.htm

329-t05-332.htm

308-fc343.htm

00-t05-343.htm

308-fc351.htm

00-t05-351.htm

308-fc352.htm

329-t05-352.htm

308-fc386.htm

329-t05-386.htm

308-fc415.htm

00-t05-415.htm

308-fc418.htm

00-t05-418.htm

308-fc426.htm

329-t05-426.htm

308-fc428.htm

00-t05-428.htm

308-fc429.htm

00-t05-429.htm

308-fc435.htm

329-t05-435.htm

308-fc441.htm

00-t05-441.htm

308-fc442.htm

00-t05-442.htm

308-fc449.htm

329-t05-449.htm

308-fc451.htm

00-t05-451.htm

308-fc452.htm

00-t05-452.htm

308-fc483.htm

00-t05-483.htm

308-fc484.htm

00-t05-484.htm

308-fc488.htm

00-t05-488.htm

308-fc515.htm

00-t05-515.htm

308-fc516.htm

00-t05-516.htm

308-fc553.htm

329-t05-553.htm

308-fc555.htm

00-t05-555.htm

308-fc556.htm

00-t05-556.htm

308-fc559.htm

308-t05-559.htm

308-fc595.htm

00-t05-595.htm

308-fc687.htm

00-t05-687.htm

308-fc689.htm

00-t05-689.htm

308-fc691.htm

00-t05-691.htm

308-fc692.htm

00-t05-692.htm

308-fc731.htm

00-t05-731.htm

308-fc741.htm

329-t05-741.htm

308-fc742.htm

329-t05-742.htm

308-fc743.htm

329-t05-743.htm

308-fc778.htm

00-t05-778.htm

308-fc1117.htm

00-t05-1117.htm

308-fc1664.htm

00-t05-1664.htm

308-fc1668.htm

308-fc1668-2wire.htm

329-t05-1668-2wire.htm

308-fc1668-3wire.htm

329-t05-1668-3wire.htm

308-fc1669.htm

308-fc1669-2wire.htm

329-t05-1669-2wire.htm

308-fc1669-3wire.htm

329-t05-1669-3wire.htm

308-fc1673.htm

00-t05-1673.htm

308-fc1677.htm

329-t05-1677.htm

308-fc1678.htm

329-t05-1678.htm

308-fc1679.htm

329-t05-1679.htm

308-fc1682.htm

329-t05-1682.htm

308-fc1683.htm

329-t05-1683.htm

308-fc1684.htm

329-t05-1684.htm

308-fc1685.htm

00-t05-1685.htm

308-fc1686.htm

00-t05-1686.htm

308-fc1691.htm

329-t05-1691.htm

308-fc1694.htm

329-t05-1694.htm

308-fc1712.htm

329-t05-1712.htm

308-fc1713.htm

329-t05-1713.htm

308-fc1714.htm

00-t05-1714.htm

308-fc1715.htm

00-t05-1715.htm

308-fc1843.htm

00-t05-1843.htm

308-fc1844.htm

00-t05-1844.htm

308-fc1847.htm

329-t05-1847.htm

308-fc1852.htm

00-t05-1852.htm

308-fc1866.htm

00-t05-1866.htm

308-fc1885.htm

00-t05-1885.htm

308-fc1887.htm

329-t05-1887.htm

308-fc1896.htm

00-t05-1896.htm

308-fc1938.htm

00-t05-1938.htm

308-fc1942.htm

00-t05-1942.htm

308-fc1961.htm

00-t05-1961.htm

308-fc1962.htm

00-t05-1962.htm

308-fc1974.htm

00-t05-1974.htm

308-fc1992.htm

329-t05-1992.htm

308-fc2198.htm

00-t05-2198.htm

308-fc2272.htm

329-t05-2272.htm

308-fc2273.htm

00-t05-2273.htm

308-fc2274.htm

00-t05-2274.htm

308-fc2288.htm

00-t05-2288.htm

308-fc2311.htm

00-t05-2311.htm

308-fc2346.htm

00-t05-2346.htm

308-fc2349.htm

00-t05-2349.htm

308-fc2353.htm

00-t05-2353.htm

308-fc2357.htm

329-t05-2357.htm

308-fc2373.htm

00-t05-2373.htm

308-fc2374.htm

00-t05-2374.htm

308-fc2375.htm

00-t05-2375.htm

308-fc2376.htm

00-t05-2376.htm

308-fc2377.htm

00-t05-2377.htm

308-fc2387.htm

329-t05-2387.htm

308-fc2448.htm

00-t05-2448.htm

308-fc2554.htm

00-t05-2554.htm

308-fc2555.htm

00-t05-2555.htm

308-fc2556.htm

00-t05-2556.htm

308-fc2634.htm

329-t05-2634.htm

308-fc2635.htm

00-t05-2635.htm

308-fc2636.htm

329-t05-2636.htm

308-fc2637.htm

329-t05-2637.htm

308-fc2646.htm

00-t05-2646.htm

308-fc2753.htm

329-t05-2753.htm

308-fc2771.htm

329-t05-2771.htm

308-fc2961.htm

00-t05-2961.htm

308-fc2962.htm

00-t05-2962.htm

308-fc2976.htm

329-t05-2976.htm

308-fc3142.htm

329-t05-3142.htm

308-fc3143.htm

329-t05-3143.htm

308-fc3144.htm

329-t05-3144.htm

308-fc3146.htm

329-t05-3146.htm

308-fc3147.htm

329-t05-3147.htm

308-fc3148.htm

329-t05-3148.htm

308-fc3151.htm

329-t05-3151.htm

308-fc3165.htm

329-t05-3165.htm

308-fc3228.htm

329-t05-3228.htm

308-fc3229.htm

329-t05-3229.htm

308-fc3231.htm

329-t05-3231.htm

308-fc3232.htm

329-t05-3232.htm

308-fc3235.htm

329-t05-3235.htm

308-fc3237.htm

329-t05-3237.htm

308-fc3238.htm

329-t05-3238.htm

308-fc3239.htm

329-t05-3239.htm

308-fc3241.htm

329-t05-3241.htm

308-fc3242.htm

329-t05-3242.htm

308-fc3251.htm

329-t05-3251.htm

308-fc3258.htm

329-t05-3258.htm

308-fc3261.htm

329-t05-3261.htm

308-fc3313.htm

329-t05-3313.htm

308-fc3314.htm

329-t05-3314.htm

308-fc3315.htm

329-t05-3315.htm

308-fc3326.htm

00-t05-3326.htm

308-fc3328.htm

00-t05-3328.htm

308-fc3341.htm

329-t05-3341.htm

308-fc3385.htm

00-t05-3385.htm

308-fc3422.htm

329-t05-3422.htm

308-fc3423.htm

329-t05-3423.htm

308-fc3425.htm

329-t05-3425.htm

308-fc3497.htm

00-t05-3497.htm

308-fc3498.htm

00-t05-3498.htm

308-fc3539.htm

00-t05-3539.htm

308-fc3541.htm

00-t05-3541.htm

308-fc3545.htm

00-t05-3545.htm

308-fc3547.htm

00-t05-3547.htm

308-fc3555.htm

00-t05-3555.htm

308-fc3558.htm

329-t05-3558.htm

308-fc3559.htm

329-t05-3559.htm

308-fc3562.htm

329-t05-3562.htm

308-fc3563.htm

329-t05-3563.htm

308-fc3567.htm

329-t05-3567.htm

308-fc3568.htm

329-t05-3568.htm

308-fc3571.htm

329-t05-3571.htm

308-fc3572.htm

329-t05-3572.htm

308-fc3574.htm

329-t05-3574.htm

308-fc3575.htm

329-t05-3575.htm

308-fc3577.htm

329-t05-3577.htm

308-fc3578.htm

329-t05-3578.htm

308-fc3582.htm

329-t05-3582.htm

308-fc3583.htm

00-t05-3583.htm

308-fc3596.htm

329-t05-3596.htm

308-fc3649.htm

00-t05-3649.htm

308-fc3681.htm

00-t05-3681.htm

308-fc3682.htm

00-t05-3682.htm

308-fc3697.htm

00-t05-3697.htm

308-fc3717.htm

00-t05-3717.htm

308-fc3718.htm

00-t05-3718.htm

308-fc3724.htm

00-t05-3724.htm

308-fc3725.htm

00-t05-3725.htm

308-fc3727.htm

308-t05-3727.htm

308-fc3748.htm

329-t05-3748.htm

308-fc3749.htm

329-t05-3749.htm

308-fc3867.htm

00-t05-3867.htm

308-fc3868.htm

329-t05-3868.htm

308-fc3876.htm

00-t05-3876.htm

308-fc3877.htm

00-t05-3877.htm

308-fc3878.htm

00-t05-3878.htm

308-fc3931.htm

329-t05-3931.htm

308-fc4135.htm

329-t05-4135.htm

308-fc4152.htm

329-t05-4152.htm

308-fc4155.htm

329-t05-4155.htm

308-fc4156.htm

329-t05-4156.htm

308-fc4157.htm

329-t05-4157.htm

308-fc4159.htm

329-t05-4159.htm

308-fc4164.htm

00-t05-4164.htm

308-fc4165.htm

00-t05-4165.htm

308-fc4166.htm

00-t05-4166.htm

308-fc4168.htm

00-t05-4168.htm

308-fc4169.htm

329-t05-4169.htm

308-fc4171.htm

329-t05-4171.htm

308-fc4213.htm

329-t05-4213.htm

308-fc4241.htm

00-t05-4241.htm

308-fc4243.htm

329-t05-4243.htm

308-fc4249.htm

329-t05-4249.htm

308-fc4261.htm

329-t05-4261.htm

308-fc4262.htm

308-t05-4262.htm

308-fc4263.htm

308-t05-4263.htm

308-fc4265.htm

308-t05-4265.htm

308-fc4277.htm

00-t05-4277.htm

308-fc4517.htm

00-t05-4517.htm

308-fc4533.htm

329-t05-4533.htm

308-fc4534.htm

329-t05-4534.htm

308-fc4572.htm

329-t05-4572.htm

308-fc4585.htm

00-t05-4585.htm

308-fc4737.htm

329-t05-4737.htm

308-fc4739.htm

329-t05-4739.htm

308-fc4741.htm

329-t05-4741.htm

308-fc4742.htm

329-t05-4742.htm

308-fc4743.htm

329-t05-4743.htm

308-fc4744.htm

329-t05-4744.htm

308-fc4745.htm

329-t05-4745.htm

308-fc4768.htm

00-t05-4768.htm

308-fc4769.htm

00-t05-4769.htm

308-fc4863.htm

00-t05-4863.htm

308-fc4867.htm

308-t05-4867.htm

308-fc4956.htm

00-t05-4956.htm

308-fc4957.htm

00-t05-4957.htm

308-fc5177.htm

00-t05-5177.htm

308-fc5386.htm

329-t05-5386.htm

308-fc5387.htm

329-t05-5387.htm

308-fc5388.htm

329-t05-5388.htm

308-fc5389.htm

329-t05-5389.htm

308-fc5391.htm

329-t05-5391.htm

308-fc5392.htm

329-t05-5392.htm

308-fc5393.htm

329-t05-5393.htm

308-fc5394.htm

329-t05-5394.htm

308-fc5395.htm

329-t05-5395.htm

308-fc5396.htm

329-t05-5396.htm

308-fc5576.htm

329-t05-5576.htm

308-fc5585.htm

308-t05-5585.htm

308-fc5617.htm

329-t05-5617.htm

308-fc5631.htm

329-t05-5631.htm

308-fc5632.htm

329-t05-5632.htm

308-fc5653.htm

329-t05-5653.htm

308-fc5654.htm

329-t05-5654.htm

308-fc5879.htm

329-t05-5879.htm

308-fc5881.htm

329-t05-5881.htm

308-fc5882.htm

329-t05-5882.htm