QSNT14 CM876 N102

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111.

Last Modified: 14-Apr-2013
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code 115.

Last Modified: 22-May-2013


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 122.

Last Modified: 22-May-2013


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 123.

Last Modified: 22-May-2013


Fault Code Path Selection

FAULT CODE 207-fc131
Fault Code Path Selection

Do you have a dual potentiometer throttle pedal? | Go to 207-fc131dp
Do you have an integrated sensor switch (ISS) throttle pedal? | Go to 207-fc131iss

Last Modified: 17-Oct-2014


Fault Code Path Selection

FAULT CODE 207-fc132
Fault Code Path Selection

Do you have a dual potentiometer throttle pedal? | Go to 207-fc132dp
Do you have an integrated sensor switch (ISS) throttle pedal? | Go to 207-fc132iss

Last Modified: 17-Oct-2014


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 133.

Last Modified: 24-Sep-2014


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the remote accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged remote accelerator pedal or lever position sensor

Open circuit in the remote accelerator signal, supply wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 134.

Last Modified: 23-May-2013


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was greater than 4.75-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
  • A malfunctioning engine oil rifle pressure sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 135.

Last Modified: 16-Apr-2013


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P0522 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was less than 0.25-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • A malfunctioning engine oil rifle pressure sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 141.

Last Modified: 16-Apr-2013


Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine power derate.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 14-Apr-2014


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to a voltage source.

  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 23-May-2013


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 23-May-2013


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 146.

Last Modified: 23-May-2013


Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data valid but below normal operational range - Most Severe Level

FAULT CODE 147

Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data valid but below normal operational range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P91 SPN: 91 FMI: 1/1 LAMP: Red SRT: | Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid But Below Normal Operating Range - Most Severe Level. A frequency of less than 100 HZ has been detected at the frequency throttle input to the ECM. | Engine power derate.
Frequency Throttle Circuit

Circuit Description

This type of throttle interface is designed to accept a variable frequency signal as the throttle signal. An electronic component generates a square wave logic-level signal in which the frequency of the signal corresponds to a throttle command. The frequency values are established by the calibration in the electronic control module (ECM).

Component Location

Throttle location varies with each OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle frequency was less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

  • The frequency throttle can be used in conjunction with a voltage throttle or by itself.

Open circuit in the frequency throttle signal wire.

Shorted to ground frequency throttle signal wire.

Malfunctioning frequency throttle.

Incorrect frequency throttle reference (input) voltage.

Refer to Troubleshooting Fault Code 147.

Last Modified: 24-May-2013


Accelerator Pedal or Lever Position Sensor 1 - Data valid but above normal operational range - Most Severe Level

FAULT CODE 148

Accelerator Pedal or Lever Position Sensor 1 - Data valid but above normal operational range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P91 SPN: 91 FMI: 0/0 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 - Data Valid But Above Normal Operating Range - Most Severe Level. A frequency of more than 1500 Hz has been detected at the frequency throttle input to the ECM. | Engine power derate.
Frequency Throttle Circuit

Circuit Description

This type of throttle interface is designed to accept a variable frequency signal as the throttle signal. An electronic component generates a square wave logic-level signal in which the frequency of the signal corresponds to a throttle command. The frequency values are established by the calibration in the electronic control module (ECM).

Component Location

Throttle location varies with each OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle frequency was higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

The frequency accelerator can be used either in conjunction with a voltage accelerator or by itself.

Possible causes:

Malfunctioning frequency throttle.

Incorrect frequency throttle application

Refer to Troubleshooting Fault Code 148.

Last Modified: 24-May-2013


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant temperature was greater than 113°C [ 235°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 27-May-2013


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to voltage source.

  • Malfunctioning intake manifold pressure/temperature sensor
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 153.

Last Modified: 27-May-2013


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor

Open circuit in the wire harness

  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 154.

Last Modified: 27-May-2013


Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 105°C [221°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 27-May-2013


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was less than a 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code 187.

Last Modified: 31-May-2013


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 195.

Last Modified: 31-May-2013


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P2558 SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open signal circuit in the OEM harness, connectors, or sensor

Signal circuit shorted to ground in the OEM harness, connector, or sensor

  • Damaged sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 196.

Last Modified: 31-May-2013


Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P2560 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor 1 - 3 Wire Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 197.

Last Modified: 16-Aug-2013


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was greater than 4.95-VDC for more than 10 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.

Shorted to a voltage source.

Refer to Troubleshooting Fault Code 212.

Last Modified: 03-Jun-2013


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was less than 0.1-VDC for more than 10 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 213.

Last Modified: 03-Jun-2013


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamps starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214.

Last Modified: 03-Jun-2013


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | None on performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • An open return circuit in the engine harness

Signal circuit shorted to sensor supply or battery voltage.

  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 221.

Last Modified: 03-Jun-2013


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor.

Supply wire open or shorted to ground.

Refer to Troubleshooting Fault Code 222.

Last Modified: 03-Jun-2013


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was greater than 5.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 03-Jun-2013


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine power derate.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 03-Jun-2013


Coolant Level - Data valid but below normal operational range - Most Severe Level

FAULT CODE 235

Coolant Level - Data valid but below normal operational range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Engine power derate.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code 235.

Last Modified: 03-Jun-2013


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: P105 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was less than a 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 19-Apr-2013


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 03-Jun-2013


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect INSITE™ electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 241.

Last Modified: 03-Jun-2013


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

The ECM detects a valid engine speed signal from the vehicle speed sensor.

The keyswitch must be turned ON, and the vehicle speed and engine speed must be zero for 30 seconds.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 242.

Last Modified: 14-Apr-2014


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 245.

Last Modified: 03-Jun-2013


Engine Fuel Shutoff Valve Driver Circuit - Voltage below normal, or shorted to low source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage below normal, or shorted to low source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit | Engine will be shut down.
Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

  • The engine may not start.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not malfunctioned and pulled down the voltage on the fuel shutoff circuit. Inspect the engine-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.

Possible causes of this fault code include:

Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.

Refer to Troubleshooting Fault Code 254.

Last Modified: 19-Jun-2013


Engine Fuel Shutoff Valve Driver Circuit - Voltage above normal, or shorted to high source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Possible reduced engine performance.
Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine may not start.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is wired correctly and feeding voltage into the fuel shutoff supply circuit.

Possible causes of this fault code include:

Open circuit in the engine harness, connectors, or shutoff valve.

Fuel shutoff valve signal wire shorted to a voltage source in the harness.

Refer to Troubleshooting Fault Code 255.

Last Modified: 19-Jun-2013


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 23-Apr-2013


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 286.

Last Modified: 23-Apr-2013


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Amber SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine can ONLY idle or engine will NOT accelerate to full speed.
OEM/Vehicle Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator as 0 percent, but the secondary throttle position sensor indicates it is NOT in the idle position.

The OEM VECU determined that the accelerator signal wire was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. Use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287.

Last Modified: 05-Jun-2013


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
OEM/Vehicle Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

NOTE: It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 288.

Last Modified: 23-Apr-2013


Auxiliary Temperature Sensor Input 1 - Special Instructions

FAULT CODE 292

Auxiliary Temperature Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 292 PID: P441 SPN: 441 FMI: 14/14 LAMP: Red SRT: | Auxiliary Temperature Sensor Input 1 - Special Instructions. | Engine power derate.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine protection limit for the OEM input device was exceeded.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is activated when the temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code 292.

Last Modified: 19-Jun-2013


Auxiliary Temperature Sensor Input 1 Circuit - Voltage above normal, or shorted to high source

FAULT CODE 293

Auxiliary Temperature Sensor Input 1 Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P441 SPN: 441 FMI: 3/3 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the OEM temperature sensor circuit is open or shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open return circuit in the harness, connectors, or sensor

Signal shorted to a voltage source.

Refer to Troubleshooting Fault Code 293.

Last Modified: 19-Jun-2013


Auxiliary Temperature Sensor Input 1 Circuit - Voltage below normal, or shorted to low source

FAULT CODE 294

Auxiliary Temperature Sensor Input 1 Circuit - Voltage below normal, or shorted to low source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P441 SPN: 441 FMI: 4/4 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine protection limit for the OEM input device was exceeded.

The ECM detects that the OEM temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the harness.

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 294.

Last Modified: 19-Jun-2013


Auxiliary Pressure Sensor Input 2 - Special Instructions

FAULT CODE 296

Auxiliary Pressure Sensor Input 2 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296 PID: P443 SPN: 1388 FMI: 14/14 LAMP: Red SRT: | Auxiliary Pressure Sensor Input 2 - Special Instructions | Engine power derate.
Auxiliary Pressure Sensor Input 2 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine protection limit for the OEM input device was exceeded.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code 296.

Last Modified: 19-Jun-2013


Auxiliary Pressure Sensor Input 2 Circuit - Voltage above normal, or shorted to high source

FAULT CODE 297

Auxiliary Pressure Sensor Input 2 Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P443 SPN: 1388 FMI: 3/3 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input 2 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the OEM pressure signal circuit was out of range high

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 297.

Last Modified: 19-Jun-2013


Auxiliary Pressure Sensor Input 2 Circuit - Voltage below normal, or shorted to low source

FAULT CODE 298

Auxiliary Pressure Sensor Input 2 Circuit - Voltage below normal, or shorted to low source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P443 SPN: 1388 FMI: 4/4 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input 2 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the OEM pressure signal circuit was out of range low

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

Supply line open or shorted to ground.

Refer to Troubleshooting Fault Code 298.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 1 Circuit - Current above normal or grounded circuit

FAULT CODE 311

Injector Solenoid Driver Cylinder 1 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S1 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 1 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 311.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 5 Circuit - Current above normal or grounded circuit

FAULT CODE 312

Injector Solenoid Driver Cylinder 5 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S5 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 5 when the voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 312.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 3 Circuit - Current above normal or grounded circuit

FAULT CODE 313

Injector Solenoid Driver Cylinder 3 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S3 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 3 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 313.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 6 Circuit - Current above normal or grounded circuit

FAULT CODE 314

Injector Solenoid Driver Cylinder 6 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S6 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 5 when the voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 314.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 2 Circuit - Current above normal or grounded circuit

FAULT CODE 315

Injector Solenoid Driver Cylinder 2 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S2 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 2 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 315.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 4 Circuit - Current above normal or grounded circuit

FAULT CODE 321

Injector Solenoid Driver Cylinder 4 Circuit - Current above normal or grounded circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S4 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 4 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

Short circuit to ground in the engine harness or injector.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 321.

Last Modified: 19-Jun-2013


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Current detected at injector 1 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 322.

Last Modified: 05-Jun-2013


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Current detected at injector 5 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 323.

Last Modified: 06-Jun-2013


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Current detected at injector 3 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 324.

Last Modified: 06-Jun-2013


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Current detected at injector 6 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 325.

Last Modified: 06-Jun-2013


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Current detected at injector 2 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 331.

Last Modified: 06-Jun-2013


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Current detected at injector 4 when voltage is turned OFF. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 332.

Last Modified: 06-Jun-2013


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 06-Jun-2013


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: P110 SPN: 627 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Engine may not start or may be difficult to start.
Injector Power Supply Circuit

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; if this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm, the primary engine speed sensor signal is present, and the battery charge is above a minimum threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 06-Jun-2013


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was less than 4.75-VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352.

Last Modified: 06-Jun-2013


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Wiring Harness portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5 volt supply line can be caused by a short circuit to Battery power supply, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 386.

Last Modified: 06-Jun-2013


Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine power derate.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level

Damaged oil pressure sensor

  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 06-Jun-2013


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 25-Apr-2013


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Engine power derate.
Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the maximum engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421.

Last Modified: 06-Jun-2013


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was greater than 4.95-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

Open return circuit in the harness, connectors, or sensor

  • SIGNAL wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428.

Last Modified: 25-Apr-2013


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 429.

Last Modified: 07-Jun-2013


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit on either the idle validation on-idle or off-idle signal circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuit, a loose connection, uncalibrated accelerator pedal or lever assembly, or miswired idle validation switch.

When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.

Refer to Troubleshooting Fault Code 431.

Last Modified: 14-Apr-2014


Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

FAULT CODE 432

Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration. Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the position of the throttle pedal position and the idle validation switch do not match.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault is logged when both the on-idle and off-idle validation switches disagree with the accelerator pedal or lever position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault code will stay active until the pedal or lever is cycled through its full travel.

When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.

Refer to Troubleshooting Fault Code 432.

Last Modified: 19-Jun-2013


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70°C or 158°F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Do not start the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Damaged oil pressure sensor

Open circuit in the engine oil pressure sensor signal wire

High resistance in the engine oil pressure sensor signal or return lines.

Refer to Troubleshooting Fault Code 435.

Last Modified: 08-Jun-2013


Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine will be shut down. Engine may not start or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the main battery supply voltage was less than 9-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 08-Jun-2013


Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the main battery supply voltage was greater than 36-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Faulty alternator or regulator that is overcharging the system

  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 08-Jun-2013


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Engine power derate.
Intake Manifold 1 Temperature/Pressure Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include.

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 488.

Last Modified: 19-Jun-2013


Auxiliary Input/Output 2 Circuit - Voltage above normal, or shorted to high source

FAULT CODE 527

Auxiliary Input/Output 2 Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: P154 SPN: 702 FMI: 3/3 LAMP: Amber SRT: | Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source. An open or short circuit detected on the dual output A signal circuit. | None on performance.
Auxiliary Input/Output 2 Circuit

Circuit Description

The Engine Control Module (ECM) provides a signal to the original equipment manufacturer (OEM) output control solenoid to turn the OEM supplied accessory ON and OFF. The OEM output control circuit varies by OEM. They can use a solenoid return that is wired to the ECM or use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the dual output A signal is commanded off.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected voltage on the dual output A signal circuit when it is commanded off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, the dual output A signal must be commanded off for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately zero volts. If it detects a high voltage, this fault is recorded. If Fault Code 527 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground. Possible causes of this fault include:

Open circuit in the OEM harness or OEM output control solenoid

Short circuit to voltage source in the OEM harness

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 527.

Last Modified: 08-Jun-2013


Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 528

Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P93 SPN: 93 FMI: 2/2 LAMP: Amber SRT: | Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect. An error has been detected in the alternate torque switch circuit. | Torque curve setting defaults to default curve.
Alternate Torque Circuit

Circuit Description

The torque curve switch circuit allows the operator to select from up to three preprogrammed torque curves using a two - or three-position switch, depending on which the OEM has provided.

Component Location

The location of the torque curve switch circuit varies with each OEM and equipment model. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the switch voltage does not match the calibratible value

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.

Shop Talk

The switch can be monitored for proper operation in INSITE™ electronic service tool. If the switch is changing state correctly on the service tool, then the problem does not lie in the switch circuit.

The three position-switch has three states:

Position 1 - open

Position 2 - closed

Position 3 - 1500 ohm resistance.

The two position-switch has two states:

Position 1 - open

Position 2 - closed.

Refer to Troubleshooting Fault Code 528.

Last Modified: 14-Apr-2014


Auxiliary Input/Output 3 Circuit - Voltage above normal, or shorted to high source

FAULT CODE 529

Auxiliary Input/Output 3 Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S51 SPN: 703 FMI: 3/3 LAMP: Amber SRT: | Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source. An open or short circuit detected on the dual output B signal circuit. | None on performance.
Auxiliary Input/Output 3 Circuit

Circuit Description

The Engine Control Module (ECM) provides a signal to the original equipment manufacturer (OEM) output control solenoid to turn the OEM supplied accessory ON and OFF. The OEM output control circuit varies by OEM. They can use a solenoid return that is wired to the ECM or use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the dual output B signal is commanded off.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected voltage on the dual output B signal circuit when it is commanded off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately zero volts. If it detects a high voltage, this fault is recorded. If Fault Code 529 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground.

Possible causes of this fault include:

Open circuit in the OEM harness or OEM output control solenoid

Short circuit to voltage source in the OEM harness

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 529.

Last Modified: 08-Jun-2013


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 584.

Last Modified: 08-Jun-2013


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 585.

Last Modified: 08-Jun-2013


Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use INSITE™ electronic service tool to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 596.

Last Modified: 08-Jun-2013


Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 597.

Last Modified: 08-Jun-2013


Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 598.

Last Modified: 08-Jun-2013


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: S25 SPN: 640 FMI: 14/14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has been exceeded for the dual outputs calibrated limits. | Engine will be shut down.
Auxiliary Commanded Dual Output Shutdown Circuit

Circuit Description

Dual outputs based on sensed parameters provide up to two independent switched outputs for OEM use. The state of each switched output can be determined by different inputs to the electronic control module (ECM) depending on the engine platform. The ECM can provide different outputs to OEM devices if any of the inputs are above or below calibrated thresholds. Each switched output is independent of the other with respect to control parameter input and threshold settings.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine protection limit has been exceeded for the dual output calibrated limits

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code is activated when one of the OEM defined inputs has exceeded a calibratible limit. The triggers for shutdown are OEM dependent.

Refer to Troubleshooting Fault Code 599.

Last Modified: 26-Jun-2013


Engine Shut Down Hot - Condition Exists

FAULT CODE 611

Engine Shut Down Hot - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: S116 SPN: 1383 FMI: 11/31 LAMP: None SRT: | Engine Shut Down Hot - Condition Exists. The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold. | Possible reduced engine performance.
Electronic Control Module (ECM)

Circuit Description

The engine control module (ECM) uses inputs from the engine coolant temp sensor, engine speed sensor, keyswitch, and calculated engine torque for this diagnostic.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected engine speed is 0 within 15 seconds of the engine operating under a load.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code that will only become active if the engine was shut down with the keyswitch before proper engine cooldown.

Refer to Troubleshooting Fault Code 611.

Last Modified: 08-Jun-2013


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | None on performance.
Maintenance Reminder

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Use the INSITE electronic service tool to reset the Maintenance Monitor feature.

The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 09-Jun-2013


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 08-Jan-2014


Engine ECU Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Above normal, or Shorted to High source. High signal voltage or open circuit detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697.

Last Modified: 09-Jun-2013


Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698.

Last Modified: 09-Jun-2013


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 778.

Last Modified: 08-Jan-2014


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.

Use INSITE electronic service tool to verify the fault code is inactive.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 09-Jun-2013


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 09-Jun-2013


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal position sensor

Open circuit in the accelerator signal, or supply wire in the OEM harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 09-Jun-2013


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2
  • Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1242.

Last Modified: 09-Jun-2013


Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 is dedicated for the secondary accelerator pedal position sensor in the OEM wiring harness. Sensor supply 5 can also be used for other sensors in the OEM wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 09-Jun-2013


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 is dedicated for the secondary accelerator pedal position sensor in the OEM wiring harness. Sensor supply 5 can also be used for other sensors in the OEM wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 09-Jun-2013


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water-In-Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 09-Jun-2013


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduced engine performance.
Engine (Exhaust) Brake Driver Circuit

Circuit Description

The exhaust brake is used to retard engine speed by creating high exhaust back pressure, subsequently slowing the vehicle down and extending the life of the service brakes. This back pressure is obtained by restricting airflow through the exhaust system with a butterfly valve.

Component Location

The exhaust brake is located in the exhaust stream, after the turbocharger outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust brake control circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the engine harness.

Open circuit in the engine harness, exhaust brake harness, or engine exhaust brake relay

A malfunctioning engine brake ralay

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 2182.

Last Modified: 13-Jun-2013


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine (Exhaust) Brake Driver Circuit

Circuit Description

The exhaust brake is used to retard engine speed by creating high exhaust back pressure, subsequently slowing the vehicle down and extending the life of the service brakes. This back pressure is obtained by restricting airflow through the exhaust system with a butterfly valve.

Component Location

The exhaust brake is located in the exhaust stream, after the turbocharger outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust brake control circuit was shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness

A malfunctioning engine brake relay

  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 2183.

Last Modified: 13-Jun-2013


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 13-Jun-2013


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 13-Jun-2013


Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S51 SPN: 703 FMI: 14/14 LAMP: Red SRT: | Auxiliary Equipment Sensor Input 3 Engine Protection Critical — Special Instructions. The emergency door of the vehicle has been detected open. | Engine will be shut down.
Auxiliary Equipment Sensor Input 3 Engine Protection Circuit

Circuit Description

Some applications use the OEM switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the engine is cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the OEM switch input changed state and activated the engine protection settings.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This diagnostic will operate differently for every application.

The OEM switch input can be calibrated to be normally open or normally closed.

Possible causes of this fault include:

Switch activation by user

Short in the switch wiring

Incorrectly calibrated feature.

If this feature is set so that the switch is normally closed, turning on this feature on an application without an OEM switch input will activate the Engine Protection at every start up.

Refer to Troubleshooting Fault Code 2195.

Last Modified: 14-Apr-2014


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the harness or fan control solenoid.
  • A short circuit to voltage source in the OEM harness.
  • A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2377.

Last Modified: 24-Sep-2014


Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P2560 SPN: 111 FMI: 17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448.

Last Modified: 14-Jun-2013


Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2555 PID: S70 SPN: 729 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays while 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal was detected to be greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Intake air heater relay signal wire not connected to the relay

Intake air heater relay return wire not connected to the relay

Open circuit in the intake air heater relay signal wire

Open circuit in the intake air heater relay return wire

Intake air heater signal wire shorted to a voltage source.

Refer to Troubleshooting Fault Code 2555.

Last Modified: 14-Jun-2013


Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: S70 SPN: 729 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays while 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A shorted intake air heater relay

Intake air heater relay supply wire shorted to ground.

Refer to Troubleshooting Fault Code 2556.

Last Modified: 14-Jun-2013


Auxiliary PWM Driver 1 Circuit - Voltage above normal, or shorted to high source

FAULT CODE 2557

Auxiliary PWM Driver 1 Circuit - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: S57 SPN: 697 FMI: 3/3 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the pulse width modulation (PWM) auxiliary circuit. | Possible reduced engine performance.
Auxiliary PWM Driver 1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the electronic control module (ECM) to determine when to shift the transmission. The return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM wiring diagram for the location of the transmission shift modulator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects high signal voltage detected at the analog torque circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning transmission shift modulator

Open circuit in the output device driver return line

Pin-to-pin short in the output device driver line.

Refer to Troubleshooting Fault Code 2557.

Last Modified: 16-Aug-2013


Auxiliary PWM Driver 1 Circuit - Voltage below normal, or shorted to low source

FAULT CODE 2558

Auxiliary PWM Driver 1 Circuit - Voltage below normal, or shorted to low source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: S57 SPN: 697 FMI: 4/4 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the analog torque circuit. | Possible reduced engine performance.
Auxiliary PWM Driver 1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the electronic control module (ECM) to determine when to shift the transmission. The return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM wiring diagram for the location of the transmission shift modulator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects low signal voltage detected at the analog torque circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning transmission shift modulator

An short circuit to ground on the output device driver line

A short pin-to-pin in the output device driver line.

Refer to Troubleshooting Fault Code 2558.

Last Modified: 19-Jun-2013


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine protection warning limit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • Engine torque will be reduced.
  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 14-Jun-2013


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The intake manifold pressure sensor is reading an erratic value. | None on performance.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70°C or 158°F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This diagnostic consists of two parts. At key OFF, the sensor readings for intake manifold pressure, barometric air pressure, oil pressure (if available), and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned OFF. This fault can also be set active when the intake manifold pressure is too high or low for the current engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault include:

A damaged intake manifold pressure sensor

A damaged barometric pressure sensor A damaged barometric pressure sensor

Leaks in the air intake system between the turbocharger and intake manifold

Restriction in the charge-air cooler

A damaged turbocharger speed sensor

A damaged turbocharger compressor intake temperature sensor.

Refer to Troubleshooting Fault Code 2973.

Last Modified: 14-Jun-2013


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131 (Dual Potentiometer)

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 (Dual Potentiometer) PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 131.

Last Modified: 20-Oct-2014


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131 (Integrated Sensor Switch)

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 (Integrated Sensor Switch) PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch is “ON”. With keyswitch “ON”, slowly push the accelerator to the floor and release. Do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Accelerator supply shorted to battery
  • Open accelerator pedal return circuit in the harness or connections

Failed accelerator pedal or lever position sensor.

Refer to Troubleshooting Fault Code 131 (Integrated Sensor Switch).

Last Modified: 20-Oct-2014


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132 (Dual Potentiometer)

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 (Dual Potentiometer) PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed. If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply wire in the harness or connectors

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132.

Last Modified: 20-Oct-2014


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132 (Integrated Sensor Switch)

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 (Integrated Sensor Switch) PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

The three wires in the accelerator position sensor circuit must be twisted together.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Open circuit in the accelerator signal, or supply wire in the OEM harness or connectors.

  • Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132 (Integrated Sensor Switch).

Last Modified: 20-Oct-2014


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 2556 - Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM3250 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 active and Fault Code 2556 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 active and Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 active?
YES NO

A damaged intake air heater relay has been detected.

Replace the intake air heater relay. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

For 12 volt systems, both leads must be tested.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the intake air heater relay wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 06-May-2017


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES NO

Swap the engine position sensor connectors.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Feb-2014


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment harness (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 VOLT SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment harness (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 is active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

A damaged accelerator pedal has been detected. See equipment manufacturer service information for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position +5 volt SUPPLY pin to the remote accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the remote accelerator pedal position +5 volt SUPPLY pin and the remote accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal has been detected.

Replace the remote accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.7 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB5.9 CM2880 B127 | 4383645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High troubleshooting symptom tree in Section TS in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2014


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

  • For the ISG11 CM2880 G106, ISG12 CM2880 G107, and QSNT14 CM876 N102 engines: Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manfiold air temperature reading. |
 | STEP 1A. Monitor intake manfiold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manfiold air temperature reading.

Guided Step 1A - Monitor intake manfiold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS, in the appropriate service manual.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL9.5 CM2150 SN | 4310608
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G106 | 4332695
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G107 | 4332690
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G108 | 4332901
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G109 | 4332906
Cooling System | Refer to Procedure 008-018 | QSNT14 CM876 N102 | 4325993
Cooling System | Refer to Procedure 008-018 | QSB7 CM2880 B117 | 4358390
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F104 | 4332741
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F108 | 4332746
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2880 F112 | 4383825
Cooling System | Refer to Procedure 008-018 | QSL9.3 CM2880 L113 | 4383811
Cooling System | Refer to Procedure 008-018 | QSC8.3 CM2880 C102 | 4388785
Cooling System | Refer to Procedure 008-018 | QSB5.9 CM2880 B139 | 4388870
Cooling System | Refer to Procedure 008-018 | QSB3.9 CM2880 B138 | 5411050
Cooling System | Refer to Procedure 008-018 | ISD6.7 CM2880 D101 | 5411372
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F129 | 5411325
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

Reference the Coolant Loss troubleshooting symptom tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likley cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL9.5 CM2150 SN | 4310608
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB3.9 CM2220 B107 | 4310792
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSNT14 CM876 N102 | 4325993
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB4.5 CM2150 B108 | 4326163
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB6.7 CM2150 B109 | 4326168
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 F116 | 4383664
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDCto 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL9.5 CM2150 SN | 4310608
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB3.9 CM2220 B107 | 4310792
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSNT14 CM876 N102 | 4325993
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB4.5 CM2150 B108 | 4326163
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB6.7 CM2150 B109 | 4326168
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 F116 | 4383664
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct revolutions per minute (rpm) reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to the engine tachometer red area.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct revolutions per minute (rpm) reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above high idle speed.

–

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 l113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 l113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2150 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 l113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Dec-2016


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the engine control module (ECM). | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Repair the damaged connector pins.
  • Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector and engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or see equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See equipment manufacturer service information to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Aug-2014


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity level set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering evidence, incorrect installation, or external device present?
 | STEP 2B. Check for open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering evidence, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed reading by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2013


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4363825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 0 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 is active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine electronic control module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the multiplexing configuration.

Check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Note: Use the following for OEM specific multiplexing configuration information. Refer to Multiplexing Troubleshooting, Bulletin 4021378.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2013


FAULT CODE 287 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

Note: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of 0.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-085 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than 0.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?

YES NO
No Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-085 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Oct-2013


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the engine ECM and compare to the engine ECM configuration

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or the OEM VECU.

Use the appropriate OEM service manual for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly notappear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value greater than 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or the OEM VECU.

Use the appropriate OEM service manual for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate fuel injector 1. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate fuel injector 2. |
 | STEP 3A-2. Isolate fuel injector 3. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground. This is not required for 4-cylinder engines.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check fuel injector wiring harness for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground. This is not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground. This is not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector. Not required for 4-cylinder engines.
  • Measure the resistance between the cylinder fuel injector solenoid 3 RETURN pin and all other pins in the wiring harness ECM connector. Not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector 1.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate fuel injector 2.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 1.
  • Disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6 cylinder engines: No repair.

For 4 cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate fuel injector 3.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and fuel injector solenoid 1 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and the injector solenoid 1 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in Section 3.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and the fuel injector solenoid 1 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 1 has been detected. Replace fuel injector 1.

Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for short circuits. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the ECM or injector malfunction. |
 | STEP 3A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 3A-1. Complete injector isolation. |
 | STEP 3A-2. Complete injector isolation. |
 | STEP 3A-3. Check for active fault codes. |
STEP 4. | Check the injector and injector circuit for an open circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 2 ohms?
 | STEP 4B-1. Check the injector solenoid for an open circuit. |
 | STEP 4C. Check the injector solenoid for a short circuit. | Fault code follow the injector?
 | STEP 4D. Check for active fault codes. | Fault codes still active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness for short circuits.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short circuit to ground has been detected in the injector circuit.

Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2C - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the cylinder 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 4 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 5A

Guided Step 3 - Isolate the ECM or injector malfunction.

Guided Step 3A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes for 6-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Bank Fault Codes for 4-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 331.
  • Bank 2 - Rear Bank: Fault Codes 324, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A-1

Go to 5A

Guided Step 3A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the injector and injector circuit for an open circuit.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit..

  • Measure the resistance between the cylinder number 5 SIGNAL pin and cylinder number 5 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4B-1

Guided Step 4B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 SIGNAL pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate the fuel injector. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate the fuel injector. |
 | STEP 3A-2. Isolate the fuel injector. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector harness for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • For 6-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

For 6-cylinder engines: Replace fuel injector number 1.

For 4-cylinder engines: Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • For 6-cylinder engines: Connect the fuel injector wiring harness to fuel injector number 1, and disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Connect the fuel injector wiring harness to fuel injector number 3, and disconnect the fuel injector wiring harness from fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No Repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

For 6-cylinder engine: Replace fuel injector number 2.

For 4-cylinder engines: Replace fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and fuel injector solenoid 3 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and the injector solenoid 3 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and the fuel injector solenoid 3 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 3 has been detected. Replace fuel injector 3. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for short circuits. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the ECM or injector malfunction. |
 | STEP 3A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 3A-1. Complete injector isolation. |
 | STEP 3A-2. Complete injector isolation. |
 | STEP 3A-3. Check for active fault codes. |
STEP 4. | Check the injector and injector circuit for an open circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 2 ohms?
 | STEP 4B-1. Check the injector solenoid for an open circuit. |
 | STEP 4C. Check the injector solenoid for a short circuit. | Fault code follow the injector?
 | STEP 4D. Check for active fault codes. | Fault codes still active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness for short circuits.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short circuit to ground has been detected in the injector circuit.

Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2C - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the cylinder 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 4 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 5A

Guided Step 3 - Isolate the ECM or injector malfunction.

Guided Step 3A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes for 6-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Bank Fault Codes for 4-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 331.
  • Bank 2 - Rear Bank: Fault Codes 324, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A-1

Go to 5A

Guided Step 3A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the injector and injector circuit for an open circuit.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit..

  • Measure the resistance between the cylinder number 6 SIGNAL pin and cylinder number 6 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4B-1

Guided Step 4B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 SIGNAL pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate fuel injector 1. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate fuel injector 2. |
 | STEP 3A-2. Isolate fuel injector 3. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground. (Not required for 4-cylinder engines).

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector wiring harness for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground. (Not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground. (Not required for 4-cylinder engines.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector. (Not required for 4-cylinder engines)
  • Measure the resistance between the cylinder fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector. (Not required for 4-cylinder engines)

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate fuel injector 1.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate fuel injector 2.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 1.
  • Disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate fuel injector 3.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and fuel injector solenoid 2 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and the injector solenoid 2 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and the fuel injector solenoid 2 RETURN pin on the fuel injector solenoid

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 2 has been detected. Replace fuel injector 2. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate the fuel injector. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate the fuel injector. |
 | STEP 3A-2. Isolate the fuel injector. |
STEP 4. | Check the injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check fuel injector wiring harness for a short circuit to ground:

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground:

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin on the fuel injector solenoid and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 5 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 6 RETURN pin and all other pins in the engine wiring harness ECM connector.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 4.
  • For 6-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

For 6-cylinder engines: Replace injector number 5.

For 4-cylinder engines: Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 5.
  • Disconnect the fuel injector wiring harness from fuel injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker lever cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the enginewiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and fuel injector solenoid 4 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and the injector solenoid 4 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and the fuel injector solenoid 4 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 4 has been detected. Replace fuel injector 4. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connectors, or pins, if possible. Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than 3 inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Calibrate the ECM. |
 | STEP 4A. Calibrate the ECM. | Fault Code 343 active after Calibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than 3 inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the original equipment manufacturer (OEM) power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY(+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Dirty or damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Calibrate the ECM.

Guided Step 4A - Calibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration.

Fault Code 343 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2200 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2200 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Operate the engine. | Will the engine start?
 | STEP 1C. Read the fault codes. | Fault Code 351 active?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Operate the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine.

Will the engine start?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES NO

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

 No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Refer to Lubricating Oil Pressure Low symptom tree in the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Feb-2013


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active?
 | STEP 1B. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-May-2016


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms (MΩ)?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms (MΩ)?
YES NO

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the ECM engine connector.

Refer to the circuit or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water-in-fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 435 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141 | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 and Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An in-range failure of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery voltage. | Less than +20 VDC for 12 volt system and less than +32 VDC for 24 volt system?
 | STEP 2B. Check the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than +20 VDC for 12 volt system

Less than +32 VDC for 24 volt system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Jun-2014


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the connection malfunction.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin to ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, SUPPLY wire, and return circuit. | Greater than 3.75-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 is inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin to ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within original equipment manufacturer (OEM) specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a short circuit in the power harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within original equipment manufacturer (OEM) specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness.

Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | Greater than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (ampere).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

Refer to the OEM service manual for location and procedure.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery SUPPLY (+) pins and all other pins of the power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the SUPPLY wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jun-2014


FAULT CODE 697 - Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check battery ground(s), engine block, and chassis ground. | Connections tight and corrosion-free?
 | STEP 3D. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3E. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3F. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle.

If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See the equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system];

During cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM power harness/OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM harness from the OEM power connector to the batteries.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3C - Check battery ground(s), engine block, and chassis ground.

Conditions

  • Turn keyswitch OFF.

Action

Check battery ground(s), engine block, and chassis ground.

  • Check all battery ground(s), engine block, and chassis ground for properly grounded, tightened, and free of corrosion.

See equipment manufacturer service information and wiring diagram for grounds information.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM power harness/OEM harness connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the OEM power harness/OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Apr-2017


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSC3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSC5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1241 is active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See the equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. Refer to Procedure 019-071 in Section 19.

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jun-2014


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If Necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jun-2014


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 VOLT SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 VOLT SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2014


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2120 B108 | 4326163
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the coolant temperature. |
 | STEP 1A. Monitor the coolant temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor the coolant temperature.

Guided Step 1A - Monitor the coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the Coolant Temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 131 (ISS) - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758, male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996, female Weather Pack™ test lead, and Part Number 3824910, 6-pin repair connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal. |
 | STEP 2A. Inspect the harness and accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for continuity from the engine control module (ECM) to accelerator position sensor. | Less than 10 ohms?
 | STEP 2C. Check the accelerator position resistance. | Between 2000 and 3000 ohms?
 | STEP 2D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? (Released resistance must be at least 1000 ohms more than depressed resistance.)
STEP 3. | Check for the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from the accelerator position signal to all other pins in the ECM OEM connector. | Less than 100k ohms?
 | STEP 3C. Check for a short circuit from the accelerator position signal to battery supply (+) in the ECM power connector. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for continuity from ECM-to-accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for continuity from ECM-to-accelerator position sensor.

  • Measure the resistance from accelerator SIGNAL pin of the ECM OEM harness connector to the accelerator SIGNAL pin of the accelerator position sensor connector.
  • Measure the resistance from sensor SUPPLY 4 +5-VDC supply pin of the ECM OEM harness connector to +5-VDC supply pin of the accelerator position sensor.
  • Measure the resistance from sensor SUPPLY 4 RETURN pin of the ECM OEM harness connector to the return pin of the accelerator position sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the accelerator position sensor wiring. Refer to Procedure 019-071 in Section 19. Refer to Procedure 019-201 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY wire and the accelerator position sensor RETURN wire on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Between 2000 and 3000 ohms?
YES NO
No Repair

Replace the accelerator position sensor. See equipment manufacturer service information.

Go to 2D

Go to 4A

Guided Step 2D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Take the measurement when the pedal is depressed and again when released.

  • Measure the resistance between the +5-VDC SUPPLY wire and the SIGNAL wire on the sensor side of the accelerator position sensor.

Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? (Released resistance must be at least 1000 ohms more than depressed resistance.)

YES NO
No Repair

Replace the accelerator position sensor. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.

Dirty or damaged pins?
YES NO

Repair the damaged pins or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from the accelerator position signal to all other pins in the ECM OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from the accelerator position signal to all other pins in the OEM harness.

  • Measure the resistance from accelerator position signal to all other pins in the ECM OEM connector.

Less than 100k ohms?
YES NO

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit from the accelerator position signal to battery supply (+) in the ECM power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the power connector from ECM.

Action

Check for a short circuit from the accelerator position signal to battery (+) in the OEM harness.

  • Measure the resistance between accelerator position signal in the ECM OEM connector and battery supply (+) in the power connector from ECM.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4A - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2014


FAULT CODE 132 (ISS) - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758, male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996, female Weather Pack™ test lead, and Part Number 3824910, 6-pin repair connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal. |
 | STEP 2A. Inspect the harness and accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for continuity from the engine control module (ECM) to accelerator position sensor. | Less than 10 ohms?
 | STEP 2C. Check the accelerator position resistance. | Between 2000 and 3000 ohms?
 | STEP 2D. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? (Released resistance must be at least 1000 ohms more than depressed resistance.)
STEP 3. | Check for the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the harness, bulkhead connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from the accelerator position signal to all other pins in the ECM OEM connector. | Less than 100k ohms?
 | STEP 3C. Check for a short circuit from the accelerator position signal to engine block. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check for an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator position sensor.

Guided Step 2A - Inspect the harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for continuity from ECM-to-accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator pedal.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for continuity from ECM-to-accelerator position sensor.

  • Measure the resistance from accelerator SIGNAL pin of the ECM OEM harness connector to the accelerator SIGNAL pin of the accelerator position sensor connector.
  • Measure the resistance from sensor supply 4 +5-VDC SUPPLY pin of the ECM OEM harness connector to +5-VDC SUPPLY pin of the accelerator position sensor.
  • Measure the resistance from sensor supply 4 RETURN pin of the ECM OEM harness connector to the RETURN pin of the accelerator position sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the accelerator position sensor wiring harness. Refer to Procedure 019-071 in Section 19. Refer to Procedure 019-201 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the accelerator position resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY wire and the accelerator position sensor RETURN wire on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Between 2000 and 3000 ohms?
YES NO
No Repair

Replace the accelerator position sensor. See equipment manufacturer service information.

Go to 2D

Go to 4A

Guided Step 2D - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Take the measurement when the pedal is depressed and again when released.

  • Measure the resistance between the +5-VDC SUPPLY wire and the SIGNAL wire on the sensor side of the accelerator position sensor.

Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? (Released resistance must be at least 1000 ohms more than depressed resistance.)

YES NO
No Repair

Replace the accelerator position sensor. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Inspect the harness and the ECM connector pins for:

  • Bent or broken pins
  • Pushed back or expanded pins
  • Corroded pins
  • Moisture in or on the connector
  • Missing or damaged seals.

Dirty or damaged pins?
YES NO

Repair the damaged pins or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from the accelerator position signal to all other pins in the ECM OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from the accelerator position signal to all other pins in the OEM harness.

  • Measure the resistance from accelerator position signal to all other pins in the ECM OEM connector.

Less than 100k ohms?
YES NO

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for a short circuit from the accelerator position signal to engine block.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit from the accelerator position signal to engine block.

  • Measure the resistance between the accelerator position signal pin in the ECM OEM connector and engine block.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4A - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2014


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. |
 | STEP 2A. Inspect the remote remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 133 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695 and/or 1696.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit supply voltage and return circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position sensor +5 VOLT SUPPLY pin to the remote accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES NO

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM dealership for repair instructions.

Replace the remote accelerator pedal or lever. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal in Section TS, in the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 147 - Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid But Below Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 147 inactive?
STEP 2. | Check the frequency throttle and circuit. |
 | STEP 2A. Inspect the frequency throttle and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short-to-ground in the frequency throttle. | Greater than 100K ohms?
 | STEP 2C. Check for correct frequency throttle input voltage. | Voltage greater than original equipment manufacturer (OEM) specifications?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 147 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 147 inactive?
YES | NO
No Repair | No Repair

Intermittent fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check frequency throttle and circuit.

Guided Step 2A - Inspect the frequency throttle and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the frequency throttle and connector pins.

Action

Inspect the OEM harness and frequency throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short-to-ground in the frequency throttle.

Conditions

  • Turn keyswitch OFF
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a frequency throttle output short to ground.

  • Measure the resistance between the frequency throttle SIGNAL pin and ground at the frequency throttle connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A shorted frequency throttle has been detected.

Repair or replace the frequency throttle.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for correct frequency throttle input voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the frequency throttle from the OEM harness.

Action

Check the frequency throttle reference (input) voltage.

  • Measure frequency throttle reference (input) voltage.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than OEM specifications?
YES NO
No Repair

An incorrect reference (input) voltage to the frequency throttle has been detected.

Repair or replace the frequency throttle reference (input) circuit.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and frequency throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector frequency throttle SIGNAL pin and the OEM harness frequency throttle connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector frequency throttle SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

An shorted to ground SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 147 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use the INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 148 - Accelerator Pedal or Lever Position Sensor 1 - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 148 inactive?
STEP 2. | Check the frequency throttle and circuit. |
 | STEP 2A. Inspect the frequency throttle and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 147 active and Fault Code 148 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 148 is active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 148 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 148 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the frequency throttle and circuit.

Guided Step 2A - Inspect the frequency throttle and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the frequency throttle from the OEM harness.

Action

Inspect the OEM harness and frequency throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missung. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the frequency throttle from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 147 active and Fault Code 148 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the frequency throttle to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 148 is active?
YES NO

A malfunctioning frequency throttle has been detected.

Repair or replace the frequency throttle.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Repair the damaged harness, connector, or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM haness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the frequency throttle from the OEM hanress.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the frequency throttle SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted SIGNAL circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 148 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A malfunctioning frequency throttle has been detected.

Repair or replace the frequency throttle.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use the INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Engine Position Sensor | Refer to Procedure 019-038 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the engine speed/position sensor 2 and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine speed/position sensor 2 and circuit connected to the sensor number 2 supply and return. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the engine speed/position sensor 2 and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed/camshaft position sensor 2 from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the eninge speed/position sensor 2 and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed/position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the engine speed/position sensor.

Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Sensor | Refer to Procedure 019-017 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Sensor | Refer to Procedure 019-017 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Sep-2014


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 inactive and Fault Code 213 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 inactive and Fault Code 213 active?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive and Fault Code 213 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO

A damaged sensor has been detected.

Replace the engine oil temperature sensor.

Refer to Procedure 019-067 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following general resistance measurement techniques procedure. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2014


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Feb-2014


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 214?
YES | NO
No Repair | No Repair

Refer to the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSN14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is avaiable. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the original equipment manufacturer (OEM) service manual before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the engine control module (ECM) calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Feb-2014


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information for resistance specification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 005-043 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for extra wires connected to the fuel shutoff valve. | More than one wire connected to valve?
 | STEP 2C. Check for a pin-to-ground short circuit in the fuel shutoff valve. | 7 to 8 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0-VDC?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 254 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for extra wires connected to the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Extra wires connected to the fuel shutoff valve powering devices on the vehicle can cause this fault to be active.

  • Inspect the fuel shutoff valve terminal for more than one wire.

More than one wire connected to valve?
YES NO

Remove extra wires.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin-to-ground short circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance between the fuel shutoff valve terminal stud and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7 to 8 ohms?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 005-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the ECM fuel shutoff valve voltage.

  • Use a multimeter to measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin and ground.

Reference the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 255 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 005-043 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | 7 to 8 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0-VDC?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance between the fuel shutoff valve ring terminal stud and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7 to 8 ohms?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 005-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the ECM fuel shutoff valve voltage.

  • Measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for circuit continuity.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness fuel shutoff valve connector and the fuel shutoff valve SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 292 - Auxiliary Temperature Sensor Input 1 - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 292. | Active or inactive counts of Fault Code 292?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 292.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 292?
YES NO

The engine protection limit has been exceeded for the original equipment manufacturer (OEM) supplied pressure or temperature input. Refer to the OEM service manual.

No Repair

OEM service manual

Repair complete

Guided Step 2 - Check the engine control module (ECM) calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Feb-2014


FAULT CODE 293 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 293 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160K ohms?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 293 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor and connector pins.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and the RETURN pin at the OEM temperature sensor connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

180 ohms to 160K ohms?
YES NO

Refer to the OEM service manual for additional specifications.

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor RETURN pin, and the OEM harness OEM temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor SIGNAL pin and the OEM harness OEM temperature sensor connector SIGNAL pin.

Reference the circuit art or wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit art or wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 294 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 294 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 293 active and Fault Code 294 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 294 active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater then 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 294 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 active and Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 active?
YES NO

A damaged sensor has been detected.

Replace the OEM temperature sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and ground.

Use the following procedure for resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 296 - Auxiliary Pressure Sensor Input 2 - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 296. | Active or inactive counts of Fault Code 296?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 296.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 296?
YES NO

The engine protection limit has been exceeded for the original equipment manufacturer (OEM) supplied pressure input. Refer to the OEM service manual.

No Repair

OEM service manual.

Repair complete

Last Modified: 25-Feb-2014


FAULT CODE 297 - Auxiliary Pressure Sensor Input 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply fault code(s) active?
STEP 2. | Check the original equipment manufacturer (OEM) pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 298 active and Fault Code 297 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 297 active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 297 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault code(s) active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 active and Fault Code 297 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM Pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Reference the circuit art or wiring diagram for connector pin identification

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active?
YES NO

A damaged sensor has been detected.

Replace the OEM pressure sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Reference the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Reference the circuit art or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Reference the circuit art or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 298 - Auxiliary Pressure Sensor Input 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor Supply Fault Code(s) active?
STEP 2. | Check the OEM pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 297 active and Fault Code 298 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 298 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 298 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor Supply Fault Code(s) activ?
YES | NO
No Repair | No Repair

Refer tothe appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

For general inspection techniques refer to Component Connector and Pin Inspection Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the OEM pressure SUPPLY pin and the OEM pressure SIGNAL pin at the OEM pressure sensor connector of the OEM harness.

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active and Fault Code 298 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 is active?
YES NO

A damaged sensor has been detected.

Replace the OEM pressure sensor.

Refer to OEM troubleshooting procedures.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques., Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure SIGNAL pin and the OEM harness OEM pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques., Refer to Procedure 019-360 in Section 19.

Less than 10 ohms
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques., Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted signal circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques., Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Feb-2014


FAULT CODE 311 - Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3C. Check for a short to voltage source in the engine harness. | Less than 1.5-VDCD
 | STEP 3D. Check for an inactive fault code. | Fault Code 311 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector connector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin at injector connector of engine harness to engine block ground.
  • Measure the voltage between the injector RETURN pin at injector connector of engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Apr-2014


FAULT CODE 312 - Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 1.0 to 1.2 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3D. Check for an inactive fault code. | Fault Code 312 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 312 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 313 - Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control modulel (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 1.0 to 1.2 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3D. Check for an inactive fault code. | Fault Code 313 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 313 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 314 - Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSN14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 314 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 314 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 315 - Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSN14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 1.0 to 1.2 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3D. Check for an inactive fault code. | Fault Code 315 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 315 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 321 - Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | QSN14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 1.0 to 1.2 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3D. Check for an inactive fault code. | Fault Code 321 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Assciated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1.0 to 1.2 ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure Refer to Procedure019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 321 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSN14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control moduel (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 1 wire.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Oct-2014


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification symptom troubleshooting tree in Section TS

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Mar-2014


FAULT CODE 431 - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent,or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the original equipment manufacturer (OEM) harness. | Integrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the integrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the integrated sensor switch for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the integrated sensor switch for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the harness.

Verify the integrated sensor switch is connected to the OEM harness.

Integrated sensor switch connected to the OEM harness?
YES NO
No Repair

Connect the integrated sensor switch to the OEM harness. See equipment manufacturer service information..

Go to 1B

Go to 3A

Guided Step 1B - Inspect the integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever depressed.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Replace the integrated sensor switch.

See equipment manufacturer service information.

Go to 1D

Go to 3A

Guided Step 1D - Check the integrated sensor switch for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the integrated sensor switch connector with the pedal or lever released and depressed.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the integrated sensor switch.

See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Short circuit on two connectors - pin-to-pin check.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the OEM harness ECM connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 11-Sep-2014


FAULT CODE 432 - Accelerator Pedal or Lever Idle Validation Switch - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSN14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

For Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™, test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 432 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 432 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released) [200 to 1500 ohms (depressed)]?
 | STEP 3B-1. Inspect the OEM harness and connector pins. |
 | STEP 3B-2. Check the accelerator pedal or lever position sensor resistance. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Disable the fault code. | Fault Code 432 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch OFF.
  • All components connected.
  • Turn keyswitch ON.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the ECM connector of the OEM harness.

Refer to the wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [200 to 1500 ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from OEM harness.

Action

Inspect the OEM harness and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B-2

Guided Step 3B-2 - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the accelerator pedal or lever position sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [200 to 1500 ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES NO

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the accelerator pedal or lever assembly. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 432 is inactive.

Fault Code 432 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No repair.

Go to 1A

Last Modified: 17-Oct-2014


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Use INSITE™ electronic service tool to monitor intake manifold temperature. | INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Use INSITE™ electronic service tool to monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the intake manifold temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to the appropriate troubleshooting symptom tree.

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Mar-2014


FAULT CODE 527 - Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 527 inactive?
STEP 2. | Check the OEM output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 100 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, supply line, and return circuit. | Greater the 3.75-VDC?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 527 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 527 is inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control harness and OEM output control solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and RETURN circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check the OEM output control solenoid diagnostic supply voltage and RETURN circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM circuit diagram or wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the faulty connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open OEM control output solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 527 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Feb-2014


FAULT CODE 528 - Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 528 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Alternate torque switch operating correctly?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 528 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Inspect the alternate torque switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check the functionality of the alternate torque switch.

Use the following manual for troubleshooting information for the alternate torque switch. Refer to OEM service manual.

Alternate torque switch operating correctly?
YES NO
No Repair

Replace the alternate torque switch.

Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF,
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the alternate torque switch circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector alternate torque switch pin and the OEM harness alternate torque switch pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Feb-2014


FAULT CODE 529 - Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 10 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit. | Greater than 3.75-VDC?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to pin-short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control harness and OEM output control solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Refer to the circuit diagram or the wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

IF the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the faulty connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the fillowing:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open OEM control output solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 599 - Auxiliary Commanded Dual Output Shutdown - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 599. | Active or inactive counts of Fault Code 599?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

The engine protection limit for the original equipment manufacturer (OEM) supplied auxiliary device has been exceeded. See equipment manufacturer service information.

No Repair

See equipment manufacturer service information.

Repair complete.

Last Modified: 23-Feb-2014


FAULT CODE 611 - Engine Shut Down Hot - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | No action required. |
 | STEP 1A. No action required. | Was the engine shut down before proper cool down?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 611 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - No action required.

Guided Step 1A - No action required.

Conditions

None

Action

Engine Hot Shutdown - Condition Exists.

The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold.

Was the engine shut down before proper cool down?
YES | NO
No Repair | No Repair

Go to None

Go to None

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 611 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-Mar-2014


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine position sensor 1 and connector. |
 | STEP 2A. Inspect the engine position sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine position sensor 1 for damage. | Damaged sensor?
STEP 3. | Check the engine position sensor 1 circuit. |
 | STEP 3A. Check the engine position sensor 1 supply voltage and return circuit. | Between 4.75 to 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open engine position sensor 1 signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the engine position sensor 1 signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the engine position sensor 1 condition. |
 | STEP 3C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check for an open engine position sensor 1 signal circuit in the engine wiring harness. |
 | STEP 3C-2. Check the fault code and verify engine position sensor 1 condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor 1 and connector.

Guided Step 2A - Inspect the engine position sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 1 from the engine harness.

Action

Inspect the engine harness and engine position sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor 1 connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine position sensor 1 for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 1 from the engine harness.
  • Remove the engine position sensor 1 from the gear housing cover. Refer to Procedure 019-038 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the camshaft gear and related components. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine position sensor 1 circuit.

Guided Step 3A - Check the engine position sensor 1 supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine position sensor 1 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor 1 +5 volt SUPPLY pin and the engine position sensor 1 RETURN pin at the engine position sensor 1 connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open engine position sensor 1 signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 1 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine position sensor 1 SIGNAL pin at the engine position sensor 1 engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the engine position sensor 1 signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine position sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine position sensor 1 SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine position sensor 1 from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the engine position sensor 1 from the engine block and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-038 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the engine position sensor 1 condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged engine position sensor 1 has been detected.

Replace the engine position sensor 1. Refer to Procedure 019-038 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open engine position sensor 1 signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the engine position sensor 1 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor 1 +5 volt SUPPLY pin and the engine position sensor 1 RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify engine position sensor 1 condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the engine position sensor 2 and connector. |
 | STEP 2A. Inspect the engine position sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine position sensor 2 for damage. | Damaged sensor?
STEP 3. | Check the engine position sensor 2 circuit. |
 | STEP 3A. Check the engine position sensor 2 supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open engine position sensor 2 signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the engine position sensor 2 signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate engine position sensor 2 air gap. |
 | STEP 3B-4. Check the fault code and verify the engine position sensor 2 condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify engine position sensor 2 condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor 2 and connector.

Guided Step 2A - Inspect the engine position sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 2 from the engine harness.

Action

Inspect the engine harness and engine position sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine position sensor 2 for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 2 from the engine harness.
  • Remove the engine position sensor 2 from the gear housing cover. Refer to Procedure 019-038 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-038 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine position sensor 2 circuit.

Guided Step 3A - Check the engine position sensor 2 supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine position sensor 2 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor 2 +5 volt SUPPLY pin and the engine position sensor 2 RETURN pin at the engine position sensor 2 connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open engine position sensor 2 signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor 2 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine position sensor 2 SIGNAL pin at the engine position sensor 2 engine harness connector to the engine position sensor 2 SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the engine position sensor 2 signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine position sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine position sensor 2 SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate engine position sensor 2 air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the engine position sensor 2 from the gear housing and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-038 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the engine position sensor 2 condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged engine position sensor 2 has been detected.

Replace the engine position sensor 2. Refer to Procedure 019-038 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the engine position sensor 2 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor 2 +5 volt SUPPLY pin and the engine position sensor 2 RETURN pin at the ECM.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify engine position sensor 2 condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2014


FAULT CODE 1695 - Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.
  • Disconnect the coolant level sensor from the OEM harness, if equipped.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.
  • Disconnect the coolant level sensor from the OEM harness, if equipped.

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Mar-2014


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Check the circuit response. | Fault Code 1696 active?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Check the circuit response. | Fault Code 1696 active?
 | STEP 2D. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator/lever position sensor. See the equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote throttle from the OEM harness, if equipped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the remote throttle. See the equipment manufacturer service information.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the OEM pressure sensor. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM OEM connector or OEM harness connector.

Repair the damaged pins.

Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the remote throttle, if equipped, from the OEM harness.
  • Disconnect the OEM pressure sensor, if equipped, from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5-VDC SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the remote throttle, if equipped, from the OEM harness.
  • Disconnect the OEM pressure sensor, if equipped, from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5-VDC SUPPLY pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Mar-2014


FAULT CODE 2182 - Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2182 inactive?
STEP 2. | Check the exhaust brake actuator and circuit. |
 | STEP 2A. Inspect the exhaust brake actuator and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the exhaust brake actuator. | Less than original equipment manufacturer (OEM) specification?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the exhaust brake actuator return circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2182 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust brake actuator and circuit.

Guided Step 2A - Inspect the exhaust brake actuator and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Inspect the engine harness and exhaust brake actuator connections for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the exhaust brake actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Check the exhaust brake actuator resistance.

  • Measure the resistance between the exhaust brake SIGNAL pin and the exhaust brake RETURN pin at the exhaust brake actuator.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than OEM specification?
YES NO
No Repair

An open circuit has been detected in the exhaust brake actuator.

Replace the exhaust brake actuator.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and ECM engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness connector exhaust brake actuator SIGNAL pin and the engine harness exhaust brake actuator connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open exhaust brake actuator SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the exhaust brake actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine harness ECM connector.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust brake actuator RETURN pin at the exhaust brake actuator connector to ground.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit between the RETURN wire and chassis or engine block ground has been detected.

Refer to the wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the engine harness, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust brake from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust brake actuator SIGNAL pin in the engine harness connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pins identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the exhaust brake actuator SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 2183 - Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2183 inactive?
STEP 2. | Check the exhaust brake actuator and circuit. |
 | STEP 2A. Inspect the exhaust brake actuator and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2182 active and Fault Code 2183 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2183 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2183 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust brake actuator and circuit.

Guided Step 2A - Inspect the exhaust brake actuator and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Inspect the engine harness and exhaust brake actuator connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust brake actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 active and Fault Code 2283 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify actuator condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust brake actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 active?
YES NO

A malfunctioning exhaust brake actuator has been detected.

Replace the exhaust brake actuator.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Check for a pin-to-ground short

  • Measure the resistance between the exhaust brake actuator SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to- ground short circuit on the exhaust brake actuator SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF. Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust brake actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust brake actuator SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to- ground short circuit on the exhaust brake SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 2195 - Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2195 active?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2195 active?
YES NO

The fault code indicates that the emergency door of the vehicle has been opened.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • The current ECM code and revision number in the ECM can be found using INSITE™ service tool. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 12-Nov-2013


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) , all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufcturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in fan control solenoid return circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid.

See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness fan control solenoid connector fan control solenoid RETURN pin and the OEM harness ECM fan control solenoid RETURN pin (or ground).

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSNT14 CM876 N102 | 4325993
Engine Coolant Sensor | Refer to Procedure 019-017 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Use the following procedure to replace the engine coolant sensor. Refer to Procedure 019-017 in the Associated Procedures Table or the original equipment manufacturer (OEM) service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Sep-2013


FAULT CODE 2555 - Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Resistance value is correct?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

For the resistance value, refer to the OEM service manual.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

The resistance value is correct?
YES NO
No Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay RETURN pin and the OEM harness intake air heater relay connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 2557 - Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the auxiliary pulse width modulation (PWM) component and circuit |
 | STEP 2A. Inspect the auxiliary PWM component and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the auxiliary PWM component | Resistance value is correct?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the auxiliary PWM component. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the auxiliary PWM component and circuit

Guided Step 2A - Inspect the auxiliary PWM component and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Inspect the engine harness and the auxiliary PWM component connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the auxiliary PWM component.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check the auxiliary PWM component resistance.

  • Measure the resistance between the auxiliary PWM component SIGNAL pin and the auxiliary PWM component RETURN pin at the auxiliary PWM component.

For the resistance value, refer to the OEM service manual.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance value is correct?
YES NO
No Repair

An open circuit has been detected in the auxiliary PWM component.

Replace the auxiliary PWM component. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector the auxiliary PWM component SIGNAL pin and the engine the auxiliary PWM component connector SIGNAL pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open auxiliary PWM component signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the auxiliary PWM component.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector auxiliary PWM component RETURN pin and the engine harness auxiliary PWM component connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open auxiliary PWM component return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary PWM component SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary PWM component SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 2558 - Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 2. | Check the auxiliary pulse width modulation (PWM) component and circuit |
 | STEP 2A. Inspect the auxiliary PWM component and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2557 active and Fault Code 2558 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2558 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the auxiliary PWM component and circuit

Guided Step 2A - Inspect the auxiliary PWM component and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Inspect the engine harness and the auxiliary PWM component connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary PWM component from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 active and Fault Code 2558 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the auxiliary PWM component to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 active?
YES NO

A damaged auxiliary PWM component has been detected.

Replace the auxiliary PWM component. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary PWM component SIGNAL pin in the engine harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the auxiliary PWM component wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the auxiliary PWM component from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary PWM component SIGNAL pin in the engine harness ECM connector and all other pins in the engine connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary PWM component SIGNAL wire has been detected in the engine harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSNT14 CM876 N102 | 4325993
Charge-Air Cooler | Refer to Procedure 010-027 | QSNT14 CM876 N102 | 4325993
Turbocharger | Refer to Procedure 010-033 | QSNT14 CM876 N102 | 4325993
Exhaust Restriction | Refer to Procedure 011-009 | QSNT14 CM876 N102 | 4325993
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSNT14 CM876 N102 | 4325993
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Code 122, 123, 221, or 222?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm Hg [2 in Hg] of local barometric pressure and intake manifold pressure?
STEP 3. | Check the air intake system for leaks. |
 | STEP 3A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 3B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 3C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 3D. Check for a restricted charge-air cooler. | Differential pressure across the charge-air cooler within specifications?
STEP 4. | Check exhaust system for restriction. |
 | STEP 4A. Check the exhaust system. | Exhaust restriction within specifications?
STEP 5. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 5A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 123 active?
 | STEP 5C. Check the circuit response. | Fault Code 122 active?
STEP 6. | Check the ECM and engine harness. |
 | STEP 6A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the circuit response. | Fault Code 123 active?
 | STEP 6C. Check the circuit response. | Fault Code 122 active?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code and malfunction indicator lamp (MIL). | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 122, 123, 221, or 222?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and compare to the Data Monitor/Logger.

  • Compare the barometric pressure with the intake manifold pressure at keyswitch ON.

Refer to Procedure 019-004 in the Associated Procedures Table for specifications.

INSITE™ electronic service tool reading within 51 mm Hg [2 in Hg] of local barometric pressure and intake manifold pressure?
YES NO
No Repair

Check the wiring harness for resistance.

  • Repair or replace if needed. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the barometric pressure sensor if the wiring harness is not damaged. Refer to Procedure 019-004 in the Associated Procedures Table.

Replace the intake manifold pressure/temperature sensor if Fault Code 2973 is still active after replacing the barometric pressure sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the air intake system for leaks.

Guided Step 3A - Check the charge-air cooler for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 3C

Guided Step 3C - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3D

Guided Step 3D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge-air cooler within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, if necessary.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust system for restriction.

Guided Step 4A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 7A

Go to 5A

Guided Step 5 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 5A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Refer to the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM and engine harness.

Guided Step 6A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6C

Go to 7A

Guided Step 6C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code and MIL.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


INDEX
207-fc111.htm

178-t05-111.htm

207-fc115.htm

178-t05-115.htm

207-fc122.htm

178-t05-122.htm

207-fc123.htm

178-t05-123.htm

207-fc131.htm

207-fc131dp.htm

178-t05-131.htm

207-fc131iss.htm

207-t05-131iss.htm

207-fc132.htm

207-fc132dp.htm

178-t05-132.htm

207-fc132iss.htm

207-t05-132iss.htm

207-fc133.htm

207-t05-133.htm

207-fc134.htm

178-t05-134.htm

207-fc135.htm

178-t05-135.htm

207-fc141.htm

178-t05-141.htm

207-fc143.htm

178-t05-143.htm

207-fc144.htm

178-t05-144.htm

207-fc145.htm

178-t05-145.htm

207-fc146.htm

207-t05-146.htm

207-fc147.htm

207-t05-147.htm

207-fc148.htm

207-t05-148.htm

207-fc151.htm

178-t05-151.htm

207-fc153.htm

178-t05-153.htm

207-fc154.htm

178-t05-154.htm

207-fc155.htm

178-t05-155.htm

207-fc187.htm

207-t05-187.htm

207-fc195.htm

207-t05-195.htm

207-fc196.htm

207-t05-196.htm

207-fc197.htm

178-t05-197.htm

207-fc212.htm

207-t05-212.htm

207-fc213.htm

207-t05-213.htm

207-fc214.htm

207-t05-214.htm

207-fc221.htm

178-t05-221.htm

207-fc222.htm

178-t05-222.htm

207-fc227.htm

207-t05-227.htm

207-fc234.htm

178-t05-234.htm

207-fc235.htm

207-t05-235.htm

207-fc238.htm

178-t05-238.htm

207-fc239.htm

178-t05-239.htm

207-fc241.htm

178-t05-241.htm

207-fc242.htm

178-t05-242.htm

207-fc245.htm

207-t05-245.htm

207-fc254.htm

207-t05-254.htm

207-fc255.htm

207-t05-255.htm

207-fc285.htm

178-t05-285.htm

207-fc286.htm

178-t05-286.htm

207-fc287.htm

178-t05-287.htm

207-fc288.htm

178-t05-288.htm

207-fc292.htm

207-t05-292.htm

207-fc293.htm

207-t05-293.htm

207-fc294.htm

207-t05-294.htm

207-fc296.htm

207-t05-296.htm

207-fc297.htm

207-t05-297.htm

207-fc298.htm

207-t05-298.htm

207-fc311.htm

207-t05-311.htm

207-fc312.htm

207-t05-312.htm

207-fc313.htm

207-t05-313.htm

207-fc314.htm

207-t05-314.htm

207-fc315.htm

207-t05-315.htm

207-fc321.htm

207-t05-321.htm

207-fc322.htm

178-t05-322.htm

207-fc323.htm

178-t05-323.htm

207-fc324.htm

178-t05-324.htm

207-fc325.htm

178-t05-325.htm

207-fc331.htm

178-t05-331.htm

207-fc332.htm

178-t05-332.htm

207-fc343.htm

178-t05-343.htm

207-fc351.htm

178-t05-351.htm

207-fc352.htm

207-t05-352.htm

207-fc386.htm

207-t05-386.htm

207-fc415.htm

178-t05-415.htm

207-fc418.htm

178-t05-418.htm

207-fc421.htm

207-t05-421.htm

207-fc428.htm

178-t05-428.htm

207-fc429.htm

178-t05-429.htm

207-fc431.htm

207-t05-431.htm

207-fc432.htm

207-t05-432.htm

207-fc435.htm

178-t05-435.htm

207-fc441.htm

178-t05-441.htm

207-fc442.htm

178-t05-442.htm

207-fc488.htm

207-t05-488.htm

207-fc527.htm

207-t05-527.htm

207-fc528.htm

207-t05-528.htm

207-fc529.htm

207-t05-529.htm

207-fc584.htm

178-t05-584.htm

207-fc585.htm

178-t05-585.htm

207-fc596.htm

178-t05-596.htm

207-fc597.htm

178-t05-597.htm

207-fc598.htm

178-t05-598.htm

207-fc599.htm

207-t05-599.htm

207-fc611.htm

207-t05-611.htm

207-fc649.htm

178-t05-649.htm

207-fc689.htm

207-t05-689.htm

207-fc697.htm

178-t05-697.htm

207-fc698.htm

178-t05-698.htm

207-fc778.htm

207-t05-778.htm

207-fc1117.htm

178-t05-1117.htm

207-fc1239.htm

178-t05-1239.htm

207-fc1241.htm

178-t05-1241.htm

207-fc1242.htm

178-t05-1242.htm

207-fc1695.htm

207-t05-1695.htm

207-fc1696.htm

207-t05-1696.htm

207-fc1852.htm

178-t05-1852.htm

207-fc2182.htm

207-t05-2182.htm

207-fc2183.htm

207-t05-2183.htm

207-fc2185.htm

178-t05-2185.htm

207-fc2186.htm

178-t05-2186.htm

207-fc2195.htm

207-t05-2195.htm

207-fc2377.htm

207-t05-2377.htm

207-fc2448.htm

207-t05-2448.htm

207-fc2555.htm

207-t05-2555.htm

207-fc2556.htm

00-t05-2556.htm

207-fc2557.htm

207-t05-2557.htm

207-fc2558.htm

207-t05-2558.htm

207-fc2963.htm

178-t05-2963.htm

207-fc2973.htm

207-t05-2973.htm