QSB4.5/6.7/7-DM CM850/CM2850 - Power Gen/Marine Auxiliary

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module (ECM) - Critical Internal Failure

FAULT CODE 111

Engine Control Module (ECM) - Critical Internal Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module (ECM) - critical internal failure. Error internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel system side of the engine. It is attached to the engine block at the front of the engine just behind the front gear cover. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 04-Oct-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Crankshaft Speed/Position Sensor Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Crankshaft Speed/Position Sensor Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2 LAMP: Red SRT: | Engine Magnetic Crankshaft Speed/Position Sensor Lost Both of Two Signal - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the primary engine speed sensor and the backup engine speed sensor signals are reversed. | Fueling to the injectors is disabled, and the engine can not be started.
Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The engine speed sensor (crankshaft position sensor) SUPPLY and RETURN wires are on the sensor supply and return circuit 1 and are not shared with any other sensors. The camshaft speed sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Component Location

The crankshaft speed sensor and the camshaft position sensor is located on the intake side of the engine, in the front gear cover, under the stage 2 fuel filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The main engine speed sensor (crankshaft position sensor) and the backup engine speed sensor (camshaft position sensor) are located in close proximity to one another. The same sensor is used in both locations. (Connector key is the same.) A P-clip on the engine wiring harness prohibits the harness connectors from being connected to the incorrect sensors. However, if the P-clip is omitted, it is possible to plug the wiring harness connectors into the incorrect sensors. If this occurs, the ECM will detect the problem and the engine will not start. Once the connector problem is corrected, the engine can be started and the fault code will become inactive.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 23-Aug-2012


Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | No engine protection for circuit or sensor failure.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the engine control module (ECM) through the engine harness. If the intake manifold pressure sensor circuit fails out of range high, the ECM will assume a default intake manifold pressure and fueling will be limited based on this default value. This will cause a derate like condition and limit the maximum power of the engine.

There is no engine protection for a circuit or sensor failure.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, ambient air pressure sensor, and coolant pressure sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122.

Last Modified: 23-Aug-2012


Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold pressure circuit. | None - No engine protection for circuit sensor failure.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the engine control module (ECM) through the engine harness. If the intake manifold pressure sensor circuit falls out of range low, the ECM will assume a default intake manifold pressure and fueling will be limited based on this default value. This will cause a derate like condition and limit the maximum power of the engine.

There is no engine protection for a circuit or sensor failure.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, ambient air pressure sensor, and coolant pressure sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123.

Last Modified: 23-Aug-2012


Oil Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Oil Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Oil Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | None. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Possible cause of this fault code:

  • A pin-to-pin short circuit in the SIGNAL wire.

Does the fault code occur only in cold weather? If so, allow the oil to warm up and see if the fault code goes inactive.

Refer to Troubleshooting Fault Code t05-135.

Last Modified: 24-Aug-2012


Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the engine control module (ECM) to monitorthe lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The oil pressure sensor is located on the left side of the engine block. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 24-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Engine shutdown if enabled.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 23-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | None, no engine protection for circuit or sensor failure.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The coolant temperature sensor is located in the front of the cylinder head next to the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Before troubleshooting Fault Code 144, check for multiple faults.

The coolant temperature sensor shares RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Temperature (C) | Temperature [F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 23-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None. No engine protection for circuit or sensor failure.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) tomonitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The coolant temperature sensor is located on the front of the cylinder head next to the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The coolant temperature sensor shares RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 23-Aug-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. | None
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the front of the cylinder head next to the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that the engine coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Section TS.

Refer to Troubleshooting Fault Code t05-146.

Last Modified: 20-Sep-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. | Engine will shutdown if enabled.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The coolant temperature sensor is located on the front of the cylinder head next to the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 23-Aug-2012


Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | None. No engine protection for circuit or sensor failure.
Intake Manifold Air Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake pressure/temperature sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 5497 to 6050
77 | 25 | 1940 to 2089
104 | 40 | 1114 to 1186
212 | 100 | 180.4 to 185.1
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 23-Aug-2012


Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | None. No engine protection for circuit or sensor failure.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake pressure/temperature sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 5497 to 6050
25 | 77 | 1940 to 2089
40 | 104 | 1114 to 1186
100 | 212 | 180.4 to 185.1

Refer to Troubleshooting Fault Code t05-154.

Last Modified: 23-Aug-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. | Engine will shutdown if enabled.
Engine Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness. No derate condition occurs for marine engines.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air aftercooler
  • High turbocharger compressor outlet temperature
  • Verify that the aftercooler coolant flow is not blocked or clogged with debris.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 24-Aug-2012


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. | None, no engine protection for circuit or sensor failure.
Sensor Supply 2 Circuit

Circuit Description

Sensor supply number 2 of the engine control module (ECM) is provided +5 VDC through pin number 22 in the original equipment manufacturer (OEM) harness for the droop adjust potentiometer.

Component Location

The sensor supply number 2 circuit is located in the ECM.

Shop Talk

Low voltage on the +5-VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 23-Aug-2012


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor 1 Circuit

Circuit Description

The engine control module (ECM) supplies a +5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

On engines with a heat exchanger, the engine coolant level sensor is located on the engine expansion tank. Refer to Procedure 102-002 in Section E.

On engines with a radiator or keel cooler, reference the OEM service manual for the location of the engine coolant level sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber light immediately after the diagnostic runs and passes.

Shop Talk

The coolant level sensor shares SUPPLY and RETURN wires in the engine harness with the fuel supply pressure sensor.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195.

Last Modified: 17-Sep-2012


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor 1 Circuit

Circuit Description

The engine control module (ECM) provides a +5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

On engines with a heat exchanger, the engine coolant level sensor is located in the on-engine expansion tank. Refer to Procedure 102-002 in Section E.

On engines with a radiator or keel cooler, reference the OEM service manual for the location of the engine coolant level sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber light immediately after the diagnostic runs and passes.

Shop Talk

The coolant level sensor shares SUPPLY and RETURN wires in the engine harness with the fuel supply pressure sensor.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196.

Last Modified: 17-Sep-2012


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | Engine will shut down if enabled.
Engine Coolant Level

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

On engines with a heat exchanger, the engine coolant level sensor is located in the on-engine expansion tank. Refer to Procedure 100-002 in Section E.

For engines with a radiator or keel cooler, refer to the OEM service manual.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

  • The ECM detects that the coolant level sensor signal voltage is higher than 3-VDC for more than 30 seconds, indicating a very low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light after 30 seconds, and the red light after 90 seconds, when low engine coolant level has been detected.
  • The engine will shutdown after 5 minutes, if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to inactive immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber light immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or expansion tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code t05-197.

Last Modified: 13-Sep-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies +5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located on the left side of the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine oil temperature sensor shares RETURN wires in the engine harness with the following sensors:.

  • Fuel supply pressure sensor
  • Coolant level sensor
  • Water-in-fuel sensor
  • Exhaust stack sensor.

An open RETURN can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-212.

Last Modified: 06-Sep-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located on the left side of the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine oil temperature sensor shares RETURN wires in the engine harness with the following sensors:

  • Fuel supply pressure sensor
  • Coolant level sensor
  • Water-in-fuel sensor
  • Exhaust stack sensor.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-213.

Last Modified: 06-Sep-2012


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
Engine Oil Temperature Circuit

Circuit Description

The engine oil temperature 1 sensor is used by the engine control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the engine oil temperature 1 sensor SIGNAL pin and converts it to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system.

Component Location

The engine oil temperature 1 sensor is located in the oil pan adapter on the exhaust side of the engine under the starter.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for high engine oil temperature. Reference the Engine Oil Temperature Above Normal troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 06-Sep-2012


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | None. No engine protection for circuit or sensor malfunction.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the engine control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

The barometric pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

  • Camshaft speed sensor
  • Intake pressure/temperature sensor
  • Fuel rail pressure sensor
  • Engine oil pressure sensor
  • Crankcase pressure sensor
  • Coolant pressure sensor.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 06-Sep-2012


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric (ambient air) pressure circuit. | None. No engine protection for circuit or sensor malfunction.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the engine control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

The barometric pressure sensor sharesSUPPLY and RETURN wires in the engine harness with the following sensors:

  • Camshaft speed sensor
  • Intake pressure/temperature sensor
  • Fuel rail pressure sensor
  • Engine oil pressure sensor
  • Crankcase pressure sensor
  • Engine coolant pressure sensor.

Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 06-Sep-2012


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | None. No engine protection for circuit or sensor failure.
Sensor Supply Voltage Number 2 Circuit

Circuit Description

The sensor supply number 2, of the engine control module (ECM), is provided a +5 volt supply through pin number 22 in the OEM harness from the droop adjustment potentiometer.

Component Location

Sensor supply number 2 is located inside the ECM. The droop adjustment potentiometer is located in the C Command control panel.

Shop Talk

High voltage on the +5 VDC supply line can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 25-Sep-2012


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: SPN: 109 FMI: 1 LAMP: Red SRT: | Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Coolant pressure signal indicates coolant pressure is below the engine protection critical limit. | Engine will shutdown, if enabled.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the engine control module (ECM) to monitor the coolant pressure. If the coolant pressure drops below the engine protection limit, Fault Code 228 will log.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine below the exhaust manifold next to cylinder number 4.

Shop Talk

Possible causes of this fault code include:

  • Low coolant pressure.
Refer to Troubleshooting Fault Code t05-228.

Last Modified: 06-Sep-2012


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: SPN: 109 FMI: 3 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the coolant pressure sensor circuit. | None. No engine protection for circuit or sensor malfunction.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the engine control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the coolant pressure signal pin and converts it to a pressure value.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine block under the exhaust manifold, next to cylinder number 4.

Shop Talk

The coolant pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors:

  • Camshaft speed sensor
  • Intake pressure/temperature sensor
  • Fuel rail pressure sensor
  • Engine oil pressure sensor
  • Crankcase pressure sensor
  • Barometric (ambient air) pressure sensor.

Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 231, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-231.

Last Modified: 06-Sep-2012


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the coolant pressure sensor circuit. | None. No engine protection for circuit or sensor malfunction.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the engine control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the coolant pressure signal pin and converts it to a pressure value.

Component Location

The coolant pressure sensor is located on the exhaust side of the engine, under the exhaust manifold, next to cylinder number 4.

Shop Talk

The coolant pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors:

  • Camshaft speed sensor
  • Intake pressure/temperature sensor
  • Fuel rail pressure sensor
  • Engine oil pressure sensor
  • Crankcase pressure sensor
  • Ambient air pressure sensor.

Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 232, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-232.

Last Modified: 13-Sep-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed is above the engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Camshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor and the camshaft engine position sensor provide engine speed and position information to the engine control module (ECM) through the engine harness.

Component Location

The crankshaft speed sensor and the camshaft position sensor is located on the intake side of the engine, in the front gear cover, under the Stage 2 fuel filter. Refer to Procedure 102-002 in Section E.

Shop Talk

The camshaft position sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors:

  • Intake pressure/temperature sensor
  • Fuel rail pressure sensor
  • Oil pressure sensor
  • Crankcase pressure sensor
  • Barometric air pressure sensor
  • Coolant pressure sensor.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Rapid loss of loading on the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering. Check the drive unit for possible rapid or sudden unloading of the engine.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 25-Sep-2012


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. Low engine coolant level detected. | Engine will shutdown, if enabled.
Coolant Level Sensor 1 Circuit

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the engine control module (ECM) through the OEM harness.

Component Location

On engines with a heat exchanger, the engine coolant level sensor is located in the expansion tank on the engine. Refer to Procedure 100-002 in Section E.

For engines with a radiator or keel cooler, refer to the original equipment manufacturer (OEM) service manual.

Shop Talk

This fault code becomes active when the coolant level inside the radiator top tank or expansion tank drops below the sensor level. Fill the radiator or expansion tank with coolant.Refer to Procedure 008-018 in Section 8.

Refer to Troubleshooting Fault Code t05-235.

Last Modified: 06-Sep-2012


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 611 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit. | None.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides +5 VDC for the frequency adjust potentiometer, the fuel delivery pressure sensor, and the coolant level sensor. If the supply wire to these sensors is damaged, the sensors will not work properly.

Component Location

The frequency adjust potentiometer is located in the C Command Control Panel, the fuel delivery pressure sensor is located on the fuel filter head and the coolant level sensor is located in the engine mounted expansion tank or on the original equipment manufacturer (OEM) supplied radiator or remote expansion tank. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The coolant level sensor shares SUPPLY and RETURN wires in the 60-pin engine wiring harness with the fuel supply pressure sensor and RETURN wires with water-in-fuel sensor, exhaust stack sensor and oil pressure sensor. The frequency adjust potentiometer shares RETURN wires with the speed load bias in the 50-pin OEM wiring harness. Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a malfunctioning sensor, or a malfunctioning engine control module (ECM) power supply.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 04-Oct-2012


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the +5 volt sensor supply circuit. | None.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides +5 VDC for the frequency adjust potentiometer, the fuel delivery pressure sensor, and the coolant level sensor. If the supply wire to these sensors is damaged, the sensors will not work properly.

Component Location

The frequency adjust potentiometer is located in the C Command Control Panel, the fuel delivery pressure sensor is located on the fuel filter head, and the coolant level sensor is located in the engine mounted expansion tank or on the original equipment manufacturer (OEM) supplied radiator or remote expansion tank. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The coolant level sensor shares SUPPLY and RETURN wires in the 60-pin engine wiring harness with the fuel supply pressure sensor and RETURN wires with the water-in-fuel sensor, the exhaust stack sensor, and the oil pressure sensor. The frequency adjust potentiometer shares RETURN wires with the speed load bias in the 50-pin OEM wiring harness. High voltage on the 5-VDC supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged engine control module (ECM).

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 01-Oct-2012


Exhaust Stack Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 248

Exhaust Stack Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 248 PID: SPN: 173 FMI: 16 LAMP: Amber SRT: | Exhaust Stack Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. Exhaust stack temperature is above engine protection limit. | None.
Exhaust Stack Temperature Sensor 1 Circuit

Circuit Description

The exhaust stack temperature sensor 1 circuit monitors exhaust stack temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust stack temperature sensor 1 is located in the 90 degree exhaust elbow, after the turbocharger. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust stack temperature sensor 1 measures the temperature of the exhaust air as it exits the turbocharger and into the exhaust stack. This fault code indicates that exhaust stack temperature has exceeded the warning threshold limits for high exhaust stack temperature.

Exhaust Stack Temperature
Temperature (°C) | Temperature [°F] | Resistance (ohms)
50 | 122 | 2,326,245
100 | 212 | 289,445 to 481,411
200 | 392 | 25,922 to 35,567
300 | 572 | 5,297 to 6,608
400 | 752 | 1,634 to 1,926
500 | 932 | 681 to 771
600 | 1112 | 347 to 379
700 | 1292 | 197 to 219
800 | 1472 | 124 to 139
900 | 1652 | 84.2 to 94.9
1000 | 1832 | 64.5
Refer to Troubleshooting Fault Code t05-248.

Last Modified: 04-Oct-2012


High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel pump actuator circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
Electronic Fuel Control Actuator Circuit

Circuit Description

The circuit is a pulse width modulation (PWM) driver in the engine control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. PWM duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel control actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is reenabled at keyswitch ON. If the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 may have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code t05-271.

Last Modified: 29-Aug-2012


High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the fuel pump actuator circuit. | Engine will not run or engine will run poorly.
High Fuel Pressure Solenoid Valve Circuit

Circuit Description

The circuit is a pulse width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects an open in the fuel pump actuator circuit. Causes of this fault code are a short circuit to a positive voltage or an open circuit in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 could have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit such as loose pins and bad connections. If the fault code is intermittent, look closely for loose wire connections at the ECM connector. Also, if the fault code is intermittent, wiggle the harness and the electronic fuel control.

Refer to Troubleshooting Fault Code t05-272.

Last Modified: 29-Aug-2012


Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 281

Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 PID: S126 SPN: 1347 FMI: 7 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment. A pumping imbalance between the front and rear pumping plungers has been detected. | Engine will not run or possible low power.
High Pressure Pump

Circuit Description

The fuel pump contains three barrel and plunger assemblies; each barrel and plunger assembly utilizes an inlet and outlet check valve. Fuel at gear pump pressure is metered through the fuel pump actuator and unseats one of the three inlet check valves as the fuel at gear pump pressure enters the pumping chamber. As the pumping plunger begins its upward motion, the pressure in the pumping chamber increases rapidly and the inlet check valve is closed. As pressure reaches accumulator pressure, the outlet check valve is opened. As the plunger travels upward, fuel exits past the outlet check valve and pressurizes the fuel rail.

Component Location

The fuel pump is located on the rear gear housing on the intake side of the engine. The barrel and plunger and check valve assemblies are part of the fuel pump head sub-assembly.

Shop Talk

Fault Code 281 will most likely come active while operating at a steady state loaded condition. At this condition commanded fuel pressures are highest and the pump's pressure balance is affected the most.

If a high pressure seal has failed, pump head drain flow will be excessive. If a damaged seal has progressed far enough, the engine may not start because of an inability to develop fuel rail pressure.

If the engine will not start, there are two indications that the pump head has malfunctioned:

  • The drain flow will be excessive. This can be measured while cranking the engine. Use the following procedure in Service Manual, QSB7-DM CM850, Bulletin 4310679. Refer to Procedure 006-012 in Section 6.
  • The pumping plungers are broken or mechanically stuck. Use the following procedure in Service Manual, QSB7-DM CM850, Bulletin 4310679. Refer to Procedure 005-016 in Section 5.

A faulty fuel pressure sensor signal due to a damaged fuel pressure sensor SIGNAL wire will cause the fuel pressure sensor to be inconsistent. This condition can cause Fault Code 281 to become active on an intermittent basis.

Refer to Troubleshooting Fault Code t05-281.

Last Modified: 11-Sep-2012


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The Cummins® ECM did not receive a multiplexed message from an OEM VECU or SIM within the time limit or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard-wired to a system integration module (SIM). The sensor and switch values and states can then be transmitted from the SIM to the Cummins® ECM over the SAE J1939 data link.

Messages sent from SIMs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and original equipment manufacturer (OEM) VECUs must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 in Section E.

The J1939 data link wiring location varies by OEM. The SIM is located in the vessel interface panel (VIP).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will turn off the amber light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, malfunctioning OEM VECU, or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-285.

Last Modified: 06-Sep-2012


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The engine control module (ECM) expected information from a multiplexed device, but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Multiplexing Configuration

Circuit Description

Normally switches and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard-wired to a system integration module (SIM). The sensor and switch values and states can then be transmitted from the SIM to the Cummins® ECM over the SAE J1939 data link.

Messages sent from the SIM are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 in Section E.

The J1939 data link wiring and VECU location vary by original equipment manufacturer (OEM). The SIM is located on the engine or in the vessel interface panel (VIP) in marine applications.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286.

Last Modified: 04-Oct-2012


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. The barometric air pressure sensor is reading an erratic value at initial key-on. | None.
Ambient Air Pressure Circuit

Circuit Description

The barometric pressure sensor is used by the engine control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Use the following procedure for a detailed component location view in Service Manual, QSB7-DM CM850, Bulletin 4310679. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine barometric pressure reading is compared to the other pressure sensor values at initial key-on. If the value of engine barometric pressure does not match the readings from pressure sensors within a pre-defined tolerance, this fault code is logged. To make the diagnostic run, turn the keyswitch on for 15 seconds before cranking the engine.

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading
  • High resistance in the barometric pressure sensor signal or return lines
  • Stuck in-range intake manifold pressure sensor.
Refer to Troubleshooting Fault Code t05-295.

Last Modified: 23-Aug-2012


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 1 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker lever cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • An open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-322.

Last Modified: 29-Aug-2012


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 5 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker lever cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-323.

Last Modified: 29-Aug-2012


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 3 injector or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-324.

Last Modified: 29-Aug-2012


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 6 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker lever cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring, and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harnesses or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-325.

Last Modified: 29-Aug-2012


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 2 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker lever cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring, and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-331.

Last Modified: 29-Aug-2012


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 4 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker lever cover gasket. Internal injector harnesses are located under the rocker lever cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to three injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuits whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harnesses or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harnesses - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-332.

Last Modified: 29-Aug-2012


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S254 SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The enginecontrol module (ECM) measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
Injector Circuit

Circuit Description

Between each injection event, the ECM attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive when the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage. These parameters can be monitored using INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-351.

Last Modified: 04-Oct-2012


Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 1079 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine could possibly not start.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

The sensor supply voltage number 1 on the engine control module (ECM) provides (+) 5 volt supply for the crankshaft speed sensor.

Component Location

The sensor supply number 1 is located in the ECM on pin number 16 on the 60-pin connector.

Shop Talk

Low voltage on the (+) 5 volt supply line can be caused by a short circuit to ground in a SUPPLY wire, a short circuit between a SUPPLY wire and a RETURN wire, a damaged or malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 29-Aug-2012


Sensor Supply Voltage Number 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply Voltage Number 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 1079 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine could possibly not start.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

The sensor supply voltage number 1 on the engine control module (ECM) provides (+) 5 volt supply for the engine speed.

Component Location

The sensor supply number 1 is located in the ECM on pin number 16 of the 60-pin connector.

Shop Talk

High voltage on the sensor supply line can be caused by an individual sensor SUPPLY wire in the harness shorted to battery voltage or a malfunctioning ECM power supply. Engine could possibly not start due to loss of engine speed sensor signal.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 29-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine will shutdown, if enabled.
Engine Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will close and cause Fault Code 415 to log. When the engine is not running, the oil pressure switch will be closed. The oil pressure switch will open when oil pressure is above 48 kPa [7 psi].

Component Location

The oil pressure sensor is located on the intake side of the engine on the engine block below the fuel filter. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 04-Sep-2012


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Amber (Maintenance flashout) SRT: | Water-in-Fuel Indicator Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel (WIF) sensor is attached to the Stage 1 fuel filter assembly. The engine control module (ECM) monitors the water-in-fuel sensor in order to flag a fault when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a SIGNAL wire.

Component Location

The water-in-fuel sensor is mounted at the base of the water/fuel separator bowl on the Stage 1 fuel filter housing. This fuel/water separator housing contains a serviceable element. The Stage 1 fuel filter housing location will vary with each original equipment manufacturer (OEM). Marine applications utilize a dual WIF sensor configuration. This assembly incorporates a Y-harness with either two WIF sensors (duplex filtering) or one WIF sensor and a terminating resistor.

Shop Talk

The sensor is not integrated into the fuel filter and is a serviceable item.

Possible causes for this fault code include:

  • Water-in-fuel
  • Damaged sensor
  • Fuel contamination.
Refer to Troubleshooting Fault Code t05-418.

Last Modified: 29-Aug-2012


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature 1 signal indicates engine oil temperature is above engine protection warning limit. | Engine will shut down, if enabled.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor 1 is used by the engine control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the engine oil temperature 1 SIGNAL pin and converts this to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system.

Component Location

The engine oil temperature sensor 1 is located in the oil pan adapter on the left side of the engine below the starter motor. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that engine oil temperature has exceeded the engine protection limits for high engine oil temperature. Refer to Engine Oil Temperature Above Normal troubleshooting symptom tree in the service manual, QSB7-DM Bulletin 4310679, Section TS, t107.

Refer to Troubleshooting Fault Code t05-421

Last Modified: 11-Sep-2012


Coolant Level - Data Erratic, Intermittent, or Incorrect

FAULT CODE 422

Coolant Level - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Amber SRT: | Coolant Level - Data Erratic, Intermittent, or Incorrect. Signal from the sensor is open or shorted to ground. | Engine will shutdown, if enabled.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor shares SUPPLY and RETURN wires in the engine harness with the fuel supply pressure sensor. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The coolant level sensor is located in the engine mounted expansion tank. Use the following procedure in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679. Refer to Procedure 100-002 in Section E. If there is an OEM supplied remote expansion tank, refer to the OEM service manual.

Shop Talk

Possible causes for this fault code include:

  • Open circuit
  • Short circuit to ground
  • Short circuit to another signal
  • Damaged connnector or wiring.
Refer to Troubleshooting Fault Code t05-422.

Last Modified: 04-Sep-2012


Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 425

Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 425 PID: P175 SPN: 612 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect. | Severity based torque derate and possible engine shutdown.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the oil temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil pan on the left side of the engine below the starter motor.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part of the diagnostics runs when the key is turned ON and before the engine is detected. The ECM senses the condition of the sensor and the oil temperature relative to the other temperature sensors on the engine prior to starting the engine after sitting for 10 or more hours.
  • The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber lamp after the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 10 hours. After the 10 hour cold soak, start the engine.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil temperature sensor shares RETURN wires in the engine harness with the following sensors: fuel supply pressure sensor, coolant level sensor, water-in-fuel sensor, and exhaust stack sensor. Possible causes of this fault code include:

  • Malfunctioning oil temperature sensor.
  • High resistance in the engine oil temperature signal or return circuit.
Refer to Troubleshooting Fault Code 425.

Last Modified: 12-Sep-2012


SAE J1939 Data Link - Cannot Transmit

FAULT CODE 426

SAE J1939 Data Link - Cannot Transmit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Cannot Transmit. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance. J1939 devices possibly do not operate.
SAE J1939 Data Link Circuit

Circuit Description

ECMs, electronic displays, electronic panel systems, and electronic service tools can communicate with each other over the J1939 data link. Messages sent from these devices are received by the ECM and used for controlling the engine.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the SAE J1939 data link having an intermittent electrical problem, and the ECM (or another SAE J1939 device) tying up communications because of an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426.

Last Modified: 04-Oct-2012


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: S168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine control module (ECM) supply voltage is below the minimum system voltage level. | Engine may stop running or be difficult to start.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 10-amp fuse in the unswitched battery wire to protect the original engine manufacturing (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness.This direct link provides a constant power supply for the ECM; only circuits 1 and 3 are used for unswitched battery. The location of the battery will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6 volts.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441.

Last Modified: 11-Sep-2012


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 10-amp fuse in the unswitched battery wire to protect the OEM harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM; only circuits 1 and 3 are used for unswitched battery. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual for battery location.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds 36 volts. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442

Last Modified: 11-Sep-2012


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The fuel pressure signal indicates that fuel pressure has exceeded high-pressure, the maximum limit for the given engine rating. | None or possible power interruption associated with dump valve reset.
Injector Metering Rail 1 Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The engine control module (ECM) monitors the injector metering rail 1 pressure and engine operating conditions and changes the flow command to maintain the proper injector metering rail 1 pressure. Changes to the flow-command result in opening or closing of the fuel pump pressurizing assembly.

The high-pressure relief valve is set to trip at 1950 bar [28,282 Psi]. After it trips, it then regulates at 900 to 1300 bar [13,053 to 18,854 psi].

Note: Mechanical dump valve has not popped.

Component Location

The high-pressure fuel pump is mounted to the rear gear housing, on the left side of the engine. Refer to Procedure 100-002 in Section E for a detailed componet location view.

Shop Talk

Replace the high-pressure mechanical dump valve even if the fault goes away.

Refer to Troubleshooting Fault Code t05-449.

Last Modified: 23-Oct-2012


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at rail fuel pressure sensor circuit. | Automotive: Power and/or speed derate. Marine: None.
Original Wiring Harness - Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the engine control module (ECM) to monitor the fuel pressure in the fuel rail. The rail fuel pressure sensor gets +5 VDC from the sensor supply 4 circuit from the ECM which is shared by the camshaft speed sensor, intake manifold pressure/temperature sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and the coolant pressure sensor.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel rail pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor and coolant pressure sensor.

This fault code will become active if there is an open circuit on any of the three pins (+5 volt SUPPLY, SIGNAL, and RETURN) that connect the sensor or the ECM to the wiring harness.

This fault will also be active if the SIGNAL wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the SIGNAL wire)
  • Open circuit on the SIGNAL wire
  • Open circuit on the +5-VDC SUPPLY wire
  • Open circuit on the RETURN wire
  • Damaged sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-451.

Last Modified: 11-Sep-2012


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | None.
Original Wiring Harness - Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the engine control module (ECM) to monitor the fuel pressure in the fuel rail. The rail fuel pressure sensor gets +5-VDC from the sensor supply 4 circuit from the ECM which is shared by the camshaft speed sensor, intake manifold pressure/temperature sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and the coolant pressure sensor.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel rail pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor and coolant pressure sensor.

This fault code will become inactive any time the keyswitch is ON and the SIGNAL pin voltage of the ECM is too low. This can be caused by a short circuit to ground on the +5-VDC SUPPLY or SIGNAL wire. This fault will also become active if a device that is powered by the common +5-VDC power supply is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Engine harness: the SUPPLY or SIGNAL wire is shorted to ground
  • Other components: any component connected to the common power supply is shorted to ground
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-452.

Last Modified: 11-Sep-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection warning limit. | Engine will shut down, if enabled.
Intake Manifold Air Temperature

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, shutdown will occur, if enabled.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the air from the aftercooler as it passes through the intake manifold. Possible causes of this fault code include:

  • Plugged aftercooler
  • Restricted air flow through the aftercooler
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 20-Sep-2012


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: SPN: 94 FMI: 3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action taken by the engine control module (ECM).
Rail Fuel Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes the information to the ECM through the engine harness.

Component Location

The fuel delivery pressure sensor is located on the inlet side of Stage 2 on the engine fuel filter. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel supply pressure sensor shares SUPPLY and RETURN wires in the engine harness with the coolant level sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Codee 546, check for multiple fault codes.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-546.

Last Modified: 04-Oct-2012


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: SPN: 94 FMI: 4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No action taken by the engine control module (ECM).
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes information to the ECM through the engine harness.

Component Location

The fuel delivery pressure sensor is located on the inlet side of Stage 2 on the engine fuel filter. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel supply pressure sensor shares SUPPLY and RETURN wires in the engine harness with the coolant level sensor. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 547, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-547.

Last Modified: 11-Sep-2012


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than commanded pressure. | None or possible engine noise associated with higher-injection pressures (especially at idle or light load). Peak performance is limited.
Fuel Rail Pressure Sensor

Circuit Description

The ECM monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (open the fuel pump actuator) or decrease (close the fuel pump actuator) the fuel supply to the high pressure pump.

Component Location

The fuel pressure sensor is located in the fuel rail on the air intake side of the engine. The fuel pump actuator is located on the front of the high-pressure fuel pump.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 449 may also become active.

Refer to Troubleshooting Fault Code t05-553.

Last Modified: 11-Sep-2012


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P157 SPN: 157 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected that the fuel pressure signal is not changing. | The ECM will estimate fuel pressure and peak performance may be limited.
Fuel Rail Pressure Sensor

Circuit Description

The fuel pressure sensor contains SUPPLY, SIGNAL, and RETURN pins. The ECM provides +5-VDC to the fuel pressure sensor. This +5-VDC power supply is a shared supply. Other sensors on this circuit are the intake manifold temperature/pressure sensor, backup engine position sensor (or cam speed sensor), oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Component Location

The fuel pressure sensor is located in the high-pressure fuel rail on the air intake side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can become active any time the engine is loaded and the ECM detects the fuel pressure in the high-pressure fuel rail is not changing. This fault code will become inactive whenever the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit. If the fault code occurs intermittently (can not be reproduced during a load test), then inspect each of the following for poor connections or damage:

  • Camshaft (backup engine) position sensor
  • Intake manifold pressure sensor
  • Fuel rail pressure sensor
  • Oil pressure sensor
  • Crankcase pressure sensor
  • Ambient air pressure sensor
  • Coolant pressure sensor.
Refer to Troubleshooting Fault Code t05-554.

Last Modified: 11-Sep-2012


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 16/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase filter is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located on top of the rocker lever cover in front of the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber lamp when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures.

Refer to Troubleshooting Fault Code t05-555.

Last Modified: 04-Oct-2012


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: SPN: 101 FMI: 0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level | Engine will shut down, if enabled.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used by the engine control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the crankcase pressure SIGNAL pin and converts it to a pressure value. The crankcase pressure value is used by the ECM for the engine protection system.

Component Location

The crankcase pressure sensor is located on top of the rocker lever cover in front of the crankcase ventilation filter. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankcase pressure sensor is used in the engine protection section of the calibration. When the ECM detects that the crankcase pressure is above the engine protection limit in the calibration for at least 5 seconds, it will log Fault Code 556 and light a red lamp indicating that the engine must be shut down.

Possible causes of this fault code include:

  • Dirty/obstructed breather filter
  • Damaged piston rings
  • Oil level too high
  • Damaged turbocharger seals
  • Damaged power cylinder

Confirm that the crankcase breathers and breather tubes are not obstructed. Refer to Procedure 003-001 in Section 3. Refer to Procedure 003-018 in Section 3 of the QSB7-DM Service Manual, Bulletin 4310679.

Refer to Troubleshooting Fault Code t05-556.

Last Modified: 31-Aug-2012


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P94 SPN: 94 FMI: 0/18 LAMP: Yellow SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Fuel Flow Diagram

Circuit Description

The fuel pressure control loop relies on fuel pressure from the high-pressure side of the fuel pump. The ECM monitors engine operating conditions and the pressure at the fuel rail and signals the fuel actuator on the high-pressure fuel pump to provide more or less fuel to the high-pressure side of the fuel pump.

The fuel flow circuit includes, in the following order:

  • OEM fuel tank
  • 10 micron original engine manufacturing (OEM) supplied, off-engine fuel filter
  • 7 micron Cummins® supplied, single or dual, off-engine fuel filter with water-in-filter sensor and priming pump
  • OEM fuel supply line to inlet connection on engine
  • Fuel supply tube to low-pressure gear pump
  • 3 micron on engine pressure side fuel filter
  • High-pressure fuel pump
  • High-pressure fuel line to high-pressure fuel rail
  • High-pressure pump
  • High-pressure system (including fuel rail and fuel rail pressure relief valve), injectors, and high-pressure lines
  • Low-pressure fuel drain lines from high-pressure fuel rail, back of cylinder head to fuel pump drain to OEM fuel tank.

Component Location

The high-pressure fuel pump is mounted to the rear gear housing on the intake side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The troubleshooting steps for Fault Code 559 and Fault Code 2215 are the same.

For all active and non-active Fault Code 559 troubleshooting, reference Fault Code 2215 troubleshooting tree.

Refer to Troubleshooting Fault Code t05-559.

Last Modified: 11-Oct-2012


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor.
Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed information to the engine control module (ECM). The sensor is powered by +5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The crankshaft engine speed sensor is located on the intake side of the engine in the front gear cover under the Stage 2 fuel filter. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the crankshaft engine speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the sensor target teeth or tone wheel.

INSITE™ electronic service tool monitor parameter associated with this fault code and sensor include:

  • Engine speed sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-689.

Last Modified: 03-Oct-2012


Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 731

Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment. Mechanical misalignment between the crankshaft and camshaft engine speed sensors. | Engine performance may be limited. Excessive smoke, hard start, and rough idle possible.
Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The engine speed sensor and camshaft position sensor provide an engine speed and position signal to the engine control module (ECM) through the engine harness.

Component Location

The engine speed sensor and camshaft position sensor are located in the front gear cover on the intake side of the engine under the Stage 2 fuel filter. See the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault will become active anytime the ECM receives a signal from both the primary engine position sensor (crankshaft sensor) and the backup engine position sensor (camshaft sensor), and the ECM determines that the camshaft and crankshaft signals are not in the correct phase. If this fault code is active immediately following a repair that includes camshaft removal, it is likely that the camshaft gear was installed incorrectly and is not timed correctly.

Refer to Troubleshooting Fault Code t05-731.

Last Modified: 23-Aug-2012


Engine Control Module Data Lost - Condition Exists

FAULT CODE 757

Engine Control Module Data Lost - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 757 PID: None SPN: 611 FMI: 11/31 LAMP: Amber SRT: | Engine Control Module Data Lost - Condition Exists. Severe loss of data from the ECM. | Possible no noticeable performance effects, engine stalling, or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is a single 10 ampere fuse in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post. Pins 2 and 3 are optional circuits possibly not used by the original equipment manufacturer (OEM). Refer to the OEM wiring diagram for detailed information on these circuits.

Component Location

The ECM is located on the left side of the engine, near the front of the engine. The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-757.

Last Modified: 27-Aug-2012


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine will shutdown, if enabled.
Intake Manifold Air Temperature/Pressure Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM).

Component Location

The intake manifold 1 temperature sensor is located on the air intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs. The ECM monitors the change in the intake manifold temperature sensor over a period of time and logs a fault. The engine will shut down due to excessive temperature change, if enabled.

Possible causes of this fault include:

  • Restricted air flow through the aftercooler
  • Malfunctioning valves
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-783.

Last Modified: 23-Aug-2012


Cylinder Power Imbalance Detected

FAULT CODE 951

Cylinder Power Imbalance Detected

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 951 PID: P166 SPN: 166 FMI: 2 LAMP: None SRT: | Cylinder Power Imbalance Detected. A power imbalance between cylinders was detected by the ECM. | Possible low power, rough idle, or misfire.
Cylinder Circuit

Circuit Description

An algorithm in the engine control module (ECM) calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power. A fault lamp does not illuminate while this fault code is active.

Component Location

The ECM is located on the intake side of the engine, below the stage 2 fuel filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If Fault Code 951 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire,” it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 951 should be disregarded unless other performance symptoms are present.

Causes of cylinder imbalance can include:

  • Valve lash out of adjustment (compare actual valve lash to the reset limits)
  • Cylinder damage (check for high blowby when the engine is loaded)
  • Valve damage or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket damage (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Extremely damaged HPC/injector interface (examine the high-pressure fuel connector at the injector end); this problem will also cause excessive fuel return and Fault Code 2292
  • Injector malfunction (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code t05-951.

Last Modified: 11-Sep-2012


Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect. Supply voltage to the engine control module (ECM) fell below +6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine stalling or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

This fault is set active if the ECM battery supply voltage drops below +6.2-VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

Where the fault code is inactive, familiarize yourself with the shutdown practices used by the operator. For example, if there are controls that can interrupt the ECM power supply (before the end of the 30 second power down process after key OFF), these should be considered as potential causse when the fault code is being addressed. This should be explained to the operator.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active.

This fault can also be caused by a short to ground in the injector wiring harness. Check to be sure the injector wires are oriented so that they will not interfere with a rocker lever or other components in the overhead system. Keep in mind that certain operating conditions could cause the rocker levers to operate outside their normal range of motion.

This fault code can also be caused by noise transmitted over the J1587 or J1939 data links. The transmitted noise can cause a momentary interruption in the ECM power, which causes Fault Code 1117 to log. During troubleshooting, isolate the engine from the vessel to determine if any of the data links are conducting noise to the engine.

Refer to Troubleshooting Fault Code t05-1117.

Last Modified: 06-Sep-2012


Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1139

Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S001 SPN: 651 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 1. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a malfunctioning or damaged injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will ocur in that cylinder. If this condition occurs, the engine will typically shut down and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1139.

Last Modified: 23-Aug-2012


Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1141

Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S002 SPN: 652 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 2. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a malfunctioning or damaged injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically shut down and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1141.

Last Modified: 23-Aug-2012


Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1142

Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S003 SPN: 653 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 3. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a malfunctioning or damaged injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically shut down and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1142.

Last Modified: 23-Aug-2012


Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1143

Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S004 SPN: 654 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 4. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a malfunctioning or damaged injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically shut down and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1143.

Last Modified: 23-Aug-2012


Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1144

Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S005 SPN: 655 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 5. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a malfunctioning or damaged injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1144.

Last Modified: 24-Aug-2012


Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1145

Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S006 SPN: 656 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 6. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The engine control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by a malfunctioning or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a malfunctioning or damaged injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1145.

Last Modified: 23-Aug-2012


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1376

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1376 PID: SPN: 723 FMI: 2 LAMP: Maintenance SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine camshaft speed/position signal. | Possible poor starting.
Engine Camshaft Speed/Position Sensor

Circuit Description

The engine camshaft speed/position sensor provides engine position information to the engine control module (ECM). The engine camshaft speed/position sensor is powered by +5 VDC from the sensor supply 4 circuit.

Component Location

The engine camshaft speed/position sensor is located on the intake side of the engine, in the front gear cover, under the Stage 2 fuel filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code is recorded when the ECM does not receive a signal or receives a degraded signal from the engine camshaft speed/position sensor.

The fault code will go inactive when the normal backup camshaft speed/position sensor signal is detected.

The camshaft speed sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the camshaft speed/position sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the engine camshaft speed/position sensor target teeth or camshaft gear.

INSITE™ electronic service tool monitor parameters associated with this fault code and sensor include:

  • Camshaft speed/position sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

If this fault code occurs intermittently, Fault Code 2322 will also be active or have high inactive counts.

Refer to Troubleshooting Fault Code t05-1376.

Last Modified: 20-Sep-2012


Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: SPN: 4182 FMI: 3 LAMP: Amber SRT: | Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The frequency adjust potentiometer will go to the default value.
Frequency Adjust Potentiometer Circuit

Circuit Description

The frequency adjust potentiometer is used to regulate the frequency. The operator can adjust the breakpoint frequency for the 100 percent 0.8 power factor load acceptance. This is the frequency at which the voltage starts to drop. The engine control module (ECM) monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will trip Fault Code 1411 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

Refer to the original equipment manufacturer (OEM) service manual.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1411.

Last Modified: 04-Oct-2012


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: SPN: 4183 FMI: 3 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The droop adjust potentiometer will go to the default value.
Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located in the customer interface box (CIB). Refer to the original equipment manufacturer (OEM) service manual.

Shop Talk

The droop adjust potentiometer shares SUPPLY and RETURN wires in the engine harness with the frequency adjust potentiameter and speed load bias.

Possible causes of the fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted or sensor supply or battery voltage
  • +5-VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code t05-1412.

Last Modified: 20-Sep-2012


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: SPN: 629 FMI: 12 LAMP: Maintenance SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine will possibly not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel system side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-1597.

Last Modified: 20-Sep-2012


Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure sensor circuit. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the engine control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage is too high, Fault Code 1843 will become active and the amber lamp will illuminate.

Component Location

The crankcase pressure sensor is located on top of the rocker lever cover, in front of the ventilation filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1843, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 20-Sep-2012


Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the engine control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage is too low, Fault Code 1844 will become active and the amber light will illuminate.

Component Location

The crankcase pressure sensor is located on top of the rocker lever cover, in front of the ventilation filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1844, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 20-Sep-2012


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel indicator circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel indicator sensor is attached to the stage1 fuel filter. The water-in-fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel indicator sensor circuit contains two wires: a water-in-fuel indicator RETURN (sensor return 3) ground wire and a water-in-fuel indicator SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the stage 1 fuel filter. The stage1 fuel filter is located off-engine.

Shop Talk

The water-in-fuel sensor is located in the stage 1 filter housing. It is a serviceable part.

The water-in-fuel sensor shares RETURN wires in the engine harness with the following sensors: fuel supply pressure sensor, coolant level sensor, exhaust stack sensor, and oil temperature sensor.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor.
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1845.

Last Modified: 04-Oct-2012


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel indicator circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel indicator sensor is attached to the stage 1 fuel filter. The water-in-fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel indicator sensor circuit contains two wires: a water-in-fuel indicator RETURN (sensor return 3) ground wire and a water-in-fuel indicator SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the stage 1 fuel filter. The stage 1 fuel filter is located off-engine.

Shop Talk

The water-in-fuel sensor is located in the stage 1 filter housing. It is a serviceable part.

The water-in-fuel sensor shares RETURN wires in the engine harness with the following sensors: fuel supply pressure sensor, coolant level sensor, exhaust stack sensor, and oil temperature sensor.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-1846.

Last Modified: 04-Oct-2012


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: SPN: 110 FMI: 14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature 1 signal indicates engine coolant temperature is above engine protection warning limit. | Engine will shutdown, if enabled.
Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature 1 value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located in the front of the cylinder head, next to the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Refer to Troubleshooting Fault Code t05-1847.

Last Modified: 20-Sep-2012


Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water-In-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel indicator sensor is attached to the stage1 fuel filter. The water-in-fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires; a ground wire and SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the stage 1 fuel filter. The stage 1 fuel filter is located off-engine.

Shop Talk

The water-in-fuel indicator sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

If this fault code is active and there is no water in the fuel filter, a malfunctioning water-in-fuel sensor is a likely cause.

Refer to Troubleshooting Fault Code t05-1852.

Last Modified: 20-Sep-2012


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Fuel pressure signal indicates that fuel pressure has exceeded the maximum limit for the given engine rating. | None, or possible engine noise associated with higher injection pressure (especially at idle or light load). Peak performance may be limited.
Fuel System

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump.

Shop Talk

Fault Code 1911 is activated when the sensed fuel rail pressure reaches the opening pressure of the fuel rail pressure relief valve. The sensed pressure has exceeded the system target range.

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System issues that result in a loss of pressure control can cause the rail pressure to exceed the normal operating pressures and open the pressure relief valve. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically, causing a momentary loss of power (less than 1 second).

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following: suction fuel lines, original equipment manufacturer (OEM) fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load are followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559), a tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. An electric fuel control actuator with excessive leakage will result in high fuel rail pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting for the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code 1911.

Last Modified: 20-Sep-2012


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 16/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a +5-VDC reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the +5-VDC reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located on top of the rocker lever cover, in front of the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure reading has been 407 mm H20 [16.0 in H20] or higher for 2 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber lamp when the fault code has been detected.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch and start the engine. Use INSITE™ electronic service tool “Data Monitor/Logger” feature to monitor "Crankcase Pressure" with the engine running. If the crankcase pressure reading is below 407 mm H20 [16.0 in H20], the repair has been validated.
  • The "Reset All Faults" command in INSITE™ electronic service tool can then be used to clear active and inactive faults.
  • The ECM will turn off the amber lamp after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather element may need to be replaced.

Refer to Troubleshooting Fault Code t05-1974.

Last Modified: 27-Sep-2012


Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3 LAMP: Amber SRT: | Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source | Engine will not synchronize with the grid if connected.
Speed/Load Governing Bias Circuit

Circuit Description

The speed/load governing bias circuit controls the engine speed, in order to match a required grid frequency and phase.

Component Location

The speed/load bias control can be located inthe customer interface box (CIB). Refer to the original equipment manufacturer (OEM) service manual for the speed/load governing bias control location.

Shop Talk

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1978.

Last Modified: 20-Sep-2012


Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4 LAMP: Amber SRT: | Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize.
Speed/Load Governing Bias Circuit

Circuit Description

The speed/load governing bias circuit controls the engine speed, in order to match a required grid frequency and phase.

Component Location

The speed/load bias control can be located in the customer interface box (CIB). Refer to the original equipment manufacturer (OEM) service manual for the speed/load governing bias control location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or engine harness
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1979.

Last Modified: 20-Sep-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine crankshaft speed/position signal indicates engine speed above engine protection limit. | Engine shutdown.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the engine control module (ECM) through the engine harness.

Component Location

The engine crankshaft speed/position sensor and the camshaft speed/position sensor are located on the intake side of the engine, in the front gear cover, under the Stage 2 fuel filter. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-1992.

Last Modified: 04-Oct-2012


Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at +5 volt sensor supply circuit 4. | Engine may run rough, poor performance, or shutdown.
Sensor Supply 4 Circuit

Circuit Description

The engine control module (ECM) supplies +5 VDC to the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Component Location

The sensors are located:

• Camshaft speed sensor located on the front gear cover

• Intake pressure/temperature sensor located on the intake manifold air connector

• Fuel rail pressure sensor located on the back of the high pressure fuel rail

• Oil pressure sensor located under the intake manifold

• Crankcase pressure sensor located on top of the rocker lever cover

• Ambient air pressure sensor located on top of the ECM

• Coolant pressure sensor located under the exhaust manifold.

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault is logged when the ECM senses more than +5.25 volts on the +5 VDC sensor supply voltage 4 circuit. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than +5 volts.

Refer to Troubleshooting Fault Code t05-2185.

Last Modified: 20-Sep-2012


Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at +5 VDC sensor supply circuit 4. | Significant loss of performance and possible engine shutdown.
Sensor Supply 4 Circuit

Circuit Description

The engine control module (ECM) supplies +5 VDC to the following sensors: camshaft speed sensor, intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Component Location

The sensors are located:

• Camshaft speed sensor located in the front gear cover

• Intake pressure/temperature sensor located in the intake manifold air connector

• Fuel rail pressure sensor located in the back of the high pressure fuel rail

• Oil pressure sensor located under the intake manifold

• Crankcase pressure sensor located on top of the rocker lever cover

• Ambient air pressure sensor located on top of the ECM

• Coolant pressure sensor located under the exhaust manifold.

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and return circuit, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-2186.

Last Modified: 20-Sep-2012


Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P94 SPN: 94 FMI: 0/18 LAMP: Yellow SRT: | Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Fuel Flow Diagram

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order:

  • OEM fuel tank
  • 10 micron original equipment manufacturer (OEM) supplied, off-engine fuel filter
  • 7 micron Cummins® supplied, single or dual, off-engine fuel filter with water-in-filter sensor and priming pump
  • OEM fuel supply line to inlet connection on-engine
  • Fuel supply tube to low pressure gear pump
  • 3 micron on-engine pressure side fuel filter
  • High-pressure fuel pump
  • High-pressure fuel line to high pressure fuel rail
  • High-pressure system (including fuel rail and fuel rail pressure relief valve), injectors, and high-pressure lines
  • Low-pressure fuel drain lines from high-pressure fuel rail, back of cylinder head to fuel pump drain to OEM fuel tank.

Component Location

The high-pressure fuel pump is mounted to the rear gear housing, on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

If the engine will not start and Fault Code 2215 becomes active during cranking, but no speed sensor fault codes exist, monitor the fuel rail pressure with INSITE™ electronic service tool. If the rail pressure is low, check the following:

  • Fuel system prime (make sure there is fuel in the tanks and the system is primed)
  • Fuel lift pump pressure. Refer to Procedure 006-020 in Section 6.
  • Fuel gear pump pressure. Refer to Procedure 006-020 in Section 6.

If the gear pump pressure is OK, test for system leakage:

  • Injector leakage. Refer to Procedure 006-026 in Section 6.
  • Fuel rail pressure relief valve.

If Fault Code 2215 is inactive and there are no existing performance complaints, it is possible the engine was run out of fuel or the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 2215 sets when the engine is running and measured rail fuel rail pressure remains at least 10 Mpa [1450 psi] less than commanded pressure. Once detected, Fault Code 2215 will remain active until the engine is turned off or until the measured fuel rail pressure matches the commanded fuel rail pressure. When a condition exists that causes Fault Code 2215 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 2215 occurs, the fuel system has lost its ability to maintain fuel rail pressure. Causes of this fault include:

  • Excessive fuel inlet restriction
  • Fuel filter plugging
  • Air in the fuel system
  • Fuel gear pump output low
  • Fuel gear pump pressure regulator sticking or leaking
  • High-pressure pump capacity decay (high leakage to drain from the high-pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 10 Mpa [1450 psi] lower than actual pressure.

Intermittent ECM power supply connections can cause Fault Code 2215. If the engine is running with an active Fault Code 2215 and Fault Codes 449 or 2311 are not present, check the ECM power supply for intermittent connections. Fault Code 1117 can also be active if this fault condition exists.

Inactive Fault Code:

Troubleshooting inactive Fault Code 2215 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 2215, operate the engine in a diagnostic load test to duplicate the fault code. The most common causes of intermittent Fault Code 2215 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, and intermittent fuel supply restrictions, such as debris floating in the fuel tank. Check the high pressure connector (HPC) and connector torque and torque to specification if necessary. Operate the engine in a diagnostic load test to duplicate the fault code.

Refer to Troubleshooting Fault Code t05-2215

Last Modified: 27-Sep-2012


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2249

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2249 PID: P157 SPN: 157 FMI: 1 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Rail Fuel Pressure

Circuit Description

The engine control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 2249 is very similar to Fault Code 559, except that the fault triggers at a different fuel pressure threshold limit. If Fault Code 2249 is active, the troubleshooting procedures for Fault Code 559 must be followed.

Refer to Troubleshooting Fault Code t05-2249.

Last Modified: 20-Sep-2012


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: SPN: 94 FMI: 15 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The fuel pump supply pressure is high. | Low power or engine smoke.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction
  • Pinched or damaged fuel supply line
Refer to Troubleshooting Fault Code t05-2261.

Last Modified: 23-Aug-2012


Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: SPN: 94 FMI: 17 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level. | Engine hard to start or will not start. Possible low power.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • High stage 1 fuel filter restriction
  • High fuel inlet restriction
  • Low fuel flow from gerotor
  • Air in the fuel.
Refer to Troubleshooting Fault Code t05-2262.

Last Modified: 23-Aug-2012


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The 24-VDC circuit is a pulse width modulated driver in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is located on the Stage 1 suction side fuel filter. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code becomes active if the ECM detects an open circuit at keyswitch ON. The cause of this fault code is an open circuit in the electric fuel lift pump circuit.

If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. At keyswitch ON, the lift pump duty cycle ramps to 100 percent. This fault code can detect open circuit conditions only at keyswitch ON. If an open circuit condition is indicated after the engine is started (while the lift pump is already running), Fault Code 2265 will not become active.

Refer to Troubleshooting Fault Code t05-2265

Last Modified: 23-Aug-2012


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The 24-VDC circuit is a pulse width modulated driver in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is located on the Stage 1 suction side fuel filter. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

This fault code becomes active when the ECM detects a short circuit to ground or high current in the electric lift pump circuit. Causes for this fault code are short circuit to ground or low resistance.

During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can also become active if the lift pump rotor stalls or seizes. When the fault conditions are detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is enabled at keyswitch ON, and if the cause is no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-2266

Last Modified: 23-Aug-2012


Fuel Inlet Meter Device - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2292

Fuel Inlet Meter Device - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2292 PID: SPN: FMI: 16 LAMP: Amber SRT: | Fuel Inlet Meter Device - Data Valid But Above Normal Operating Range - Moderately Severe Level. The flow demand is higher than expected. | Possibly hard to start; low power; possible engine smoke.
Fuel System

Circuit Description

The fuel pressure control loop relies on fuel pressure supplied to the high-pressure pump by the electric lift pump and low-pressure pump. The engine control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the electric fuel control actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order of fuel flow:

  • Fuel tank
  • Stage 0 OEM 10 micron supplied fuel filter
  • Stage 1 Cummins® supplied 7 micron fuel filter, with water-in-fuel sensor and priming pump
  • OEM fuel supply line
  • Stage 2 on-engine 3 micron fuel filter
  • Fuel filter
  • Gear pump
  • Electronic fuel control actuator
  • High-pressure fuel pump
  • Fuel rail (includes rail pressure relief valve and pressure sensor)
  • High-pressure fuel lines
  • High-pressure fuel connectors (HPCs)
  • Injectors
  • Return to tank.

Component Location

The electronic fuel control actuator is located on the fuel pump. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Causes of this fault code include the following: High inlet restriction, plugged fuel filter, low lift pump pressure, low resistance to the electronic fuel control actuator, stuck or restricted electronic fuel control actuator, system return (excessive return flow from the injectors, high-pressure pump, or rail pressure relief valve), or tampering.

Fault Code 2292 sets when the ECM commands the electronic fuel control actuator to open more than expected to maintain rail pressure. Fault Code 2215 sets when the ECM opens the electronic fuel control actuator to fully open and rail pressure is still lower than commanded.

Once the repair has been made, this fault code will require approximately 15 to 20 minutes of engine running under load to be set inactive.

Refer to Troubleshooting Fault Code t05-2292

Last Modified: 11-Sep-2012


Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2293

Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2293 PID: SPN: FMI: 18 LAMP: Amber SRT: | Fuel inlet meter device flow demand lower than expected - data valid but below normal operating range - moderately severe level. The flow demand is lower than expected. | None or possible engine noise associated with higher injection pressures especially under light load. Engine power is lower than expected.
Fuel System

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electronic fuel control actuator) or decrease (CLOSE the electronic fuel control actuator) the fuel supply to the high-pressure pump.

Component Location

The electronic fuel control actuator is installed on the high-pressure fuel pump. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Fault Code 2293 is activated when the electronic fuel control actuator is closed more than expected to lower rail fuel pressure.

An electric fuel control actuator with excessive leakage can possibly result in high rail fuel pressures at idle or light load. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the high-pressure fuel pump. This excess drain fuel can enter the pumping chamber and pressurize the rail. Check the fuel drain line restriction. High resistance or an open circuit in the electric fuel control actuator can cause this fault to log. Air in the fuel can result in pressure changes that would cause this fault to log. High lift pump delivery pressure could cause this fault to log, as could tampering with the rail fuel pressure sensor.

Once the repair has been made, this fault code will require approximately 15 to 20 minutes of running the engine under load to be set inactive.

Refer to Troubleshooting Fault Code t05-2293

Last Modified: 23-Oct-2012


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Fuel pump actuator circuit resistance too high or too low. | Possible low power.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulation driver in the engine control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The electronic fuel control actuator valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads.

Component Location

The fuel pump actuator valve is located on the engine-mounted fuel pump housing. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault is set when the fuel pump actuator circuit has intermittent circuit problems.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber light immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

The ECM will turn OFF the amber light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit failures that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical problem exists, it is possible for the fault code to become active and then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the valve will open for a fraction of a second while the circuit is faulty, causing the pressure relief valve to open. After this has occurred, the ECM will attempt to reset the pressure relief valve, provided the fuel pump actuator circuit has not failed.

Refer to Troubleshooting Fault Code t05-2311

Last Modified: 23-Aug-2012


Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2 LAMP: None SRT: | Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | Engine can exhibit misfire as control switches from the primary to the backup speed sensor.
Engine Speed/Position Sensor Number 1 Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed information to the engine control module (ECM). The sensor is powered by +5-VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine speed/position sensor is located on the intake side of the engine, in the front gear cover, under the Stage 2 fuel filter. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than three continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than three seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If, over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

An intermittent “misfire” may occur when the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. There may be intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active when the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive with the keyswitch in the ON postion or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Failures that can cause this fault:

  • Intermittent loss of primary speed sensor signal. The most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321.

Last Modified: 25-Sep-2012


Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2 LAMP: None SRT: | Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | Possible low power.
Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The camshaft position sensor provides information to the engine control module (ECM). The sensor is powered by (+) 5-VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft. The camshaft speed sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Component Location

The crankshaft speed/position sensor and the camshaft speed sensor are located on the intake side of the engine, in the front gear cover, under the Stage 2 fuel filter. Refer to Procedure 100-002 in Section E.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active if the signal from the secondary speed sensor is not present or degraded for more than three continuous seconds. If over a period of time, the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON, or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

The camshaft speed sensor shares SUPPLY and RETURN wires in the engine harness with the following sensors: intake pressure/temperature sensor, fuel rail pressure sensor, oil pressure sensor, crankcase pressure sensor, ambient air pressure sensor, and coolant pressure sensor.

Causes for this fault code:

  • Intermittent loss of primary speed sensor signal. The most likely cause is an intermittent open or short circuit, as can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector, where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Look for target wheel damage.
Refer to Troubleshooting Fault Code t05-2322.

Last Modified: 11-Sep-2012


Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2557

Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: SPN: 697 FMI: 3 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the pulse width modulated (PWM) OEM device. | Can not control PWM actuated OEM device.
Auxiliary PWM Driver Circuit

Circuit Description

A PWM OEM device uses this signal from the engine control module (ECM).

Component Location

Refer to the OEM diagram for the location of the PWM OEM device.

Shop Talk

This fault can be caused by the following:

  • A damaged PWM OEM device
  • An open circuit in the output device driver RETURN wire
  • A short pin-to-pin in the output device driver wire.
Refer to Troubleshooting Fault Code t05-2557

Last Modified: 27-Aug-2012


Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2558

Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: SPN: 697 FMI: 4 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the pulse wideth modulated OEM device. | Can not control pulse width modulated (PWM) OEM device.
Auxiliary PWM Driver Circuit

Circuit Description

The Auxiliary PWM driver circuit is used to drive the Dedicated PWM Output feature in marine applications. This feature provides a PWM output signal proportional to the percent power of the engine. This signal can be used by the original equipment manufacturer (OEM) and interfaced to vessel integration systems.

Component Location

Refer to the OEM troubleshooting and repair manual for the location of the PWM OEM device.

Shop Talk

When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can be caused by the following:

  • A damaged PWM OEM device
  • An short circuit to ground on the output device driver wire
  • A short pin-to-pin in the output device driver wire.
Refer to Troubleshooting Fault Code t05-2558

Last Modified: 25-Sep-2012


Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2737

Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2737 PID: SPN: 173 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Exhaust gas temperature sensor 1 signal indicates exhaust gas temperature above engine protection critical limit. | None.
Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The exhaust stack temperature sensor 1 is used by the engine control module (ECM) to monitor the exhaust stack temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The exhaust stack temperature value is used by the ECM for the engine protection system.

Component Location

The exhaust stack temperature sensor is located in the exhaust elbow, after the turbocharger. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

This fault code indicates that the exhaust temperature has exceeded the engine protection limits for high exhaust temperature.

Refer to Troubleshooting Fault Code 2737.

Last Modified: 11-Sep-2012


Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an intake manifold pressure signal that is too high or too low for present engine operating conditions. | None. No engine protection for circuit or sensor failure.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the ECM through the engine harness.

Component Location

The intake manifold pressure sensor is located in the intake air connector on the intake manifold. Refer to Procedure 100-002 in Section Efor a detailed component view.

Shop Talk

The intake manifold pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high or too low for the present engine operating conditions. The ECM compares the intake manifold pressure reading to turbocharger speed (estimated by the ECM in some engines) to determine if the pressure reading is valid.

Possible causes of this fault are:

  • Malfunctioning intake manifold pressure sensor
  • Malfunctioning barometric pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold.
  • Restriction in the aftercooler.
Refer to Troubleshooting Fault Code t05-2973.

Last Modified: 26-Sep-2012


Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3695

Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3695 PID: SPN: 4182 FMI: 4 LAMP: Amber SRT: | Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source. | The frequency adjust potentiometer will go to the default value.
Frequency Adjust Potentiometer Circuit

Circuit Description

The frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the frequency. An external parallel/load share controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

The frequency adjust potentiometer can be located in the customer interface box (CIB). Refer to the OEM service manual.

Shop Talk

If Fault Code 3695 goes active, the frequency adjust potentiometer will not respond.

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3695.

Last Modified: 06-Sep-2012


Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3696

Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3696 PID: SPN: 4183 FMI: 4 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source. | The droop adjust potentiometer will go to the default value.
Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer can be located in the Customer Interface Box (CIB). Refer to the OEM service manual.

Shop Talk

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3696.

Last Modified: 04-Oct-2012


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module (ECM) - Critical Internal Failure

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Is Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Are there less than 3 counts?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 115 - Engine Magnetic Crankshaft Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Determine if Fault Code 115 becomes active during cranking. | Fault Code 115 becomes active during cranking?
 | STEP 1B. Inspect the engine harness. | Harness connectors connected to correct sensors?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Determine if Fault Code 115 becomes active during cranking.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine by engaging the starter for at least 10 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 becomes active during cranking?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness connectors for correct connections.

  • Make sure that the main engine speed sensor (crankshaft position sensor) and the backup engine speed sensor (camshaft position sensor) are connected to the engine wiring harness correctly.

Harness connectors connected to correct sensors?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 115 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Aug-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the engine control module and engine harness |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to erase the inactive fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 135 - Oil Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2185 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Proccedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Proccedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Proccedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 141 - Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the oil pressure +5 VOLT SUPPY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Reference the Lubricating Oil Pressure Below or Above Normal troubleshooting symptom tree in Section TS in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 29-Aug-2012


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms and 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 to 160k ohms?
YES NO
No Repair

A damaged sensor has been detected.

Replace the engine coolant temperature sensor.

  • Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4B

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit resistance. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?

YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor.

  • Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?

YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 29-Aug-2012


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 04-Oct-2012


FAULT CODE 153 - Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the intake manifold air temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the intake manifold air temperature sensor.

  • Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit dirgram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 154 - Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?

YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Refer to Procedure 019-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?

YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for Fault Code 155. | Active or inactive counts of Fault Code 155?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for Fault Code 155.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 155.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 155?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree.

Repair complete

Last Modified: 04-Oct-2012


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 -female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596- male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the circuits connected to the sensor supply number 2 and return. |
 | STEP 2A. Inspect the droop circuit connected to the sensor supply number 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 187 inactive?
 | STEP 4B. Cleat the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the circuits connected to the sensor supply number 2 and return.

Guided Step 2A - Inspect the droop circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the droop circuit from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the droop adjustment circuit from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the droop adjustment harness.

  • See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location of all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Nov-2015


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 239 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 19 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 239

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 239 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the engine control module (ECM) and orignal equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 239

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between theOEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected inseries to determine which contains the openreturn circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Repair complete.

Repair complete.

Last Modified: 26-Sep-2012


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Reference the appropriate circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Reference the appropriate circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Reference the appropriate circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the appropriate circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Sep-2012


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Sep-2012


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 214?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Oct-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the barometric pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM engine connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM circuit response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2186.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Sep-2012


FAULT CODE 228 - Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 228.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Sep-2012


FAULT CODE 231 - Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Pressure Sensor | Refer to Procedure 019-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 231 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 231 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness 60-pin connector.

Action

Check the coolant pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the coolant pressure sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

A damaged coolant pressure sensor has been detected.

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the coolant pressure SIGNAL line of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open coolant pressure RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 231 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2012


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Pressure Sensor | Refer to Procedure 019-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 232 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 231 active and Fault Code 232 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 232 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 232 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2186.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the coolant pressure sensor harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

A damaged coolant pressure sensor has been detected.

  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted coolant pressure supply (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associate Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 232 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an altenate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the original equipment manufacturer (OEM) harness and vehicle speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Active fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

Check if the operator reported a fuel-controlled event where the engine rapidly accelerated to 2070 (60 Hz) or 1725 (50 Hz).

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 731.

Go to 1C

Fault Codes 689 and 731

Guided Step 1C - Inspect the OEM harness and vehicle speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234.

Active fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a sea trail to check if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Using INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Cooling System | Refer to Procedure 008-018 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the original equipment manufacturer (OEM) service manual before replacing the coolant level sensor.

No Repair

Go to the appropriate troubleshooting steps.

Repair complete.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822758 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit |
 | STEP 2C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both ECM engine harness connectors from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM engine harness connector and the 50 pin ECM connector from the ECM.
  • Disconnect the fuel supply pressure sensor and coolant level sensor from the ECM engine harness connector.
  • Disconnect the speed bias adjustment potentiometer from the 50 pin ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 3 pin in ECM engine harness connector and all other pins in the ECM engine harness connector.
  • Measure the resistance between the sensor SUPPLY 3 pin in 50 pin ECM connector and all other pins in the 50-Pin ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY 3 circuit wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM engine harness connector and the 50 pin ECM connector from the ECM.
  • Disconnect the fuel supply pressure sensor and coolant level sensor from the ECM engine harness connector.
  • Disconnect the speed bias adjustment potentiometer from the 50 pin ECM connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY voltage 3 pin in the ECM engine harness connector and ground.
  • Measure the resistance between the sensor SUPPLY voltage 3 pin in the 50-pin ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor SUPPLY 3 wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Nov-2015


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM wiring harness.

  • Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 3 wire.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 248 - Exhaust Stack Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust stack temperature sensor 1 accuracy. |
 | STEP 1A. Verify the exhaust stack temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the exhaust stack temperature sensor 1 reading in INSITE™ electronic service tool
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 248 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust stack temperature sensor 1 accuracy.

Guided Step 1A - Verify the exhaust stack temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust stack temperature sensor 1 accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the exhaust stack temperature sensor 1.

The probe must extend into the exhaust flow and must not touch the exhaust manifold, except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the exhaust stack temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer yes to this step.

Does the thermocouple agree with the exhaust stack temperature sensor 1 reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged exhaust stack temperature sensor 1 has been detected.

Replace the exhaust stack temperature sensor 1. Refer to Procedure 019-013 in the Associated Procedures Table.

Reference the Exhaust Stack Temperature Above Normal troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 248 is inactive.

Fault Code 248 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 271 - High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

NOTE: Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool , to read the fault code.

Fault Code 271 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 272 - High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel pump actuator. | Between 0.1 and 5 ohms?
 | STEP 2C. Check the fuel pump actuator diagnostic signal voltage and return circuit. | Greater than 3.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel pump actuator return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel pump actuator diagnostic signal voltage. | Greater than 3.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Actuator continuity - pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedures for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage and return circuit.

  • Measure the voltage between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the engine harness actuator connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel pump actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness fuel pump actuator RETURN pin and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin-to-ground circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel pump actuator diagnostic signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage from the fuel pump actuator SIGNAL pin to the fuel pump actuator RETURN pin at the ECM connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the engine harness continuity for a pin-to-pin short circuit:

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 272 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 08-Aug-2012


FAULT CODE 281 - Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Air in Fuel | Refer to Procedure 006-003 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 281 has occurred at least one time during engine operation?
STEP 2. | Check for air in fuel. |
 | STEP 2A. Check for air in fuel. | Air in fuel?
STEP 3. | Check the fuel pressure sensor connector. |
 | STEP 3A. Inspect the fuel pressure sensor connector and wiring connections. | Dirty or damaged pins?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 281 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear all inactive fault codes.
  • Operate the engine at the steady state loaded condition.

Action

Check for fault codes.

  • Use INSITE™ the electronic service tool to read the fault codes.

Fault Code 281 has occurred at least one time during engine operation?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check for air in fuel.

Guided Step 2A - Check for air in fuel.

Conditions

  • Install a Compuchek® fitting at the outlet of the pressure side fuel filter.
  • Start the engine and allow it to idle.
  • Connect a test hose at the fuel filter head and run it into a bucket.

Action

Check for air in fuel as the engine idles.

Perform the air in fuel test. Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

The suction side fuel lines, suction filter, or tank pick-up is allowing air to enter fuel supply.

Repair or replace the fuel lines, suction filter, or tank pick-up.

 No Repair

Go to 1A

Go to 3A

Guided Step 3 - Check the fuel pressure sensor connector.

Guided Step 3A - Inspect the fuel pressure sensor connector and wiring connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pressure sensor connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

NOTE: A bad connection on the fuel pressure sensor or intermittent wiring connections can cause the signal reading to fluctuate and cause this fault code to become active on an intermittent basis.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Operate the engine at a steady-state loaded condition.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 281 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-Oct-2012


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication with INSITE™ electronic service tool.

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the data link harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to circuit diagram or wiring diagram for component pin inspection.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using the INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 286 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use the INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-Oct-2012


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Pressure at Altitude | Refer to Procedure 018-028 | Marine Auxiliary QSB7-DM CM850 | 4310679
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 221 or 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
 | STEP 3D. Check the harness resistance. | Harness resistance less than 3 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 221 and 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the resistance of the engine harness signal and return wires.

  • Measure the resistance between the barometric pressure sensor SIGNAL pin at the barometric pressure sensor engine harness connector and the barometric pressure sensor SIGNAL pin at the ECM engine harness connector.
  • Measure the resistance between the barometric pressure sensor RETURN pin at the barometric pressure sensor engine harness connector and the barometric pressure sensor RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram of the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Harness resistance less than 3 ohms?
YES NO

An in-range malfunction of the barometric pressure sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

High resistance has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Barometric Air Pressure to the local barometric pressure. Use the following procedure for barometric pressure values at altitude. Refer to Procedure 018-028 in the Associated Procedures Table.

INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 08-Aug-2012


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 10 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins? | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for active fault codes. | Same mutliple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 1 cylinder with the injector from number 4 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air inake connection if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between thecylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 1 cylinder is damaged. Replace injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the injector harness passthroughconnector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 325, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 2 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins? | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for active fault codes. | Same mutliple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 325, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 5 cylinder with the injector from number 2 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air inake connection if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between thecylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 5 cylinder is damaged. Replace injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the injector harness passthroughconnector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 2 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins? | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for active fault codes. | Same multiple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 3 cylinder with the injector from number 6 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air inake connection if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between thecylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 3 cylinder is damaged. Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between thecylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin andengine block ground.
  • Measure the resistance between thecylinder number 3 DRIVER pin andengine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair or replace the injector harness passthroughconnector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 325, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 2 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 4B. Check for active fault codes. | Same multiple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 325, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 6 cylinder with the injector from number 3 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air inake connection if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replacethe engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 6 cylinder is damaged. Replace the injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins, or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal ifit is damaged or missing.

Repair or replace the injector harness passthroughconnector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 2 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for active fault codes. | Same multiple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 2 cylinder with the injector from number 5 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air inake connection if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between thecylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 2 cylinder is damaged. Replace the damaged injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin andengine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 1 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 2 DRIVER and cylinder number 3 DRIVER pins.
  • Measure the resistance from the cylinder number 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 2 RETURN and cylinder number 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the injector harness pass-through connector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit | Less than 2 ohms?
 | STEP 2C. Inspect the injector harness pass-through connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 2 ohms?
 | STEP 2E. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit. | Less than 2 ohms?
 | STEP 2G. Read the fault codes. | Same multiple injector (same bank) fault codes active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3B-1. Inspect the injector harness and pass-through connector pins. |
 | STEP 3B-2. Check the injector solenoids for short circuits to ground. |
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits. |
 | STEP 3C-2. Check the engine harness for short circuits. |
STEP 4. | Verify the ECM damage. |
 | STEP 4A. Inspect the injector harnesses and pass-through connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for active fault codes. | Same multiple (same bank) injector fault codes active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 5A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Identify if this is an injector or ECM fault.

Replace the injector from number 4 cylinder with the injector from number 1 cylinder.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2G

Go to 2C

Guided Step 2C - Inspect the injector harness pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the air intake connection, if required.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the injector harness pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the injector harness at the pass-through connector.

Action

Check for continuity in the injector and injector harness

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin at the injector pass-through connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2E

Guided Step 2E - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector
  • Remove the rocker lever. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

5A

Go to 2F

Guided Step 2F - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector harness at the pass-through connector.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for continuity.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 2G - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple injector (same bank) fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The original injector from number 4 cylinder is damaged. Replace the damaged injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors corresponding to the cylinders that are on the front bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Inspect the injector harness and pass-through.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the injector harness and injector harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected inthe engine harness connector.

Repair the damaged pins. Repair or replace the injector harness, or replace the injector harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B-2

Guided Step 3B-2 - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the injector harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the front and middle injector pass-through connectors from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C-2 - Check the engine harness for short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the front, middle, and rear injector pass-through connectors from the engine harness.

Action

Check for a short circuit to pin-to-pin.

  • Measure the resistance from the cylinder number 4 DRIVER pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the cylinder number 5 DRIVER and cylinder number 6 DRIVER pins.
  • Measure the resistance from the cylinder number 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the cylinder number 5 RETURN and cylinder number 6 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Verify the ECM damage.

Guided Step 4A - Inspect the injector harnesses and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal injector harnesses and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: If the injector harness insulation is damaged, it is possible for the injector fault to become active during engine operation while the short to ground can possibly not be measured when the engine is not running. Close inspection of the injector harness is recommended.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the injector harness pass-through connector. Replace the injector harness if the wire insulation is damaged.

  • Refer to Procedure 019-206 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Aug-2012


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 322, 323, 324, 325, 331, and 332 active during engine operation?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, and 332 active during engine operation?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.

Action

Inspect the ECM power supply and fuses connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Clean the connector and pins. Repair or replace the damaged harness, pins, fuses, or connectors.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.
  • Disconnect the ECM power supply harness from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: The INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Code 322, 323, 324, 325, 331, and 332 do not occur?

YES NO

Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure that the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Aug-2012


FAULT CODE 352 - Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the engine crankshaft speed/position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the original equipment manufacturer (OEM) pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the OEM harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the OEM harness for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit in the OEM harness ECM battery (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase speed position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase speed/position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine crankcase speed/position sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the OEM pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the OEM harness. Refer to the OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

There is a short in the engine harness pulling the sensor supply voltage down.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-071 in Section 19.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the OEM harness. Refer to the OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.

Action

Check the OEM harness for a short circuit to ground.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the OEM harness.

A damaged connection has been detected in the engine harness.

  • Repair the damaged pins. Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the OEM harness for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.

Action

Check the OEM harness for a short circuit pin-to-pin.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit in the OEM harness ECM battery (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness battery supply connector from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.

Action

Measure the resistance between the OEM +5 volt SUPPLY pin in the OEM harness ECM connector and the ECM battery (-) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Aug-2012


FAULT CODE 386 - Sensor Supply Voltage Number 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the original equipment manufacturer (OEM) +5-VDC supply. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the OEM harness for a short circuit pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check the OEM harness for a short circuit to ECM battery (+). | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

There is a short in the engine harness causing the sensor +5-VDC SUPPLY wire to have too high a voltage.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM +5 VDC supply.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM harness for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.

Action

Check the OEM harness for a short circuit pin-to-pin.

  • Measure the resistance between the OEM +5-VDC SUPPLY pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the OEM harness for a short circuit to ECM battery (+).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness battery supply connector from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM harness, if equipped.

Action

Check for a short circuit to ECM battery (+) in the OEM harness.

  • Measure the resistance between the OEM +5-VDC SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the ECM power connector on the engine harness battery supply.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822758 - male Deutsch™/Amp™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch/™Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Check the engine harness and engine control module (ECM). |
 | STEP 3A. Check the supply voltage at the oil pressure connector. | 4.75 to 5.25-VDC?
 | STEP 3B. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch OFF.
  • Connect mechanical oil pressure gauge.
  • Turn keyswitch ON.
  • Operate engine at idle speed.

Action

Check the engine oil pressure.

  • Refer to OEM service manual.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Guided Step 3 - Check the engine harness and ECM.

Guided Step 3A - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Replace the oil pressure switch. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the engine harness ECM connector port and engine block ground.

Refer to the circuit diagram or wiring diagram form connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 03-Oct-2012


FAULT CODE 418 - Water-in-Fuel Indicator Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 418 active?
 | STEP 1B. Check for water-in-fuel/water separator bowl. | Fault Code 418 still active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Within range of 210k - 230k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 418 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 418 inactive?
 | STEP 3C. Check for an inactive fault code. | Fault Code 418 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 418 inactive?
 | STEP 4B. Fault Code 418 inactive. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for water-in-fuel/water separator bowl.

Conditions

  • Turn keyswitch OFF.

Action

Check for water-in-fuel/water separator bowl.

  • Drain the water from the fuel filter housing.

Fault Code 418 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel (WIF) sensor from the WIF sensor harness. (Check both in dual WIF configuration.)

Action

Check the sensor resistance.

  • Measure the resistance between the WIF SIGNAL pin and the WIF RETURN pin at the WIF sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 210k to 230k ohms?
YES NO

Any corrosion, damage, or buildup on the probe tips is a sign of contaminated fuel. If there is fuel contamination present, use the following service bulletin Fuels for Cummins® Engines for information on treating this condition. Refer to Bulletin 3379001. The primary and secondary fuel filters as well as all other WIF sensors on board must be replaced as well.

  • Replace the WIF sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the WIF sensor and WIF harness to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 3A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 418 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 10-Aug-2012


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 421.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES NO

Reference the Engine Oil Temperature Above Normal troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 03-Oct-2012


FAULT CODE 422 - Coolant Level - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 422 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Verify the coolant level. | Coolant level normal?
STEP 3. | Check the coolant level sensor and harness. |
 | STEP 3A. Inspect the engine harness and coolant level sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 422 active?
STEP 4. | Check the ECM and harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 422 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 5. | Verify the coolant level. |
 | STEP 5A. Verify the coolant level with INSITE™ electronic service tool. | INSITE™ electronic service tool reading of coolant level correct?
 | STEP 5B. Check the sensor supply voltage. | 4.5 to 5.5-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6B

Guided Step 2 - Check the coolant level.

Guided Step 2A - Verify the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap or top tank reservoir and inspect the coolant level.

Coolant level normal?
YES NO
No Repair

Add coolant to the system. Reference the Cummins® Coolant Requirements and Maintenance, Bulletin 3666132.

Go to 2B

Go to 6A

Guided Step 3 - Check the coolant level sensor and harness.

Guided Step 3A - Inspect the engine harness and coolant level sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the engine harness.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 6B

Guided Step 4 - Check the ECM and harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Coolant Level Sensor.
  • Disconnect the engine harness connector 1 and 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to the SIGNAL pins in the OEM harness sensor connector.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to the coolant level RETURN pin in the OEM harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the engine harness connector 2.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the coolant level RETURN pins in the engine harness ECM connector 2 to all other pins in the engine harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Verify the coolant level.

Guided Step 5A - Verify the coolant level with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Install the shorting plug into the coolant level sensor connector.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to verify the coolant level.

  • Verify the Engine Coolant Level Sensor high reading is ”Normal” with INSITE™ electronic service tool.

Is INSITE™ electronic service tool reading of the coolant level correct?
YES NO
No Repair

Replace the sensor. Refer to the OEM service manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the coolant level SUPPLY pin in the sensor connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.5-VDC?
YES NO

  • Repair or replace the coolant level sensor. Refer to the OEM service manual.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 422 is inactive.

Fault Code 422 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Sep-2012


FAULT CODE 425 - Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 212 and 213. | Fault Code 212 or 213 active?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check circuit response. | Fault Code 212 active?
 | STEP 2C. Check circuit response. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check circuit response. | Fault Code 212 active?
 | STEP 3C. Check circuit response. | Fault Code 213 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 212 and 213.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 or 213 active?
YES | NO
No Repair | No Repair

Fault Code 212 or 213 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and oil temperature sensor connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and the oil temperature RETURN pin at the oil temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Replace the oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil temperature SIGNAL pin and oil temperature RETURN pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Repair complete

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2012


FAULT CODE 426 - SAE J1939 Data Link - Cannot Transmit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 communication. |
 | STEP 1A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Attempt to communicate with the ECM. Use INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM. Use an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?

YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the original engine manufacturer (OEM) troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

No Repair

Refer to the OEM troubleshooting and repair manual for information on troubleshooting and vehicle SAE J1939 network

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins, if possible.

Reference the Resistance Measurements Using a Multimeter and a Wiring Diagram. Refer to Procedure 019-360 in Section 19.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect the INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM troubleshooting and repair manual

Refer to the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the original engine manufacturer (OEM) power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Clean the terminals and tighten the loose connections.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 24-VDC.

Cranking conditions:

  • At least 12-VDC (24-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-amp fuse is installed correctly.

  • Inspect the 10-amp fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-amp fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and electronic control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. . Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. . Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 inactive?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than 32 VDC?
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the original engine manufacturer (OEM) power harness connector from the engine control module (ECM).

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second engine control module (ECM) battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than 32 VDC?
YES NO
No Repair

Install the battery system correctly. Refer to the equipment manufacturer's troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amps).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Sep-2012


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Lines | Refer to Procedure 006-024 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

Fuel is flammable. Keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271, 272, 2311, 2261, 451, or 452 active, or are there many inactive counts of fault codes 271, 272, 2311,2261, 451, or 452?
STEP 2. | Clear the operation of the low pressure fuel system. |
 | STEP 2A. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2B. Check the first stage fuel filter inlet pressure. | Fuel pressure greater than 0.35 bar [5psi]?
STEP 3. | Check the operation of the fuel pump pressurizing assembly 1. |
 | STEP 3A. Inspect the fuel pump pressurizing assembly 1 o-ring. | O-ring cut or shaved?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault codes inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 271, 272, 2311, 2261, 451, or 452 active, or are there many inactive counts of fault codes 271, 272, 2311, 2261, 451, or 452?

YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the operation of the low-pressure fuel system.

Guided Step 2A - Check for air in the fuel.

Conditions

  • Remove the air bleed line from the fuel drain manifold.
  • Plug the port in fuel drain manifold.
  • Operate engine at idle.

Action

Measure the fuel flow.

Air present in the fuel flow line??
YES NO

Repair or replace the damaged line or loose connection.

Refer to Procedure 006-024 in the Associated Procedures Table.

Replace the mechanical dump valve.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the first stage fuel filter inlet pressure.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure gauge into fuel filter head port at inlet.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

If the engine will not start, perform this test while cranking the engine.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Refer to the original engine manufacturer (OEM) service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the operation of the fuel pump pressurizing assembly 1.

Guided Step 3A - Inspect the fuel pump pressurizing assembly 1 o-ring.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump pressurizing assembly 1.

  • Remove the fuel pump pressurizing assembly 1.
  • Refer to Procedure 005-016 in the Associated Procedures Table.
  • Inspect the fuel pump actuator o-ring.
  • If the o-ring is cut or shaved; fuel can be bypassing the fuel pump pressurizing assembly 1 and entering the high-pressure pump.

O-ring cut or shaved?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault codes inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2012


FAULT CODE 451 - Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 is active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor.

  • Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure +5 VOLT SUPPLY pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 451 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Oct-2012


FAULT CODE 452 - Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 452 in
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic serive tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor.

  • Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VOLT SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

An open return circuit or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Oct-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 488. | Active or inactive counts of Fault Code 488?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 488.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 488?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 04-Oct-2012


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 239 active in same source address as Fault Code 546?
 | STEP 1B. Check for an inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 547 active and Fault code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active in same source address as Fault Code 546?
YES | NO
No Repair | No Repair

Fault Code 239

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active and Fault code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 3, pin 33) to the fuel delivery pressure RETURN (sensor return 3, pin 38) pin at the sensor connector of the engine harness.

Use a wiring diagram for connector pin identificaton and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active?
YES NO

A damaged sensor has been detected.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active and Fault code 546 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor SUPPLY 3, pin 33) pin to the fuel delivery pressure RETURN (sensor RETURN 3, pin 38) pin at the ECM engine connector.

Use a wiring diagram for connector pin identificaton and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 inactive?
YES NO

  • None. The removal and installation of the connector corrected the fault.

An open fuel delivery pressure RETURN(sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Return to the appropriate troubleshooting steps

Last Modified: 03-Oct-2012


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 238 active in same source address as Fault Code 547?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Resistance between 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault code 546 active and fault code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the fuel delivery pressure 5 VOLT SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2). |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active in same source address as Fault Code 547?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 238.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel delivery pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 VOLT SUPPLY (sensor supply 3, pin 33 to the fuel delivery pressure RETURN (sensor return 3, pin-38 at the sensor connector of the engine harness.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the fuel delivery pressure 5 VOLT SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the fuel delivery sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify fuel delivery pressure sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged sensor has been detected.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 VOLT SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor supply 2) pin at the ECM 60-pin connector port of the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

An open or shorted fuel delivery pressure 5 VOLT SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected inseries to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the connector.

  • Refer to Procedure 019-209 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 VOLT SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active and Fault Code 547 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or short signal circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to
Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Oct-2012


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Drain Line Restriction | Refer to Procedure 006-012 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel pump actuator fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271, 272, 2185, 2186, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Monitor rail pressure with INSITE™ electronic service tool. | Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Check drain line restriction |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check the low pressure fuel system. |
 | STEP 4A. Check for excessive supply pump fuel pressure. | Is pressure greater than 1207 kPa [175 psi]?
 | STEP 4B. Check the fuel pump actuator. | Is the inboard o-ring cut or shaved?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 553 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fuel pump actuator fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 2185, 2186, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Run INSITE™ electronic service tool monitor
  • Engine not running.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the low pressure fuel system.

Guided Step 4A - Check for excessive supply pump fuel pressure.

Conditions

  • Engine running.

Action

Install an M10 standard thread o-ring diagnostic fitting, Part Number 3824842, at the pressure-side fuel filter outlet port.

Install a 0 to 2068 kPa [0 to 300 psi] pressure gauge at the outlet of the pressure side filter.

  • Operate the engine at idle and measure the pressure at the gear pump outlet.

Refer to Procedure 005-045 in the Associated Procedures Table.

Is pressure greater than 1207 kPa [175 psi]?
YES NO

Replace the fuel gear pump assembly.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pump actuator.

Remove the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

  • Inspect the fuel pump actuator inboard o-ring. If this o-ring is cut or shaved, fuel may be permitted to bypass the fuel pump actuator and enter the high-pressure pump.

Is the inboard o-ring cut or shaved?
YES NO

Replace the damaged o-ring.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2185 and 2186. | Fault Code 2185 or 2186 is active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2185 active?
 | STEP 2C. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 2185 active?
 | STEP 3C. Check the circuit response. | Fault Code 2186 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 554 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 451 and 452.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure signal pin and the rail fuel pressure return pin at the rail fuel pressure connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure SIGNAL pin and rail fuel pressure RETURN pin at the ECM engine connector.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 554 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Oct-2012


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 555?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Is the pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Check mileage / hours on the crankcase breather filter since last maintenance. | Is the filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Are the oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Is the crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 555?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine not running.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to to monitor "Crankcase Pressure".

Is the pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage / hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate maintenance record (miles / hours) of the latest crankcase breather filter replacement.

Action

Check mileage / hours on the crankcase breather filter since last maintenance.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine application.

Is the filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather filter. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Are the oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the Crankcase Blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Keyswitch ON.
  • Engine running.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Is the crankcase blowby measurement within specification?
YES NO

Refer to Procedure 019-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • Reference the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Oct-2012


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify the crankcase pressure sensor. | Does the crankcase pressure sensor agree with the mechanical gauge?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code? | Fault Code 556 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the crankcase pressure sensor.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the SAE J1939 data link connector on the engine harness.
  • Start engine.

Action

Verify the crankcase pressure sensor accuracy with a gauge.

  • NOTE: Operate the engine at rated rpm and full load (wide open throttle) until a steady reading is obtained.

Does the crankcase pressure sensor agree with the mechanical gauge?
YES NO

Replace the crankcase pressure sensor.

 No Repair

Go to 2A

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code 556 is inactive.

Is Fault Code 556 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 03-Oct-2012


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 559 active or has high inactive counts?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 is active or has high inactive counts?
YES | NO
No Repair | No Repair

Go to Fault Code 2215 troubleshooting tree.

Repair complete

Last Modified: 11-Oct-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Speed Sensor | Refer to Procedure 019-042 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the crankshaft engine speed sensor and circuit. |
 | STEP 2A. Inspect the crankshaft engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Crankshaft engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the crankshaft engine speed sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate crankshaft engine speed sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor crankshaft engine speed sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • While engine idles, monitor the fault code status.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankshaft engine speed sensor and circuit.

Guided Step 2A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage at the sensor connector.

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the sensor connector of the engine harness.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Crankshaft engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed SIGNAL pin at the sensor connector of the engine harness. Check for the appropriate ECM response.

  • Use the INSITE™ electronic service tool monitor mode to read the crankshaft engine speed sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Crankshaft engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the crankshaft engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft engine speed sensor from the engine. Refer to Procedure 019-042 in the Associated Procedures Table.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or speed teeth.

Damaged sensor tip?
YES NO

Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft engine speed sensor from the engine. Refer to Procedure 019-042 in the Associated Procedures Table.
  • Make sure the crankshaft engine speed sensor is connected to the harness.
  • Connect INSITE™ electronic service tool.

Action

Use the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor. Inspect for the following:

Check for the appropriate response.

  • Read the crankshaft engine speed sensor state using INSITE™ electronic service tool monitor mode.

Crankshaft engine speed sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate crankshaft engine speed sensor air gap.

Conditions

  • Turn keyswitch ON.
  • Install the crankshaft engine speed sensor to the engine. Use the following procedure. Refer to Procedure 019-042 in the Associated Procedures Table.
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the crankshaft engine speed sensor state of the crankshaft engine speed sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Crankshaft engine speed sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the crankshaft tone wheel for damage or spinning.

Refer to the appropriate base engine troubleshooting and repair manual for the repair or replacement.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Monitor crankshaft engine speed sensor state equals low?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor crankshaft engine speed sensor state equals high?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the ECM engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Oct-2012


FAULT CODE 731 - Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Camshaft | Refer to Procedure 001-008 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankshaft | Refer to Procedure 001-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | Marine Auxiliary QSB7-DM CM850 | 4310679
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | Are all grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check static timing. | Camshaft and crankshaft timing marks properly aligned at top dead center?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Is fault code 731 the only active fault?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the engine and position sensors for damage.

Any damage?
YES NO

Replace the camshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Replace the engine speed sensor (ESS). Refer to Procedure 019-042 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the crankshaft and camshaft tone wheels for damage.

Any damage?
YES NO

Replace the tone wheel.

  • Replace the camshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Replace the engine speed sensor (ESS). Refer to Procedure 019-042 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.
  • Replace the crankshaft. Replace the camshaft. Refer to Procedure 001-016 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Check for correct engine static timing.

Guided Step 4A - Check static timing.

Conditions

  • Remove the gear cover.
  • Rotate the engine to top dead center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Check the timing.

Inspect the engine static timing.

Are the camshaft and crankshaft timing marks properly aligned at TDC?
YES NO
No Repair

Remove and install camshaft to properly align timing marks at TDC.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Note: Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 757 - Engine Control Module Data Lost - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Are other fault codes active?
STEP 2. | Check the batteries and the power harness connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 24-VDC? (During cranking: At least (+) 12-VDC)?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the original equipment manufacturer (OEM) fuses. |
 | STEP 3A. Verify that the OEM fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Verify that the OEM fuses are not blown. | Are any fuses blown?
STEP 4. | Check the power connector. |
 | STEP 4A. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 5. | Calibrate the ECM. |
 | STEP 5A. Calibrate the ECM. | Fault Code 757 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 757 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Are other fault codes active?
YES NO

Troubleshoot the active fault codes.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pin of the power harness ECM connector and the positive (+) battery terminal.
  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (-) pin of the power harness ECM connector and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques, Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 24-VDC? (During cranking: At least (+) 12-VDC)?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.

Are connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM fuses.

Guided Step 3A - Verify that the OEM fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuses are installed correctly.

Inspect the OEM fuses for correct installation.

Are fuses installed correctly?
YES NO
No Repair

Install the fuses correctly.

Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Verify that the OEM fuses are not blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuses are not blown.

Inspect for blown fuses.

Are any fuses blown?
YES NO

Replace the fuses.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the power connector.

Guided Step 4A - Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Are any wires damaged?
YES NO

Repair or replace the damaged wiring.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Calibrate the ECM.

Guided Step 5A - Calibrate the ECM.

Conditions

  • Connect all components.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM.

Is Fault Code 757 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 30 seconds.
  • Turn keyswitch ON.

Fault Code 757 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Aug-2012


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ service tool monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer YES to this step.

Thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Reference the Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree in Section TS of the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 951 - Cylinder Power Imbalance Detected

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fuel system fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system component fault codes active or have accumulated inactive counts?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test and/or the automated cylinder balance diagnostic test. | All cylinders test okay?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 951 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fuel system fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system component fault codes active or have accumulated inactive counts?
YES NO

Troubleshoot full system component fault codes.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test and/or the automated cylinder balance diagnostic test.

Conditions

  • Turn keyswitch ON.
  • Allow the engine to run at idle speed.
  • Connect INSITE™ electronic service tool.

Action

Perform the cylinder cutout test and/or the automated cylinder balance diagnostic test.

Use the automated cylinder balance diagnostic test to determine the power contribution of each cylinder.

All cylinders test okay?
YES NO
No Repair

Failure of cylinder test can be due to faulty engine brakes, valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or injector malfunction.

Investigate, diagnose, and correct the condition of the applicable component that is possibly out of adjustment or malfunctioning. “Swap” injectors between cylinders to see whether or not the problem follows that injector.

Go to 3A

Reference the appropriate sections in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that the fault code is inactive.

Fault Code 951 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Aug-2012


FAULT CODE 1117 - Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the batteries and the power connector. |
 | STEP 1A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
STEP 2. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the battery power circuit. | At least + 10-VDC [+ 20-VDC for a 24 volt system]?
 | STEP 2B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 2B-2. Check if the OEM fuse is blown. |
 | STEP 2B-3. Check the add-on or accessory wiring at the positive (+) terminal of the battery. |
 | STEP 2C. Check the resistance of the battery supply circuit. | Less than 1.0 ohm?
 | STEP 2D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 2E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Check the engine harness and the ECM connector pins. | Dirty or damaged pins?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the batteries and the power connector.

Guided Step 1A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative (-) battery terminal while trying to start the engine.

Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM power harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

At least + 10-VDC [+ 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

–

Is fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 2B-3

Guided Step 2B-3 - Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 2C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.
  • Disconnect the positive (+) terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive (+) battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative (-) battery connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohm?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input-to-ECM wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, such as solenoids or relays.

Keyswitch input wire interrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to the keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Check the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ to verify Fault Code 1117 is inactive.

NOTE: For Fault Code 1117 to become inactive, the ECM must go through one complete shutdown.

Fault Code 1117 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1139 - Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1139. | Active or high inactive counts of Fault Code 1139 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knock goes away and Fault Code 1139 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1139 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1139.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1139 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector number 1.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Start the engine and idle for 1 minute.

Engine knock goes away and Fault Code 1139 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector.

  • Refer to Procedure 006-026 Associated Procedures Table.

 No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 Associated Procedures Table.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1139 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1141 - Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1141. | Active or high inactive counts of Fault Code 1141 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knock goes away and Fault Code 1141 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1141 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1141 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector number 2.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Engine knock goes away and Fault Code 1141 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A-1

See Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1142 - Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1142. | Active or high inactive counts of Fault Code 1142 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knock goes away and Fault Code 1142 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1142.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1142 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector number 3.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Engine knock goes away and Fault Code 1142 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1142 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1143 - Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1143. | Active or high inactive counts of Fault Code 1143 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock go away and Fault Code 1143 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1143 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Using the fuel system leak tester blocking tool, Part Number 3164325, block the fuel flow going to injector number 4.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Does the engine knock go away and Fault Code 1143 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1143 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1144 - Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1144. | Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knocks, and excessive exhaust smoke goes away and Fault Code 1144 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1144 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1144.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 5.

  • Refer to Procedure 006-026 in the Associated Procedures Table.
  • Start the engine and idle for 1 minute.

Engine knock and excessive exhaust smoke goes away and Fault Code 1144 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use the INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1145 - Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1145. | Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knocks, excessive exhaust smoke goes away, and Fault Code 1145 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1145 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector number 6.

  • Refer to Procedure 006-026 in the Associated Procedures Table.
  • Start the engine and idle for one minute.

Engine knocks, excessive exhaust smoke go away, and Fault Code 1145 is inactive?
YES NO

A stuck open injector nozzle has been detected.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


Fault Code 1376 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Camshaft Gear (Camshaft Installed) | Refer to Procedure 001-012 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1376 active?
STEP 2. | Check the engine camshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine camshaft speed/ position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine camshaft speed/position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine camshaft speed/position sensor air gap. |
 | STEP 2D. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the engine control module response. | Monitor Engine Speed Backup Sensor State equals low?
 | STEP 2E-1. Check the engine control module response. |
STEP 3. | Check the engine control module. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine control module sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Check the camshaft gear. |
 | STEP 4A. Inspect the sensor air gap. | Air gap within specifications?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1376 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 1376 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine camshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine camshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine camshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the voltage at the engine camshaft speed/position sensor connector.

  • Measure the voltage between the engine camshaft speed/position +5 VOLT SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN (sensor return 2) pin at the engine camshaft speed/position sensor connector of the engine harness.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Engine camshaft speed/position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Place a jumper wire between the engine camshaft speed/position +5 VOLT SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the engine camshaft speed/position sensor connector of the engine harness.
  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Engine camshaft speed/position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine camshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor from the engine. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine camshaft speed/position sensor.

  • Damaged sensor tip
  • Physical signs of the camshaft speed/position sensor touching the speed teeth.

Damaged sensor tip?
YES NO

Replace the engine camshaft speed/position sensor.

  • Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor from the engine. Refer to Procedure 019-363 in the Associated Procedures Table.
  • Make sure the engine camshaft speed/position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine camshaft speed/position sensor.

  • Use the ratchet drive side of the socket tool that was used to remove the engine camshaft speed/position sensor from the engine, placing it flush on the engine camshaft speed/position sensor so that the edge of the socket is on the edge of the engine camshaft speed/position sensor. Slowly slide the socket in a perpendicular direction to the line marked on the engine camshaft speed/position sensor or in a perpendicular direction to the mounting bracket of the engine camshaft speed/position sensor.
  • Check for the appropriate engine control module response.
  • Use INSITE™ electronic service tool Monitor Mode to read the Engine Speed Backup Sensor State.

Engine Speed Backup Sensor State transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Replace the engine camshaft speed/position sensor.

  • Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Install the engine camshaft speed/position sensor to the engine and connect it to the harness. Refer to Procedure 019-363 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Momentarily engage the starter, but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the camshaft position sensor state of the engine camshaft speed/position sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine Speed Backup Sensor State transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the camshaft gear teeth for damage or spinning.

  • Refer to Procedure 001-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60-pin connector.

Action

Inspect the engine harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state.

Monitor Engine Speed Backup Sensor State equals low?
YES NO
No Repair

Replace the engine control module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Place a jumper wire between the engine camshaft speed/position 5 VOLT SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the engine control module port.
  • Use INSITE™ electronic service tool to read the engine camshaft speed/position sensor state using the monitor mode.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor Engine Speed Backup Sensor State equals high?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the damaged section.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the engine control module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60-pin connector.

Action

Inspect the engine control module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the engine control module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine control module sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine control module 60-pin connector.
  • Turn keyswitch ON.

Action

Check the engine control module sensor supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position 5 VOLT SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN (sensor return 2) pin at the engine control module engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the engine control module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check camshaft gear.

Guided Step 4A - Inspect the sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap and target wheel.

  • Remove the engine camshaft speed/position sensor from the gear housing and measure the air gap at several points in the crankshaft's revolution.
  • Use the Measure section of the following procedure. Refer to Procedure 019-363 in Section 19.

Air gap within specifications?
YES NO

Replace or shim the engine camshaft speed/position sensor if the air gap is out of specification.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1376 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 04-Oct-2012


FAULT CODE 1411 - Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the frequency adjust potentiometer. |
 | STEP 1A. Inspect the frequency adjust potentiometer assembly for damage to pins. | No damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the frequency adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | No damaged pins?
 | STEP . |
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP . |
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP . |
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the frequency adjust potentiometer.

Guided Step 1A - Inspect the frequency adjust potentiometer assembly for damage to pins.

Conditions

  • Place the Run/Stop switch in the STOP position.

Action

Inspect the frequency adjust potentiometer assembly for damage to pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Replace the frequency adjust potentiometer. Refer to the original equipment manufacturer (OEM) service manual.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the interface harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Place the Run/Stop switch in the STOP position.
  • Disconnect the frequency adjust potentiometer connector from the harness connector.

Action

Check the frequency adjust potentiometer resistance.

  • Measure the resistance between the frequency adjust potentiometer pins using a multimeter.

Less than 5k ohms?
YES NO
No Repair

Replace the frequency adjust potentiometer. Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the frequency adjust potentiometer.

Conditions

  • Place the Run/Stop switch in the STOP position.
  • Disconnect the frequency adjust potentiometer connector from the harness connector.
  • Adjust the frequency adjust potentiometer throughout its entire range.

Action

Check the resistance range of the frequency adjust potentiometer.

  • Measure the resistance between the frequency adjust potentiometer pins using a multimeter.

Resistance varies?
YES NO
No Repair

Replace the frequency adjust potentiometer. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 2 - Check the interface harness.

Guided Step 2A - Inspect the interface harness and the ECM connector pins.

Conditions

  • Place the Run/Stop switch in the STOP position.
  • Disconnect the interface harness from the ECM.

Action

Inspect the interface harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Repair the interface harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the generator interface harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 2) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 2) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the generator interface harness.

Repair the generator interface harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the Run/Stop switch in the STOP position.
  • Disconnect the interface harness from the ECM.
  • Disconnect the bulb from the interface harness.

Action

Check for an open circuit.

  • Measure the resistance between the frequency adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 VOLT SUPPLY (sensor supply 2) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair or replace the generator interface harness.

  • Repair the interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the interface harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short circuit on the optional gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 VOLT SUPPLY (sensor supply 2) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE electronic service tool to verify that the fault code is inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM port and 60-pin connectors.
  • Disconnect the OEM harness connectors from the engine harness connectors.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 2) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 2) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional gain adjust potentiometer return (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the optional gain adjust potentiometer 5 VOLT SUPPLY (sensor supply 2) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunction in the generator drive harness or potentiometer has occurred. Refer to the OEM service manual.

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 VOLT SUPPLY (sensor supply 2) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 1597 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597 | Less than three counts?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to check fault code status.

Fault Code 1597 active?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Are there less than three counts?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1843 - Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1843 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2185

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged crankcase pressure sensor.

Check all harnesses connected in series.

Repair the engine harness..

  • Refer to Procedure 019-043 in the Associated Procedures Table

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 VOLT SUPPLY (sensor supply 4, pin 37) pin to the crankcase pressure RETURN (sensor return 4, pin 47) pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 VOLT SUPPLY (sensor supply 4 pin-37) pin to the crankcase pressure RETURN (sensor return supply 4) pin-47 at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open crankcase pressure RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 1843 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1844 - Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1844 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2186

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of engine harness or damaged crankcase pressure sensor.

Check harnesses connected in series.

Repair the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 VOLT SUPPLY (sensor supply 4) 37-pin to the crankcase pressure RETURN (sensor return 4) 47-pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the crankcase pressure 5 VOLT SUPPLY (sensor supply 4) 34 pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 VOLT SUPPLY (sensor supply 4) 37-pin to the crankcase pressure RETURN (sensor return 4) 47-pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted crankcase pressure 5 VOLT SUPPLY (sensor supply 4) circuit has been detected in the engine harness.

Repair or replace the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the crankcase pressure 5 VOLT SUPPLY (sensor supply 4) 37-pin and the crankcase pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open circuit or a pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot each section of harness to determine which contains the open or pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


Fault Code 1845 - Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1845 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the water-in-fuel sensor resistance. | Greater than 200k ohms?
 | STEP 2C. Check the fault codes and verify water-in-fuel sensor condition. | Fault Code 1845 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1845 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1845 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the engine harness and the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor connector from the engine harness connector.

Action

Inspect the engine harness and water-in-fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the water-in-fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water-in-fuel indicator sensor.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin number 14 and the water-in-fuel indicator RETURN (sensor return 3) 38-pin at the water-in-fuel sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO

Replace the water-in-fuel indicator sensor.

  • Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1846 active and Fault Code 1845 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector water-in-fuel indicator sensor RETURN (sensor return 3) 38-pin and the engine harness water-in-fuel indicator sensor connector RETURN (sensor return 3) 38-pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel indicator SIGNAL pin and the water-in-fuel indicator SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. The cause of the failure should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1845 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


Fault Code 1846 - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1846 active?
STEP 2. | Check the water-in-fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 200k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 200k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1846 inactive?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1846 inactive ?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and water-in-fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the water-in-fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water-in-fuel indicator sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-127 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify water-in-fuel indicator sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES NO

A damaged water-in-fuel indicator sensor has been detected.

Replace the water-in-fuel indicator sensor.

  • Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the water-in-fuel indicator sensor.

Action

Inspect the engine harness, water-in-fuel indicator sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the water-in-fuel indicator SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnection.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. The cause of the malfunction should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1846 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 1847?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1847.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the Marine Auxiliary QSB7-DM CM850 Service Manual, Bulletin 4310679.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Sep-2012


FAULT CODE 1852 - Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1852. | Active or inactive counts of Fault Code 1852?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1852 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1852.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain the water from the fuel filter.

 No Repair

Repair complete

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1852 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Sep-2012


FAULT CODE 1911 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air in Fuel | Refer to Procedure 006-003 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Drain Line Restriction | Refer to Procedure 006-012 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Inlet Restriction | Refer to Procedure 006-020 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 449, 2311, or 2185 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify the rail fuel pressure sensor reads in-range. | Pressure 0 ± 40 bar [0 ± 580 psi]?
 | STEP 2B. Inspect the fuel pressure sensor SIGNAL wire and connector pins. | Dirty or damaged pins?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check the fuel inlet restriction. | Fuel inlet restriction within the specifications outlined in Procedure 006-020?
 | STEP 3B. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015?
 | STEP 3C. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015?
STEP 4. | Check drain line restriction. |
 | STEP 4A. Check the drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 5C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
 | STEP 5D. Monitor the fuel rail pressure at idle. | Measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5E. Inspect the fuel pump actuator for damage. | O-rings on the fuel pump actuator damaged?
STEP 6. | Check the engine harness. |
 | STEP 6A. Inspect the engine harness engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 6C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 6D. Check for an intermittent engine harness failure. | Fault Codes 2311, 271, and/or 272 become active?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault codes inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 271, 272, 449, 2311, or 2185 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify the rail fuel pressure sensor reads in-range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor reads in-range.

Pressure 0 ± 40 bar [0 ± 580 psi]?
YES NO
No Repair

The fuel pressure sensor is incorrectly reading a fuel pressure.

Replace the rail fuel pressure sensor.

  • Refer to the following Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 7A

Guided Step 2B - Inspect the fuel pressure sensor SIGNAL wire and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ECM from engine harness.

Action

Inspect the fuel pressure sensor SIGNAL wire and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: A bad connection on the fuel pressure sensor SIGNAL wire can cause the signal reading to fluctuate and cause this fault code to become active on an intermittent basis.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins.

  • Refer to the following Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction-side fuel filters plugged
  • Fuel heater valves are restricted
  • Original equipment manufacturer (OEM) fuel lines pinched or restricted
  • Fuel tank stand pipes restricted

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic, paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction-side fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the fuel filter pressure drop.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel pressure drop across the filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Fuel pressure drop within the specifications outlined in Procedure 006-015?
YES NO
No Repair

Make sure the filter pump pressure into the filter is within specification.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

If the pump meets specifications, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

The source of air entry should be isolated to one for the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s)

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 0 ohms and less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5C

Go to 7A

Guided Step 5C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator for a short to ground.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Greater than 100 ohms?
YES NO
No Repair

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5D

Go to 7A

Guided Step 5D - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Operate the engine at idle for at least 1 minute to purge air induced from the previous steps.

  • Use INSITE™ electronic service tool to monitor commanded fuel rail pressure and measured fuel rail pressure.

Measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5E

Guided Step 5E - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Action

Inspect the fuel pump actuator o-rings for damage.

O-rings on the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator o-rings.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the engine harness.

Guided Step 6A - Inspect the engine harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6C

Go to 7A

Guided Step 6C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness for a short to ground.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6D

Go to 7A

Guided Step 6D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If the short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 1974 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 1974?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Check mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2B. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, valves, breather tube, or oil separator plugged?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1974 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Check mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate maintenance record (miles/hours) of latest crankcase breather filter replacement.

Action

Check mileage/hours on the crankcase breather filter since last maintenance.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine applications.

Filter below maintenance interval?
YES NO
No Repair

Replace the crankcase breather element.

Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.

Replace the crankcase breather element.

Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Oct-2012


FAULT CODE 1978 - Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 2185 active?
STEP 2. | Check the speed/load governing bias circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1978 active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 2185.

Go to 2A

Guided Step 2 - Check the speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 is active?
YES NO

A malfunction on the generator set side has been detected.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin OEM port and 60-pin connectors.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector speed/load bias RETURN (sensor return 3) 32-pin and the OEM harness connector speed/load bias RETURN (sensor return 3) 32-pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open speed/load bias RETURN (sensor return 3) 32-pin circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete.

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 1979 - Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 2186 active?
STEP 2. | Check the speed/load governing bias circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Sensor supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2186.

Go to 2A

Guided Step 2 - Check the speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 47-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the speed/load bias 5 VOLT SIGNAL (sensor supply 3) 47-pin and the speed/load bias RETURN (sensor return 3) 47-pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the speed/load bias 5 VOLT SUPPLY (sensor supply 3) pin and the speed/load bias SIGNAL pin at the OEM 47-pin connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES NO

A malfunction on the generator set side has been detected.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector and 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 47-pin connector speed/load governing bias SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open speed/load governing bias signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-360 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the speed/load governing bias SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to the following Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engien control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed/position sensor reading with INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to the following Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not operating above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not operating above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine.

  • Check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 2185 - Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. | Greater then 100K ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

Measure the resistance between the accelerator pedal +5 VOLT SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the accelerator pedal +5 VOLT SUPPLY wire.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the unswitched battery supply OEM harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Check for a short circuit to battery.

Measure the resistance between the accelerator pedal SUPPLY pin in the OEM harness ECM connector and the ECM battery SUPPLY (+) pin of the power harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM.

  • Refer to the following Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2186 - Sensor Supply 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ambient Air Pressure Sensor | Refer to Procedure 019-004 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Coolant Pressure Sensor | Refer to Procedure 019-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine Auxiliary QSB7-DM CM850 | 4310679
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine Auxiliary QSB7-DM CM850 | 4310679
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the rail fuel pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the camshaft speed sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the intake manifold air temperature/pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the engine oil pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the crankcase pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the ambient air pressure sensor and circuit connected to the sensor supply and return. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the rail fuel pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the camshaft speed sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the intake manifold air temperature/pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the intake manifold air temperature/pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the engine oil pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the crankcase pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2G - Inspect the ambient air pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

Refer to Procedure 019-071 in Section 19.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and all other pins in the engine harness ECM connector

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Nov-2015


FAULT CODE 2215 - Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Inlet Restriction | Refer to Procedure 006-020 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Lines | Refer to Procedure 006-024 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | Marine Auxiliary QSB7-DM CM850 | 4310679
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 449, 1117, or 2311 active or high inactive counts?
 | STEP 1B. Inspect for external fuel leaks. | Fuel leaks present?
 | STEP 1C. Verify the rail fuel pressure sensor accuracy. | Fuel rail pressure +/- 43 bar [+/- 624 psi]?
STEP 2. | Check engine operation. |
 | STEP 2A. Attempt to start the engine. | Engine start?
 | STEP 2B. Check the fuel supply. | Adequate amount of fuel in the tank?
STEP 3. | Check the low-pressure fuel system. (Engine not running) |
 | STEP 3A. Measure the fuel gear pump pressure. | Fuel gear pump pressure greater than specifications?
STEP 4. | Check the low-pressure fuel system. (Engine running) |
 | STEP 4A. Check for external fuel leak. | Any external fuel leaks?
 | STEP 4B. Check for air in the high-pressure pump fuel supply. | Air present in the fuel supply?
 | STEP 4C. Measure inlet restriction at the OEM connection point. | OEM inlet restriction above specification?
 | STEP 4D. Measure inlet restriction at the gear pump inlet. | Gear pump inlet restriction above specification?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Measure the fuel pump head flow. | Fuel pump head flow greater than 100 cc [3.4 oz] in 30 seconds of cranking?
 | STEP 5B. Check for excessive fuel return from the fuel injector drain line. | Fuel injector leakage excessive?
 | STEP 5C. Check for excessive fuel return from the high-pressure pump. | Fuel pump leakage excessive?
 | STEP 5D. Check for excessive leakage from the rail fuel pressure relief valve. | Rail fuel pressure relief valve leaking more than 30 drops per minute?
STEP 6. | Verify the repair is complete. |
 | STEP 6A. Disable the fault code. | Fault Code 2215 becomes active during loaded engine operation?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449, 1117, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for external fuel leaks.

  • Look for fuel leaking from loose fuel fittings and damaged fuel lines, or damaged components.

Fuel leaks present?
YES NO

Repair the fuel leak.

  • Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswtich ON
  • INSITE™ electronic service tool connected
  • Monitor INSITE™ electronic service tool
  • Do not operate the engine.

Action

Make sure the correct sensor part number is installed in the high pressure fuel rail.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Fuel rail pressure 0 +/- 43 bar [0 +/- 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor.

  • Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2A

Go to 6A

Guided Step 2 - Check engine operation.

Guided Step 2A - Check to see if the engine will start.

Conditions

  • Turn keyswitch ON.

Action

Attempt to start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel supply.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank for fuel.

Adequate amount of fuel in the tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 3A

Go to 6A

Guided Step 3 - Check the low-pressure fuel system. (Engine not running)

Guided Step 3A - Measure fuel gear pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure the gear pump pressure during cranking.

Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel gear pump pressure greater than specifications?
YES NO
No Repair

Replace the high-pressure fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 4 - Check the low-pressure fuel system. (Engine running)

Guided Step 4A - Check for external fuel leak.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle.
  • Inspect for external fuel leaks.

Any external fuel leaks?
YES NO

Repair all fuel leaks.

Reference the appropriate procedure in Section 6.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for air in the high-pressure pump fuel supply.

Conditions

  • Operate engine.

Action

Check for air in the fuel.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Air present in the fuel supply?
YES NO

  • Locate and correct the cause of air ingestion in the fuel supply system.
  • Sources of air ingestion include loose fuel filters, loose fuel line fittings, loose or cracked fuel tank standpipes, or severe restrictions in the fuel supply lines and filters.

No Repair

Go to 6A

Go to 4C

Guided Step 4C - Measure the inlet restriction at the OEM connection point.

Conditions

  • Engine running.

Action

Measure the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

If the engine will not start or the engine starts and stalls, be sure fuel is primed to the gear pump. This test is only valid if the engine is running.

OEM inlet restriction above specification?

YES NO

A fuel restriction exists upstream of the OEM connection point. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Measure the inlet restriction at the gear pump inlet.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Refer to Procedure 006-020 in Section 6.

If the engine will not start or the engine starts and stalls, be sure fuel is primed to the gear pump. This test is only valid if the engine is running.

Gear pump inlet restriction above specification?
YES NO

A restriction may exist between the OEM connection and the gear pump inlet.

Refer to Procedure 006-020 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4E

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Measure the fuel pump head flow.

Conditions

  • Disconnect the high-pressure fuel outlet line from the high-pressure injection pump. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Disconnect the fuel pump aactuator connector.
  • Insert a clear hose to the outlet of the high-pressure injection pump and run the other end into a graduated cylinder. Refer to Procedure 005-016 in the Associated Procedures Table.

Action

Crank the engine for 30 seconds.

  • Measure the fuel pump head flow.

Fuel pump head flow greater than 100 cc [3.4 oz] in 30 seconds of cranking?
YES NO
No Repair

Replace the fuel pump head. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check for excessive fuel return from the fuel injector drain line.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 006-026 in the Associated Procedures Table.

Action

Start the engine.

  • Use INSITE™ electronic service tool high-pressure test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel injector return line.
  • Refer to Procedure 006-026 in the Associated Procedures Table.

Fuel injector leakage excessive?
YES NO

Isolate the injector high-pressure connector(s) that are the cause of the excessive leakage.

Tighten the loose high-pressure fuel connectors.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check for excessive fuel return from the high-pressure pump.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 006-020 in the Associated Procedures Table.
  • Route a hose from the test fitting into a clean graduated cylinder.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Start the engine.

  • Use INSITE™ electronic service tool high-pressure control relief pressure test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel pump head.
  • Refer to Procedure 006-020 in the Associated Procedures Table.

Fuel pump leakage excessive?
YES NO

Replace the high-pressure fuel pump.

Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5D

Guided Step 5D - Check for excessive fuel return from the rail fuel pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 006-061 in the Associated Procedures Table.

Action

Start the engine.

  • Use INSITE™ electronic service tool high-pressure control relief pressure test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel rail pressure relief valve.

If the engine will not start, perform this test while cranking the engine. Refer to Procedure 006-061 in the Associated Procedures Table.

Fail fuel pressure relief valve leaking more than 30 drops per minute?
YES NO

Replace the rail fuel pressure relief valve.

Refer to Procedure 006-061 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the repair is complete.

Guided Step 6A - Disable the fault code.

Conditions

  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the fault code.

  • Road test the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 became active during loaded engine operation?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 6B

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 01-Oct-2012


FAULT CODE 2249 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fuel system fault codes. | Fault Code 2249 active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fuel system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fuel system fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2249 active?
YES NO

Follow the troubleshooting procedures for Fault Code 559.

 No Repair

Fault Code 559 troubleshooting.

Repair complete.

Last Modified: 08-Sep-2012


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Inspect the low-pressure fuel lines. | Low-pressure fuel lines pinched or damaged?
 | STEP 1B. Check the stage 2 fuel filter restriction. | Restriction across the fuel filter more than 203 mm-Hg [8 in-Hg] clean and 584 mm-Hg [23 in-Hg] dirty?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2261 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the low-pressure fuel system.

Guided Step 1A - Inspect the low-pressure fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the low-pressure fuel lines for pinches or damage.

Check the low-pressure fuel system.

Low-pressure fuel lines pinched or damaged?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the stage 2 fuel filter restriction.

Conditions

  • Connect INSITE™ electronic service tool.
  • Remove the fuel temperature sensor.
  • Install the pressure gauge into the temperature sensor port.

Action

Install the pressure gauge.

  • Operate the engine at high idle.
  • Compare the reading on the gauge with the fuel supply pressure reading in INSITE™ electronic service tool.

Restriction across the fuel filter more than 203 mm-Hg [8 in-Hg] clean and 584 mm-Hg [23 in-Hg] dirty?
YES NO

Replace the fuel filter. Refer to Procedure 006-015 in the Associated Procedures Table.

Replace the high-pressure fuel pump assembly.Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2261 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air In Fuel | Refer to Procedure 006-003 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Inlet Restriction | Refer to Procedure 006-020 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Lines | Refer to Procedure 006-024 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2265, 2266, 1911, and/or 559 active?
STEP 2. | Check if engine will not start or engine starts and dies. |
 | STEP 2A. Attempt to start the engine. | Engine starts and continues running?
STEP 3. | Check the low-pressure side of the fuel system. |
 | STEP 3A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 3B. Check the stage 1 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 3C. Check the stage 2 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 3D. Check for air in the fuel. | Air present in the fuel flow?
 | STEP 3E. Inspect the OEM fuel supply hose and fuel tank. | Fuel inlet restriction greater than 102 mm-Hg [4 in-Hg]?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2262 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2265, 2266, 1911, and/or 559 active?
YES | NO
No Repair | No Repair

Fault Codes 2265, 2266, 1911 and/or 559.

Go to 2A

Guided Step 2 - Check if engine will not start or engine starts and dies.

Guided Step 2A - Attempt to start the engine.

Conditions

  • Start engine.

Action

Try to start the engine.

Check if engine will not start or engine starts and dies.

Engine starts and continues running?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Engine Performance troubleshooting symptom tree in Section TT.

Guided Step 3 - Check the low-ressure side of the fuel system.

Guided Step 3A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Check for external fuel leaks or evidence of leaks.

Fuel leaking externally?
YES NO

Repair all fuel leaks. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at idle and measure the restriction across the stage 1 fuel filter.
  • Clean 76 mm-Hg [3 in-Hg]
  • Dirty 152 mm-Hg [6 in-Hg]
  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel filter restriction less than specifications?
YES NO
No Repair

The restriction across the stage 1 filter is above specification. Replace the first stage fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at idle and measure the restriction across the stage 2 fuel filter.
  • Clean 209 mm-Hg [8 in-Hg]
  • Dirty 1034 mm-Hg [40 in-Hg]
  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel filter restriction less than specifications?
YES NO
No Repair

The restriction across the stage 2 filter is above specification. Replace the second stage fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for air in fuel.

Conditions

  • Disconnect the air bleed line from the fuel drain manifold block. Plug the port in the fuel drain manifold.
  • Operate the engine at idle.

Action

Check for air in fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air present in the fuel flow?
YES NO

Repair all fuel leaks.

Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Inspect the OEM fuel supply hose and fuel tank.

Conditions

  • Shut engine OFF and turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Operate the engine at idle and measure the inlet restriction.
  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel inlet restriction greater than 102 mm-Hg [4 in-Hg]?
YES NO

Refer to the OEM service manual for repair instructions.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2262 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 2. | Check the electric fuel lift pump relay circuit. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump relay connector pins. | Dirty or damaged pins?
STEP 3. | Check the electric fuel lift pump. |
 | STEP 3A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the electric fuel lift pump. | Less than 20 ohms?
 | STEP 3C. Check the electric fuel lift pump supply voltage and return circuit. | Greater than 18.0-VDC? (for 24-VDC system)
 | STEP 3D. Check for an open circuit in the electric fuel lift pump relay return circuit. | Less than 10 ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM electric fuel lift pump diagnostic supply voltage. | Greater than 18.0-VDC? (for 24-VDC system)
 | STEP 4C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?

YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 2 - Check the electric fuel lift pump relay circuit.

Guided Step 2A - Inspect the engine harness and electric fuel lift pump relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Inspect the engine harness, electric fuel lift pump wiring harness, and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the electric fuel lift pump.

Guided Step 3A - Inspect the engine harness and electric fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and electric fuel lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the electric fuel lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Check for an open circuit in the electric fuel lift pump.

  • Measure the resistance between the electric fuel lift pump SUPPLY and the electric fuel lift pump RETURN pins at the electric fuel lift pump connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 20 ohms?
YES NO
No Repair

A damaged electric fuel lift pump has been detected.

Replace the electric fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check the electric fuel lift pump supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.
  • Install the Deutsch™ 2-pin breakout tool, Part Number 3163531, between the lift pump and the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the electric fuel lift pump SUPPLY pin and the electric fuel lift pump RETURN pin using the Deutsch™ 2-pin breakout tool.

Greater than 18.0 VDC? (for 24 VDC system)
YES | NO
No Repair | No Repair

Go to 4D

Go to 3D

Guided Step 3D - Check for an open circuit in the electric fuel lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine harness.

Action

Measure the resistance between the engine harness electric fuel lift pump RETURN pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness or connector pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM electric fuel lift pump diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the electric fuel lift pump SUPPLY pin (1) and the electric fuel lift pump RETURN pin (11) at the engine harness ECM connector port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 18.0 VDC? (for 24-VDC system)
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin at the electric fuel lift pump connector and the electric fuel lift pump SUPPLY pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 2. | Check the electric fuel lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 active and Fault Code 2266 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2266 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2265 active and Fault Code 2266 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?

YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the electric fuel lift pump.

Guided Step 2A - Inspect the engine harness and electric fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and electric fuel lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active and Fault Code 2266s inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the electric fuel lift pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES NO

A damaged electric fuel lift pump has been detected.

Replace the electric fuel lift pump.

Refer to Procedure 005-045 in the Assocated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active and Fault Code 2266s inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2266 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Oct-2012


FAULT CODE 2292 - Fuel Inlet Meter Device - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Lift Pump | Refer to Procedure 005-045 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Inlet Restriction | Refer to Procedure 006-020 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Supply Lines | Refer to Procedure 006-024 | Marine Auxiliary QSB7-DM CM850 | 4310679
Injector | Refer to Procedure 006-026 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2215 or 2266 inactive?
STEP 2. | Check the operation of the low-pressure fuel system. |
 | STEP 2A. Check for external fuel leaks | Fuel leaks present?
STEP 3. | Check the lift pump. |
 | STEP 3A. Measure the lift pump pressure. | Lift pump pressure meets minimum specification?
 | STEP 3B. Measure the lift pump inlet restriction. | Less than 152 mm-Hg [6 in-Hg]?
STEP 4. | Check the fuel filter restriction. |
 | STEP 4A. Measure the pressure drop across the fuel filter. | Drop in pressure less than 34 kPa [5 psi]?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Check for leakage from the rail fuel pressure relief valve. | Fuel return within specification?
 | STEP 5B. Check for excessive fuel return leak from the high-pressure fuel system, injectors, and high-pressure connectors. | Fuel leakage within specification?
 | STEP 5C. Check for excessive fuel return from the high-pressure fuel pump. | Fuel return within specification?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault codes inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 or 2266 inactive?
YES NO
No Repair

Troubleshoot appropriate fault codes.

Go to 2A

Appropriate fault code

Guided Step 2 - Check the operation of the low-pressure fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for external fuel leaks.

  • Start the engine and let it idle.
  • Inspect for external fuel leaks.

Fuel leaks present?
YES NO

Repair the fuel leaks.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the lift pump.

Guided Step 3A - Measure the lift pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure the lift pump performance.

  • Refer to Procedure 005-045 in the Associated Procedures Table.

Lift pump pressure meets minimum specification?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Measure the lift pump inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Measure the lift pump inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Less than 152 mm-Hg [6 in-Hg]?
YES NO

Replace the electric lift pump.

Refer to Procedure 005-045 in the Associated Procedures Table.

Replace the OEM fuel filter or repair the cause of the inlet restriction.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel filter restriction.

Guided Step 4A - Measure the pressure drop across the fuel filter.

Conditions

  • Turn keyswitch ON.
  • Run the engine at rated condition.

Action

Measure the pressure drop across the fuel filter.

  • Refer to Procedure 006-015 in the Associated Procedures Table.

Drop in pressure less than 34 kPa [5 psi]?

YES NO
No Repair

Replace the pressure-side filter and verify the pressure-side fuel lines are not restricted.

Go to 5A

Go to 6A

Guided Step 5 - Check high-pressure fuel system.

Guided Step 5A - Check for leakage from the rail fuel pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the rail fuel pressure relief valve.

Action

Check for leakage from the rail fuel pressure relief valve.

  • Install test fittings to measure the fuel return.
  • Refer to Procedure 006-016 in the Associated Procedures Table.

Fuel return within specification?
YES NO
No Repair

Replace the rail fuel pressure relief valve. Refer to Procedure 006-016 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check for excessive fuel return leak from the high-pressure fuel system, injectors, and high-pressure connectors.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the injectors and high-pressure connectors.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Fuel leakage within specification?
YES NO
No Repair

Isolate the source of the leak and repair it.

Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check for excessive fuel return from the high-pressure fuel pump.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the high-pressure fuel pump.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Install test fittings to measure the fuel return from the fuel pump.
  • Refer to Procedure 005-016 in the Associated Procedures Table.

Fuel return within specification?
YES NO
No Repair

Replace the high-pressure fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Perform a 15 to 20 minute road test or run the engine on the dynamometer.
  • Verify the fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2293 - Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | Marine Auxiliary QSB7-DM CM850 | 4310679
Air In Fuel | Refer to Procedure 006-003 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Drain Line Restriction | Refer to Procedure 006-012 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Drain Lines | Refer to Procedure 006-013 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, and/or 2311 inactive?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify that the rail fuel pressure sensor reads in-range. | Pressure = 0 ±40 bar [0 ±580 psi]?
STEP 3. | Check the operation of the low-pressure fuel system. |
 | STEP 3A. Check for air in fuel. | Air present?
 | STEP 3B. Check for excessive lift pump fuel pressure. | Less than 137 kPa [20 psi]?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check the fuel return drain line for excessive restriction. | Less than 18 kPa [2.7 psi]?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, and/or 2311 inactive?
YES NO
No Repair

Troubleshoot applicable fault codes for the electronic fuel control actuator.

Go to 2A

Applicable Fault Code 271, 272, and/or 2311

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify the rail fuel pressure sensor reads in-range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to electronic service tool read the rail fuel pressure.

–

Pressure = 0 ±40 bar [0 ±580 psi]?
YES NO
No Repair

Replace the sensor or repair the engine harness.

  • Refer to Procedure 019-115 in the Associated Procedures Table.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the operation of the low-pressure fuel system.

Guided Step 3A - Check for air in fuel.

Conditions

  • Connect a test hose at the fuel filter head inlet and run a hose into a bucket.
  • Turn keyswitch ON. (The electric lift pump will run for approximately one minute.)

Action

Check for air in fuel as the lift pump runs.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air present?
YES NO

Refer to Procedure 006-003 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for excessive lift pump fuel pressure.

Conditions

  • Turn keyswitch ON.

Action

Check for excessive lift pump fuel pressure.

  • Install a pressure gauge at the inlet port of the fuel filter head with a M10 Compuchek™ fitting, Part Number 3824842.
  • Start the engine and let it idle.
  • Measure the pressure at the fuel filter head outlet.

Less than 137 kPa [20 psi]?
YES NO
No Repair

The internal pressure regulator has malfunctioned.

Replace the electric fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check the fuel return drain line for excessive restriction.

Conditions

  • Install a pressure gauge in the fuel return line banjo bolt at the high-pressure fuel pump drain manifold.
  • Turn keyswitch ON.

Action

Check the fuel return drain line for excessive restriction.

  • Operate the engine at high idle speed.
  • Measure the fuel return drain line restriction.
  • Refer to Procedure 006-012 in the Associated Procedures Table.

Less than 18 kPa [2.7 psi]?
YES NO

Test the electronic fuel control actuator circuit for high resistance or an open circuit.

Replace the electronic fuel control actuator. Refer to Procedure 019-117 in Section 19.

Repair or replace the fuel return drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Perform a 15 to 20 minute road test or run the engine on a dynamometer.
  • Verify fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Fuel Pump Actuator | Refer to Procedure 019-117 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel pump actuator valve. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness condition. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is running, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Load test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect air gap and target wheel. | Is air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2321 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 689 has a number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

Fault Code 689 is active or has a high number of inactive counts?
YES | NO
No Repair | No Repair

Refer to Fault Code 689 troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clear the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Load test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.

Action

Start the engine. Allow the engine to accelerate to rated speed.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in Section 19.

Is air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target wheel runout is excessive, replace the target wheel.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to accelerate to rated speed.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2321 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting symptom trees

Last Modified: 04-Oct-2012


FAULT CODE 2322 - Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679
Camshaft Position Sensor | Refer to Procedure 019-363 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1376 active ors high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Load test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specifications?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2322 status changes from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2322 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 1376 has a number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

Fault Code 1376 active or high number of inactive counts?
YES | NO
No Repair | No Repair

Refer to Fault Code 1376 troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clear the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Load test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.

Action

Start the engine and allow it to accelerate to rated speed.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 1.27 mm [0.050 in]
  • Maximum Target Runout: 0.33 mm [0.013 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Fault Code 2322 status changes from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic serivce tool to verify that the fault code is inactive.

Fault Code 2322 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 04-Oct-2012


FAULT CODE 2557 - Auxiliary PMW Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the pulse width modulated OEM device and circuit. |
 | STEP 2A. Inspect the pulse width modulated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulated OEM device. | Resistance is within OEM specification?
 | STEP 2C. Check for an open circuit in the output device driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect all OEM, ECM, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2557 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulated OEM device and circuit.

Guided Step 2A - Inspect the pulse width modulated OEM device and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness.

Action

Inspect the OEM and engine harnesses and the pulse width modulated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged solenoid.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulated OEM device.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check the pulse width modulated OEM device resistance.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin and the RETURN pin at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specification?
YES NO
No Repair

Replace the pulse width modulated OEM device.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the output device driver return circuit.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the output device driver RETURN pin at the pulse width modulated OEM device connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the harnesses connected in series.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean and repair, or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Keyswitch OFF
  • Disconnect all harness connector connections.

Action

Inspect the OEM and engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, OEM, or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin at the PWM actuated OEM device connector and the auxiliary pulse width modulated driver 1 SIGNAL pin at the engine harness ECM 50-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine ECM 50-pin connector and all other pins in the engine ECM 50-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2557 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Oct-2012


FAULT CODE 2558 - Auxiliary PMW Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 2. | Check the pulse width modulated OEM device. |
 | STEP 2A. Inspect the pulse width modulated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulated OEM device. | Resistance is within OEM specification?
 | STEP 2B-1. Check for a short to ground in the pulse width modulated OEM device. |
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2558 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulated OEM device.

Guided Step 2A - Inspect the pulse width modulated OEM device and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness.

Action

Inspect the OEM and engine harnesses and pulse width modulated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged solenoid.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulated OEM device.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check the modulator actuated OEM device resistance.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin and the RETURN pin at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specification?
YES NO
No Repair

Replace the pulse width modulated OEM device.

Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the pulse width modulated OEM device.

Conditions

  • Keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check for a modulator actuated OEM device output short to ground.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin and ground at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the pulse width modulated OEM device.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device harness connector.

Clean the connector and pins.

Replace the damaged section or harnesses connected in series or damaged solenoid.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the pulse width modulated actuated OEM device from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine 50-pin harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Disconnect the pulse width modulated actuated OEM device from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine ECM 50-pin connector and all other pins in the engine 50-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2558 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Oct-2012


FAULT CODE 2737 - Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2737. | Active or inactive counts of Fault Code 2737?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2737.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2737?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Aug-2012


FAULT CODE 2973 - Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | Marine Auxiliary QSB7-DM CM850 | 4310679
Barometric Pressure at Altitude | Refer to Procedure 018-028 | Marine Auxiliary QSB7-DM CM850 | 4310679
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | Marine Auxiliary QSB7-DM CM850 | 4310679
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, or 295?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the aftercooler for leaks. | Air leak present?
 | STEP 2B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 2C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
STEP 4. | Check the barometric pressure sensor. |
 | STEP 4A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 102 mm-Hg [4 in-Hg] of local barometric pressure?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2973 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, or 295?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the aftercooler for leaks.

Conditions

  • Operate engine.

Action

Check the aftercooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in the connections and hoses between the turbocharger and intake manifold inlet.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at high idle.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the barometric pressure sensor.

Guided Step 4A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

Refer to Procedure 018-028 in the Associated Procedures Table.

INSITE™ electronic service tool reading is within 102 mm-Hg [4 in-Hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Raise engine speed to 1500 rpm and hold for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2973 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 3695 - Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 238 active?
STEP 2. | Check the generator output frequency adjust potentiometer. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1411 active and Fault Code 3695 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3695 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3695 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 3695 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Reference Fault Code 238

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 47-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 47-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 3) pin and the generator output frequency adjust potentiometer RETURN (sensor return 3) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 3) and the generator output frequency adjust potentiometer SIGNAL pin at the OEM 47-pin connector of the engine harness.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 active and Fault Code 3695 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active?
YES NO

A malfunction on the generator set side has been detected. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator output frequency adjust potentiometer SIGNAL pin and the OEM 47-pin connector generator output frequency adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 3695 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-Oct-2012


FAULT CODE 3696 - Droop Adjustment Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | Marine Auxiliary QSB7-DM CM850 | 4310679
Engine Wiring Harness | Refer to Procedure 019-043 | Marine Auxiliary QSB7-DM CM850 | 4310679

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 187 active?
STEP 2. | Check the droop adjustment potentiometer circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Voltage between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1412 active and Fault Code 3696 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3696 active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3696 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 3696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187.

Go to 2A

Guided Step 2 - Check the droop adjustment potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 47-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

Refer to the circuit art or a wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer SIGNAL pin at the OEM 47-pin connector of the engine harness.

Refer to the circuit art or a wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 active and Fault Code 3696 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 47-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 active?
YES NO

An issue has been detected with the generator set controller. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector droop adjust potentiometer SIGNAL pin and the OEM 47-pin connector droop adjust potentiometer SIGNAL pin.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator droop adjust potentiometer signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 47-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3696 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Oct-2012


INDEX
192-fc111.htm

192-t05-111.htm

192-fc115.htm

192-t05-115.htm

192-fc122.htm

192-t05-122.htm

192-fc123.htm

192-t05-123.htm

192-fc135.htm

192-t05-135.htm

192-fc141.htm

192-t05-141.htm

192-fc143.htm

192-t05-143.htm

192-fc144.htm

192-t05-144.htm

192-fc145.htm

192-t05-145.htm

192-fc146.htm

192-t05-146.htm

192-fc151.htm

192-t05-151.htm

192-fc153.htm

192-t05-153.htm

192-fc154.htm

192-t05-154.htm

192-fc155.htm

192-t05-155.htm

192-fc187.htm

192-t05-187.htm

192-fc195.htm

192-t05-195.htm

192-fc196.htm

192-t05-196.htm

192-fc197.htm

192-t05-197.htm

192-fc212.htm

192-t05-212.htm

192-fc213.htm

192-t05-213.htm

192-fc214.htm

192-t05-214.htm

192-fc221.htm

192-t05-221.htm

192-fc222.htm

192-t05-222.htm

192-fc227.htm

192-t05-227.htm

192-fc228.htm

192-t05-228.htm

192-fc231.htm

192-t05-231.htm

192-fc232.htm

192-t05-232.htm

192-fc234.htm

192-t05-234.htm

192-fc235.htm

192-t05-235.htm

192-fc238.htm

192-t05-238.htm

192-fc239.htm

192-t05-239.htm

192-fc248.htm

192-t05-248.htm

192-fc271.htm

192-t05-271.htm

192-fc272.htm

192-t05-272.htm

192-fc281.htm

192-t05-281.htm

192-fc285.htm

192-t05-285.htm

192-fc286.htm

192-t05-286.htm

192-fc295.htm

192-t05-295.htm

192-fc322.htm

192-t05-322.htm

192-fc323.htm

192-t05-323.htm

192-fc324.htm

192-t05-324.htm

192-fc325.htm

192-t05-325.htm

192-fc331.htm

192-t05-331.htm

192-fc332.htm

192-t05-332.htm

192-fc351.htm

192-t05-351.htm

192-fc352.htm

192-t05-352.htm

192-fc386.htm

192-t05-386.htm

192-fc415.htm

192-t05-415.htm

192-fc418.htm

192-t05-418.htm

192-fc421.htm

192-t05-421.htm

192-fc422.htm

192-t05-422.htm

192-fc425.htm

192-t05-425.htm

192-fc426.htm

192-t05-426.htm

192-fc441.htm

192-t05-441.htm

192-fc442.htm

192-t05-442.htm

192-fc449.htm

192-t05-449.htm

192-fc451.htm

192-t05-451.htm

192-fc452.htm

192-t05-452.htm

192-fc488.htm

192-t05-488.htm

192-fc546.htm

192-t05-546.htm

192-fc547.htm

192-t05-547.htm

192-fc553.htm

192-t05-553.htm

192-fc554.htm

192-t05-554.htm

192-fc555.htm

192-t05-555.htm

192-fc556.htm

192-t05-556.htm

192-fc559.htm

192-t05-559.htm

192-fc689.htm

192-t05-689.htm

192-fc731.htm

192-t05-731.htm

192-fc757.htm

192-t05-757.htm

192-fc783.htm

192-t05-783.htm

192-fc951.htm

192-t05-951.htm

192-fc1117.htm

192-t05-1117.htm

192-fc1139.htm

192-t05-1139.htm

192-fc1141.htm

192-t05-1141.htm

192-fc1142.htm

192-t05-1142.htm

192-fc1143.htm

192-t05-1143.htm

192-fc1144.htm

192-t05-1144.htm

192-fc1145.htm

192-t05-1145.htm

192-fc1376.htm

192-t05-1376.htm

192-fc1411.htm

192-t05-1411.htm

192-fc1412.htm

192-t05-1412.htm

192-fc1597.htm

192-t05-1597.htm

192-fc1843.htm

192-t05-1843.htm

192-fc1844.htm

192-t05-1844.htm

192-fc1845.htm

192-t05-1845.htm

192-fc1846.htm

192-t05-1846.htm

192-fc1847.htm

192-t05-1847.htm

192-fc1852.htm

192-t05-1852.htm

192-fc1911.htm

192-t05-1911.htm

192-fc1974.htm

192-t05-1974.htm

192-fc1978.htm

192-t05-1978.htm

192-fc1979.htm

192-t05-1979.htm

192-fc1992.htm

192-t05-1992.htm

192-fc2185.htm

192-t05-2185.htm

192-fc2186.htm

192-t05-2186.htm

192-fc2215.htm

192-t05-2215.htm

192-fc2249.htm

192-t05-2249.htm

192-fc2261.htm

192-t05-2261.htm

192-fc2262.htm

192-t05-2262.htm

192-fc2265.htm

192-t05-2265.htm

192-fc2266.htm

192-t05-2266.htm

192-fc2292.htm

192-t05-2292.htm

192-fc2293.htm

192-t05-2293.htm

192-fc2311.htm

192-t05-2311.htm

192-fc2321.htm

192-t05-2321.htm

192-fc2322.htm

192-t05-2322.htm

192-fc2557.htm

192-t05-2557.htm

192-fc2558.htm

192-t05-2558.htm

192-fc2737.htm

192-t05-2737.htm

192-fc2973.htm

192-t05-2973.htm

192-fc3695.htm

192-t05-3695.htm

192-fc3696.htm

192-t05-3696.htm