ISX15 CM2250 SN

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 31-Aug-2019
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Engine power derate.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117 .

Last Modified: 31-Aug-2019


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code 115 .

Last Modified: 31-Aug-2019


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 122 .

Last Modified: 31-Aug-2019


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 123 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1239 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor

Damaged accelerator pedal position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1241 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2

Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1242 .

Last Modified: 31-Aug-2019


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the VGT and EGR valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault code include:

Leaks in the air intake system between the turbocharger and intake manifold

A damaged intake manifold pressure sensor

A damaged barometric pressure sensor

Restriction in the charge-air cooler

Fuel inlet restriction too high (normally caused by a restricted fuel filter).

Restriction in the exhaust system

Restriction in the air filter

Refer to Troubleshooting Fault Code 125 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 131 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132 .

Last Modified: 31-Aug-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open remote accelerator pedal or lever return circuit in the harness or connections

Remote accelerator supply shorted to battery

Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 133 .

Last Modified: 31-Aug-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged remote accelerator pedal or lever position sensor

Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 134 .

Last Modified: 31-Aug-2019


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal circuit shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 135 .

Last Modified: 31-Aug-2019


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141 .

Last Modified: 31-Aug-2019


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143 .

Last Modified: 31-Aug-2019


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 144 .

Last Modified: 31-Aug-2019


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 145 .

Last Modified: 31-Aug-2019


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 117°C [ 242°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151 .

Last Modified: 31-Aug-2019


Accelerator Pedal Position 1 - Received Network Data in Error

FAULT CODE 1515

Accelerator Pedal Position 1 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1515 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal. | Engine will only idle.
ISX15 CM2250 SN - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the multiplexed accelerator pedal or lever sensor system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1515 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 01-Apr-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Restricted air flow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 155 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 1. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 1 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1654 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system following a filter change, caused the fault. Inactive counts of Fault Code 1654 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1654 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 2. | Possible reduced engine performance.
Engine Control Module

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 2 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1655 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1655 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F]before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1655 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 3. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 3 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1656 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1656 should be disregarded unless other performance symptoms are present. The coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1656 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 4. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 4 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1657 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1657 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1657 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 5. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 5 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1658 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1658 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1658 .

Last Modified: 31-Aug-2019


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 6. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine coolant temperature is greater than 71°C [160°F].

Conditions for Setting the Fault Codes

If cylinder 6 has high or low contribution to engine speed, this fault will become active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1659 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system, following a filter change caused the fault. Inactive counts of Fault Code 1659 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1659 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1668, check for multiple faults.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor.

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1668 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the catalyst tank level sensor circuit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1669, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 1669 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1671

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1671 PID: SPN: 1761 FMI: 1/18 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The diesel exhaust fluid tank level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Low aftertreatment diesel exhaust fluid level has been detected in the diesel exhaust fluid tank.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Fault code 1671 is triggered when low diesel exhaust fluid level has been detected in the diesel exhaust fluid tank. Add diesel exhaust fluid to the tank. This fault code is only a warning for low diesel exhaust fluid tank solution level.

Refer to Troubleshooting Fault Code 1671 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was critically low.

Action Taken When the Fault Code is Active

  • The diesel exhaust fluid lamp will be flashing.

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after the engine has been shutdown, 1 hour of engine idle time, or the fuel tank has been refilled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically.This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code 1673 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 1677, check for multiple fault codes.

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1677 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1678 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

In-range failure of the diesel exhaust fluid tank temperature sensor

Damaged wiring harness

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1679 .

Last Modified: 07-Dec-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

FAULT CODE 1681

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1681 PID: SPN: 3361 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit detected an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Fault code 1681 is triggered when the aftertreatment diesel exhaust fluid dosing unit has detected an internal error.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1681 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank heater circuit is shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins® electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can not detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

Diesel exhaust fluid tank heater relay signal wire not connected to the relay

Diesel exhaust fluid tank heater relay return wire not connected to the relay

Diesel exhaust fluid tank heater signal wire and return wire shorted together

Malfunctioning diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1683 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins® electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can not detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

A shorted aftertreatment diesel exhaust fluid tank heater relay

Aftertreatment diesel exhaust fluid tank heater signal wire shorted to ground.

Refer to Troubleshooting Fault Code 1684 .

Last Modified: 31-Aug-2019


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695 .

Last Modified: 31-Aug-2019


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696 .

Last Modified: 31-Aug-2019


Air Supply Actuator - Voltage Above Normal or Shorted to High Source

FAULT CODE 1697

Air Supply Actuator - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1697 PID: SPN: 3489 FMI: 3/3 LAMP: Amber SRT: | High signal voltage has been detected at the aftertreatment diesel exhaust fluid dosing unit air solenoid circuit. | Engine power derate.
Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid pump. The air is used to transport the diesel exhaust fluid to the diesel exhaust fluid injector.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid pump. The diesel exhaust fluid pump is original equipment manufacturer (OEM) mounted. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is logged when the supply voltage to the air solenoid is greater than +12-VDC.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Air solenoid signal wire shorted to a voltage supply

Failed aftertreatment diesel exhaust fluid dosing unit

Refer to Troubleshooting Fault Code 1697 .

Last Modified: 31-Aug-2019


Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1698

Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1698 PID: SPN: 3489 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage has been detected at the aftertreatment diesel exhaust fluid dosing unit air solenoid circuit. | Engine power derate.
Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid pump. The air is used to transport the diesel exhaust fluid to the diesel exhaust fluid injector.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid pump. The diesel exhaust fluid pump is original equipment manufacturer (OEM) mounted. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the air supply actuator signal voltage was greater than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Open circuit in the air solenoid signal wire or in the air solenoid return wire

Shorted pin-to-pin air solenoid signal wire

Malfunctioning air solenoid

Malfunctioning DEF pump

Refer to Troubleshooting Fault Code 1698 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

FAULT CODE 1711

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1711 PID: SPN: 3361 FMI: 9/9 LAMP: Amber SRT: | Data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have been interrupted. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Data link communications between the ECM and the aftertreatment diesel exhaust fluid dosing unit have been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Loss of battery voltage to the aftertreatment diesel exhaust fluid dosing unit

Loss of battery ground to the aftertreatment diesel exhaust fluid dosing unit

Loss of keyswitch input to the aftertreatment diesel exhaust fluid dosing unit

Shorted or open J1939 data link wiring between the aftertreatment diesel exhaust fluid dosing unit and the primary engine ECM

Malfunctioning aftertreatment diesel exhaust fluid dosing unit

Refer to Troubleshooting Fault Code 1711 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater has been on long enough to thaw the diesel exhaust fluid, but the SCR dosing system is still not able to prime

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Aftertreatment diesel exhaust fluid tank heater control valve stuck closed

Blockage or restrictons in the coolant plumbing to the diesel exhaust fluid tank heater

Engine coolant level low

Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1712 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | The diesel exhaust fluid tank heater is continuously in the ON position. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the DEF tank temperature was greater than 75°C [167°F] indicating the aftertreatment diesel exhaust fluid tank heater was in the ON position when the ECM was commanding the heater to be in the OFF position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Before troubleshooting this fault code, make sure the equipment is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

Reason: If there is a problem with the diesel exhaust fluid (DEF) tank heater control valve, the valve is stuck open, there is coolant leaking past the valve seat, or the valve is incorrectly installed, it can take long periods of operation at high load before the tank temperature gradually increases to the fault code threshold value of 77Â°C [170Â°F]. As soon as the temperature drops below 75Â°C [167Â°F] due to a stopped engine, overnight parking, reduced coolant temperature, and so forth, the fault code will go inactive while the root cause of the issue is still present.

Possible causes of this fault code include:

Aftertreatment diesel exhaust fluid tank heater control valve installed incorrectly, reversed relative to coolant flow direction.

Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve stuck open or leakage past the valve seat.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1713 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 175

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 175 PID: SPN: 3464 FMI: 3/3 LAMP: Red SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to battery in the engine harness.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 175 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4/4 LAMP: Red SRT: | A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine intake air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to ground when the actuator is commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 176 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: SPN: 3464 FMI: 7/7 LAMP: Red SRT: | The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

One part runs when the keyswitch is initially turned ON before the engine is started

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator failed the autozero span check.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 177 .

Last Modified: 31-Aug-2019


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852 .

Last Modified: 31-Aug-2019


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 187 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Engine power derate.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

The voltage supplied to the aftertreatment oulet NOx sensor is below +18-VDC

The voltage supplied to the aftertreatment oultet NOx sensor is above +32-VDC

The aftertreatment outlet NOx sensor has malfunctioned or is damaged

The aftertreatment outlet NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1887 .

Last Modified: 31-Aug-2019


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0/0 LAMP: Amber SRT: | The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).

Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559).

A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.

If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive, during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. A fuel pump actuator with excessive leakage will result in high rail fuel pressures at idle or light load.

Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.

The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.

Refer to Troubleshooting Fault Code 1911 .

Last Modified: 31-Aug-2019


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage

Sensor supply circuit shorted to battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 195 .

Last Modified: 31-Aug-2019


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open signal circuit in the engine harness, connectors, or sensor

Signal circuit shorted to ground in the engine harness, connector, or sensor

  • Damaged sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 196 .

Last Modified: 31-Aug-2019


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 197 .

Last Modified: 31-Aug-2019


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 212 .

Last Modified: 31-Aug-2019


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the engine harness

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 213 .

Last Modified: 31-Aug-2019


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214 .

Last Modified: 31-Aug-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was detected to be greater than 0 volts when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2182 .

Last Modified: 31-Aug-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2183 .

Last Modified: 31-Aug-2019


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185 .

Last Modified: 31-Aug-2019


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186 .

Last Modified: 31-Aug-2019


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

An open return circuit in the engine harness

Signal circuit shorted to sensor supply or battery voltage.

A malfunctioning barometric air pressure sensor

Refer to Troubleshooting Fault Code 221 .

Last Modified: 31-Aug-2019


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor.

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 222 .

Last Modified: 31-Aug-2019


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3/3 LAMP: Amber SRT: | High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine may not start or may be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump signal circuit was detected to be greater than 0-VDC when the signal was turned off by the engine control module (ECM).

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness

A short circuit to battery in the engine harness.

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 2265 .

Last Modified: 31-Aug-2019


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4/4 LAMP: Amber SRT: | High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine may not start or may be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

Conditions for Setting the Fault Codes

The engine fuel lift pump signal circuit is detected to be 0-VDC when the signal is turned on by the ECM and must be at system voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric fuel lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (lift pump partially shorted). During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29Â°C [-20Â°F]). This fault code can possibly also become active if the lift pump rotor stalls or seizes. When the fault condition is detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test for the cause of the fault code. The ECM driver is enabled at key ON. If the cause if no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code 2266 .

Last Modified: 31-Aug-2019


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227 .

Last Modified: 31-Aug-2019


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit had an intermittent circuit concern, or the fuel pump actuator resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

Fuel pump actuator high resistance

Engine harness high resistance

Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors

Fuel pump actuator with low internal resistance

Fuel pump actuator or engine harness that has shorted to ground

Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 2311 .

Last Modified: 31-Aug-2019


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Crankshaft engine speed sensor intermittent synchronization. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent "misfire" if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent "low power" if a "glitch" in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.

Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the primary engine speed sensor circuit.

Look for loose connections at the ECM connector where the pins can not be locked into the socket.

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.

Look for pin wear at the speed sensor.

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2321 .

Last Modified: 31-Aug-2019


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2/2 LAMP: None SRT: | Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems

Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the secondary engine speed sensor circuit

Look for loose connections at the ECM connector where the pins can not be locked into the socket

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit

Look for pin wear at the speed sensor

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2322 .

Last Modified: 31-Aug-2019


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

External fuel sources drawn into the intake air passage

Reverse powering (motoring) of the engine

Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

If Fault Code 234 becomes active only during engine braking, and the engine brakes fail to engage, check for a short circuit to ground in the engine brake wiring harness. The rocker lever cover must be removed to perform this inspection. Repair or replace the engine brake wiring harness as necessary.

Refer to Troubleshooting Fault Code 234 .

Last Modified: 31-Aug-2019


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | The engine coolant is severely low. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low coolant level

Refer to Troubleshooting Fault Code 235 .

Last Modified: 31-Aug-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S80 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2363 .

Last Modified: 31-Aug-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was detected to be system voltage when the PWM signal was turned off.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2367 .

Last Modified: 31-Aug-2019


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P95 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Excessive fuel flow restriction to the high pressure fuel pump has been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

There are two fuel filters and several original equipment manufacturer (OEM) supplied components that can impact this fault code. The pressure-side fuel filter is typically mounted directly to the engine, but can also be remote mounted. The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter, and the exact filter location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure was less than a calibratible value during high fuel flow conditions indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low fuel pressure at rated speed/load indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Possible causes of this fault code include:

A plugged pressure or suction side fuel filter

Collapsed fuel inlet lines

An obstructed suction tube in the fuel tank

Plugged fuel tank vents.

Malfunctioning high-pressure fuel system

Note: The mounting location of the suction side fuel filter will vary by OEM, and can possibly not be in an obvious location.

Refer to Troubleshooting Fault Code 2372 .

Last Modified: 31-Aug-2019


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2377 .

Last Modified: 31-Aug-2019


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

Short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code 238 .

Last Modified: 31-Aug-2019


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239 .

Last Modified: 31-Aug-2019


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: P171 SPN: 171 FMI: 2/2 LAMP: Amber SRT: | The ambient air temperature sensor is reading an erratic value. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of ten hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time, or the ambient air temperature was reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range ambient air temperature sensor

High resistance in the ambient air temperature sensor signal or return lines

ECM malfunction.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2398 .

Last Modified: 31-Aug-2019


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect Cummins® electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

NOTE: If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 241 .

Last Modified: 31-Aug-2019


Fan Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2412

Fan Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2412 PID: P26 SPN: 1639 FMI: 2/2 LAMP: Amber SRT: | The fan speed signal has been lost. | The fan can stay on continuously or not run at all.
ISX and ISM Fan Speed Sensor

Circuit Description

The fan speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the fan hub shaft is a ground flat in the center of the shaft. The electronic control module (ECM) interprets this signal and converts it to a fan speed reading.

Component Location

The fan speed sensor is located in the fan hub assembly. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan speed signal has been lost.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The fan will only be in the ON or OFF position.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServeâ„¢ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

The fan speed sensor is installed by the original equipment manufacturer (OEM). This fault code is triggered when the fan speed signal is reading 0 when the engine is running. This indicates a failed fan speed sensor or a failure in the OEM wiring harness.

Refer to Troubleshooting Fault Code 2412 .

Last Modified: 31-Aug-2019


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

The adjustable parameter "VSS Anti-Tampering" must be enabled.

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be zero for 30 seconds.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 242 .

Last Modified: 31-Aug-2019


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448 .

Last Modified: 31-Aug-2019


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins® electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins® electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 245 .

Last Modified: 31-Aug-2019


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2468

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2468 PID: P190 SPN: 190 FMI: 0/16 LAMP: Amber SRT: | The engine speed has exceeded a critical limit and the engine has been shut down via the engine air shutoff valve. | Engine will shut down.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The air shutoff valve is an optional component used to shutdown the engine in the event of an engine overspeed condition. It can be closed via a manual shutdown switch or via an ECM command.

Component Location

The engine air shutoff valve location can vary depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was greater than 2500 RPM for 0.25 seconds, or the operator manually tripped the engine air shutoff valve.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The air shutoff valve closes

The engine will be shut down.

Conditions for Clearing the Fault Code

  • The air shutoff valve must be reset to the open position.
  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine has been shut down via the engine air shutoff valve. This can occur automatically (engine overspeed condition) or manually (activating the engine air shutoff valve switch in the cab). In either case, this fault code will become active until the valve de-activated.

Refer to Troubleshooting Fault Code 2468 .

Last Modified: 31-Aug-2019


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at ambient air temperature circuit. | Engine power derate.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • A default value for the ambient air temperature reading is used.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 249 .

Last Modified: 31-Aug-2019


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at ambient air temperature circuit. | Engine power derate.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • A default value for the ambient air temperature reading is used.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 256 .

Last Modified: 31-Aug-2019


Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

FAULT CODE 269

Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 269 PID: S217 SPN: 1195 FMI: 2/2 LAMP: Red SRT: | Engine ignition attempt without authorization from the immobilizer anti-theft device. | The engine will not start.
Antitheft Password Valid Indicator Circuit

Circuit Description

The immobilizer anti-theft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network. Messages sent from the immobilizer anti-theft device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and location of original equipment manufacturer (OEM) installed J1939 devices varies by OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is active when the immobilizer antitheft device has not been deactivated.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is active when the anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to Troubleshooting Fault Code 269 .

Last Modified: 31-Aug-2019


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage is detected at the fuel pump actuator circuit. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is NOT detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the short circuit condition is or was intermittent.

Refer to Troubleshooting Fault Code 271 .

Last Modified: 31-Aug-2019


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272 .

Last Modified: 31-Aug-2019


Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2738

Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2738 PID: S237 SPN: 626 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit pulse width modulated (PWM) signal voltage was greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness or ether injection solenoid

A short circuit to voltage source in the OEM harness

A malfunctioning ECM.

Refer to Troubleshooting Fault Code 2738 .

Last Modified: 31-Aug-2019


Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2739

Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2739 PID: S237 SPN: 626 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit pulse width modulated (PWM) signal was not at system voltage when the PWM signal was turned ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM commands 12-VDC to the ether injection solenoid, but the voltage on the ether injection signal circuit is less than 12-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code 2739 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Engine power derate.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

The Aftertreatment Outlet NOx Sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.

Open return circuit on the aftertreatment outlet NOx sensor battery return.

Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.

Intermittent communications between the aftertreatment outlet NOx sensor and the ECM on the J1939 data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2771 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2772

Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2772 PID: SPN: 3226 FMI: 0/15 LAMP: Amber SRT: | The engine NOx output is higher than recommended levels. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, use the recommended Cummins® electronic service tool or equivalent to perform the "Aftertreatment High NOx Reset Test" found ECM Diagnostic Test.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Diesel exhaust fluid quality is not within specification

External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines

Aftertreatment nozzle has malfunctioned

Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged

Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx output

Aftertreatment nozzle is partially or completely plugged

Refer to Troubleshooting Fault Code 2772 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2773

Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2773 PID: SPN: 3226 FMI: 0/0 LAMP: Amber SRT: | The engine NOx output is higher than recommended levels. | Engine power derate.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, use the recommended Cummins® electronic service tool or equivalent to perform the "Aftertreatment High NOx Reset Test" found ECM Diagnostic Test.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Diesel exhaust fluid quality is not within specification

External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines

Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx output

Aftertreatment nozzle has malfunctioned

Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged

Aftertreatment nozzle is partially or completely plugged

Aftertreatment SCR catalyst is damaged or missing

Refer to Troubleshooting Fault Code 2773 .

Last Modified: 31-Aug-2019


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285 .

Last Modified: 31-Aug-2019


J1939 Network #1 - Out of Calibration

FAULT CODE 286

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 286 .

Last Modified: 01-Jun-2021


Accelerator Pedal Position 1 - Received Network Data in Error

FAULT CODE 287

Accelerator Pedal Position 1 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Amber SRT: | The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Engine can ONLY idle or engine will NOT accelerate to full speed.
OEM/Vehicle Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator as 0 percent, but the secondary throttle position sensor indicates it is NOT in the idle position.

The OEM VECU determined that the accelerator signal wire was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. Use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287 .

Last Modified: 01-Apr-2021


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. Use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 288 .

Last Modified: 31-Aug-2019


Proprietary Datalink Error (OEM/Vehicle Datalink) - Abnormal Update Rate

FAULT CODE 291

Proprietary Datalink Error (OEM/Vehicle Datalink) - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 291 PID: S248 SPN: 625 FMI: 9/9 LAMP: Red SRT: | The engine could possibly not start. | The immobilizer anti-theft system will not operate properly. The engine could possibly not start.
OEM/Vehicle Data Link Circuit

Circuit Description

The immobilizer anti-theft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network. Messages sent from the immobilizer anti-theft device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) was not able to communicate with the immobilizer anti-theft system via the J1939 data link

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault can occur for the following reasons:

When the ECM is set up to receive information from an OEM device, but the OEM device is not be transmitting the message for that component. Or when a multiplexed component is enabled in the CumminsÂ ECM, but the source address of the OEM device transmitting the component message is incorrect in the CumminsÂ ECM.

This fault can be caused by a malfunctioning J1939 data link connection between the immobilizer anti-theft device and CumminsÂ ECM, a malfunctioning connection between the component and the immobilizer anti-theft device, malfunctioning immobilizer anti-theft device or malfunctioning CumminsÂ ECM. It could be necessary to contact the OEM for proper multiplexing configuration.

Refer to Troubleshooting Fault Code 291 .

Last Modified: 31-Aug-2019


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine coolant temperature is above the engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963 .

Last Modified: 31-Aug-2019


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

An undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 2964 .

Last Modified: 31-Aug-2019


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70Â°C or 158Â°F.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged intake manifold pressure sensor

A damaged barometric pressure sensor

Leaks in the air intake system between the turbocharger and intake manifold

Restriction in the charge-air cooler

Refer to Troubleshooting Fault Code 2973 .

Last Modified: 31-Aug-2019


Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3139

Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3139 PID: SPN: 3667 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the air shutoff circuit. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Circuit

Circuit Description

The air shutoff valve is an OEM installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the ECM supplies 12-VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The engine air shutoff valve location can vary depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine air shutoff driver was shorted to voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open engine air shutoff circuit

Short circuit to voltage in the engine air shutoff circuit

Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3139 .

Last Modified: 31-Aug-2019


Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3141

Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3141 PID: SPN: 3667 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine air shutoff circuit. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Circuit

Circuit Description

The air shutoff valve is an OEM installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the ECM supplies 12-VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The engine air shutoff valve location can vary depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine air shut off driver was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine air shutoff circuit

Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3141 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Engine power derate.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SCR intake temperature sensor signal voltage was greater than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3142 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Engine power derate.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SCR intake temperature sensor signal voltage was less than 0.13-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3143 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3144

Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2/2 LAMP: Amber SRT: | The SCR intake temperature sensor is not changing with engine operating conditions. | Engine power derate.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60Â°C [140Â°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the SCR catalyst intake temperature is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Stuck in-range SCR intake temperature sensor

High resistance in the SCR intake temperature sensor signal or return lines

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3144 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the SCR outlet temperature sensor circuit. | Engine power derate.
Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) outlet temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3146 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the SCR outlet temperature sensor circuit. | Engine power derate.
Aftertreatment SCR Outlet Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) outlet temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system. The sensor is located after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3147 .

Last Modified: 31-Aug-2019


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3164

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3164 PID: SPN: 4360 FMI: 0/15 LAMP: None SRT: | High SCR intake temperature has been detected. | Possible reduced engine performance.
Aftertreatment SCR Intake Temperature Sensor

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR intake temperature sensor

Upstream exhaust system malfunction.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3164 .

Last Modified: 31-Aug-2019


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance.
Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the real-time clock battery voltage was 3.3-VDC.

Action Taken When the Fault Code is Active

The ECM flashes the amber CHECK ENGINE lamp and/or illuminates the Malfunction Indicator Lamp (MIL) at initial key-on when the diagnostic runs and fails.

The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319 .

Last Modified: 31-Aug-2019


Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 322 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 323 .

Last Modified: 01-Jul-2021


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3236

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3236 PID: SPN: 4363 FMI: 0/15 LAMP: Amber SRT: | High SCR outlet temperature has been detected. | Engine power derate.
Aftertreatment SCR Outlet Temperature Sensor

Circuit Description

The selective catalytic reduction (SCR) outlet temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature exiting the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR outlet temperature sensor is located in the aftertreatment system. The sensor is located after the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3236 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: SPN: 4340 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins® electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3237 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3238

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3238 PID: SPN: 4340 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaustl Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins® electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

A malfunctioning line heater

Malfunctioning line heater relay

Refer to Troubleshooting Fault Code 3238 .

Last Modified: 31-Aug-2019


Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 324 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 325 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 331 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 332 .

Last Modified: 01-Jul-2021


Accelerator Pedal Position 1 - Abnormal Update Rate

FAULT CODE 3326

Accelerator Pedal Position 1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9/9 LAMP: Red SRT: | The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3326 .

Last Modified: 01-Apr-2021


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3328 .

Last Modified: 31-Aug-2019


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 11/31 LAMP: None SRT: | The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The anti-lock bracking (ABS) controller detected certain driving conditions and inhibited cruise control.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 3374 .

Last Modified: 31-Aug-2019


Transmission Output Shaft Speed - Received Network Data in Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined there was a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Refer to Troubleshooting Fault Code 3418 .

Last Modified: 31-Aug-2019


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343 .

Last Modified: 31-Aug-2019


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Invalid switch configuration adjustable parameter setting have been detected by the Engine Control Module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The Original Equipment Manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled using recommended Cummins® electronic service tool or equivalent, such as such as the accelerator interlock/engine torque limit switch or the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

The output or switched inputs to this diagnostic are found in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected features which share a common input or output to the ECM were simultaneously enabled..

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with the recommended Cummins® electronic service tool or equivalent or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346 .

Last Modified: 31-Aug-2019


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3488 .

Last Modified: 31-Aug-2019


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Injector Power Supply Circuit

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm, the primary engine speed sensor signal is present, and the battery charge is above a minimum threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 .

Last Modified: 31-Aug-2019


Wheel-Based Vehicle Speed - Received Network Data in Error

FAULT CODE 3525

Wheel-Based Vehicle Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3525 PID: SPN: 84 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the wheel-based vehicle speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3525 .

Last Modified: 31-Aug-2019


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3526 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

FAULT CODE 3527

Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3527 PID: SPN: 558 FMI: 2/19 LAMP: Red SRT: | The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the accelerator pedal or lever idle validation switch.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3527 .

Last Modified: 31-Aug-2019


Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

FAULT CODE 3528

Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3528 PID: SPN: 558 FMI: 9/9 LAMP: Red SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the accelerator pedal or lever idle validation switch. | Engine will only idle.
ISX15 CM2250 SN - Accelerator Pedal or Lever Idle Validation Switch Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3528 .

Last Modified: 31-Aug-2019


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

A short circuit to battery in the engine harness.

An open circuit in the engine harness

Refer to Troubleshooting Fault Code 3539 .

Last Modified: 31-Aug-2019


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

A short circuit to ground in the engine harness

An open circuit in the engine harness

Refer to Troubleshooting Fault Code 3541 .

Last Modified: 31-Aug-2019


Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3542

Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3542 PID: SPN: 51 FMI: 2/2 LAMP: Amber SRT: | The engine intake air throttle posistion feedback is erratic or incorrect. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

Refer to Troubleshooting Fault Code 3542 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists

FAULT CODE 3548

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3548 PID: SPN: 5392 FMI: 11/31 LAMP: Amber SRT: | The dosing unit is unable to prime. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

For an air-assisted SCR aftertreatment system, the aftertreatment diesel exhaust fluid dosing unit requires air pressure from the OEM air tanks in order to prime and help carry the diesel exhuast fluid from the dosing unit to the aftertreatment nozzle. The diesel exhaust fluid dosing unit precisely measures the amount of diesel exhaust fluid to be injected into the aftertreatment system. The diesel exhaust fluid dosing unit has three primary cycles: priming, dosing, and purging. The priming cycle occurs at initial engine start makes sure that diesel exhaust fluid is available at the diesel exhaust fluid dosing unit. During the dosing cycle, the diesel exhaust fluid is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle confirms that all the diesel exhaust fluid is removed from the diesel exhaust fluid lines and aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is started and runs while the dosing unit is in the priming state, which could last up to 12 minutes after initial key-on.

Conditions for Setting the Fault Codes

The dosing unit will attempt to prime every 30 seconds for 20 attempts. If the dosing unit has been unable to prime after completing all attempts, this fault code will become active. The dosing unit can take up to 12 minutes to complete the priming cycle before the fault code will become active.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The diesel exhaust fluid dosing unit system consists of three phases. These phases occur in the following sequence: Priming, dosing, and purging. This fault code is set when the dosing unit is unable to prime.

Fault Code 3548 is triggered by the following external failure modes:

Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank

Low air pressure is detected at the dosing control unit

Plugged or restricted inline air filter

Blocked, restricted, frozen, or leaking dosing unit supply line

Diesel exhaust fluid dosing unit drawing in air through loose or damaged lines or connectors.

Fault Code 3548 is triggered by the following internal diesel exhaust fluid dosing unit failure modes:

Build up of DEF crystals in the dosing unit restricts air flow to the aftertreatment nozzle

Internal pressure sensor or poppet valve failure causing the diesel exhaust fluid dosing unit to fail to prime. This will cause diesel exhaust fluid to flow from the aftertreatment nozzle during priming.

If diesel exhaust fluid lines blocked by buildup are detected, make sure that the dosing unit is purging correctly at key OFF. Incomplete purging of the dosing unit can also result in dosing unit damage caused by the freezing of the leftover diesel exhaust fluid in the system. Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of the recommended Cummins® electronic service tool or equivalent. If the vehicle is equipped with a battery isolation switch, it must have a built-in delay device to prevent powering down of the dosing unit until the purge sequence is complete. If an OEM issue is identified as the cause of the malfunction, it must be documented and reported to the OEM as appropriate.

Refer to Troubleshooting Fault Code 3548 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3569

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3569 PID: SPN: 3362 FMI: 7/7 LAMP: Amber SRT: | An issue with diesel exhaust fluid delivery has been detected. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detected a mechanical failure of the dosing input lines, and diesel exhaust fluid was not being delivered to the dosing valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

This fault indicates that the diesel exhaust fluid dosing unit was able to build pressure, but could not complete the priming cycle.Troubleshoot all other active SCR related faults before this fault.

Possible causes of this fault code include:

Blocked or restricted DEF dosing valve

Blocked or restricted aftertreatment dosing valve supply line

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3569 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is initially started and the SCR system is priming.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

Blocked, restricted, or frozen diesel exhaust fluid dosing unit return line or return line fitting

Malfunctioning diesel exhaust fluid dosing unit.

If diesel exhaust fluid lines blocked by buildup are detected, make sure that the dosing unit is purging correctly at key OFF. Incomplete purging of the dosing unit can also result in dosing unit damage caused by the freezing of the leftover diesel exhaust fluid in the system. Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of the recommended Cummins® electronic service tool or equivalent. If the vehicle is equipped with a battery isolation switch, it must have a built-in delay device to prevent powering down of the dosing unit until the purge sequence is complete. If an OEM issue is identified as the cause of the malfunction, it must be documented and reported to the OEM as appropriate.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3575 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

A damaged aftertreatment outlet NOx sensor

Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3583 .

Last Modified: 31-Aug-2019


Coolant Level Sensor - Abnormal Update Rate

FAULT CODE 3613

Coolant Level Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3613 PID: SPN: 111 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the coolant level sensor. | Possible reduced engine performance.
J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 3613 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | Engine power derate.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins® electronic service tool or equivalent.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3681 .

Last Modified: 31-Aug-2019


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

A malfunction of the ECM software.

Refer to Troubleshooting Fault Code 3697 .

Last Modified: 31-Aug-2019


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: SPN: 1675 FMI: 11/31 LAMP: None SRT: | The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Starter Mode Overcrank Protection

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737 .

Last Modified: 31-Aug-2019


Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3738

Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3738 PID: SPN: 3489 FMI: 1/18 LAMP: Amber SRT: | The air or diesel exhaust fluid supply to the dosing unit has been lost. | Engine power derate.
Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid pump. The air is used to transport the diesel exhaust fluid to the diesel exhaust fluid injector.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid pump. The diesel exhaust fluid pump is original equipment manufacturer (OEM) mounted. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the Selective Catalytic Reduction (SCR) system is dosing diesel exhaust fluid into the aftertreatment system.

Conditions for Setting the Fault Codes

The dosing unit detects that the air supply has been lost while dosing diesel exhaust fluid into the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

OEM air supply tubing damaged or leaking

Malfunctioning air solenoid

Malfunctioning aftertreatment diesel exhaust fluid dosing unit

Refer to Troubleshooting Fault Code 3738 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: SPN: 3226 FMI: 2/20 LAMP: Amber SRT: | An offset in the outlet NOx sensor reading has been detected. | Engine power derate.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the outlet NOx sensor reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment outlet NOx sensor

Diesel exhaust fluid crystallization or deposits

Improperly installed aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3749 .

Last Modified: 31-Aug-2019


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low oil pressure

Incorrect oil level

Damaged oil pressure sensor

Engine harness shorted to ground.

Refer to Troubleshooting Fault Code 415 .

Last Modified: 31-Aug-2019


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418 .

Last Modified: 31-Aug-2019


Anti-Lock Braking (ABS) Active - Condition Exists

FAULT CODE 4215

Anti-Lock Braking (ABS) Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4215 PID: SPN: 563 FMI: 11/31 LAMP: None SRT: | Cruise control was paused due to an anti-wheel slip message from the ABS controller. | Adaptive cruise control will not operate. Standard cruise control may not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) disabled cruise control due to an anti-wheel slip message from the anti-lock braking (ABS) controller.

Action Taken When the Fault Code is Active

Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information only fault code to indicate that cruise control was interrupted due to a message from the ABS controller. No troubleshooting is necessary.

Refer to Troubleshooting Fault Code 4215 .

Last Modified: 31-Aug-2019


Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 425

Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 425 PID: P175 SPN: 175 FMI: 2/2 LAMP: Amber SRT: | The engine oil temperature is erratic. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 10 hours before this part of the diagnostic will run.

The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 10 hours. After the 10 hour cold soak, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning oil temperature sensor.

Resistance in the signal line

Refer to Troubleshooting Fault Code 425 .

Last Modified: 31-Aug-2019


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428 .

Last Modified: 31-Aug-2019


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the water-in-fuel circuit. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor, or connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 429 .

Last Modified: 31-Aug-2019


Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

FAULT CODE 4293

Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4293 PID: SPN: 5097 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the brake lamp relay driver circuit. | None on performance.
Brake Lamp Relay Circuit

Circuit Description

The brake lamp relay is an OEM optional component used to illuminate the vehicle's brake lamps under conditions when the engine is braking.

Component Location

The brake lamp relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake lamp relay driver circuit was shorted to high source or open circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

An open circuit in the OEM harness

A short circuit to battery in the OEM harness

Refer to Troubleshooting Fault Code 4293 .

Last Modified: 31-Aug-2019


Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4294

Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4294 PID: SPN: 5097 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the brake lamp relay driver circuit. | None on performance.
Brake Lamp Relay Circuit

Circuit Description

The brake lamp relay is an OEM optional component used to illuminate the vehicle's brake lamps under conditions when the engine is braking.

Component Location

The brake lamp relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake lamp relay driver circuit was shorted to low source.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

A short circuit to ground in the OEM harness

Refer to Troubleshooting Fault Code 4294 .

Last Modified: 31-Aug-2019


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Damaged oil pressure sensor

Open circuit in the engine oil pressure sensor signal wire

Short circuit in the engine oil pressure sensor signal wire to a voltage source.

Refer to Troubleshooting Fault Code 435 .

Last Modified: 31-Aug-2019


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441 .

Last Modified: 31-Aug-2019


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Faulty alternator or regulator that is overcharging the system

Batteries connected in series instead of parallel

Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442 .

Last Modified: 31-Aug-2019


Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4484

Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4484 PID: SPN: 3667 FMI: 7/7 LAMP: Red SRT: | Engine air shutoff failed to close during test mode. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve is either an original equipment manufacturer (OEM) or CumminsÂ installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12-VDC to the air shutoff solenoid. This solenoid then activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is either an OEM or CumminsÂ installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic only runs during an Air Shutoff Valve Test.

Conditions for Setting the Fault Codes

The ECM detects that the air shutoff valve has not closed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins® electronic service tool or equivalent to calibrate the ECM.
  • NOTE: The engine must be calibrated again to clear the fault code. This is done because of the hazardous operating environment and safety considerations.
  • To validate the repair, the Air Shutoff Valve Test must be performed again and successfully passed.

Shop Talk

Potential causes of this fault code include:

Malfunctioning air shutoff valve solenoid.

Malfunctioning air shutoff valve.

Broken or disconnected air shutoff position switch SIGNAL wire.

Broken or disconnected air shutoff position switch RETURN wire.

Refer to Troubleshooting Fault Code 4484 .

Last Modified: 31-Aug-2019


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor responds to pressure changes in the fuel rail. The fuel rail pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at low rail pressures. The ECM will detect a high signal voltage during high rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

Voltage (+5-VDC or higher shorted to the signal wire)

Open circuit on the signal wire

Open circuit on the 5 Volt supply wire

Open circuit on the return wire

Malfunctioning sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 451 .

Last Modified: 31-Aug-2019


Vehicle Identification Number - Out of Calibration

FAULT CODE 4517

Vehicle Identification Number - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4517 PID: SPN: 237 FMI: 13/13 LAMP: Amber SRT: | The vehicle identification number has not been programmed into the ECM. | None on performance.
Engine Control Module (ECM)

Circuit Description

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the vehicle identification number (VIN) was not programmed in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

Refer to Troubleshooting Fault Code 4517 .

Last Modified: 31-Aug-2019


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor responds to pressure changes in the fuel rail. The fuel rail pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at low rail pressures. The ECM will detect a high signal voltage during high rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

Supply or signal wire is shorted to ground.

Damaged sensor

Damaged ECM.

Refer to Troubleshooting Fault Code 452 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9/9 LAMP: Amber SRT: | The ECM lost communication with the aftertreatment diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect terminating resistance of the SAE J1939 datalink circuit

Intermittent communication from the aftertreatment diesel exhaust fluid tank temperature sensor

An open or short circuit in the SAE J1939 datalink circuit

Refer to Troubleshooting Fault Code 4572 .

Last Modified: 31-Aug-2019


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0/0 LAMP: Red SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components. The engine will be derated for protection purposes.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 4642 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Refer to Troubleshooting Fault Code 4731 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank level sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4732 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4739 .

Last Modified: 31-Aug-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | A valid diesel exhaust fluid tank level reading has NOT been received. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, and leave the key in the ON position for 2 hours.

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Tampering of the aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4769 .

Last Modified: 31-Aug-2019


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 515 .

Last Modified: 31-Aug-2019


Engine Air Shutoff Status - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5221

Engine Air Shutoff Status - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5221 PID: SPN: 3667 FMI: 2/2 LAMP: Red SRT: | Engine Air Shutoff - Data Erratic, Intermittent, or Incorrect. | The engine air shutoff valve will be disabled.
Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve position switch is located inside the air shutoff valve. During testing, the engine is accelerated and the air shutoff valve closes at a predetermined engine speed. When the air shutoff valve closes, the position switch closes. The ECM monitors the Air Shutoff Valve Position Signal circuit for a change indicating the switch closed.

Component Location

The air shutoff valve position switch is located inside the air shutoff valve. The air shutoff valve is either an OEM or CumminsÂ installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic only runs during an Air Shutoff Valve Test.

Conditions for Setting the Fault Codes

The ECM detects that the air shutoff valve position switch has not closed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To clear the fault code and validate the repair, the air shutoff valve must be reset. The air shutoff valve test must be performed and the ECM must see the air shutoff valve position switch close.

Shop Talk

Potential causes of this fault code include:

Malfunctioning air shutoff valve solenoid.

Malfunctioning air shutoff valve.

Malfunctioning air shutoff valve position switch

Broken or disconnected air shutoff position switch SIGNAL wire.

Broken or disconnected air shutoff position switch RETURN wire.

Refer to Troubleshooting Fault Code 5221 .

Last Modified: 31-Aug-2019


Engine/Transmission Match - Out of Calibration

FAULT CODE 5297

Engine/Transmission Match - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5297 PID: SPN: 747 FMI: 13/13 LAMP: None SRT: | The ECM Calibration is not correct for the transmission. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

The Transmission ECU location varies by application, Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM Calibration and the Transmission ECU software are mismatched. The ECM calibration has SmartAdvantage or Advanced Dynamic Efficient Powertrain (ADEPT) features enabled, but the transmission ECU software is not compatible.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect or incomplete transmission up fit installation.

Missed or timed out J1939 messages.

ECM Calibration is not compatible for the transmission ECU software.

ECM updated include SmartAdvantage or Advanced Dynamic Efficient Powertrain (ADEPT) feature and the transmission ECU has an older version of software.

Refer to Troubleshooting Fault Code 5297 .

Last Modified: 31-Aug-2019


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553 .

Last Modified: 31-Aug-2019


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was less than the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the engine will not start and Fault Code 559 becomes active during cranking, but no speed sensor fault codes exist, monitor rail pressure with the recommended Cummins® electronic service tool or equivalent. The procedures referred to in this troubleshooting tree will also have checks for engine no-start conditions.

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine.

If the fuel rail pressure is low, check the following:

Fuel system prime (make sure there is fuel in the tanks and the system is primed)

Fuel lift pump pressure

Fuel gear pump pressure

If the gear pump pressure is OK, test the system for leakage:

High-pressure pump leakage

Injector leakage

Fuel rail pressure relief valve

If Fault Code 559 is inactive and there are no existing performance complaints, it is possible the vehicle was run out of fuel or the fault came active if the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 559 sets when the engine is operating and measured rail fuel pressure remains at least 100 bar [1450 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure.

Causes of this fault include:

Fuel inlet restrictions

Fuel filter plugging

Fuel gear pump output low

Fuel gear pump pressure actuator sticking or leaking

High pressure pump capacity decay (high leakage to drain from the high-pressure pump)

Fuel rail pressure relief valve leaks to drain

Fuel rail pressure relief valve opens at too low a pressure

Injector fuel circuit leaks to drain

Pressure sensor reads more than 100 bar [1450 psi] lower than actual pressure

Air in the fuel.

A few bubbles exiting the line during the test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following; suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).

The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.

Intermittent ECM power supply connections can cause Fault Code 559. If the engine is running with an active Fault Code 559 and Fault Codes 449, 1911, or 2311 are not present, check the ECM power supply for intermittent connections or battery issues. Fault Code 1117 can also be active if this fault condition exits. Verify the vehicle system voltage by monitoring battery voltage in the recommended Cummins® electronic service tool or equivalent data monitor or connecting a digital volt ohm meter to the batteries. This will help identify a potential system voltage issue. Refer to the OEM service manual for specified voltage range and troubleshooting procedures.

Inactive Fault Code/Exhausted Troubleshooting Tree:

Troubleshooting inactive Fault Code 559 can be difficult. For engines with high counts of inactive Fault Code 559, or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Be certain to have a fuel pressure gauge installed at the pressure filter outlet side during the test. The most common causes of intermittent Fault Code 559 that are difficult to create are leaking high pressure connectors that only leak when the engine and the fuel are hot, intermittent fuel supply restrictions (such as debris floating in the fuel tank), or a fuel pressure relief valve that opens prematurely. Check the high-pressure connector and connector torque and tighten to specification, if necessary. Use the recommended Cummins® electronic service tool or equivalent to log fuel system parameters during testing.

Refer to Troubleshooting Fault Code 559 .

Last Modified: 31-Aug-2019


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 584 .

Last Modified: 31-Aug-2019


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 585 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5879

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5879 PID: SPN: 3464 FMI: 3/3 LAMP: Amber SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to battery in the engine harness.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5879 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5881

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5881 PID: SPN: 3464 FMI: 4/4 LAMP: Amber SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to battery in the engine harness.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5881 .

Last Modified: 31-Aug-2019


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5882

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5882 PID: SPN: 3464 FMI: 7/7 LAMP: Amber SRT: | The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

One part runs when the keyswitch is initially turned ON before the engine is started

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator failed the autozero span check.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5882 .

Last Modified: 31-Aug-2019


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | High turbocharger speed has been detected by the ECM. | Engine power derate.
ECM Microprocessor

Circuit Description

The Engine Control Module (ECM) calculates turbocharger speed based on air to fuel ratio, final timing and inputs from the intake manifold temperature and pressure (Combo) sensor, ambient air pressure sensor and the engine speed sensor. If the calculated turbocharger speed becomes too high, it will cause a derate condition.

Component Location

There is not a physical turbocharger speed sensor in the system. The turbocharger speed is a calculation of intake manifold temperature, intake manifold pressure, ambient air pressure, engine speed, air to fuel ratio, and fuel timing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Intake manifold temperature and pressure (Combo) sensor

Engine speed sensor

Ambient air pressure sensor

Engine Control Module (ECM) calibration

Refer to Troubleshooting Fault Code 595 .

Last Modified: 31-Aug-2019


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | High battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Overcharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 596 .

Last Modified: 31-Aug-2019


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 597 .

Last Modified: 31-Aug-2019


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Undercharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 598 .

Last Modified: 31-Aug-2019


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Change the engine oil and filter. | None on performance.
Maintenance Reminder

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins® electronic service tool or equivalent to reset the Maintenance Monitor feature.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in the recommended Cummins® electronic service tool or equivalent. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649 .

Last Modified: 31-Aug-2019


Transmission Gear Ratio Module - Abnormal Update Rate

FAULT CODE 6724

Transmission Gear Ratio Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6724 PID: SPN: 581 FMI: 9/9 LAMP: None SRT: | The ECM failed to recieve a message from the transmission control module. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6724 .

Last Modified: 31-Aug-2019


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness

Damaged or malfunctioning engine speed sensor

Damaged tone wheel

Sensor air gap that is too small or too large.

Refer to Troubleshooting Fault Code 689 .

Last Modified: 31-Aug-2019


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes of this fault code include:

Engine speed sensor rings that are loose or not aligned correctly

Mechanical misalignment.

Refer to Troubleshooting Fault Code 731 .

Last Modified: 31-Aug-2019


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.

Damaged or malfunctioning camshaft position sensor.

Damaged speed indicator lobe.

Sensor air gap that is too large or small.

Refer to Troubleshooting Fault Code 778 .

Last Modified: 31-Aug-2019


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
ISX15 CM2250 SN - Adaptive Cruise Control Mode Circuit

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 784 .

Last Modified: 31-Aug-2019


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

ISX15 CM2250 SN

Fault Code: 111 | SPN: 629 | FMI: 12
Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. ECM calibration revision history check
  2. ECM Malfunction

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM Malfunction

Solution: S00008831

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 115 | SPN: 612 | FMI: 2
Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Camshaft position sensor is damaged
  3. Engine crankshaft speed/position sensor check
  4. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 122 | SPN: 102 | FMI: 3
Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00000411

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the sensor disconnected: 123

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00000456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 123
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 123

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 123 | SPN: 102 | FMI: 4
Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor is malfunctioning

Solution: S00007822

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 125 | SPN: 102 | FMI: 18
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor has carbon buildup
  4. Intake manifold pressure sensor stuck in-range
  5. Leaks in the intake air system
  6. Charge air cooler system leak
  7. High exhaust restriction
  8. Turbocharger wastegate actuator is malfunctioning
  9. Turbocharger is malfunctioning
  10. ECM calibration revision history check
  11. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000794

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 629, 687, 2387, 2449, 2634, 2635, 2636, 3348, 3616
  • EGR: 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger wastegate actuator is malfunctioning

Solution: S00002135

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Turbocharger is malfunctioning

Solution: S00008465

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger.

Refer to Procedure 010-033

  • Visually inspect the air filter and air intake system for leaks allowing dirt and dust to enter the turbocharger.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 131 | SPN: 91 | FMI: 3
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the sensor disconnected: 132

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 132 | SPN: 91 | FMI: 4
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to ground short
  7. Accelerator pedal position sensor circuit pin to pin short
  8. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the accelerator pedal position sensor SUPPLY pin and the accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 131

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 133 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor SIGNAL wire shorted to high source
  6. Remote accelerator pedal position sensor open circuit check
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code become active with the remote accelerator pedal position sensor disconnected: 134

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor SIGNAL wire shorted to high source

Solution: S00000452

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector 2 and SUPPLY pin in the OEM wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor open circuit check

Solution: S00000449

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM wiring harness accelerator pedal connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 134 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor open circuit check
  6. Remote accelerator pedal position sensor circuit pin to ground short
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000048

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000370

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the remote accelerator pedal position sensor SUPPLY pin and the remote accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 133

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor circuit pin to ground short

Solution: S00000454

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SUPPLY pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 135 | SPN: 100 | FMI: 3
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor voltage check
  3. Lubricating oil pressure sensor voltage check at the ECM
  4. Lubricating oil pressure sensor circuit response
  5. Lubricating oil pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor voltage check

Solution: S00000455

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the lubricating oil pressure SUPPLY pin to the lubricating oil pressure RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Lubricating oil pressure sensor voltage check at the ECM

Refer to S00000745

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure sensor voltage check at the ECM

Solution: S00000745

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the oil pressure SUPPLY pin to the oil pressure RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Lubricating oil pressure sensor circuit response

Solution: S00000376

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the sensor disconnected: 141

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00001231

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 141
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 141

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 141 | SPN: 100 | FMI: 4
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor voltage check
  3. Lubricating oil pressure sensor voltage check at the ECM
  4. Lubricating oil pressure sensor circuit response
  5. Lubricating oil pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor voltage check

Solution: S00000455

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the lubricating oil pressure SUPPLY pin to the lubricating oil pressure RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Lubricating oil pressure sensor voltage check at the ECM

Refer to S00000745

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure sensor voltage check at the ECM

Solution: S00000745

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the oil pressure SUPPLY pin to the oil pressure RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Lubricating oil pressure sensor circuit response

Solution: S00000377

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00000445

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 135
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 143 | SPN: 100 | FMI: 18
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Basic oil system checks
  4. Contaminated lubricating oil
  5. Lubricating oil pressure sensor stuck in-range
  6. Lubricating oil filter plugged
  7. Lubricating oil pressure relief valve is malfunctioning
  8. Loose or broken lubricating oil suction tube
  9. Main lubricating oil pressure regulator is malfunctioning
  10. Lubricating oil pump is malfunctioning
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009809

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb160024

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 144 | SPN: 110 | FMI: 3
Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code become active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 145
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 145 | SPN: 110 | FMI: 4
Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000313

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code became active with the sensor disconnected: 144

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000319

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 144
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 144

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 151 | SPN: 110 | FMI: 0
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Radiator shutters malfunctioning (if equipped)
  6. Coolant temperature sensor resistance check
  7. Fan clutch operates incorrectly
  8. Thermostat is malfunctioning
  9. Out-of-chassis opening temperature test
  10. Malfunctioning cooling fan drive or cooling fan controls
  11. Combustion gases entering the cooling system
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 153 | SPN: 105 | FMI: 3
Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00000354

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000576

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 154
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 154 | SPN: 105 | FMI: 4
Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00001234

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the sensor disconnected: 153

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000479

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 153
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 153

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 155 | SPN: 105 | FMI: 0
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Cooling fan component inspection
  3. High intake manifold temperature basic checks
  4. Radiator is externally obstructed
  5. Fan clutch operates incorrectly
  6. Intake manifold temperature sensor stuck in-range
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Leaks in the intake air system
  10. Charge air cooler system leak
  11. Malfunctioning cooling fan drive or cooling fan controls
  12. Turbocharger is malfunctioning
  13. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000050

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Fan control circuit: 245, 2377

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 175 | SPN: 3464 | FMI: 3
Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Open circuit in the engine intake throttle actuator motor
  3. Engine intake throttle actuator motor resistance check
  4. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00009808

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb120060

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Open circuit in the engine intake throttle actuator motor

Solution: S00000804

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor connector RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 15 Ω

Linked Solutions

Click on the link below:

  • Engine intake throttle actuator motor resistance check

Refer to S00000805

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator motor resistance check

Solution: S00000805

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is greater than the following specification: 15 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 15 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 176 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Engine intake throttle actuator motor shorted to ground
  3. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00009808

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb120060

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator motor shorted to ground

Solution: S00000493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 177 | SPN: 3464 | FMI: 7
Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Restricted engine intake throttle
  2. ECM calibration revision history check
  3. Engine intake throttle actuator not responding or out of adjustment

1 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator not responding or out of adjustment

Solution: S00001034

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 187 | SPN: 3510 | FMI: 4
Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal

1 - ECM sensor supply 2 voltage above normal

Solution: S00006005

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Perform the following actions one at a time:
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine barometric pressure sensor from the engine wiring harness.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine wiring harness.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 25-Jan-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 195 | SPN: 111 | FMI: 3
Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant level sensor circuit response (2-wire)
  2. Coolant level sensor is malfunctioning
  3. Coolant level sensor open circuit check (3-wire)
  4. Coolant level sensor open circuit check (2-wire)
  5. Coolant level sensor circuit pin to pin short (3-wire)
  6. Coolant level sensor circuit pin to pin short (2-wire)

1 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 196 | SPN: 111 | FMI: 4
Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level sensor voltage check
  3. Coolant level sensor circuit check
  4. Coolant level sensor circuit response (2-wire)
  5. Coolant level sensor is malfunctioning
  6. Coolant level sensor open circuit check (3-wire)
  7. Coolant level sensor open circuit check (2-wire)
  8. Coolant level sensor circuit pin to ground short
  9. Coolant level sensor circuit pin to pin short (3-wire)
  10. Coolant level sensor circuit pin to pin short (2-wire)

1 - Check for primary fault codes

Solution: S00000054

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level sensor voltage check

Solution: S00000727

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the coolant level sensor SUPPLY pin to the coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Coolant level sensor circuit check

Refer to S00000815

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor circuit check

Solution: S00000815

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to ground short

Solution: S00000499

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 197 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 212 | SPN: 175 | FMI: 3
Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check
  2. Lubricating oil temperature sensor circuit response
  3. Lubricating oil temperature sensor circuit response at the ECM

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil temperature sensor circuit response

Solution: S00003662

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the jumper wire in place: 213

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor circuit response at the ECM

Solution: S00000586

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 213
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 213

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 213 | SPN: 175 | FMI: 4
Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check
  2. Lubricating oil temperature sensor circuit response
  3. Lubricating oil temperature sensor circuit response at the ECM

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil temperature sensor circuit response

Solution: S00000371

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the sensor disconnected: 212

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor circuit response at the ECM

Solution: S00000585

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 212
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 212

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 214 | SPN: 175 | FMI: 0
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil temperature sensor resistance check
  4. Lubricating oil thermostat is malfunctioning
  5. Lubricating oil cooler is malfunctioning or restricted
  6. Lubricating oil cooler is leaking
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil cooler is malfunctioning or restricted

Solution: S00000543

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the lubricating oil cooler for debris.

Refer to Procedure 007-003

Specification

  • If debris is found in the lubricating oil cooler, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the lubricating oil cooler.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil cooler is leaking

Solution: S00000810

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Pressure test the lubricating oil cooler.

Refer to Procedure 007-003

Specification

  • If there are any lubricating oil cooler leaks during the pressure test or any damage is observed during inspection, then a malfunctioning lubricating oil cooler or gaskets have been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil cooler.

Refer to Procedure 007-003

  • Replace the lubricating oil cooler element, mounting plate gasket or o-ring.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 221 | SPN: 108 | FMI: 3
Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric pressure sensor voltage check
  3. Barometric pressure sensor voltage check at the ECM
  4. Barometric pressure sensor circuit response
  5. Barometric sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000060

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 386
  • Sensor supply 2: 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Barometric pressure sensor circuit response

Solution: S00000372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the sensor disconnected: 222

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric sensor circuit response at the ECM

Solution: S00000579

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 222
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 222

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 222 | SPN: 108 | FMI: 4
Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric pressure sensor voltage check
  3. Barometric pressure sensor voltage check at the ECM
  4. Barometric pressure sensor circuit response
  5. Barometric sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000062

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352
  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Barometric pressure sensor circuit response

Solution: S00000373

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric sensor circuit response at the ECM

Solution: S00000581

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 221
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 227 | SPN: 3510 | FMI: 3
Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 2 voltage above normal

Solution: S00000992

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 227
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 227

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 234 | SPN: 190 | FMI: 0
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine speed sensor is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000067

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689
  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 235 | SPN: 111 | FMI: 1
Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 238 | SPN: 3511 | FMI: 4
Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage below normal

Solution: S00001086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 239 | SPN: 3511 | FMI: 3
Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage above normal

Solution: S00000819

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 239
  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 239

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 241 | SPN: 84 | FMI: 2
Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Vehicle speed sensor resistance check
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. Mechanical gear slippage causing erratic wheel speed data
  8. ECM calibration revision history check

1 - Vehicle speed sensor resistance check

Solution: S00003664

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Specification

  • If the resistance is not within specification, then a malfunctioning vehicle speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 242 | SPN: 84 | FMI: 10
Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Troubleshooting Summary

  1. Incorrect vehicle speed signal
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Incorrect vehicle speed signal

Solution: S00003601

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the vehicle speed sensor while the vehicle is stationary.
  • Drive vehicle or test on chassis dynamometer.
  • Compare the sensor reading from the recommended Cummins® electronic service tool or equivalent to the reading on the vehicle dash.

Specification

  • If the recommended Cummins® electronic service tool or equivalent and vehicle dash reading do not match, then an incorrect parameter setting has been detected.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 245 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid resistance check
  2. Fan control solenoid circuit pin to ground short
  3. Fan control solenoid circuit pin to pin short
  4. Fan control solenoid is malfunctioning

1 - Fan control solenoid resistance check

Solution: S00001059

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan control solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fan control solenoid resistance does not meet specification, then a malfunctioning fan control solenoid has been detected.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to ground short

Solution: S00001060

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 249 | SPN: 171 | FMI: 3
Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor open circuit check
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000374

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the sensor connector of the OEM wiring harness
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the jumper wire in place: 256

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 256 | SPN: 171 | FMI: 4
Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor circuit pin to ground short
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000375

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the sensor disconnected: 249

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor circuit pin to ground short

Solution: S00003624

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 269 | SPN: 1195 | FMI: 2
Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Immobilizer anti-theft device not deactivated
  2. ECM calibration revision history check

1 - Immobilizer anti-theft device not deactivated

Solution: S00001698

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the immobilizer anti-theft device has not been deactivated, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Deactivate the immobilizer anti-theft device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 271 | SPN: 1347 | FMI: 4
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator circuit pin to ground short
  3. Fuel pump actuator circuit pin to pin short
  4. ECM calibration revision history check

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator circuit pin to pin short

Solution: S00000500

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 272 | SPN: 1347 | FMI: 3
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator open circuit check
  3. Fuel pump actuator circuit pin to ground short
  4. Fuel pump actuator circuit pin to pin short
  5. ECM calibration revision history check
  6. Fuel pump actuator is malfunctioning

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator open circuit check

Solution: S00000508

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness fuel pump actuator RETURN pin at the ECM connector of the engine wiring harness and the fuel pump actuator RETURN pin at the fuel pump actuator connector.
  • Measure the resistance between the engine wiring harness fuel pump actuator SIGNAL pin at the ECM connector of the engine wiring harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator circuit pin to pin short

Solution: S00000500

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 285 | SPN: 639 | FMI: 9
SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 286 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 287 | SPN: 91 | FMI: 19
Accelerator Pedal Position 1 - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 288 | SPN: 974 | FMI: 19
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 291 | SPN: 625 | FMI: 9
Proprietary Datalink Error (OEM/Vehicle Datalink) - Abnormal Update Rate

Troubleshooting Summary

  1. Immobilizer anti-theft device configuration incorrect
  2. ECM calibration revision history check

1 - Immobilizer anti-theft device configuration incorrect

Solution: S00002082

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify the immobilizer anti-theft device is correct for the engine configuration.

Refer to OEM Service Manual

Specification

  • If the immobilizer anti-theft device is not correct for the engine configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the immobilizer anti-theft device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 319 | SPN: 251 | FMI: 2
Real Time Clock - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Real-time clock power interrupted or is incorrect
  2. Low real-time clock battery voltage
  3. Real time clock open circuit check
  4. Real time clock circuit pin to ground short
  5. Engine wiring harness has a pin to pin short
  6. ECM calibration revision history check

1 - Real-time clock power interrupted or is incorrect

Solution: S00000525

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Select Advanced ECM Data - Real Time Clock Settings.
  • Check if the address for the Real Time Clock signal is correct per OEM specification.
  • Check to ensure Real Time Clock is enabled and adjust "Auto Set" if required.

Refer to Procedure 019-311

Specification

  • None

Linked Solutions

  • None

Repair

  • Modify the real-time clock battery setting to the correct configuration.

Refer to Procedure 019-311

  • Enable the real time clock.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low real-time clock battery voltage

Solution: S00000526

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.

Action

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Specification

  • Voltage must be within the following specification: 3.3 - 3.6 VDC

Linked Solutions

  • None

Repair

  • Replace the real-time clock battery.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Real time clock open circuit check

Solution: S00001966

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the real time clock battery engine wiring harness connector and the real time clock battery SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the real time clock battery RETURN pin at the real time clock battery engine wiring harness connector and the real time clock battery RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Real time clock circuit pin to ground short

Solution: S00001964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the engine wiring harness ECM connect to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine wiring harness has a pin to pin short

Solution: S00001967

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the ECM connector of the engine wiring harness and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 322 | SPN: 651 | FMI: 5
Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 1 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 1 current below normal or open circuit

Solution: S00000513

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 322

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 323 | SPN: 655 | FMI: 5
Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 5 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 5 current below normal or open circuit

Solution: S00000506

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 323

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 324 | SPN: 653 | FMI: 5
Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 3 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 3 current below normal or open circuit

Solution: S00000509

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 324

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 325 | SPN: 656 | FMI: 5
Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 6 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 6 current below normal or open circuit

Solution: S00000510

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 325

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 331 | SPN: 652 | FMI: 5
Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 2 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 2 current below normal or open circuit

Solution: S00000512

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 331

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 332 | SPN: 654 | FMI: 5
Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 4 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 4 current below normal or open circuit

Solution: S00000511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 332

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 343 | SPN: 629 | FMI: 12
Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Charging system alternator is malfunctioning
  4. Keyswitch open circuit check
  5. ECM calibration revision history check
  6. ECM Malfunction

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 346 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00002237

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.

Verify the following parameters:

Refer to Procedure 019-078

  • Accelerator interlock switch.
  • Powertrain protection torque limit switch.
  • Clutch pedal position switch.
  • Engine protection shutdown manual override switch.
  • Idle shutdown accessory relay.
  • Engine brake lamp output.
  • Air shutoff valve.

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 351 | SPN: 3597 | FMI: 12
Injector Power Supply - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. Battery or battery cables are malfunctioning
  3. ECM power supply open circuit check
  4. Engine control module power supply circuit pin to ground short
  5. ECM calibration revision history check
  6. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000077

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM power supply open circuit check

Solution: S00001889

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the OEM wiring harness connector and the battery positive (+) pins at the battery positive (+) connection.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 0.5 Ω
  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 0.5 Ω

Linked Solutions

Click on the link below:

  • Engine control module power supply circuit pin to ground short

Refer to S00002882

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • None
Next Solution

3.1 - Engine control module power supply circuit pin to ground short

Solution: S00002882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery negative (-) pins at the OEM wiring harness connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 415 | SPN: 100 | FMI: 1
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Basic oil system checks
  4. Contaminated lubricating oil
  5. Lubricating oil pressure sensor stuck in-range
  6. Lubricating oil filter plugged
  7. Lubricating oil pressure relief valve is malfunctioning
  8. Loose or broken lubricating oil suction tube
  9. Main lubricating oil pressure regulator is malfunctioning
  10. Lubricating oil pump is malfunctioning
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009808

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb120060

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 418 | SPN: 97 | FMI: 15
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Water accumulation in the fuel filter
  3. Water in fuel sensor circuit pin to ground short
  4. OEM wiring harness has a pin to pin short
  5. ECM calibration revision history check
  6. Water in fuel sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000079

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 428, 429

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor circuit pin to ground short

Solution: S00000874

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 425 | SPN: 175 | FMI: 2
Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil temperature sensor resistance check
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 212, 213

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 428 | SPN: 97 | FMI: 3
Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect water-in-fuel sensor installed
  2. Water in fuel sensor open circuit check
  3. OEM wiring harness has a pin to pin short
  4. Water in fuel sensor is malfunctioning

1 - Incorrect water-in-fuel sensor installed

Solution: S00000588

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct water-in-fuel sensor is being used for the engine application.

Specification

  • If the water in fuel sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Install the correct water in fuel sensor for the engine configuration.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor open circuit check

Solution: S00001865

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water in fuel sensor SIGNAL pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the water in fuel sensor RETURN pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 429 | SPN: 97 | FMI: 4
Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Water in fuel sensor circuit pin to ground short
  2. OEM wiring harness has a pin to pin short
  3. Water in fuel sensor is malfunctioning

1 - Water in fuel sensor circuit pin to ground short

Solution: S00000874

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 435 | SPN: 100 | FMI: 2
Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor stuck in-range
  3. Lubricating oil pressure check
  4. Lubricating oil pressure relief valve is malfunctioning
  5. Main lubricating oil pressure regulator is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000087

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure check

Solution: S00003162

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Install a mechanical gauge on the engine.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Monitor the lubricating oil pressure.

Specification

  • If the lubricating oil pressure is not within specification, then proceed to the Linked Solutions section.

Refer to Procedure 018-017

Linked Solutions

  • Lubricating oil pressure relief valve is malfunctioning

Refer to S00004717

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00004717

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Perform following checks for progressive damage.

  • Perform the oil filter analysis.

Refer to Procedure 007-083

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 441 | SPN: 168 | FMI: 18
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. Unswitched battery open circuit check
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 442 | SPN: 168 | FMI: 16
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 451 | SPN: 157 | FMI: 3
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Fuel rail pressure sensor voltage check
  4. Fuel rail pressure sensor voltage check at the ECM
  5. Fuel rail pressure sensor circuit response
  6. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00002469

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel rail pressure sensor circuit response

Solution: S00000378

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000604

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 452
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 452 | SPN: 157 | FMI: 4
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail pressure sensor circuit response
  5. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail pressure sensor circuit response

Solution: S00000379

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the sensor disconnected: 451

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000605

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 451
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 451

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 515 | SPN: 3514 | FMI: 3
Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage above normal

Solution: S00000026

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 515
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 515

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 553 | SPN: 157 | FMI: 16
Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator o-ring is malfunctioning
  6. ECM calibration revision history check
  7. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000108

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 449, 2311

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator o-ring is malfunctioning

Solution: S00000620

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

  • Visually inspect fuel pump actuator for a cut or damaged o-ring.
  • Visually inspect the wiring or body of the actuator for damage.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the o-ring.

Refer to Procedure 019-117

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 559 | SPN: 157 | FMI: 18
Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine will not start
  3. Low pressure fuel system component is malfunctioning
  4. Fuel Inlet Restriction check
  5. Air in fuel check
  6. Fuel filter differential and gear pump pressure check
  7. Fuel injector return flow check
  8. Fuel injector isolation test
  9. Fuel pressure relief valve return flow excessive
  10. Air in fuel check
  11. High-Pressure Fuel Pump Performance Test
  12. Fuel pump actuator is malfunctioning
  13. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000109

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 281, 449, 451, 452, 484, 553, 1911, 2311, 2343, 2372, 3727, 4691, 4726, 5585
  • Fuel injector: 322, 323, 324, 325, 331, 332
  • Voltage: 1117
  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - High-Pressure Fuel Pump Performance Test

Solution: S00005120

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Fuel Pump Performance Test.

Refer to Procedure 005-236

Specification

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the upper region of the graph, the fuel pump is functioning properly.

Refer to Procedure 005-236

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the lower region of the graph, then a malfunctioning fuel pump has been detected.

Refer to Procedure 005-236

  • If the test readings are in the gray area, the fuel pump head must be removed and the fuel pump camshaft and fuel pump camshaft tappet rollers must be inspected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel pump head.

Refer to Procedure 005-227

  • Replace high pressure fuel pump.

Refer to Procedure 005-227

Refer to tsb140019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Fuel pump actuator is malfunctioning

Solution: S00001170

Verification

Conditions

  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor Commanded Fuel Rail Pressure.
  • Monitor Measured Fuel Rail Pressure.

Specification

  • Proceed to the Repair section if the Measured Fuel Rail Pressure deviates from the Commanded Fuel Rail Pressure by more than following: 100 bar [1450 psi]
  • Proceed to the next solution if the Measured Fuel Rail Pressure does not deviate from the Commanded Fuel Rail Pressure by more than the following: 100 bar [1450 psi]

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 584 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay open circuit check
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 585 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay circuit pin to ground short
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 595 | SPN: 103 | FMI: 16
Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Intake manifold pressure sensor has carbon buildup
  2. Intake manifold pressure sensor stuck in-range
  3. Turbocharger speed sensor circuit pin to ground short
  4. ECM calibration revision history check
  5. Turbocharger speed sensor is malfunctioning

1 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor circuit pin to ground short

Solution: S00000673

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the turbocharger speed SIGNAL pin at the engine wiring harness ECM connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 596 | SPN: 167 | FMI: 16
Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 597 | SPN: 167 | FMI: 18
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Loose alternator belt
  3. Charging system alternator is malfunctioning
  4. Unswitched battery open circuit check
  5. Unswitched battery circuit pin to pin short
  6. Loose charging system alternator pulley
  7. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose alternator belt

Solution: S00000665

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 013-005

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 013-021

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 013-005

  • Replace the alternator belt.

Refer to Procedure 013-005

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose charging system alternator pulley

Solution: S00000666

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the alternator pulley for damage.

Refer to Procedure 013-006

  • Check the charging system alternator pulley nut torque.

Refer to Procedure 013-006

Specification

  • If damage has been observed or if alternator pulley nut torque is out of specification, the proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace or adjust the charging system alternator pulley so that it is tight on the shaft.

Refer to Procedure 013-006

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 598 | SPN: 167 | FMI: 1
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Loose alternator belt
  4. Charging system alternator is malfunctioning
  5. Unswitched battery open circuit check
  6. Unswitched battery circuit pin to pin short
  7. ECM calibration revision history check

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Loose alternator belt

Solution: S00000665

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 013-005

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 013-021

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 013-005

  • Replace the alternator belt.

Refer to Procedure 013-005

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 649 | SPN: 1378 | FMI: 31
Engine Oil Change Interval - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Oil change interval maintenance warning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Oil change interval maintenance warning

Solution: S00000671

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the lubricating oil maintenance interval has been exceeded.

Linked Solutions

  • None

Repair

  • Change the lubricating oil.

Refer to Procedure 007-037

  • Change the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 689 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankshaft tone wheel is damaged
  3. Crankshaft position sensor voltage check
  4. Crankshaft position sensor voltage check at the ECM
  5. Engine crankshaft speed/position sensor check
  6. Crankshaft position sensor open circuit check
  7. Crankshaft position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 3: 238, 239
  • Crankshaft speed/position sensor: 284

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankshaft tone wheel is damaged

Solution: S00000683

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor voltage check

Solution: S00000678

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft position sensor SUPPLY pin and the crankshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankshaft position sensor voltage check at the ECM

Refer to S00000679

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Crankshaft position sensor voltage check at the ECM

Solution: S00000679

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft positon sensor SUPPLY pin and the crankshaft positon sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft position sensor circuit pin to pin short

Solution: S00000674

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 731 | SPN: 723 | FMI: 7
Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intermittent ground connection
  3. Incorrect base engine timing
  4. Camshaft position sensor is damaged
  5. Engine crankshaft speed/position sensor check
  6. Crankshaft/camshaft tone wheel
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001081

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 115, 778, 2321

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect base engine timing

Solution: S00000689

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the base engine timing.

Refer to Procedure 001-088

Specification

  • If the camshaft and crankshaft gears are not properly aligned, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Correct the base engine timing.

Refer to Procedure 001-088

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft/camshaft tone wheel

Solution: S00003847

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.
  • Visually inspect the camshaft tone wheel for defects.
  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft tone wheel.

Refer to Procedure 001-112

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 778 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. Crankshaft/camshaft tone wheel
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006538

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft/camshaft tone wheel

Solution: S00003847

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.
  • Visually inspect the camshaft tone wheel for defects.
  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft tone wheel.

Refer to Procedure 001-112

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 784 | SPN: 1590 | FMI: 2
Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Malfunctioning adaptive cruise control circuit (If equipped)
  3. Malfunctioning adaptive cruise control circuit (If equipped)
  4. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00002898

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Check the adjustable parameters settings.

Refer to Procedure 019-078

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00000701

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the vehicle for installed adaptive cruise control hardware.

Specification

  • If adaptive cruise control hardware is not installed on the vehicle, then use the recommended Cummins® electronic service tool or equivalent to disable the Adaptive Cruise feature.
  • If adaptive cruise control hardware has been installed on the vehicle, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Malfunctioning adaptive cruise control circuit (If equipped)

Refer to S00001082

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00001082

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Connect the INLINE™ data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Attempt to communicate with the ECM.
  • Select INLINE™ J1939 ECM connection.
  • Verify recommended Cummins® electronic service tool or equivalent communication with the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • For communication error, determine the cause of the loss of communication between the ECM and the adaptive cruise control hardware.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1117 | SPN: 3597 | FMI: 2
Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery power removed by battery disconnect switch
  2. Battery or battery cables are malfunctioning
  3. Battery load test
  4. Unswitched battery open circuit check
  5. Keyswitch open circuit check
  6. Intermittent ground connection
  7. ECM calibration revision history check

1 - Battery power removed by battery disconnect switch

Solution: S00000706

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify that the battery disconnect switches are being used correctly.

The keyswitch must be turned OFF first for 90 seconds before any battery disconnect switches are turned OFF.

Specification

  • If the battery disconnect switches are not being used correctly, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remind the operator how to correctly use the battery disconnect switches.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Battery load test

Solution: S00000669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the batteries.

Refer to Procedure 013-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intermittent ground connection

Solution: S00000707

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.
  • Visually inspect the ECM ground for damage, corrosion and loose connections.

Specification

  • If the ECM to cylinder block connection resistance is greater than 10 Ω, then a malfunctioning ground connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the ECM-to-ground connection.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1239 | SPN: 2623 | FMI: 3
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000134

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1241 | SPN: 2623 | FMI: 4
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to ground short
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000135

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1242 | SPN: 91 | FMI: 2
Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000136

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1515 | SPN: 91 | FMI: 19
Accelerator Pedal Position 1 - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1654 | SPN: 1323 | FMI: 31
Engine Misfire Cylinder 1 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000935

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3741, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1655 | SPN: 1324 | FMI: 31
Engine Misfire Cylinder 2 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000936

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3727, 3741, 4691, 4726, 4747, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1656 | SPN: 1325 | FMI: 31
Engine Misfire Cylinder 3 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000937

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2222, 2223, 2311, 2343, 2372, 3338, 3727, 4284, 4616, 4691, 4727, 6258, 6259, 6339, 6341, 6342, 6343
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1657 | SPN: 1326 | FMI: 31
Engine Misfire Cylinder 4 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000938

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2343, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1658 | SPN: 1327 | FMI: 31
Engine Misfire Cylinder 5 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1659 | SPN: 1328 | FMI: 31
Engine Misfire Cylinder 6 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000940

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2343, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1668 | SPN: 1761 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit response
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001645

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit response

Solution: S00000393

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor has been detected if the following fault code became active with the sensor disconnected: 1669

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00003124

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level sensor voltage SUPPLY pin and the aftertreatment diesel exhaust fluid tank level sensor voltage RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1669 | SPN: 1761 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid tank level sensor circuit response
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002469

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor circuit response

Solution: S00000392

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor has been detected if the following fault code became active with the jumper wire in place: 1668

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1671 | SPN: 1761 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1673 | SPN: 1761 | FMI: 1
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1677 | SPN: 3031 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)
  2. Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin to ground short
  3. Aftertreatment diesel exhaust fluid tank level sensor pin to pin short
  4. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)

Solution: S00000947

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1678

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank temperature sensor .

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin to ground short

Solution: S00001672

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor pin to pin short

Solution: S00003111

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1678 | SPN: 3031 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)
  2. Aftertreatment diesel exhaust fluid tank level sensor pin to pin short
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)

Solution: S00000397

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the following fault code became active with the jumper wire in place: 1677

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor pin to pin short

Solution: S00003111

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1679 | SPN: 3031 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. OEM ambient air temperature sensor stuck in-range
  3. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  4. Aftertreatment diesel exhaust fluid tank level sensor pin to pin short
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001592

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678
  • Ambient air temperature: 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00003127

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor pin to pin short

Solution: S00003111

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1681 | SPN: 3361 | FMI: 12
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Bad Intelligent Device or Component

Troubleshooting Summary

  1. OEM ambient air temperature sensor stuck in-range
  2. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003112

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 019-440

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1683 | SPN: 3363 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank heater control valve open circuit check
  2. Aftertreatment diesel exhaust fluid tank heater relay circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid tank heater control valve open circuit check

Solution: S00003122

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve RETURN pin at the aftertreatment diesel exhaust fluid tank heater control valve OEM wiring harness connector and engine block ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the aftertreatment diesel exhaust fluid tank heater control valve OEM wiring harness connector and the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank heater relay circuit pin to pin short

Solution: S00003117

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 10-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1684 | SPN: 3363 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short
  2. Aftertreatment diesel exhaust fluid tank heater relay circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short

Solution: S00003121

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank heater relay circuit pin to pin short

Solution: S00003117

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-Jun-2021


NO TITLE

ISX15 CM2250 SN

Fault Code: 1695 | SPN: 3513 | FMI: 3
Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. OEM wiring harness has a short to battery
  2. ECM calibration revision history check

1 - OEM wiring harness has a short to battery

Solution: S00000970

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector to the ECM battery (+) pins at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning ECM has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1696 | SPN: 3513 | FMI: 4
Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. OEM wiring harness has a short to ground
  2. ECM sensor supply 5 circuit pin to pin short
  3. ECM calibration revision history check

1 - OEM wiring harness has a short to ground

Solution: S00001229

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and engine block ground.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM sensor supply 5 circuit pin to pin short

Solution: S00000542

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and all other pins in the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1697 | SPN: 3489 | FMI: 3
Air Supply Actuator - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit air solenoid resistance check
  2. Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid resistance check

Solution: S00003361

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin and ground at the aftertreatment diesel exhaust fluid dosing unit air solenoid.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k ohms

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to pin short

Solution: S00003360

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit OEM wiring harness connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-May-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 1698 | SPN: 3489 | FMI: 4
Air Supply Actuator - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit air solenoid open circuit check
  2. Aftertreatment diesel exhaust fluid dosing unit air solenoid resistance check
  3. Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to ground short
  4. Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid open circuit check

Solution: S00003399

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit air solenoid OEM wiring harness connector and aftertreatment diesel exhaust fluid air solenoid SIGNAL pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid RETURN pin at the aftertreatment diesel exhaust fluid dosing unit air solenoid OEM wiring harness connector and aftertreatment diesel exhaust fluid air solenoid RETURN pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit air solenoid resistance check

Solution: S00003361

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin and ground at the aftertreatment diesel exhaust fluid dosing unit air solenoid.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to ground short

Solution: S00003398

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin and ground at the aftertreatment diesel exhaust fluid dosing unit OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit air solenoid circuit pin to pin short

Solution: S00003360

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit air solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit air solenoid SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit OEM wiring harness connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-Oct-2021


NO TITLE

ISX15 CM2250 SN

Fault Code: 1711 | SPN: 3361 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Abnormal Update Rate

Troubleshooting Summary

  1. Low battery voltage
  2. Battery load test
  3. Ground inspection
  4. J1939 data link harness open circuit check
  5. J1939 data link harness pin to ground short circuit
  6. OEM terminating resistor Ω check for the J1939 data link

1 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - J1939 data link harness open circuit check

Solution: S00003411

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid quality sensor SAE J1939 data link (+) pin at the aftertreatment diesel exhaust fluid quality sensor and the aftertreatment diesel exhaust fluid quality SAE J1939 data link (+) pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid quality sensor SAE J1939 data link (+) pin at the aftertreatment diesel exhaust fluid quality sensor and the aftertreatment diesel exhaust fluid quality SAE J1939 data link (+) pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - J1939 data link harness pin to ground short circuit

Solution: S00003416

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin at the ECM connector of the engine wiring harness and ground.
  • Measure the resistance between the SAE J1939 data link (-) pin at the ECM connector of the engine wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00002947

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect all data linked components except the variable geometry turbocharger actuator.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1712 | SPN: 3363 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. No coolant flow through diesel exhaust fluid tank heater line
  3. Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines
  4. Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000147

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678, 1679, 1683, 1684, 3242, 3576

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - No coolant flow through diesel exhaust fluid tank heater line

Solution: S00001102

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.

Specification

  • If the coolant level is low, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • For low coolant level, add coolant and visually inspect the engine components for traces of a coolant leak.

Refer to Procedure 008-018

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines

Solution: S00000784

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify that the engine coolant level is within normal operating range.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for signs of damage, leaking lines, leaking gaskets, leaking seals, or loose connections.

Refer to OEM Service Manual

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for kinks, or restrictions including the OEM in-line shutoff valve.

Refer to OEM Service Manual

Specification

  • If there are any leaks or restrictions in the aftertreatment diesel exhaust fluid tank heater coolant lines, then a malfunctioning aftertreatment diesel exhaust fluid tank heater coolant line or connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly

Solution: S00000547

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly, and not reversed.

Specification

  • If the aftertreatment diesel exhaust fluid tank heater control valve is reversed, then the incorrect installation of the aftertreatment diesel exhaust fluid tank heater control valve has been detected.
  • If the aftertreatment diesel exhaust fluid tank heater control valve is not reversed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1713 | SPN: 3363 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  3. Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000148

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678, 1679, 1683, 1684, 3576, 4737

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00000574

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly

Solution: S00000547

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly, and not reversed.

Specification

  • If the aftertreatment diesel exhaust fluid tank heater control valve is reversed, then the incorrect installation of the aftertreatment diesel exhaust fluid tank heater control valve has been detected.
  • If the aftertreatment diesel exhaust fluid tank heater control valve is not reversed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1852 | SPN: 97 | FMI: 16
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Water accumulation in the fuel filter
  2. Water in fuel sensor circuit pin to ground short
  3. ECM calibration revision history check
  4. Water in fuel sensor is malfunctioning

1 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor circuit pin to ground short

Solution: S00000874

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1887 | SPN: 3226 | FMI: 4
Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000160

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 2771, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000587

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine hours, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 1911 | SPN: 157 | FMI: 0
Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator open circuit check
  6. Fuel pump actuator circuit pin to ground short

1 - Check for primary fault codes

Solution: S00001711

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 449, 451, 452, 553, 2261, 2311, 2372, 3727

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator open circuit check

Solution: S00000771

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump actuator RETURN pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2182 | SPN: 1072 | FMI: 3
Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2183 | SPN: 1072 | FMI: 4
Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2185 | SPN: 3512 | FMI: 3
Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Sensor supply 4 circuit pin to pin short
  2. Sensor supply 4 voltage error due to ECM

1 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2186 | SPN: 3512 | FMI: 4
Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Accelerator pedal or lever position sensor circuit pin to ground short
  2. Sensor supply 4 circuit pin to pin short
  3. Sensor supply 4 voltage error due to ECM

1 - Accelerator pedal or lever position sensor circuit pin to ground short

Solution: S00000731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal or lever position sensor +5 volt SUPPLY pin in the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2265 | SPN: 1075 | FMI: 3
Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Electric fuel lift pump circuit response at the ECM
  2. Electric fuel lift pump relay is malfunctioning
  3. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump circuit response at the ECM

Solution: S00003050

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2266
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2266

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Electric fuel lift pump relay is malfunctioning

Solution: S00003334

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump relay from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the electric fuel lift pump relay SIGNAL pin 85 and the fuel lift pump relay RETURN pin 86 at the electric fuel lift pump relay.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning electric fuel lift pump relay has been detected.

Refer to Procedure 019-397

Linked Solutions

  • None

Repair

  • Replace the electric fuel lift pump relay.

Refer to Procedure 019-397

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Electric fuel lift pump circuit pin to pin short

Solution: S00003437

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the electric fuel lift pump relay SIGNAL pin at the electric fuel lift pump relay engine wiring harness connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2266 | SPN: 1075 | FMI: 4
Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Electric fuel lift pump circuit response at the ECM
  2. Electric fuel lift pump relay is malfunctioning
  3. Electric fuel lift pump circuit pin to ground short
  4. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump circuit response at the ECM

Solution: S00003049

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2265
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2265

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Electric fuel lift pump relay is malfunctioning

Solution: S00003334

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump relay from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the electric fuel lift pump relay SIGNAL pin 85 and the fuel lift pump relay RETURN pin 86 at the electric fuel lift pump relay.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning electric fuel lift pump relay has been detected.

Refer to Procedure 019-397

Linked Solutions

  • None

Repair

  • Replace the electric fuel lift pump relay.

Refer to Procedure 019-397

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Electric fuel lift pump circuit pin to ground short

Solution: S00001055

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Electric fuel lift pump circuit pin to pin short

Solution: S00003437

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the electric fuel lift pump relay SIGNAL pin at the electric fuel lift pump relay engine wiring harness connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2311 | SPN: 633 | FMI: 31
Electronic Fuel Injection Control Valve Circuit - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel pump actuator resistance check
  3. Fuel pump actuator open circuit check
  4. Fuel pump actuator circuit pin to ground short
  5. ECM calibration revision history check
  6. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator open circuit check

Solution: S00000771

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump actuator RETURN pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel pump actuator is malfunctioning

Solution: S00002783

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2321 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine crankshaft speed/position sensor check
  3. Crankshaft position sensor open circuit check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000185

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2322 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2363 | SPN: 1073 | FMI: 4
Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve resistance check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid 2 harness pin to ground short
  5. Engine brake solenoid circuit pin to pin short
  6. Engine wiring harness has a pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid 2 harness pin to ground short

Solution: S00001030

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine wiring harness has a pin to pin short

Solution: S00000774

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2367 | SPN: 1073 | FMI: 3
Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short
  5. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the engine brake connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2372 | SPN: 95 | FMI: 16
Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Engine will not start
  2. Low pressure fuel system component is malfunctioning
  3. Fuel Inlet Restriction check
  4. Air in fuel check
  5. Fuel filter differential and gear pump pressure check
  6. Fuel injector return flow check
  7. Fuel injector isolation test
  8. Fuel pressure relief valve return flow excessive
  9. Air in fuel check

1 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2377 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid open circuit check
  2. Fan control solenoid circuit pin to pin short
  3. Fan control solenoid is malfunctioning

1 - Fan control solenoid open circuit check

Solution: S00001057

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness engine control module fan control SIGNAL pin and the OEM wiring harness fan control connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness engine control module fan control RETURN pin and the OEM wiring harness fan control connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2398 | SPN: 171 | FMI: 2
Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. OEM ambient air temperature sensor stuck in-range
  4. Ambient air temperature sensor open circuit check
  5. Ambient air temperature sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000195

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2412 | SPN: 1639 | FMI: 2
Fan Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Fan speed sensor open circuit check
  2. Fan speed sensor circuit pin to ground short
  3. Fan speed sensor resistance check
  4. Fan speed sensor circuit pin to pin short
  5. Malfunctioning cooling fan drive or cooling fan controls

1 - Fan speed sensor open circuit check

Solution: S00003668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the fan speed sensor OEM wiring harness connector and the fan speed sensor SIGNAL pin OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan speed sensor circuit pin to ground short

Solution: S00003665

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan speed sensor resistance check

Solution: S00003667

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan speed sensor.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan speed sensor circuit pin to pin short

Solution: S00003666

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00001907

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Wait for 30 seconds.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning fan speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2448 | SPN: 111 | FMI: 17
Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Coolant level check
  4. Coolant level sensor open circuit check
  5. Coolant level sensor circuit pin to ground short
  6. Coolant level sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001388

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant level: 197

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2468 | SPN: 190 | FMI: 16
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Engine speed sensor is malfunctioning

1 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2738 | SPN: 626 | FMI: 3
Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ether injection solenoid resistance check
  2. Ether injection solenoid voltage check
  3. Ether injection solenoid open circuit check
  4. Ether injection solenoid open circuit check
  5. Ether injection solenoid pin to pin short in the OEM wiring harness

1 - Ether injection solenoid resistance check

Solution: S00000406

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin of the ether injection solenoid connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10k Ω

Linked Solutions

  • None

Repair

  • Replace the ether injection solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ether injection solenoid voltage check

Solution: S00001093

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Ether injection solenoid open circuit check

Refer to S00001094

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Ether injection solenoid open circuit check

Solution: S00001094

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Ether injection solenoid open circuit check

Solution: S00000407

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ether injection solenoid pin to pin short in the OEM wiring harness

Solution: S00001095

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2739 | SPN: 626 | FMI: 4
Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ether injection solenoid resistance check
  2. Ether injection solenoid voltage check
  3. Ether injection solenoid open circuit check
  4. Ether injection solenoid circuit OEM wiring harness short-to ground
  5. Ether injection solenoid pin to pin short in the OEM wiring harness

1 - Ether injection solenoid resistance check

Solution: S00001096

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin of the ether injection solenoid connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 3 Ω

Linked Solutions

  • None

Repair

  • Replace the ether injection solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ether injection solenoid voltage check

Solution: S00001093

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Ether injection solenoid open circuit check

Refer to S00001094

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Ether injection solenoid open circuit check

Solution: S00001094

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Ether injection solenoid circuit OEM wiring harness short-to ground

Solution: S00001098

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection SIGNAL pin of the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ether injection solenoid pin to pin short in the OEM wiring harness

Solution: S00001095

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2771 | SPN: 3226 | FMI: 9
Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment outlet NOx sensor has incorrect voltage
  6. Aftertreatment outlet NOx sensor open circuit
  7. Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  8. J1939 data link terminating resistance is incorrect
  9. J1939 data link engine wiring harness voltage check 3 pin service connector
  10. J1939 data link harness open circuit check
  11. OEM terminating resistor Ω check for the J1939 data link
  12. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  13. J1939 wire resistance check at the crossover connector for each component
  14. ECM calibration revision history check
  15. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000210

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment outlet NOx sensor has incorrect voltage

Solution: S00000882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Visually verify that the OEM fuses are not damaged or malfunctioning.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin to the aftertreatment outlet NOx sensor RETURN pin of the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment outlet NOx sensor open circuit

Refer to S00000883

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000883

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005692

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1711
  • A malfunctioning aftertreatment outlet NOx sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1711

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - J1939 data link terminating resistance is incorrect

Solution: S00004008

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω
  • Proceed to the next solution if the resistance is within the following specification: 54 - 66 Ω

Linked Solutions

  • J1939 data link engine wiring harness voltage check 3 pin service connector

Refer to S00004009

Repair

  • Repair or replace the aftertreatment side of SAE J1939 data link.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00004009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment side SAE J1939 data link circuit has been detected If the resistance is within the following specification: 108 - 132 Ω
  • A malfunctioning engine side SAE J1939 data link circuit has been detected If the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the aftertreatment side of SAE J1939 data link.

Refer to Procedure 019-417

  • Repair or replace the engine side of SAE J1939 data link.

Refer to Procedure 019-417

Validation

  • None
Parent Solution

6 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2772 | SPN: 3226 | FMI: 15
Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit air side flush
  3. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment exhaust system leaks
  6. Aftertreatment diesel exhaust fluid dosing unit manual purge
  7. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  8. Aftertreatment diesel exhaust fluid dosing unit air supply low
  9. Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning
  10. Aftertreatment diesel exhaust fluid dosing unit purge cycle
  11. Aftertreatment SCR temperature sensor is malfunctioning
  12. Aftertreatment SCR catalyst malfunctioning
  13. ECM calibration revision history check
  14. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002480

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1694
  • Aftertreatment diesel exhaust fluid system: 1682, 3548, 3569, ,3575, 3738

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit manual purge

Solution: S00007284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not prime, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00003144

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is within specification, then proceed to the next solution.
  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace damaged aftertreatment diesel exhaust fluid supply line.
  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit air supply low

Solution: S00003207

Verification

Conditions

  • Engine running at idle.
  • Verify adequate air pressure in the tank.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit OEM air supply lines for signs of kinks, damage or leaks.
  • Inspect the diesel exhaust fluid dosing unit OEM air supply line.

Refer to OEM Service Manual

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning

Solution: S00004014

Verification

Conditions

  • Start the engine.

Action

  • Run engine at high idle.
  • Wait for 60 seconds.
  • Turn keyswitch OFF.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing nozzle for plugging.

Refer to Procedure 011-040

Specification

  • If the aftertreatment diesel exhaust fluid nozzle is restricted, then clear the restriction from the aftertreatment diesel exhaust fluid nozzle.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid dosing unit purge cycle

Solution: S00003074

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch OFF.
  • Verify that the aftertreatment diesel exhaust fluid dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Verify that air flow is present for 30 seconds after keyswitch OFF.

Specification

  • If there are incomplete purge counts in the ECM image, then the aftertreatment diesel exhaust fluid dosing unit has failed to purge.

Linked Solutions

  • None

Repair

  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

10 - Aftertreatment SCR temperature sensor is malfunctioning

Solution: S00003394

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the SCR intake temperature sensor.

Refer to Procedure 019-449

  • Visually inspect the SCR intake temperature sensor for damage.

Refer to Procedure 019-449

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment SCR catalyst malfunctioning

Solution: S00004546

Verification

Conditions

  • Engine running.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Disable the fault code.
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

13 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2773 | SPN: 3226 | FMI: 0
Aftertreatment 1 Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit air side flush
  3. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment exhaust system leaks
  6. Aftertreatment diesel exhaust fluid dosing unit manual purge
  7. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  8. Aftertreatment diesel exhaust fluid dosing unit air supply low
  9. Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning
  10. Aftertreatment diesel exhaust fluid dosing unit purge cycle
  11. Aftertreatment SCR catalyst malfunctioning
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001754

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1682, 3548, 3569, 3575
  • Air supply actuator: 3738

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit manual purge

Solution: S00007284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not prime, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00003144

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is within specification, then proceed to the next solution.
  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace damaged aftertreatment diesel exhaust fluid supply line.
  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit air supply low

Solution: S00003207

Verification

Conditions

  • Engine running at idle.
  • Verify adequate air pressure in the tank.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit OEM air supply lines for signs of kinks, damage or leaks.
  • Inspect the diesel exhaust fluid dosing unit OEM air supply line.

Refer to OEM Service Manual

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning

Solution: S00004014

Verification

Conditions

  • Start the engine.

Action

  • Run engine at high idle.
  • Wait for 60 seconds.
  • Turn keyswitch OFF.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing nozzle for plugging.

Refer to Procedure 011-040

Specification

  • If the aftertreatment diesel exhaust fluid nozzle is restricted, then clear the restriction from the aftertreatment diesel exhaust fluid nozzle.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid dosing unit purge cycle

Solution: S00003074

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch OFF.
  • Verify that the aftertreatment diesel exhaust fluid dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Verify that air flow is present for 30 seconds after keyswitch OFF.

Specification

  • If there are incomplete purge counts in the ECM image, then the aftertreatment diesel exhaust fluid dosing unit has failed to purge.

Linked Solutions

  • None

Repair

  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

10 - Aftertreatment SCR catalyst malfunctioning

Solution: S00004546

Verification

Conditions

  • Engine running.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Disable the fault code.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2963 | SPN: 110 | FMI: 15
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Radiator shutters malfunctioning (if equipped)
  6. Coolant temperature sensor resistance check
  7. Fan clutch operates incorrectly
  8. Thermostat is malfunctioning
  9. Out-of-chassis opening temperature test
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2964 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Fan clutch operates incorrectly
  3. Intake manifold temperature sensor stuck in-range
  4. Malfunctioning cooling fan drive or cooling fan controls
  5. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 2973 | SPN: 102 | FMI: 2
Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Restricted intake air filter
  2. Intake manifold pressure sensor has carbon buildup
  3. Intake manifold pressure sensor stuck in-range
  4. Leaks in the intake air system
  5. Charge air cooler system leak
  6. Turbocharger wastegate actuator is malfunctioning
  7. Turbocharger is malfunctioning
  8. Turbocharger wastegate actuator is malfunctioning
  9. ECM calibration revision history check
  10. Intake manifold pressure sensor is malfunctioning

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00002135

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger wastegate actuator is malfunctioning

Solution: S00001652

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

  • Visually inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3139 | SPN: 3667 | FMI: 3
Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine air shutoff solenoid resistance check
  2. Engine air shutoff position switch open circuit check
  3. Engine air shutoff valve solenoid circuit pin to pin short

1 - Engine air shutoff solenoid resistance check

Solution: S00003395

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin and engine air shutoff valve solenoid RETURN pin at the engine air shutoff valve solenoid.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the air shutoff valve solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine air shutoff position switch open circuit check

Solution: S00003404

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness ECM connector air shutoff valve solenoid SIGNAL pin and the engine wiring harness 14-pin crossover connector air shutoff valve solenoid SIGNAL pin.
  • Measure the resistance between the engine wiring harness ECM connector air shutoff valve solenoid RETURN pin and the engine wiring harness 14-pin crossover connector air shutoff valve solenoid RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine air shutoff valve solenoid circuit pin to pin short

Solution: S00003403

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3141 | SPN: 3667 | FMI: 4
Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine air shutoff solenoid resistance check
  2. Engine air shutoff valve solenoid shorted to ground
  3. Engine air shutoff valve solenoid circuit pin to ground short
  4. Engine air shutoff valve solenoid circuit pin to pin short

1 - Engine air shutoff solenoid resistance check

Solution: S00003419

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin and engine air shutoff valve solenoid RETURN pin at the engine air shutoff valve solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the air shutoff valve solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine air shutoff valve solenoid shorted to ground

Solution: S00003407

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the air shutoff valve solenoid SIGNAL pin and ground at the air shutoff valve solenoid.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Replace the air shutoff valve solenoid.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine air shutoff valve solenoid circuit pin to ground short

Solution: S00003406

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine air shutoff valve solenoid circuit pin to pin short

Solution: S00003403

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3142 | SPN: 4360 | FMI: 3
Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment SCR temperature sensor module circuit resistance check
  2. Aftertreatment SCR temperature sensor circuit response
  3. Aftertreatment SCR temperature sensor open circuit check
  4. Aftertreatment SCR temperature sensor module pin to pin short circuit check
  5. Aftertreatment SCR intake temperature sensor circuit pin to pin short

1 - Aftertreatment SCR temperature sensor module circuit resistance check

Solution: S00002924

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment SCR temperature sensor circuit response

Solution: S00004036

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment SCR intake temperature sensor SIGNAL pin and the aftertreatment SCR intake temperature sensor RETURN pin at the aftertreatment SCR intake temperature sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment SCR intake temperature sensor has been detected if the following fault code became active with the jumper wire in place: 3143

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR temperature sensor open circuit check

Solution: S00003326

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness ECM connector SCR intake temperature sensor SIGNAL pin and the engine wiring harness 14-pin crossover connector aftertreatment SCR intake temperature sensor SIGNAL pin.
  • Measure the resistance between the engine wiring harness ECM connector SCR intake temperature sensor RETURN pin and the engine wiring harness 14-pin crossover connector aftertreatment SCR intake temperature sensor RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 ohms

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00003032

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR intake temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if the resistance is less than the following specification: 100k ohms

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR intake temperature sensor circuit pin to pin short

Solution: S00003325

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment SCR intake temperature sensor SIGNAL pin at the OEM wiring harness 14-pin crossover connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Replace SCR aftertreatment interface harness.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 18-Jan-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 3143 | SPN: 4360 | FMI: 4
Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment SCR temperature sensor module circuit resistance check
  2. Aftertreatment SCR temperature sensor circuit response
  3. Aftertreatment SCR intake temperature sensor circuit pin to ground short
  4. Aftertreatment SCR temperature sensor module pin to pin short circuit check
  5. Aftertreatment SCR intake temperature sensor circuit pin to pin short

1 - Aftertreatment SCR temperature sensor module circuit resistance check

Solution: S00002924

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment SCR temperature sensor circuit response

Solution: S00004037

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment SCR intake temperature sensor has been detected if the following fault code became active with the sensor disconnected: 3142

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR intake temperature sensor circuit pin to ground short

Solution: S00003396

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment SCR intake temperature sensor SIGNAL pin at the OEM wiring harness 14-pin crossover connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00003032

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR intake temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if the resistance is less than the following specification: 100k ohms

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR intake temperature sensor circuit pin to pin short

Solution: S00003325

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment SCR intake temperature sensor SIGNAL pin at the OEM wiring harness 14-pin crossover connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Replace SCR aftertreatment interface harness.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 18-Jan-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 3144 | SPN: 4360 | FMI: 2
Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module circuit resistance check
  3. Aftertreatment SCR temperature sensor module pin to pin short circuit check
  4. ECM calibration revision history check
  5. Aftertreatment SCR temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001478

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3142, 3143, 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module circuit resistance check

Solution: S00002924

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00003032

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR intake temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR temperature sensor is malfunctioning

Solution: S00007365

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3146 | SPN: 4363 | FMI: 3
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment SCR temperature sensor module circuit resistance check
  2. Aftertreatment SCR temperature sensor circuit response
  3. Aftertreatment SCR temperature sensor open circuit check
  4. Aftertreatment SCR outlet temperature sensor circuit pin to pin short
  5. Aftertreatment SCR temperature sensor module pin to pin short circuit check

1 - Aftertreatment SCR temperature sensor module circuit resistance check

Solution: S00002924

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment SCR temperature sensor circuit response

Solution: S00002896

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Wait 30 seconds before checking the circuit response.
  • Place a jumper wire between the aftertreatment SCR outlet temperature sensor SIGNAL pin and the aftertreatment SCR outlet temperature sensor RETURN pin at the aftertreatment SCR outlet temperature sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment SCR outlet temperature sensor has been detected if the following fault code became active with the jumper wire in place: 3147

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR outlet temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR temperature sensor open circuit check

Solution: S00003327

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness ECM connector SCR outlet temperature sensor SIGNAL pin and the engine wiring harness 14-pin crossover connector aftertreatment SCR outlet temperature sensor SIGNAL pin.
  • Measure the resistance between the engine wiring harness ECM connector SCR outlet temperature sensor RETURN pin and the engine wiring harness 14-pin crossover connector aftertreatment SCR outlet temperature sensor RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 ohms

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR outlet temperature sensor circuit pin to pin short

Solution: S00003365

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00003032

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR intake temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if the resistance is less than the following specification: 100k ohms

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 18-Jan-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 3147 | SPN: 4363 | FMI: 4
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment SCR temperature sensor module circuit resistance check
  2. Aftertreatment SCR temperature sensor circuit response
  3. Aftertreatment SCR outlet temperature sensor circuit pin to ground short
  4. Aftertreatment SCR outlet temperature sensor circuit pin to pin short
  5. Aftertreatment SCR temperature sensor module pin to pin short circuit check

1 - Aftertreatment SCR temperature sensor module circuit resistance check

Solution: S00002924

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment SCR temperature sensor circuit response

Solution: S00004035

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment SCR outlet temperature sensor has been detected if the following fault code became active with the sensor disconnected: 3146

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR outlet temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR outlet temperature sensor circuit pin to ground short

Solution: S00003357

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment SCR outlet temperature sensor SIGNAL pin at the OEM wiring harness 14-pin crossover connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR outlet temperature sensor circuit pin to pin short

Solution: S00003365

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00003032

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between aftertreatment SCR intake temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Measure the resistance between aftertreatment SCR outlet temperature sensor SIGNAL pin in the aftertreatment SCR temperature sensor module connector to all other pins in the aftertreatment SCR temperature sensor module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if the resistance is less than the following specification: 100k ohms

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 18-Jan-2020


NO TITLE

ISX15 CM2250 SN

Fault Code: 3164 | SPN: 4360 | FMI: 15
Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. Aftertreatment SCR temperature sensor module is malfunctioning
  6. Aftertreatment SCR temperature sensor module pin to pin short circuit check
  7. Turbocharger is malfunctioning
  8. Aftertreatment SCR temperature sensor is malfunctioning
  9. Turbocharger wastegate actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00001537

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3142, 3143, 3144, 3145, 3146, 3147, 3148, 3149

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR temperature sensor module is malfunctioning

Solution: S00002957

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run the engine at idle for the following minutes: 10
  • Monitor the aftertreatment SCR outlet temperature sensor.
  • Monitor the aftertreatment SCR intake temperature sensor.

Specification

  • Proceed to the Linked Solutions section if the aftertreatment SCR temperature sensors vary by more than the following: 24°C (43°F)
  • Proceed to the next solution if the aftertreatment SCR temperature sensors do not vary by more than the following: 24°C (43°F)

Linked Solutions

Click on the link below:

  • Aftertreatment SCR temperature sensor module pin to pin short circuit check

Refer to S00002960

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5.1 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00002960

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Turbocharger is malfunctioning

Solution: S00003258

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment SCR temperature sensor is malfunctioning

Solution: S00003394

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the SCR intake temperature sensor.

Refer to Procedure 019-449

  • Visually inspect the SCR intake temperature sensor for damage.

Refer to Procedure 019-449

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger wastegate actuator is malfunctioning

Solution: S00001652

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

  • Visually inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3236 | SPN: 4363 | FMI: 15
Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Aftertreatment SCR temperature sensor module is malfunctioning
  4. Aftertreatment SCR temperature sensor module pin to pin short circuit check
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001537

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3142, 3143, 3144, 3145, 3146, 3147, 3148, 3149

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR temperature sensor module is malfunctioning

Solution: S00002957

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run the engine at idle for the following minutes: 10
  • Monitor the aftertreatment SCR outlet temperature sensor.
  • Monitor the aftertreatment SCR intake temperature sensor.

Specification

  • Proceed to the Linked Solutions section if the aftertreatment SCR temperature sensors vary by more than the following: 24°C (43°F)
  • Proceed to the next solution if the aftertreatment SCR temperature sensors do not vary by more than the following: 24°C (43°F)

Linked Solutions

Click on the link below:

  • Aftertreatment SCR temperature sensor module pin to pin short circuit check

Refer to S00002960

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3.1 - Aftertreatment SCR temperature sensor module pin to pin short circuit check

Solution: S00002960

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the aftertreatment SCR outlet temperature sensor from the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment SCR intake temperature sensor from the aftertreatment SCR temperature sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of each circuit contained within the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-464

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3237 | SPN: 4340 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater circuit response
  2. Aftertreatment diesel exhaust fluid line heater circuit response
  3. Aftertreatment diesel exhaust fluid line heater open circuit check
  4. Aftertreatment diesel exhaust fluid line heater relay resistance check
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Aftertreatment diesel exhaust fluid line heater circuit response

Solution: S00003028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatrment diesel exhaust fluid line heater relay RETURN pin and the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If Fault Code 3238 became active and Fault Code 3237 inactive, then proceed to the Linked Solutions section.
  • If Fault Code 3238 did not become active and Fault Code 3237 did not go inactive, then proceed to the next solution.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid line heater circuit response

Refer to S00003030

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Aftertreatment diesel exhaust fluid line heater circuit response

Solution: S00003030

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If Fault Code 3237 became active, then a malfunction of the aftertreatment diesel exhaust fluid line heater relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Aftertreatment diesel exhaust fluid line heater open circuit check

Solution: S00003414

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SUPPLY pin at the aftertreatment diesel exhaust fluid line heater OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay RETURN pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay resistance check

Solution: S00003439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3238 | SPN: 4340 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay circuit pin to ground short
  2. Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short
  3. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Aftertreatment diesel exhaust fluid line heater relay circuit pin to ground short

Solution: S00004307

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SUPPLY pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short

Solution: S00004305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 relay coil SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3326 | SPN: 91 | FMI: 9
Accelerator Pedal Position 1 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3328 | SPN: 191 | FMI: 9
Transmission Output Shaft Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3374 | SPN: 1818 | FMI: 31
Roll Over Protection Brake Control Active - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3418 | SPN: 191 | FMI: 19
Transmission Output Shaft Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3488 | SPN: 563 | FMI: 9
Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3525 | SPN: 84 | FMI: 19
Wheel-Based Vehicle Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3526 | SPN: 84 | FMI: 9
Wheel-Based Vehicle Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3527 | SPN: 558 | FMI: 19
Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3528 | SPN: 558 | FMI: 9
Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3539 | SPN: 51 | FMI: 3
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00000394

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine intake throttle actuator connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00000395

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM connector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 3541
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3541 | SPN: 51 | FMI: 4
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00001369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the actuator disconnected: 3539

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00001368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 3539
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 3539

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3542 | SPN: 51 | FMI: 2
Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Ice buildup in the air system components
  3. EGR valve plugged or restricted with ice
  4. Incorrect air compressor discharge line routing
  5. Air compressor discharge line plugged or restricted with ice
  6. Restricted engine intake throttle
  7. Engine intake throttle actuator voltage check
  8. Engine intake throttle actuator voltage check at the ECM
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000303

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Intake throttle: 3539, 3541

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Ice buildup in the air system components

Solution: S00006422

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the engine was operating in temperatures at or below: 5° C [41° F]

Ice can form causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • Proceed to the Linked Solutions section if the engine was operating in temperatures at or below the following specification: 5° C [41° F]

Linked Solutions

  • EGR valve plugged or restricted with ice

Refer to S00007344

  • Incorrect air compressor discharge line routing

Refer to S00001254

  • Air compressor discharge line plugged or restricted with ice

Refer to S00001255

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR valve plugged or restricted with ice

Solution: S00007344

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.
  • Visually inspect the EGR valve for ice plugging.

Refer to Procedure 011-022

Specification

  • If the EGR valve is plugged with ice, then an EGR valve restriction has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Incorrect air compressor discharge line routing

Solution: S00001254

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually verify the air compressor discharge line maintains a constant downward slope from the air compressor to the air dryer inlet fitting.

Refer to OEM Service Manual

Specification

  • If the air compressor discharge line does not have a continuous downward slope from the air compressor to the air dryer inlet fitting, then an incorrect air compressor discharge line routing has been detected.

Linked Solutions

  • None

Repair

  • Route the air compressor discharge line so it maintains a constant downward slope.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

2.3 - Air compressor discharge line plugged or restricted with ice

Solution: S00001255

Verification

Conditions

  • Turn keyswitch OFF.
  • Air compressor discharge line removed.

Action

  • Visually inspect the air discharge line for ice plugging.
  • Visually inspect the air discharge line at the air dryer connection for moisture that could freeze and plug the air discharge line or fittings.

Specification

  • If the air compressor discharge line is plugged with ice, then an air compressor discharge line restriction has been detected.
  • If the air compressor discharge line has a lot of moisture in it, then excessive moisture has been detected in the air compressor discharge line.

Linked Solutions

  • None

Repair

  • Clear the moisture or ice from the air compressor discharge line.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

3 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3548 | SPN: 5392 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Loss of Prime - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment diesel exhaust fluid dosing unit air side flush
  4. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  5. Aftertreatment diesel exhaust fluid is contaminated
  6. Aftertreatment diesel exhaust fluid dosing unit manual purge
  7. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  8. Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning
  9. Aftertreatment diesel exhaust fluid dosing unit purge cycle

1 - Check for primary fault codes

Solution: S00002639

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1671, 1673, 1712, 3242, 3738

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00008749

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb200096

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit manual purge

Solution: S00007284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not prime, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00003144

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is within specification, then proceed to the next solution.
  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace damaged aftertreatment diesel exhaust fluid supply line.
  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning

Solution: S00006017

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the aftertreatment diesel exhaust fluid nozzle is restricted, then clear the restriction from the aftertreatment diesel exhaust fluid nozzle.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing unit purge cycle

Solution: S00003074

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch OFF.
  • Verify that the aftertreatment diesel exhaust fluid dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Verify that air flow is present for 30 seconds after keyswitch OFF.

Specification

  • If there are incomplete purge counts in the ECM image, then the aftertreatment diesel exhaust fluid dosing unit has failed to purge.

Linked Solutions

  • None

Repair

  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3569 | SPN: 3362 | FMI: 7
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment diesel exhaust fluid dosing unit air side flush
  4. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  5. Aftertreatment diesel exhaust fluid is contaminated
  6. Aftertreatment diesel exhaust fluid dosing unit manual purge
  7. Aftertreatment diesel exhaust fluid dosing unit air supply low
  8. Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning
  9. Aftertreatment diesel exhaust fluid dosing unit purge cycle

1 - Check for primary fault codes

Solution: S00002438

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1671, 1673, 1677, 1678, 1711
  • Exhaust gas temperature: 1674, 1675, 1676
  • Air supply actuator: 1697, 1698
  • Aftertreatment SCR: 3142, 3143, 3146, 3147

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00008749

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb200096

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit manual purge

Solution: S00007284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not prime, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit air supply low

Solution: S00003207

Verification

Conditions

  • Engine running at idle.
  • Verify adequate air pressure in the tank.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit OEM air supply lines for signs of kinks, damage or leaks.
  • Inspect the diesel exhaust fluid dosing unit OEM air supply line.

Refer to OEM Service Manual

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning

Solution: S00004014

Verification

Conditions

  • Start the engine.

Action

  • Run engine at high idle.
  • Wait for 60 seconds.
  • Turn keyswitch OFF.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing nozzle for plugging.

Refer to Procedure 011-040

Specification

  • If the aftertreatment diesel exhaust fluid nozzle is restricted, then clear the restriction from the aftertreatment diesel exhaust fluid nozzle.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing unit purge cycle

Solution: S00003074

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch OFF.
  • Verify that the aftertreatment diesel exhaust fluid dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Verify that air flow is present for 30 seconds after keyswitch OFF.

Specification

  • If there are incomplete purge counts in the ECM image, then the aftertreatment diesel exhaust fluid dosing unit has failed to purge.

Linked Solutions

  • None

Repair

  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3575 | SPN: 4334 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment diesel exhaust fluid dosing unit air side flush
  4. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  5. Aftertreatment diesel exhaust fluid dosing unit air supply low
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001521

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3569

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00008749

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb200096

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid dosing unit air supply low

Solution: S00003207

Verification

Conditions

  • Engine running at idle.
  • Verify adequate air pressure in the tank.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit OEM air supply lines for signs of kinks, damage or leaks.
  • Inspect the diesel exhaust fluid dosing unit OEM air supply line.

Refer to OEM Service Manual

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3583 | SPN: 5031 | FMI: 10
Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment outlet NOx sensor has incorrect voltage
  6. Aftertreatment outlet NOx sensor open circuit
  7. Aftertreatment outlet NOx sensor voltage check
  8. Battery circuit fuse has open circuit
  9. Battery or battery cables are malfunctioning
  10. Wiring harness load test
  11. Aftertreatment outlet NOx sensor open circuit
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000309

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3681
  • Aftertreatment SCR: 3144, 3146, 3147, 3148

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment outlet NOx sensor has incorrect voltage

Solution: S00000882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Visually verify that the OEM fuses are not damaged or malfunctioning.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin to the aftertreatment outlet NOx sensor RETURN pin of the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment outlet NOx sensor open circuit

Refer to S00000883

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000883

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment outlet NOx sensor voltage check

Solution: S00000869

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin to the aftertreatment outlet NOx sensor RETURN pin of the OEM wiring harness connector.
  • Measure the battery voltage during keyswitch ON and then during cranking conditions.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section and perform the Wiring Harness Load Test if the voltage is within the following specification of battery voltage: 1 VDC
  • If wiring harness has passed the Wiring Harness Load Test, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

Click on the link below:

  • Battery circuit fuse has open circuit

Refer to S00000870

  • Battery or battery cables are malfunctioning

Refer to S00000871

  • Wiring harness load test

Refer to S00000877

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Battery circuit fuse has open circuit

Solution: S00000870

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check the battery voltage.

Refer to Procedure 013-007

Specification

  • If the voltage at the battery terminal is at least 12 VDC (24 VDC for a 24 volt system), then check the fuse to ensure they are installed correctly, not blown, damaged, corroded, or improperly seated.

Refer to Procedure 019-198

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Replace the fuse.

Refer to Procedure 019-198

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Battery or battery cables are malfunctioning

Solution: S00000871

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • Visually inspect the batteries and the battery cable connections for corrosion.

Refer to Procedure 013-009

  • Check add-on components or the accessory wiring at the (+) battery terminal.
  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 0.1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Parent Solution

4.3 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000872

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3613 | SPN: 111 | FMI: 9
Coolant Level Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3681 | SPN: 3228 | FMI: 2
Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Incorrect adjustable parameter setting
  6. Aftertreatment outlet NOx sensor has incorrect voltage
  7. Aftertreatment outlet NOx sensor open circuit
  8. Aftertreatment outlet NOx sensor voltage check
  9. Battery circuit fuse has open circuit
  10. Battery or battery cables are malfunctioning
  11. Wiring harness load test
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000292

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor has incorrect voltage

Solution: S00000882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Visually verify that the OEM fuses are not damaged or malfunctioning.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin to the aftertreatment outlet NOx sensor RETURN pin of the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment outlet NOx sensor open circuit

Refer to S00000883

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000883

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment outlet NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment outlet NOx sensor voltage check

Solution: S00000869

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin to the aftertreatment outlet NOx sensor RETURN pin of the OEM wiring harness connector.
  • Measure the battery voltage during keyswitch ON and then during cranking conditions.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section and perform the Wiring Harness Load Test if the voltage is within the following specification of battery voltage: 1 VDC
  • If wiring harness has passed the Wiring Harness Load Test, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

Click on the link below:

  • Battery circuit fuse has open circuit

Refer to S00000870

  • Battery or battery cables are malfunctioning

Refer to S00000871

  • Wiring harness load test

Refer to S00000877

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Battery circuit fuse has open circuit

Solution: S00000870

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check the battery voltage.

Refer to Procedure 013-007

Specification

  • If the voltage at the battery terminal is at least 12 VDC (24 VDC for a 24 volt system), then check the fuse to ensure they are installed correctly, not blown, damaged, corroded, or improperly seated.

Refer to Procedure 019-198

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Replace the fuse.

Refer to Procedure 019-198

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Battery or battery cables are malfunctioning

Solution: S00000871

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • Visually inspect the batteries and the battery cable connections for corrosion.

Refer to Procedure 013-009

  • Check add-on components or the accessory wiring at the (+) battery terminal.
  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 0.1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Parent Solution

5.3 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3697 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000289

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Internal ECM Error

Solution: S00008078

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 90 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if a fault code from the following list is active or has greater than 3 inactive counts: 111, 335, 342, 343, 1597, 3697, 3724, 5874, 6155, 7155

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3737 | SPN: 1675 | FMI: 31
Engine Starter Mode Overcrank Protection - Condition Exists

Troubleshooting Summary

  1. Engine will not start
  2. ECM calibration revision history check

1 - Engine will not start

Solution: S00002969

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine will not start, then reset the search to crank no start.
  • If the engine is difficult to start, then reset the search to hard start / long crank time.

Linked Solutions

  • None

Repair

Only search the appropriate symptom.

  • Reset the search to crank no start.
  • Reset the search to hard start / long crank time.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3738 | SPN: 3489 | FMI: 18
Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment diesel exhaust fluid dosing unit air side flush
  4. Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning
  5. Aftertreatment diesel exhaust fluid dosing unit air supply low
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

1 - Check for primary fault codes

Solution: S00002448

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Air supply actuator: 1697, 1698

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00008749

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb200096

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit air side flush

Solution: S00009590

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the aftertreatment diesel exhaust fluid dosing unit air side flush.

Refer to Procedure 011-082

Specification

  • If air is not flowing through the aftertreatment diesel exhaust fluid nozzle line, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Refer to S00006387

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid dosing unit air solenoid is malfunctioning

Solution: S00006387

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test.

Refer to Procedure 011-058

Specification

  • If a "click" sound is not heard, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid dosing unit air supply low

Solution: S00003207

Verification

Conditions

  • Engine running at idle.
  • Verify adequate air pressure in the tank.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit OEM air supply lines for signs of kinks, damage or leaks.
  • Inspect the diesel exhaust fluid dosing unit OEM air supply line.

Refer to OEM Service Manual

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00006389

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Engine running at idle.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 3749 | SPN: 3226 | FMI: 20
Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning
  3. ECM calibration revision history check
  4. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000252

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3446, 3583, 3649, 3681, 3682, 3725
  • Aftertreatment diesel exhaust fluid system: 1681, 1682, 3574, 6485, 6486

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing nozzle is malfunctioning

Solution: S00004014

Verification

Conditions

  • Start the engine.

Action

  • Run engine at high idle.
  • Wait for 60 seconds.
  • Turn keyswitch OFF.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing nozzle for plugging.

Refer to Procedure 011-040

Specification

  • If the aftertreatment diesel exhaust fluid nozzle is restricted, then clear the restriction from the aftertreatment diesel exhaust fluid nozzle.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment diesel exhaust fluid dosing nozzle.

Refer to Procedure 011-040

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4215 | SPN: 563 | FMI: 31
Anti-Lock Braking (ABS) Active - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00002745

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.

Specification

  • Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4293 | SPN: 5097 | FMI: 3
Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake lamp relay resistance check
  2. Incorrect adjustable parameter setting
  3. Engine brake lamp relay open circuit check
  4. Engine brake lamp circuit pin to pin short

1 - Engine brake lamp relay resistance check

Solution: S00005556

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake lamp relay.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00002723

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Ensure the following adjustable parameters are set correctly for the application:

  • Verify if the vehicle has an engine brake lamp installed.
  • Verify the engine brake lamp output parameter is correctly set.

Specification

  • If the vehicle does not have an adjustable Engine Brake Lamp installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.
  • If the vehicle has a Engine Brake Lamp installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake lamp relay open circuit check

Solution: S00000951

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the engine brake lamp relay OEM wiring harness connector and the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake lamp relay RETURN pin at the engine brake lamp relay OEM wiring harness connector and the engine brake lamp relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake lamp circuit pin to pin short

Solution: S00000952

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX15 CM2250 SN

Fault Code: 4294 | SPN: 5097 | FMI: 4
Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake lamp relay resistance check
  2. Incorrect adjustable parameter setting
  3. Engine brake lamp circuit pin to ground short
  4. Engine brake lamp circuit pin to pin short

1 - Engine brake lamp relay resistance check

Solution: S00005556

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake lamp relay.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00002723

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Ensure the following adjustable parameters are set correctly for the application:

  • Verify if the vehicle has an engine brake lamp installed.
  • Verify the engine brake lamp output parameter is correctly set.

Specification

  • If the vehicle does not have an adjustable Engine Brake Lamp installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.
  • If the vehicle has a Engine Brake Lamp installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake lamp circuit pin to ground short

Solution: S00000953

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the engine brake lamp relay and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake lamp circuit pin to pin short

Solution: S00000952

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX15 CM2250 SN

Fault Code: 4484 | SPN: 3667 | FMI: 7
Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine air shutoff position switch voltage check
  3. Engine air shutoff position switch open circuit check
  4. Engine air shutoff position switch open circuit check
  5. Engine air shutoff position switch circuit pin to pin short
  6. ECM calibration revision history check
  7. Engine air shutoff position switch is malfunctioning

1 - Check for primary fault codes

Solution: S00000187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine air shutoff: 3139, 3141

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine air shutoff position switch voltage check

Solution: S00000957

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine air shutoff position switch SIGNAL pin and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch connector of the OEM wiring harness.

Specification

  • A malfunctioning engine air shutoff valve has been detected if the voltage is greater than the following specification: 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Engine air shutoff position switch open circuit check

Refer to S00000959

Repair

  • Replace the engine air shut off valve.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Engine air shutoff position switch open circuit check

Solution: S00000959

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine air shutoff position switch open circuit check

Solution: S00000960

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine wiring harness ECM connector and the engine air shutoff position switch SIGNAL pin at the engine air shutoff position switch OEM wiring harness connector.
  • Measure the resistance between the engine air shutoff position switch RETURN pin in the engine wiring harness ECM connector and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine air shutoff position switch circuit pin to pin short

Solution: S00000962

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the OEM wiring harness ECM connector and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine air shutoff position switch is malfunctioning

Solution: S00001186

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine air shutoff position switch has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine air shutoff position switch.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4517 | SPN: 237 | FMI: 13
Vehicle Identification Number - Out of Calibration

Troubleshooting Summary

  1. Vehicle identification number out of calibration
  2. ECM calibration revision history check

1 - Vehicle identification number out of calibration

Solution: S00000964

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the vehicle identification number under the vehicle/OEM information in the system ID and Dataplate section of Features and Parameters matches the vehicle.

Specification

  • If the vehicle identification number is not present it will need to be added.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Enter the appropriate information under the vehicle/OEM information in the System ID and Dataplate section of Features and Parameters.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4572 | SPN: 3031 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Troubleshooting Summary

  1. Low battery voltage
  2. Battery load test
  3. Ground inspection
  4. J1939 data link terminating resistance is incorrect
  5. J1939 data link engine wiring harness voltage check 3 pin service connector
  6. OEM terminating resistor Ω check for the J1939 data link
  7. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  8. J1939 wire resistance check at the crossover connector for each component
  9. ECM calibration revision history check

1 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - J1939 data link terminating resistance is incorrect

Solution: S00004008

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω
  • Proceed to the next solution if the resistance is within the following specification: 54 - 66 Ω

Linked Solutions

  • J1939 data link engine wiring harness voltage check 3 pin service connector

Refer to S00004009

Repair

  • Repair or replace the aftertreatment side of SAE J1939 data link.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00004009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment side SAE J1939 data link circuit has been detected If the resistance is within the following specification: 108 - 132 Ω
  • A malfunctioning engine side SAE J1939 data link circuit has been detected If the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the aftertreatment side of SAE J1939 data link.

Refer to Procedure 019-417

  • Repair or replace the engine side of SAE J1939 data link.

Refer to Procedure 019-417

Validation

  • None
Parent Solution

3 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4642 | SPN: 97 | FMI: 0
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Water accumulation in the fuel filter
  2. ECM calibration revision history check

1 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4731 | SPN: 3031 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4732 | SPN: 1761 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4739 | SPN: 1761 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 4769 | SPN: 1761 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid level is low
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000093

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 3242, 3497, 3868, 4679, 4732, 4738, 4739

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00002687

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.
  • Wait for 120 seconds.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Check the aftertreatment diesel exhaust fluid gauge on the dash.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected if the fault code is active and the aftertreatment diesel exhaust fluid gauge on the dash indicates the tank is full.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 5221 | SPN: 3667 | FMI: 2
Engine Air Shutoff Status - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine air shutoff position switch voltage check
  3. Engine air shutoff position switch open circuit check
  4. Engine air shutoff position switch open circuit check
  5. ECM calibration revision history check
  6. Engine air shutoff position switch is malfunctioning

1 - Check for primary fault codes

Solution: S00002796

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine air shutoff: 3139, 3141, 4484

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine air shutoff position switch voltage check

Solution: S00000957

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine air shutoff position switch SIGNAL pin and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch connector of the OEM wiring harness.

Specification

  • A malfunctioning engine air shutoff valve has been detected if the voltage is greater than the following specification: 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Engine air shutoff position switch open circuit check

Refer to S00000959

Repair

  • Replace the engine air shut off valve.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Engine air shutoff position switch open circuit check

Solution: S00000959

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine air shutoff position switch open circuit check

Solution: S00000960

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the engine wiring harness ECM connector and the engine air shutoff position switch SIGNAL pin at the engine air shutoff position switch OEM wiring harness connector.
  • Measure the resistance between the engine air shutoff position switch RETURN pin in the engine wiring harness ECM connector and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine air shutoff position switch is malfunctioning

Solution: S00001186

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine air shutoff position switch has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine air shutoff position switch.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 5297 | SPN: 747 | FMI: 13
Engine/Transmission Match - Out of Calibration

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. ECM calibration revision history check

1 - Technical Service Bulletin is available

Solution: S00006176

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the present Transmission Control Module software phase.

Refer to tsb150099

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the predictive engine braking parameter is correctly set.

Refer to Procedure 019-665

  • Verify the predictive gear shifting parameter is correctly set.

Refer to Procedure 019-665

  • Verify the smart coast parameter is correctly set.

Refer to Procedure 019-665

  • Verify the smart torque 2 parameter is correctly set.

Refer to Procedure 019-665

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 5879 | SPN: 3464 | FMI: 3
Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Open circuit in the engine intake throttle actuator motor
  2. Engine intake throttle actuator motor resistance check
  3. Intake throttle control actuator motor circuit pin to pin short

1 - Open circuit in the engine intake throttle actuator motor

Solution: S00000804

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor connector RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 15 Ω

Linked Solutions

Click on the link below:

  • Engine intake throttle actuator motor resistance check

Refer to S00000805

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Engine intake throttle actuator motor resistance check

Solution: S00000805

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is greater than the following specification: 15 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 15 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 5881 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine intake throttle actuator motor shorted to ground
  2. Intake throttle control actuator motor circuit pin to pin short

1 - Engine intake throttle actuator motor shorted to ground

Solution: S00000493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 5882 | SPN: 3464 | FMI: 7
Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Restricted engine intake throttle
  2. ECM calibration revision history check
  3. Engine intake throttle actuator not responding or out of adjustment

1 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator not responding or out of adjustment

Solution: S00001034

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2250 SN

Fault Code: 6724 | SPN: 581 | FMI: 9
Transmission Gear Ratio Module - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


INDEX
176-fc111.htm

176-t06-111.htm

176-fc115.htm

176-t06-115.htm

176-fc122.htm

176-t06-122.htm

176-fc123.htm

176-t06-123.htm

176-fc125.htm

176-t06-125.htm

176-fc131.htm

176-t06-131.htm

176-fc132.htm

176-t06-132.htm

176-fc133.htm

176-t06-133.htm

176-fc134.htm

176-t06-134.htm

176-fc135.htm

176-t06-135.htm

176-fc141.htm

176-t06-141.htm

176-fc143.htm

176-t06-143.htm

176-fc144.htm

176-t06-144.htm

176-fc145.htm

176-t06-145.htm

176-fc151.htm

176-t06-151.htm

176-fc153.htm

176-t06-153.htm

176-fc154.htm

176-t06-154.htm

176-fc155.htm

176-t06-155.htm

176-fc175.htm

176-t06-175.htm

176-fc176.htm

176-t06-176.htm

176-fc177.htm

176-t06-177.htm

176-fc187.htm

176-t06-187.htm

176-fc195.htm

176-t06-195.htm

176-fc196.htm

176-t06-196.htm

176-fc197.htm

176-t06-197.htm

176-fc212.htm

176-t06-212.htm

176-fc213.htm

176-t06-213.htm

176-fc214.htm

176-t06-214.htm

176-fc221.htm

176-t06-221.htm

176-fc222.htm

176-t06-222.htm

176-fc227.htm

176-t06-227.htm

176-fc234.htm

176-t06-234.htm

176-fc235.htm

176-t06-235.htm

176-fc238.htm

176-t06-238.htm

176-fc239.htm

176-t06-239.htm

176-fc241.htm

176-t06-241.htm

176-fc242.htm

176-t06-242.htm

176-fc245.htm

176-t06-245.htm

176-fc249.htm

176-t06-249.htm

176-fc256.htm

176-t06-256.htm

176-fc269.htm

176-t06-269.htm

176-fc271.htm

176-t06-271.htm

176-fc272.htm

176-t06-272.htm

176-fc285.htm

176-t06-285.htm

176-fc286.htm

176-t06-286.htm

176-fc287.htm

176-t06-287.htm

176-fc288.htm

176-t06-288.htm

176-fc291.htm

176-t06-291.htm

176-fc319.htm

176-t06-319.htm

176-fc322.htm

176-t06-322.htm

176-fc323.htm

176-t06-323.htm

176-fc324.htm

176-t06-324.htm

176-fc325.htm

176-t06-325.htm

176-fc331.htm

176-t06-331.htm

176-fc332.htm

176-t06-332.htm

176-fc343.htm

176-t06-343.htm

176-fc346.htm

176-t06-346.htm

176-fc351.htm

176-t06-351.htm

176-fc415.htm

176-t06-415.htm

176-fc418.htm

176-t06-418.htm

176-fc425.htm

176-t06-425.htm

176-fc428.htm

176-t06-428.htm

176-fc429.htm

176-t06-429.htm

176-fc435.htm

176-t06-435.htm

176-fc441.htm

176-t06-441.htm

176-fc442.htm

176-t06-442.htm

176-fc451.htm

176-t06-451.htm

176-fc452.htm

176-t06-452.htm

176-fc515.htm

176-t06-515.htm

176-fc553.htm

176-t06-553.htm

176-fc559.htm

176-t06-559.htm

176-fc584.htm

176-t06-584.htm

176-fc585.htm

176-t06-585.htm

176-fc595.htm

176-t06-595.htm

176-fc596.htm

176-t06-596.htm

176-fc597.htm

176-t06-597.htm

176-fc598.htm

176-t06-598.htm

176-fc649.htm

176-t06-649.htm

176-fc689.htm

176-t06-689.htm

176-fc731.htm

176-t06-731.htm

176-fc778.htm

176-t06-778.htm

176-fc784.htm

176-t06-784.htm

176-fc1117.htm

176-t06-1117.htm

176-fc1239.htm

176-t06-1239.htm

176-fc1241.htm

176-t06-1241.htm

176-fc1242.htm

176-t06-1242.htm

176-fc1515.htm

176-t06-1515.htm

176-fc1654.htm

176-t06-1654.htm

176-fc1655.htm

176-t06-1655.htm

176-fc1656.htm

176-t06-1656.htm

176-fc1657.htm

176-t06-1657.htm

176-fc1658.htm

176-t06-1658.htm

176-fc1659.htm

176-t06-1659.htm

176-fc1668.htm

176-t06-1668.htm

176-fc1669.htm

176-t06-1669.htm

176-fc1671.htm

176-t06-1671.htm

176-fc1673.htm

176-t06-1673.htm

176-fc1677.htm

176-t06-1677.htm

176-fc1678.htm

176-t06-1678.htm

176-fc1679.htm

176-t06-1679.htm

176-fc1681.htm

176-t06-1681.htm

176-fc1683.htm

176-t06-1683.htm

176-fc1684.htm

176-t06-1684.htm

176-fc1695.htm

176-t06-1695.htm

176-fc1696.htm

176-t06-1696.htm

176-fc1697.htm

176-t06-1697.htm

176-fc1698.htm

176-t06-1698.htm

176-fc1711.htm

176-t06-1711.htm

176-fc1712.htm

176-t06-1712.htm

176-fc1713.htm

176-t06-1713.htm

176-fc1852.htm

176-t06-1852.htm

176-fc1887.htm

176-t06-1887.htm

176-fc1911.htm

176-t06-1911.htm

176-fc2182.htm

176-t06-2182.htm

176-fc2183.htm

176-t06-2183.htm

176-fc2185.htm

176-t06-2185.htm

176-fc2186.htm

176-t06-2186.htm

176-fc2265.htm

176-t06-2265.htm

176-fc2266.htm

176-t06-2266.htm

176-fc2311.htm

176-t06-2311.htm

176-fc2321.htm

176-t06-2321.htm

176-fc2322.htm

176-t06-2322.htm

176-fc2363.htm

176-t06-2363.htm

176-fc2367.htm

176-t06-2367.htm

176-fc2372.htm

176-t06-2372.htm

176-fc2377.htm

176-t06-2377.htm

176-fc2398.htm

176-t06-2398.htm

176-fc2412.htm

176-t06-2412.htm

176-fc2448.htm

176-t06-2448.htm

176-fc2468.htm

176-t06-2468.htm

176-fc2738.htm

176-t06-2738.htm

176-fc2739.htm

176-t06-2739.htm

176-fc2771.htm

176-t06-2771.htm

176-fc2772.htm

176-t06-2772.htm

176-fc2773.htm

176-t06-2773.htm

176-fc2963.htm

176-t06-2963.htm

176-fc2964.htm

176-t06-2964.htm

176-fc2973.htm

176-t06-2973.htm

176-fc3139.htm

176-t06-3139.htm

176-fc3141.htm

176-t06-3141.htm

176-fc3142.htm

176-t06-3142.htm

176-fc3143.htm

176-t06-3143.htm

176-fc3144.htm

176-t06-3144.htm

176-fc3146.htm

176-t06-3146.htm

176-fc3147.htm

176-t06-3147.htm

176-fc3164.htm

176-t06-3164.htm

176-fc3236.htm

176-t06-3236.htm

176-fc3237.htm

176-t06-3237.htm

176-fc3238.htm

176-t06-3238.htm

176-fc3326.htm

176-t06-3326.htm

176-fc3328.htm

176-t06-3328.htm

176-fc3374.htm

176-t06-3374.htm

176-fc3418.htm

176-t06-3418.htm

176-fc3488.htm

176-t06-3488.htm

176-fc3525.htm

176-t06-3525.htm

176-fc3526.htm

176-t06-3526.htm

176-fc3527.htm

176-t06-3527.htm

176-fc3528.htm

176-t06-3528.htm

176-fc3539.htm

176-t06-3539.htm

176-fc3541.htm

176-t06-3541.htm

176-fc3542.htm

176-t06-3542.htm

176-fc3548.htm

176-t06-3548.htm

176-fc3569.htm

176-t06-3569.htm

176-fc3575.htm

176-t06-3575.htm

176-fc3583.htm

176-t06-3583.htm

176-fc3613.htm

176-t06-3613.htm

176-fc3681.htm

176-t06-3681.htm

176-fc3697.htm

176-t06-3697.htm

176-fc3737.htm

176-t06-3737.htm

176-fc3738.htm

176-t06-3738.htm

176-fc3749.htm

176-t06-3749.htm

176-fc4215.htm

176-t06-4215.htm

176-fc4293.htm

176-t06-4293.htm

176-fc4294.htm

176-t06-4294.htm

176-fc4484.htm

176-t06-4484.htm

176-fc4517.htm

176-t06-4517.htm

176-fc4572.htm

176-t06-4572.htm

176-fc4642.htm

176-t06-4642.htm

176-fc4731.htm

176-t06-4731.htm

176-fc4732.htm

176-t06-4732.htm

176-fc4739.htm

176-t06-4739.htm

176-fc4769.htm

176-t06-4769.htm

176-fc5221.htm

176-t06-5221.htm

176-fc5297.htm

176-t06-5297.htm

176-fc5879.htm

176-t06-5879.htm

176-fc5881.htm

176-t06-5881.htm

176-fc5882.htm

176-t06-5882.htm

176-fc6724.htm

176-t06-6724.htm